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This manual describes the operation method of each function of Winmostar (TM). The latest version of this document is
available from Official site. The Winmostar trade name and logo are registered trademarks (Trademark Nos. 5578852,
6378452, 6378453) of X-Ability Co. Ltd. If you are using Winmostar (TM) for the first time, please refer to Quick
Manual. See Basic Operation Flow for the basic flow of operations to perform the calculation. See Structure Building
for information on how to create molecular structures. See Details of each menu window for details on each function.
Specific operating procedures for different purposes, such as chemical reaction analysis or calculation of specific prop-
erties, can be found in the Various Tutorials.. If there is an uncertain point or it does not move as expected, please
confirm Frequently asked questions · Troubleshooting which is updated from time to time.
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CHAPTER

ONE

INTRODUCTION

Winmostar (TM) provides a graphical user interface that can efficiently manipulate quantum chemical calculations,
first principles calculations, and molecular dynamics calculations. From the creation of the initial structure, from the
calculation execution to the result analysis, you can carry out the one operation required for the simulation on Winmostar
(TM).

1.1 About quotation

When presenting data created using Winmostar(TM) at a conference or in a paper, for example, please describe Win-
mostar(TM) itself as follows. Enter the actual version used in the Version field and the year in the Year field.

Winmostar V11.13.0, X-Ability Co. Ltd., Tokyo, Japan, 2025.

Please refer to the instructions of each software for the citation of solvers and various auxiliary programs called by
Winmostar (TM).

1.2 Conventions in this manual

This manual follows the following conventions:

Ctrl+A
Indicates keyboard key or key combination operation.

OK
Labels, buttons, etc. Indicates a character string displayed on the GUI.

Tools → Preferences → Basic → License Code
It shows the flow that follows menu, tab, etc. Above example means GUI flow from the menu Tools→Preferences
and click on the tab called basic in the opened window and find the label license code.

wmset.ini, C\:winmos11\UserPref
Indicates file name or directory name.

ls /usr/local/bin
Command prompt, command to be executed at terminal.

3.14159
Indicates input to the text box of the GUI.

Note: Indicates supplementary matter.
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Warning: Indicates notes.

1.3 The libraries used

Winmostar uses the following libraries and softwares for some processings.

OpenCubeGen

OpenCubegen
Cube Generation for Gaussian, Gamess, and MOPAC packages

Author
Mitsuo Shoji
mitsuo.shoji@apchem.nagoya-u.ac.jp
Home page: http://www.geocities.jp/dr_mitsuos/index.html

Copyright (c)
All rights reserved. 2009- by Mitsuo Shoji

FermiSurfer

Copyright (c) 2014 Mitsuaki Kawamura
Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the
“Software”), to deal in the Software without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicense, and/or sell copies of the Software, and to
permit persons to whom the Software is furnished to do so, subject to
the following conditions:
The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Abbrevia 5.0

https://www.mozilla.org/en-US/MPL/1.1/

TeeChart Standard

===============================================
TeeChart Standard v2018
Copyright (c) 1995-2018 by Steema Software.
All Rights Reserved.

===============================================
SOFTWARE LICENSING CONTRACT
NOTICE TO USER: THIS IS A CONTRACT. BY CLICKING THE 'OK' BUTTON BELOW␣
→˓DURING INSTALLATION,

(continues on next page)
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(continued from previous page)

YOU ACCEPT ALL THE TERMS AND CONDITIONS OF THIS AGREEMENT.
===========================================
License Terms:
===============
-- A Single License of TeeChart Standard VCL is per developer.
-- A Site License of TeeChart Standard VCL is per "physical place" with␣
→˓unlimited number of developers
under the same company building(s).
-- For special licensing issues, volume discounts, integrations or␣
→˓redistribution please contact us at:
sales@steema.com
TeeChart Standard is royalty free under the following use conditions
==================================
You can freely distribute TeeChart Standard code COMPILED into your␣
→˓applications as executables or
dynamic link libraries, including as .Net Assemblies, VCL Packages, OCX␣
→˓ActiveX Controls or ActiveX
Forms, excepting compilation as design-time packages or compilation into a␣
→˓DLL or OCX or other library
for use as a designtime tool or for a Web server scripting environment.␣
→˓The latter case requires that a
WebServer runtime license be registered per installed server.
You are NOT allowed to distribute stand-alone TeeChart Standard files,␣
→˓TeeChart Standard source code,
TeeChart Standard manual and help file or everything else contained in␣
→˓this software without receiving
our written permission.
You are NOT allowed to distribute the TeeChart design-time package files␣
→˓and/or any of the TeeChart
\*.DCP or any other file from the source code files.
You can freely distribute the TeeChart evaluation version, located at our␣
→˓web site
http://www.steema.com
END-USER LICENSE AGREEMENT FOR STEEMA SOFTWARE SL
IMPORTANT- READ CAREFULLY BEFORE INSTALLING THE SOFTWARE.
This End User License Agreement (this "EULA") contains the terms and␣
→˓conditions regarding your use of
the SOFTWARE (as defined below) and material limitations to your rights in␣
→˓that regard.
You should read this EULA carefully.
By installing the TeeChart Standard VCL software (hereinafter the "SOFTWARE
→˓"), you are accepting the
following EULA.
I. THIS EULA.
1. Software Covered by this EULA.
This EULA governs your use of the Steema Software SL ("Steema") SOFTWARE␣
→˓enclosed either as part of
a SOFTWARE installer or otherwise accompanied herewith. The term "SOFTWARE
→˓" includes, to the
extent provided by Steema:
1) any revisions, updates and/or upgrades thereto;
2) any data, image or executable files, databases, data engines, computer␣

(continues on next page)
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(continued from previous page)

→˓software, or similar items
customarily used or distributed with computer software products;
3) anything in any form whatsoever intended to be used with or in␣
→˓conjunction with the SOFTWARE; and
4) any associated media, documentation (including physical, electronic and␣
→˓online) and printed materials
(the "Documentation").
2. This EULA is a legal agreement between you and Steema.
If you are acting as an agent of a company or another legal person, such␣
→˓as an officer or other employee
acting for your employer, then "you" and "your" mean your principal, the␣
→˓entity or other legal person for
whom you are acting. However, importantly, even if you are acting as an␣
→˓agent for another, you may still
be personally liable for violation of laws such as copyright infringement.
This EULA is a legal agreement between you and Steema.
You intend to be legally bound to this EULA to the same extent as if␣
→˓Steema and you physically signed
this EULA.
By installing, copying, or otherwise using the SOFTWARE, you agree to be␣
→˓bound by the terms and
conditions contained in this EULA.
If you do not agree to all of the terms and conditions contained in this␣
→˓EULA, you may not install or use
the SOFTWARE. If you have already installed or begun to install the␣
→˓SOFTWARE you should cancel any
install in progress and uninstall the SOFTWARE. If you do not agree to all␣
→˓of these terms and conditions,
then you must promptly return the uninstalled SOFTWARE to the place from␣
→˓which you purchased it in
accordance with the return policies of that place.
II. YOUR LICENSE TO DEVELOP AND TO DISTRIBUTE.
Detailed below, this EULA grants you three licenses:
1) a license to use the SOFTWARE to develop other software products (the
→˓"Development License");
2) a license to use and/or distribute the Developed Software (the
→˓"Distribution License"); and
3) a license to use and/or distribute the Developed Software on a Network␣
→˓Server (the "Web Server
License"). All of these licenses (individually and collectively, the
→˓"Licenses") are explained and defined in
more detail below.
1. Definitions. Terms and their respective meanings as used in this EULA:
"Network Server" means a computer with one or more computer central␣
→˓processing units (CPU's) that
operates for the purpose of serving other computers logically or␣
→˓physically connected to it, including,
but not limited to, other computers connected to it on an internal network,
→˓ intranet or the Internet.
"Web Server" means a type of Network Server that serves other computers␣
→˓more particularly connected
to it over an intranet or the Internet.

(continues on next page)
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(continued from previous page)

"Developed Software" means those computer software products that are␣
→˓developed by or through the
use of the SOFTWARE. "Developed Web Server Software" means those Developed␣
→˓Software products
that reside logically or physically on at least one Web Server and are␣
→˓operated (executed therein) by the
Web Server's central processing unit(s) (CPU).
"Developed Desktop Software" means those Developed Software products that␣
→˓are not Developed Web
Server Software, including, for example, standalone applications.
"Redistributable Files" means the SOFTWARE files or other portions of the␣
→˓SOFTWARE that are provided
by Steema and are identified as such in the Documentation for distribution␣
→˓by you with the Developed
Software.
"Developer" means a person using the SOFTWARE in accordance with the terms␣
→˓and conditions of this
EULA.
"Development License" is a "Per-seat license". Per-seat means the license␣
→˓is required for each machine
that the SOFTWARE will reside on. Every machine installing, running and/or␣
→˓using the software for
development purposes must have a licensed copy and its appropriate license.
"Developer seat" is the use of one "Per seat" licensed copy of the␣
→˓SOFTWARE by one concurrent
Developer.
2. Your Development License.
You are hereby granted a limited, royalty-free, non-exclusive right to use␣
→˓the SOFTWARE to design,
develop, and test Developed Software, on the express condition that, and␣
→˓only for so long as, you fully
comply with all terms and conditions of this EULA.
The SOFTWARE is licensed to you on a Per Seat License basis.
The Development License means that you may perform a single install of the␣
→˓SOFTWARE for use in
designing, testing and creating Developed Software on a single computer␣
→˓with a single set of input
devices, restricting the use of such computer to one concurrent Developer.␣
→˓Conversely, you may not
install or use the SOFTWARE on a computer that is a network server or a␣
→˓computer at which the
SOFTWARE is used by more than one Developer.
You may not network the SOFTWARE or any component part of it, where it is␣
→˓or may be used by more
than one Developer unless you purchase an additional Development License␣
→˓for each Developer. You
must purchase another separate license to the SOFTWARE in order to add␣
→˓additional developer seats if
the additional developers are accessing the SOFTWARE on a computer network.
→˓ If the SOFTWARE is
used to create Developed Web Server Software, then you may perform a␣
→˓single install of the SOFTWARE

(continues on next page)
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for use in designing, testing and creating Developed Web Server Software␣
→˓by a single Developer on a
single computer or Network Server. No additional End User Licenses are␣
→˓required for additional CPUs on
the single computer or Network Server.
In all cases, you may not use Steema's name, logo, or trademarks to market␣
→˓your Developed Software
without the express written consent of Steema; agree to indemnify, hold␣
→˓harmless, and defend Steema,
its suppliers and resellers, from and against any claims or lawsuits,␣
→˓including lawyer's fees that may arise
from the use or distribution of your Developed Software; you may use the␣
→˓SOFTWARE only to create
Developed Software that is significantly different than the SOFTWARE.
3. Your Distribution License.
License to Distribute Developed Desktop Software. Subject to the terms and␣
→˓conditions in this EULA,
you are granted the license to use and to distribute Developed Desktop␣
→˓Software on a royalty-free basis,
provided that the Developed Desktop Software incorporates the SOFTWARE as␣
→˓an integral part of the
Developed Software in machine language compiled format (customarily an ".
→˓exe", or ".dll", etc.). You
may not distribute, bundle, wrap or subclass the SOFTWARE as Developed␣
→˓Software which, when used in
a "designtime" development environment, exposes the programmatic interface␣
→˓of the SOFTWARE. You
may distribute, on a royalty-free basis, Redistributable Files with␣
→˓Developed Desktop Software only.
4. Your Web Server License.
Subject to the terms and conditions in this EULA, you are granted the␣
→˓license to use and to distribute
Developed Web Server Software, provided that you must purchase one Web␣
→˓Server License for each
Network Server operating the Developed Web Server Software (and/or␣
→˓Redistributable Files called or
otherwise used directly by the Developed Web Server Software).␣
→˓Notwithstanding the foregoing,
however, you may distribute or transfer, free of royalties, the␣
→˓Redistributable Files (and/or any
Developed Desktop Software) to the extent that they are used separately on␣
→˓the client/workstation side
of the network served by the Web Server.
5. License Serial Number.
Upon purchase of the SOFTWARE a unique serial number (the "Serial Number")␣
→˓is provided by Steema
either electronically or via the delivery channel. The Serial number␣
→˓provides a means to install and
Register the SOFTWARE. The Serial Number is subject to the restrictions␣
→˓set forth in this EULA and may
not be disclosed or distributed either with your Developed Software or in␣
→˓any other way. The disclosure

(continues on next page)
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or distribution of the Serial Number shall constitute a breach of this␣
→˓EULA, the effect of which shall be
the automatic termination and revocation of all the rights granted herein.
6. Updates/Upgrades.
Subject to the terms and conditions of this EULA, the Licenses are␣
→˓perpetual. Updates and upgrades to
the SOFTWARE may be provided by Steema at their discretion at timely␣
→˓intervals though Steema does
not commit to providing such updates or upgrades, and, if so provided by␣
→˓Steema, are provided upon
the terms and conditions offered at that time by Steema.
7. Evaluation Copy.
If you are using an "evaluation copy" or similar version, specifically␣
→˓designated as such by Steema on its
website or otherwise, then the Licenses are limited as follows:
a) you are granted a license to use the SOFTWARE for a period of fifty␣
→˓(50) days counted from the day of
installation (the "Evaluation Period");
b) upon completion of the Evaluation Period, you shall either
i) delete the SOFTWARE from the computer containing the installation, or␣
→˓you may
ii) contact Steema or one of its authorized dealers to purchase a license␣
→˓of the SOFTWARE, which is
subject to the terms and limitations contained herein; and
c) any Developed Software developed with an evaluation copy may not be␣
→˓distributed or used for any
commercial purpose.
III. INTELLECTUAL PROPERTY.
1. Copyright.
You agree that all right, title, and interest in and to the SOFTWARE␣
→˓(including, but not limited to, any
images, photographs, code examples and text incorporated into the␣
→˓SOFTWARE), and any copies of the
SOFTWARE, and any copyrights and other intellectual properties therein or␣
→˓related thereto are owned
exclusively by Steema, except to the limited extent that Steema may be the␣
→˓rightful license holder of
certain third-party technologies incorporated into the SOFTWARE. The␣
→˓SOFTWARE is protected by
copyright laws and international treaty provisions. The SOFTWARE is␣
→˓licensed to you, not sold to you.
Steema reserves all rights not otherwise expressly and specifically␣
→˓granted to you in this EULA.
2. Backups.
You may make one copy the SOFTWARE solely for backup or archival purposes.
3. General Limitations.
You may not reverse engineer, decompile, or disassemble the SOFTWARE,␣
→˓except and only to the extent
that applicable law expressly permits such activity notwithstanding this␣
→˓limitation.
4. Software Transfers.
You may not rent or lease the SOFTWARE. You may transfer the SOFTWARE to␣

(continues on next page)
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→˓another computer,
provided that it is completely removed from the computer from which it was␣
→˓transferred. You may
permanently transfer all of your rights under the EULA, provided that you␣
→˓retain no copies, that you
transfer all the SOFTWARE (including all component parts, the media and␣
→˓printed materials, any dates,
upgrades, this EULA and, if applicable, the Certificate of Authenticity),␣
→˓and that the recipient agrees to
the terms and conditions of this EULA as provided herein. Steema should be␣
→˓notified in writing of license
transfers where the company of the recipient is different to that of the␣
→˓original licensee. If the
SOFTWARE is an update or upgrade, any transfer must include all prior␣
→˓versions of the SOFTWARE.
5. Termination.
Without prejudice to any other rights it may have, Steema may terminate␣
→˓this EULA and the Licenses if
you fail to comply with the terms and conditions contained herein. In such␣
→˓an event, you must destroy
all copies of the SOFTWARE and all of its component parts.
IV. DISCLAIMER and WARRANTIES
1. Disclaimer
Steema's entire liability and your exclusive remedy under this EULA shall␣
→˓be, at Steema's sole option,
either (a) return of the price paid for the SOFTWARE;
(b) repair the SOFTWARE through updates distributed online. Steema cannot␣
→˓and does not guarantee
that any functions contained in the Software will meet your requirements,␣
→˓or that its operations will be
error free. The entire risk as to the Software performance or quality, or␣
→˓both, is solely with the user and
not Steema. You assume responsibility for the selection of the component␣
→˓to achieve your intended
results, and for the installation, use, and results obtained from the␣
→˓SOFTWARE.
2. Warranty.
Steema makes no warranty, to the maximum extent permitted by law, either␣
→˓implied or expressed,
including with-out limitation any warranty with respect to this Software␣
→˓documented here, its quality,
performance, or fitness for a particular purpose. In no event shall Steema␣
→˓be liable to you for damages,
whether direct or indirect, incidental, special, or consequential arising␣
→˓out the use of or any defect in the
Software, even if Steema has been advised of the possibility of such␣
→˓damages, or for any claim by any
other party. All other warranties of any kind, either express or implied,␣
→˓including but not limited to the
implied warranties of merchantability and fitness for a particular purpose,
→˓ are expressly excluded.
V. MISCELLANEOUS.

(continues on next page)
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1. This is the Entire Agreement.
This EULA (including any addendum or amendment to this EULA included with␣
→˓the SOFTWARE) is the
final, complete and exclusive statement of the entire agreement between␣
→˓you and Steema relating to
the SOFTWARE. This EULA supersedes any prior and contemporaneous proposals,
→˓ purchase orders,
advertisements, and all other communications in relation to the subject␣
→˓matter of this EULA, whether
oral or written. No terms or conditions, other than those contained in␣
→˓this EULA, and no other
understanding or agreement which in any way modifies these terms and␣
→˓conditions, shall be binding
upon the parties unless entered into in writing executed between the␣
→˓parties, or by other non-oral
manner of agreement whereby the parties objectively and definitively act␣
→˓in a manner to be bound
(such as by continuing with an installation of the SOFTWARE, "clicking-
→˓through" a questionnaire, etc.)
Employees, agents and other representatives of Steema are not permitted to␣
→˓orally modify this EULA.
2. You Indemnify Steema.
You agree to indemnify, hold harmless, and defend Steema and its suppliers␣
→˓and resellers from and
against any and all claims or lawsuits, including attorney's fees, that␣
→˓arise or result from this EULA.
3. Interpretation of this EULA.
If for any reason a court of competent jurisdiction finds any provision of␣
→˓this EULA, or any portion
thereof, to be unenforceable, that provision of this EULA will be enforced␣
→˓to the maximum extent
permissible so as to effect the intent of the parties, and the remainder␣
→˓of this EULA will continue in full
force and effect. Formatives of defined terms shall have the same meaning␣
→˓of the defined term. Failure
by either party to enforce any provision of this EULA will not be deemed a␣
→˓waiver of future enforcement
of that or any other provision. Except as otherwise required or superseded␣
→˓by law, this EULA is governed
by the laws of Spain. If the SOFTWARE was acquired outside of Spain, then␣
→˓local law may apply.
Steema Software
www.steema.com
----------------------------------------------------------------------

Packmol 18.168

MIT License
Copyright (c) 2009-2018 Leandro Martínez, José Mario Martínez, Ernesto␣
→˓Birgin
Permission is hereby granted, free of charge, to any person obtaining a␣
→˓copy

(continues on next page)
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of this software and associated documentation files (the "Software"), to␣
→˓deal
in the Software without restriction, including without limitation the␣
→˓rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in␣
→˓all
copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING␣
→˓FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN␣
→˓THE
SOFTWARE.

libssh2 1.10.0

The BSD 3-Clause License
Copyright (c) 2004-2007 Sara Golemon <sarag@libssh2.org>
Copyright (c) 2005,2006 Mikhail Gusarov <dottedmag@dottedmag.net>
Copyright (c) 2006-2007 The Written Word, Inc.
Copyright (c) 2007 Eli Fant <elifantu@mail.ru>
Copyright (c) 2009-2019 Daniel Stenberg
Copyright (C) 2008, 2009 Simon Josefsson
All rights reserved.
Redistribution and use in source and binary forms,
with or without modification, are permitted provided
that the following conditions are met:
Redistributions of source code must retain the above
copyright notice, this list of conditions and the
following disclaimer.
Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials
provided with the distribution.
Neither the name of the copyright holder nor the names
of any other contributors may be used to endorse or
promote products derived from this software without
specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR

(continues on next page)
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SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.

openssl 1.0.2m

OpenSSL License and Original SSLeay License
OpenSSL License
---------------
====================================================================
Copyright (c) 1998-2018 The OpenSSL Project. All rights reserved.
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions
are met:
1. Redistributions of source code must retain the above copyright

notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright

notice, this list of conditions and the following disclaimer in
the documentation and/or other materials provided with the
distribution.

3. All advertising materials mentioning features or use of this
software must display the following acknowledgment:
"This product includes software developed by the OpenSSL Project
for use in the OpenSSL Toolkit. (http://www.openssl.org/)"

4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to
endorse or promote products derived from this software without
prior written permission. For written permission, please contact
openssl-core@openssl.org.

5. Products derived from this software may not be called "OpenSSL"
nor may "OpenSSL" appear in their names without prior written
permission of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following
acknowledgment:
"This product includes software developed by the OpenSSL Project
for use in the OpenSSL Toolkit (http://www.openssl.org/)"

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY
EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR
ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGE.
====================================================================
This product includes cryptographic software written by Eric Young

(continues on next page)
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(eay@cryptsoft.com). This product includes software written by Tim
Hudson (tjh@cryptsoft.com).
Original SSLeay License
-----------------------
Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)
All rights reserved.
This package is an SSL implementation written
by Eric Young (eay@cryptsoft.com).
The implementation was written so as to conform with Netscapes SSL.
This library is free for commercial and non-commercial use as long as
the following conditions are aheared to. The following conditions
apply to all code found in this distribution, be it the RC4, RSA,
lhash, DES, etc., code; not just the SSL code. The SSL documentation
included with this distribution is covered by the same copyright terms
except that the holder is Tim Hudson (tjh@cryptsoft.com).
Copyright remains Eric Young's, and as such any Copyright notices in
the code are not to be removed.
If this package is used in a product, Eric Young should be given␣
→˓attribution
as the author of the parts of the library used.
This can be in the form of a textual message at program startup or
in documentation (online or textual) provided with the package.
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions
are met:
1. Redistributions of source code must retain the copyright

notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright

notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software
must display the following acknowledgement:
"This product includes cryptographic software written by
Eric Young (eay@cryptsoft.com)"
The word 'cryptographic' can be left out if the rouines from the library
being used are not cryptographic related :-).

4. If you include any Windows specific code (or a derivative thereof) from
the apps directory (application code) you must include an␣

→˓acknowledgement:
"This product includes software written by Tim Hudson (tjh@cryptsoft.

→˓com)"
THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
SUCH DAMAGE.

(continues on next page)
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(continued from previous page)

The licence and distribution terms for any publically available version or
derivative of this code cannot be changed. i.e. this code cannot simply be
copied and put under another distribution licence
[including the GNU Public Licence.]

Delphi/Pascal Wrapper around the library “libssh2”

The BSD 4-clause License and Mozilla Public License 1.1
Copyright (c) 2004-2009, Sara Golemon <sarag@libssh2.org>
Copyright (c) 2009 by Daniel Stenberg
Copyright (c) 2010 Simon Josefsson <simon@josefsson.org>}
All rights reserved.
Redistribution and use in source and binary forms,
with or without modification, are permitted provided
that the following conditions are met:
Redistributions of source code must retain the above
copyright notice, this list of conditions and the
following disclaimer.
Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials
provided with the distribution.
Neither the name of the copyright holder nor the names
of any other contributors may be used to endorse or
promote products derived from this software without
specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.
Copyright (c) 2010, Zeljko Marjanovic <savethem4ever@gmail.com>
This code is licensed under MPL 1.1
For details, see http://www.mozilla.org/MPL/MPL-1.1.html

Balloon

IMPORTANT: THIS SOFTWARE END USER LICENSE AGREEMENT (EULA) IS A LEGAL
AGREEMENT BETWEEN THE LICENSEE (HEREINAFTER "YOU", EITHER AN INDIVIDUAL
OR ANY OTHER LEGAL ENTITY) AND THE COPYRIGHT OWNER(S) OF THE BALLOON
SOFTWARE (HEREINAFTER "SOFTWARE"). READ IT CAREFULLY BEFORE DOWNLOADING
AND USING THE SOFTWARE. IT PROVIDES A LICENSE TO USE THE SOFTWARE AND
CONTAINS WARRANTY INFORMATION AND LIABILITY DISCLAIMERS. BY DOWNLOADING

(continues on next page)
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(continued from previous page)

AND/OR USING THE PROGRAM, YOU AGREE TO BECOME BOUND BY THE TERMS OF THIS
AGREEMENT. IF YOU DO NOT AGREE TO BE BOUND BY THESE TERMS, THEN DO NOT
DOWNLOAD OR USE THE SOFTWARE AND DELETE THE SOFTWARE FILES FROM YOUR
COMPUTER SYSTEM.
1. Through any use of the Software You acknowledge your acceptance of the
conditions of this license.
2. You acknowledge and agree that the Software is proprietary to the␣
→˓Copyright
owner(s), and is protected under Finnish copyright law and international
copyright treaties. You further acknowledge and agree that all right, title
and interest in and to the Software, including all intellectual property
rights, are and shall remain with the Copyright owner(s).
3. There is no fee for the use of the Software, which is provided to you
"free of charge" as a public service.
4. As is common courtesy, you agree to acknowledge your use of the Software
in any reports or publications that include any results obtained with the
Software.
5. License Grants

1. The licensee is granted a non-exclusive license to use the Software␣
→˓in

accordance with the terms of this EULA.
2. You may redistribute unmodified copies of the Software to third␣

→˓parties.
The receiver of the Software will have same rights and responsibilities␣

→˓as
if the Software would have been obtained directly from the original
distribution site, i.e. the receiver is bound by the terms of this EULA.

6. License Restrictions
1. You may not alter, merge, modify, adapt or translate the Software,
or decompile, reverse engineer, disassemble, or otherwise reduce the
Software to a human-perceivable form.
2. You may not sell, rent, lease, or sublicense the Software.
3. You may not modify the Software or create derivative works based␣

→˓upon the Software.
7. License Termination

In the event that you fail to comply with this EULA, the Copyright␣
→˓owner(s)

may terminate the license. Upon any termination of this EULA, you shall
immediately discontinue the use and destroy all copies of the Software.

8. Governing Law
This EULA shall be governed by the laws of Sweden without reference to␣

→˓its
conflict of law provisions.
The court of Stockholm, Sweden, shall be the first instance forum for
settlement of any disputes arising under this EULA.

9. WARRANTY DISCLAIMER
THE COPYRIGHT OWNER(S) PROVIDE(S) NO TECHNICAL SUPPORT, WARRANTIES OR
REMEDIES FOR THE SOFTWARE. THE PROGRAM IS PROVIDED "AS IS" AND MAY␣

→˓CONTAIN
ERRORS ("BUGS"), BE BASED ON ERRONEOUS ASSUMPTIONS, OR HAVE OTHER␣

→˓DEFECTS,
KNOWN AND UNKNOWN. CONSEQUENTLY, THERE IS NO WARRANTY WHATSOEVER FOR THE

(continues on next page)
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(continued from previous page)

PROGRAM, WHETHER EXPRESSED OR IMPLIED, INCLUDING THE SUITABILITY OF THE
PROGRAM FOR ANY PARTICULAR PURPOSE OR INFRINGEMENT; THUS YOU ACCEPT ALL
RESPONSIBILITY WITH REGARD TO THE PERFORMANCE OF THE PROGRAM, THE␣

→˓RESULTS
OBTAINED, AND THE USE AND INTERPRETATION OF SUCH RESULTS, AND ANY FUTURE
CONSEQUENCES ARISING FROM YOUR USE OF THE PROGRAM OR RESULTS DERIVED
THEREOF.

10. LIMITATION OF LIABILITY
YOU AGREE NOT TO HOLD LIABLE FOR DAMAGES, IN ANY WAY, SHAPE OR FORM,
ANY COPYRIGHT HOLDER OR OTHER PARTY HAVING THE RIGHT TO REDISTRIBUTE OR
MODIFY THE PROGRAM. SUCH DAMAGES INCLUDE BUT ARE NOT LIMITED TO GENERAL,
SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR
INABILITY TO USE THE PROGRAM,
LOSS OF DATA, INACCURATE MODIFICATION OF DATA, OR ANY OTHER LOSSES
INCURRED BY YOU OR BY A THIRD PARTY AS A RESULT OF THE USE OF THE␣

→˓PROGRAM
OR INABILITY TO USE THE PROGRAM, OR INABILITY OF THE PROGRAM TO WORK
TOGETHER WITH OTHER PROGRAMS. YOU AGREE THAT THE COPYRIGHT HOLDERS AND
OTHER RESPONSIBLE PARTIES MAY HAVE KNOWLEDGE OF SUCH DEFECTS,␣

→˓INACCURACIES,
LACK OF OPERATIONAL COMPATIBILITY WITH OTHER PROGRAMS, OR THE␣

→˓POSSIBILITY
OF SUCH DAMAGES, AMONG OTHER DEFECTS, AND THAT YOU WILL NOT HOLD THESE
PARTIES LIABLE FOR ANY DAMAGES RESULTING TO YOU OR TO A THIRD PARTY
ARISING FROM YOUR USE OF THE PROGRAM.

BALLOON Copyright © 2006-2018 Mikko Vainio.
BALLOON Copyright © 2008-2014 J. Santeri Puranen.
BALLOON Copyright © 2010 Visipoint Ltd.
All rights reserved.

JSME

Copyright (c) 2017, Novartis Institutes for BioMedical Research Inc and␣
→˓Bruno Bienfait
All rights reserved.
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.

* Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the distribution.

* Neither the name of the Novartis Institutes for BioMedical Research␣
→˓nor the

names of the authors may be used to endorse or promote products
derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED "AS IS" AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE␣
→˓IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL COPYRIGHT HOLDERS BE LIABLE FOR ANY
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES

(continues on next page)
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(continued from previous page)

(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR␣
→˓SERVICES;
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF␣
→˓THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
JSME uses code from the following libraries:

- Apache Harmony - Apache License v2.0 http://www.apache.org/
→˓licenses/

- gwt-mosaic - Apache License v2.0 http://www.apache.org/
→˓licenses/

- gwt-exporter - Apache License v2.0 http://www.apache.org/
→˓licenses/

- gwt - Apache License v2.0 http://www.apache.org/
→˓licenses/

- OpenChemLib - https://github.com/Actelion/openchemlib/blob/
→˓master/LICENSE

- InChI 1.05 - http://www.inchi-trust.org/
- emscripten - https://kripken.github.io/emscripten-site/index.

→˓html

Spglib

BSD 3-Clause "New" or "Revised" License
Copyright (c) 2014, Atsushi Togo
All rights reserved.
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions
are met:
* Redistributions of source code must retain the above copyright

notice, this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the distribution.

* Neither the name of the <organization> nor the
names of its contributors may be used to endorse or promote products
derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL <COPYRIGHT
HOLDER> BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

GEMMI

1.3. The libraries used 17
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https://www.mozilla.org/en-US/MPL/2.0/
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CHAPTER

TWO

INSTALLATION GUIDE

2.1 Software requirements

Winmostar supports the followings operating systems.

• Windows 11 (64bit)

• Windows 10 (64bit)

• Windows 8 (64bit)

• Windows 7 (64bit)

In the case of Windows Server, please obtain the FREE edition or trial and use it after verifying the operation. macOS
and Linux users can use the Windows OS after installing it on a virtual environment such as VirtualBox. It will generally
work on 32-bit operating systems, but please evaluate it with a free trial before purchasing.

2.2 Hardware requirements

The minimum spec of Winmostar is as follows.

• CPU and RAM: According to the hardware requirements of Windows 7/8/10/11

• HDD: 20 GB or more free space

It can be used with general office work, PC surfing, etc. A network connection is not required for the software to work,
so Winmostar can be used on computers that are not connected to a network. The recommended specs conform to
the recommended specs of the solver used together because the Winmostar main unit operates on a relatively low-spec
PC. If the recommended specifications of the solver are unknown, prepare a CPU machine with a high floating point
arithmetic function (number of cores x frequency). Since HDD and memory can be expanded relatively easily later,
standard capacity is acceptable.
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2.3 Recommended version of solver

Table 1: Recommended version of solver

MOPAC 6, 7
GAMESS 2020-R2
NWChem 7.0.2
Gaussian 16
Gromacs 5.0.7
LAMMPS 29/Sep/2021 ed.
Quantum ESPRESSO 7.1
OpenMX 3.8

It will generally work with versions other than the ones listed here, but please verify that it works before using it, as it
is not guaranteed to work.

2.4 Recommended remote servers

Installation instructions refer to instructions for CentOS, but various Linux OSes such as Ubuntu can be used if they
have the following features.

• Communication using SSH and SCP is possible.

• Standard shells such as bash and csh

• Can execute standard UNIX commands

• Various solvers used from Winmostar can be installed and used.

If you want to schedule jobs on the remote server, you need to install the following job scheduler on the remote server.
If you do not need job scheduling and can run calculations directly on the node to which you are connected via SSH,
you can use the remote server without installing a job scheduler. You can also add the job scheduler of your choice in
the Customization in Paid Support.

• Recommended
– Torque, OpenPBS, PBS Professional (PBS)

– Sun Grid Engine (SGE), Univa Grid Engine (UGE), Altair Grid Engine (AGE)

– Slurm Workload Manager (SLURM)

– FUJITSU Software Technical Computing Suite (PJM)

• Only some functions are supported.
– IBM Platform Load Sharing Facility (LSF)
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2.5 Installing Winmostar and solvers

If the installation cannot be performed as expected, check Frequently asked questions · Troubleshooting.

1. If you have not obtained a license code, you can register and obtain a license at the following link. The differences
between the editions can be found in the Features List.

• FREE edition

• STUDENT edition

• PROFESSIONAL edition

• PROFESSIONAL edition (trial)

2. Download the Winmostar installer for the latest stable version <https://winmostar.com/en/download#latest_
stable>`_ .

Note:
• Please check the system requirements with Hardware requirements.

• If you have already obtained the installer from a USB flash drive, DVD, or User Portal, you do not need to
do this.

3. Double-click the installer to launch it and click “Next. [On the “Select Component” screen, click “Next” with
the “64-bit executable file” checked.

Warning:
• If Winmostar is running, close it beforehand.

• The 32-bit version has been deprecated since Winmostar V11.5.0.

4. [Click “Install” to begin installation. If necessary, click Browse to change the destination folder (default is
C:\winmos11).

Warning:
• If multibyte characters such as Japanese and double-byte characters and special symbols are included

in the installation folder and the name of the higher hierarchy, some modules may cause problems.

• If the text and other items are enlarged or reduced in the display settings, the display may be partially
disrupted. For more information here.

• Installation under C:\Program Files is not possible.

Note:
• After the installation is complete, shortcuts will be created in the Start menu and on the desktop.

• If you receive a warning of anti-virus software, please ignore it and continue installation (the same below).

• If the past version of Winmostar has already been installed, it is possible to install it overwritten or change
the installation folder to coexist with the past version.

• To upgrade, check Update or Upgrade.
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5. In the case of a new installation, start Winmostar and set the license code in the dialog that appears at the first
boot.

Note:
• This operation is not necessary if the delivered licensed installer is used.

6. Follow the procedure to build a Cygwin environment for Winmostar.

Note:
• NWChem, LAMMPS, Gromacs, MODYLAS, Quantum ESPRESSO, OpenMX, and Towhee are included

in CygwinWM. (However, NWChem, LAMMPS, and Quantum ESPRESSO will be included in Cyg-
winWM version 04/05/2023 or later.

• If you want to run NWChem in parallel, you need to install MPICH according to the NWChem Installation
Manual in the next step.

7. For the solver to be used on a Windows PC (local machine) on which Winmostar is installed, follow the instruc-
tions in the link below. If you want to perform calculations only on a remote server, you must also install it on
the local machine. Some solvers are already installed with CygwinWM and do not need to be installed here.

• GAMESS Installation Manual for Windows

• NWChem installation manual for Windows

• Gaussian installation manual for Windows

• NAMD installation manual for Windows

• FDMNES Installation Manual for Windows

• AkaiKKR installation manual for Windows

If you are using Winmostar V11.4.X or earlier, CygwinWM 07/15/2022 or earlier version, or 32-bit environment (dep-
recated), please also see below.

• LAMMPS Installation Manual for Windows

• Quantum ESPRESSO for Windows Installation Manual

Note:
• LAMMPS installation is required to use the Polymer Builder. (Winmostar V11.4.X or earlier or

CygwinWM 07/15/2022 version or earlier)

• There is no need to install a solver that you do not plan to use.

• If you want to use MOPAC6 with extended maximum number of atoms, you can get it from MOPAC6
(not guaranteed).

8. If necessary, exclude the installation folders of Winmostar, CygwinWM, and solver from the monitoring target
in the configuration of the security software you are using.

9. Change the setting to display the extension of each file on Explorer.

• Not required.
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• If you don’t know how to set it up, check Q. How do I view the extension in Windows Explorer?.

10. If you want to submit jobs to the remote server and schedule jobs on the remote server, make sure that the
supported job scheduler is installed on the server. If you do not have Slurm, follow the steps in the link below to
install Slurm.

• Slurm installation method (for Rocky Linux).

Note:
• If job scheduling is not required and calculations can be performed directly on the node to which

SSH is connected, there is no need to install a job scheduler on the remote server.

• Various job schedulers other than Slurm are also available from Winmostar, so you do not necessarily
need to install Slurm. If you are installing a new job scheduler, the procedure for Slurm is relatively
simple.

11. When submitting a job to a remote server, install the solver used in the destination server according to the fol-
lowing procedure.

• GAMESS installation manual for Linux (only Japanese)

• NWChem installation manual for Linux <https://winmostar.com/en/gmx4wm_en_linux.html>`_

• Gromacs for Linux Installation Manual (only Japanese)

• LAMMPS instllation manual for Linux (only Japanese)

• Quantum ESPRESSO installation manual for Linux (only Japanese)

• OpenMX installation manual for Linux (only Japanese)

• DCDFTBMD installation manual for Linux (only Japanese)

12. Now, you are ready to use Winmostar. Please refer to Tutorials if necessary

2.6 Uninstalling Winmostar

You can uninstall by deleting Winmostar installation folder and shortcut.

2.7 Update

Updates (minor version or revisions) can be performed in the same way as the installation. Example: V11.0.0 to
V11.1.0, V10.4.0 to V10.4.5

• If you want to keep the old version, you can take over the settings by copying the files under the UserPref folder
of the old version to the following in the UserPref folder of the new version.

• The UserPref folder is located under the Winmostar installation folder.
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2.8 Upgrade

Upgrades (major version updates) can be performed in the same way as installations. Example: V8.000→V9.0.0,
V10.0.0→V10.0.0

• If you are upgrading from V3, V4, V5 or V6, you can take over the configuration by copying the configuration
files atoms1.wmx, winmos_server.ini, wm_nmr.ref, and wm_irscale.ref under the installation folder of the old
version to the UserPref folder under V11.

• If you are upgrading from V7, V8 or V9, you can take over the settings by copying wmset.ini, atoms1.wmx,
winmos_server.ini, wm_nmr.ref, and wm_irscale.ref under the UserPref folder of the old version to the UserPref
folder of V11.

• The UserPref folder is located under the Winmostar installation folder.

• For more information, see V11 Migration Guide, V10 Migration Guide and V9 Migration Guide.
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CHAPTER

THREE

MAIN WINDOW

3.1 Role of each part

The window (called Main Window ) that appears after starting Winmostar has the
configuration shown below. In the title of Main Window, the name of the file cur-
rently being edited, the license and version of Winmostar in use are displayed.

Toolbar
Here you can also select commonly used functions in the main menu. You can check the role of each
button by overlaying the pointer. In addition, only the following functions perform special operations.

• Depending on the solver selected in the Solver pull-down menu

(default is MOPAC) in the first row of the upper
toolbar, the role of buttons such as Configure, Run will change.

• Depending on the element selected in the Select element used in editing operations pull-down
menu, the behavior of Add Atom and Change Element buttons beside it will change.

Project Display Area
Projects created in the past are displayed in Recently used projects. Double-click on an item to open
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that project. The project display area is only visible in project mode. Working Folder displays the
working folder for the currently opened project. Clicking on Options allows you to select operations
for the selected working folder. Double-clicking on an item opens the input file for that working
folder. The eyeball icon will appear in the working folder that contains the file displayed in the
molecule display area. If that folder is not selected with working folder, the eyeball icon will appear
red. In action, an operation on the working folder selected by working folder will appear.

Viewport
The molecular structure currently being edited is displayed. By default, the structure where carbon
atom (green) and hydrogen atom (yellow) are bonded is displayed.If the View→ Items→ Information
menu is checked, detailed information will be displayed at the top and bottom.Red circle indicates
atom selection marker.In group selection state, atoms are surrounded by blue circles.You can tog-
gle the number displayed on the side of each atom and the type of charge value from the View →
Labels/Charges menu.The color scheme can be changed from the Tools → Preferences → View . If
the :menuselection: View –> Display items –> Molecular information` menu is checked, detailed
information is displayed at the top and bottom. For structures with charge or spin, the total charge
(Qtot) and root mean square (Qrms) are displayed at the bottom. For structures with cells, the density
and lattice constant are displayed at the bottom. If the dipole moment was calculated directly from
the wavefunction obtained in the quantum chemical calculation and read from the log of the quantum
chemical calculation, its value is also displayed. For structures with cells, the density and lattice
constant are displayed at the bottom. In project mode, the name of the file being displayed is shown
at the top of the molecule display area. If the file being displayed is not contained in the working
folder selected in the working folder, it is displayed in red.

Animation operation area
The animation control buttons are displayed. Click title to show/hide.

Keyword Editor
The settings in the Keyword Settings window for each solver will be displayed. Alias characters such
as %WM_XYZ%, %WM_ZMAT%, etc. appear in the molecular structure-dependent parts of the
keywords. Click title to show/hide.

Coordinate Viewer
The coordinates of each atom of the molecular structure displayed in Viewport are displayed. The
Display format at the top allows you to switch the display format. By default XYZ is selected.In a
state where no group is selected, the line selected in Coordinate Viewer matches the atom with the
marker (red circle). You can make a group selection (blue circle) by selecting multiple lines with
Ctrl+left click or Shift+left click. Click on the title to show/hide it.

3.2 Mouse controls

In Viewport, you can operate with the mouse as shown in the table below. Details on how to select
molecules/atoms can be found in Select menu.
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Modifier
Key

Left click Left drag Right click Right drag/
Wheel

None Move marker Roll camera Show context menu Zoom in/out
Shift

Select molecule
or unselect

Pan camera Delete atom

Ctrl

Select each atoms
or unselect

Select atoms in rect-
angle area

Ctrl+Shift Replace with Frag-
ment

Note that you can also zoom in or out by left-dragging the right end of Viewrport.

3.3 Shortcut keys

In Main Window you can use the shortcut keys in the table below.

Table 1: Basic operations

New Ctrl+N
Open Ctrl+O
Save Ctrl+S
Save As Shift+Ctrl+S
Undo Ctrl+Z
Redo Ctrl+Y
Cut Group Ctrl+X
Copy Group Ctrl+C
Paste Group Ctrl+V
Help F1

Table 2: Modelling

Replace with Fragment F6
Add Atom by Specifying Position F4
Delete atom Shift+F4
Add/Change Bond F7
Delete Bond F8
Move Atom (Translate) F5
Change Element Shift+F5
Add Hydrogens to All Atoms Ctrl+H
Delete Group Ctrl+D
Build Ring F9
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Table 3: Modifying structure

Quick Optimization Ctrl+G
Move Group (Direct) Ctrl+M
Rotate Around Axis (2 Marked Atoms) Ctrl+R
Rotate Around Axis (3 Marked Atoms) Ctrl+A
Change Optimization Flags of Group Ctrl+I
Adjust All Bond Length Ctrl+J
Orbit Group Around Marked Atom Ctrl+F
Quick Optimization for Group Ctrl+L

Table 4: Controlling Display

Zoom In F3
Zoom Out F2
Fit to Window Ctrl+4
Align View Ctrl+1, 2, 3
Show Keyword Editor & Coordinate Viewer F10
Export Image Ctrl+Alt+I
Copy Image Ctrl+Alt+C
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CHAPTER

FOUR

BASIC OPERATION FLOW

Here, we introduce the basic operation flow of quantum chemical calculation, molecular dynamics calculation, or first
principles calculation using Winmostar. Start Winmostar and click on file → new project in project mode or file →
new file in file mode.

Project Mode
You can manage jobs without being aware of individual files. We recommend using this mode for non-free users.

File Mode
Explicitly operates on individual files, with procedures compatible with V10 and earlier. Use this mode when
using the free version or a solver/job scheduler that does not support project mode, or when running calculations
using input files for each solver created outside of Winmostar.

4.1 For project mode

A description of the files that make up the project can be found in New Project.

(1) Create initial structure

Click file → New Project and follow the Structure Building procedure to create the system you
want to calculate. Click file → New project with current structure to switch from file mode to
project mode, for example, with an existing structure file open. If you want to run calculations
on an existing structure file, you can click file → New Project and then use file → Import File
to load the structure.

(2) Configure simulation conditions

Select the solver you want to use at Sovlver pull-down menu

, and click Workflow Setup button .
The # of Jobs specifies the number of jobs to be executed this time. If # of Jobs is 2 or more,
jobs are executed sequentially, with the final structure of each job being used as the initial
structure of the next job. In the central part of the workflow settings window, you specify the
calculation conditions for each job. Finally, click OK.

(3) Run simulation

• To execute calculations on Windows PC with Winmostar installed ( **Local job** )

In the Job Settings window, check Run Job on this machine and click Run. Enter the num-
ber of MPI processes to use ( # of MPI Procs ) or the number of threads per MPI process
( # of Threads/MPI Proc ) (or total threads if no MPI is used) in the Number of Parallels
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field . For the parameter and structure scan functions, enter the number of parallels for each
calculation. The Winmostar Job Manager processes the registered jobs in order. After
executing, check the status of each working folder in the project display area. If the com-
putation proceeded normally, the state will change from NEW to PEND to RUN to END.
If there is an anomaly, the state will be ABORT. Project Display Area, hovering the cursor
over a working folder will display an error message. Click on the working folder and in the
Actions click on Log to see the log of the calculation. To stop a job, right-click on the job
you want to stop in the working folder in the project view area and click Stop.

• When running on a Linux machine connected to the network on Winmostar installed PC (Remote
job)

You can also check the instructions at Remote Job Tutorial (Japanese only). In the Job
Settings window, check the Run job on remote machine checkbox. In the Profile select the
server settings you want to use. If there is no appropriate profile, click Config and enter the
server information. See Remote Job Setup Procedures in file mode for more information.
If you need to specify a separate environment variable to use the solver on a remote server,
click New in the Template Script, edit the shell script to use when submitting jobs, and select
it in Template Script. options are arguments for commands (such as qsub) to submit jobs on
remote servers. Typically, options are entered that depend on the type of queue you want
to use and your machine configuration. You can use Alias string available for remote job
function in this field to abstractly specify the number of parallels, etc. Profile and Options
can be tested with Test Connection. Details of the Test Connection can be found at Test
Connection. You can also use Control to check for free queues, etc.

Enter the number of MPI processes to use ( # of MPI Procs ) or the number of
threads per MPI process ( # of Threads/MPI Proc ) (or the total number of threads
if MPI is not used) in # of Parallel. (If you don’t use MPI, enter the number of
threads per MPI process. (For the parameter and structure scan functions, enter
the number of parallels for each calculation.)

The job description can be a description of the working folder that will be created by the
execution. This description can be modified later with Get Info. Finally, click Run. The reg-
istered jobs will be executed in order on the remote server. After execution, check the status
of each working folder in the project display area. If the calculation proceeded normally, the
state will change from NEW to SEND to PEND to RUN to END(Rem) to RECV to END(-).
If there is an abnormality, the status becomes ABORT. If the job status is not determined
successfully, use Recheck Status. Error message appears when hovering the cursor over the
working folder in the project display area. Right-click on the working folder and click Open
Remote stdout or Open Remote stderr to see the standard output and standard error when
executed remotely. You can see the log of the calculation by clicking on the working folder
and clicking Log in Actions. If the status is END(-) and you have finished successfully on
the remote server, click on the working folder and under Actions click Receive All Remote
Output Files and all output files will be saved to the local Transfer to machine. To stop a
job, right-click on the job you want to stop in the working folder in the project view area
and click Stop. If you want to check the end of the log or retrieve and visualize some files
while the job is running, right-click the target job in the working folder of the project view
area and click Control Remote Job/Server ` in the :guilabel:`Project View Area. See Each
function of the Submit Remote Job window for instructions on how to operate the Control
Remote Job/Server window that opens.

• If you do not want to run the calculation directly from Winmostar and only want to save the file

Configure Job window, set up as you would for a local or remote job, then check Do not
run own part after saving file and click Save at the bottom right. Then click File → View
in Explorer to see the set of saved input files, batch files, and shell scripts. If you want to
run the job later, use Run.
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(5) Display and analyze physical quantities

(6) Extend job

(1) Create initial structure

Click file → New File and follow the Structure Building procedure to create the system you
want to calculate.

(2) Configure simulation conditions

Select the solver you want to use at Sovlver pull-down menu

, and click Keyword Setup button .
For some solvers, if you put a pointer over the keyword column, the meaning of that keyword
will appear.

(3) Run simulation

• To execute calculations on Windows PC with Winmostar installed ( **Local job** )

– With the configure window open, press the Run button.

– Press the OK button to close the configure window. So if you want to modify the
keywords directly, enter at Keyword Editor or edit the input file from the Open in Text

Editor using any text editor. Then click the Run button on the tool bar .

After clicking Run, if the input file is not saved, entering the name of the input file will be
saved, then the job will be registered in Winmostar Job Manager. Winmostar Job Manager
will process the registered jobs in order. When you want to abort a job, close the appropriate
console window or perform Ctrl-C while the appropriate console window is active.

• When running on a Linux machine connected to the network on Winmostar installed PC (Remote
job)

Press the OK button to close the configure window. Next, click the Submit Remote Job

button on the tool bar to set up connection to the server. See Remote Job Setup
Procedures in file mode for how to set it up. After that, press the Send & Submit button on
the Submit Remote Job window to save and transfer (send) the input file and register the job
at the remote server (submit) at once. Registered jobs are executed in order on the remote
server. When the job ends on the remote server Press the Get All Files button to transfer
the file output from the calculation to the Windows PC where Winmostar is installed. See
Remote Job Operation Procedures in File Mode for other detailed operations. If you want
to abort a job, remember the job ID that appears immediately after you run Send & Submit,
and in the Submit Remote Job window, click Queue → Kill Click `Submitted Job and enter
the job ID.

• If you do not want to run the calculation directly from Winmostar and only want to save the file
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For LAMMPS, Gromacs, and Quantum ESPRESSO:

Go to the Options tab in the keyword configuration window, press the Dump all
files for remote button, enter a file name and save it.

For other solvers:

Close the Keyword Setup window by clicking the OK button. Then click File
→ Save As to save the file. If you want to save not only the input file but also
accompanying files such as shell scripts, use the project mode.

(4) Confirm log

Press the Open Log File button on the toolbar. You are asked which file to open.
If the input file of the calculation you want to check log is displayed in the main window, open
the file selected by default. The log file is displayed with a text editor, then check whether the
job has ended normally or abnormally.

(5) Display and analyze physical quantities

If the job has ended normally, press the Analysis button on the toolbar and select
the menu of physical quantities you want to display. You will be asked which file to open, so
choose as appropriate. As with log checking, the one associated with the file displayed in the
main window is selected by default. When you specify a file, a window for the result display is
displayed.

• To visualize the structure optimization process or trajectory, press the Animation button on

the tool bar .

• To plot changes of energies and temperature during SCF or MD calculation, press the

Energy Plot button on the tool bar.

• For analysis of molecular shape, use functions below Tool menu.

(6) Extend job

If it is necessary to extend or continue the job, open the configure window again and start the
job.

• For MD, check Continue Simulation in the configure window.

• For Quantum ESPRESSO, set Continue to Output Direcotory in the configure window.

• If you want to run simulation after the structure optimization for semi-empirical QM or QM

solvers, press the Animation button on the toolbar, display the final structure
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on the main window and configure for the next job.
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FIVE

STRUCTURE BUILDING

5.1 Modelling a single molecule

Select one of the following methods.

• Draw and read structure expressions with file → import → Structural Formula.

• Read SMILES format string from File → Import → SMILES.

• Load files in various formats (PDB, mol, mol2, SDF, CIF, xyz, etc.) by file → Import File or drag
and drop into the main window.

• Build 3D molecular structure from directly on the main window.

Return to the initial structure with edit → Reset Structure and select the required operation
from Edit menu as appropriate.

1. Execute Replace with Fragment to the initial structure (carbon and hydrogen atoms) so
that the shape approaches a certain degree to the target molecule.

2. For structures with adjacent aromatic rings, execute Build Ring.

3. Execute Delete at the place where you want to delete the unnecessary substructure.

4. In a place where you want to add a hydrogen atom, execute To marked atoms (Single),
(Double), (Triple).

5. Execute Element at the place where you want to change the element of atom.

6. Execute Add/Change Bond where you want to create chemical bonds. Also change the
type of binding by the same operation.

7. Execute Quick Optimization to adjust to a reasonable atomic arrangement. (Only when
the number of atoms is small)

8. To explicitly rotate the substructure, execute Modify Selected Group → Rotate Around
Axis (2 Marked Atoms).

9. For molecules that can take various conformations, Tools→Conformation Search (Bal-
loon) and choose a structure with low energy.

• In the case of a polymer, you can model a whole molecule directly, but it is more efficient to use the
method of Creating polymer melt system.
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5.2 Assigning point charges

I will show you how to set up the point charges required for MD calculations on Winmostar. First create a
single molecule using the Modelling a single molecule method, then assign the charges using the following
method. The assigned charges can be displayed and checked by changing Label/Charge. Note that there
is no need to explicitly set the charge for water molecules, since the water model charge values selected at
the time of force field assignment are applied unconditionally. If you want to average or shift the charge
of some atoms, use Average the group’s charge or Shift Charges of Group.

• Assign Gasteiger charge.

Assigning a charge manually by MD → Assign Charges Manually → Use AM1-
BCC/Gasteiger charges. For ions, input the charge in Total charge [e]. If it is an ion,
input the charge in Total charge [e].

• Assign RESP charge automatically.

:Assigning charges by menuselection:MD –> manually assign charge –> Use RESP charges
procedure. For ions, enter the charge in Total charge [e].

• Manually assign RESP charges in GAMESS or Gaussian.

1. In file mode, at QM → GAMESS/Gaussian → Keyword Setup → Easy Setup, set the calcula-
tion method and basis functions to “HF/6-31G*”, select Method Select :guilabel:`Method and
ESP/RESP. For ions, enter the charge in Charge.

2. Close the Easy Setup window with the OK button and press the Run button in the
GAMESS/Gaussian Setup window to run the calculation

3. When the GAMESS/Gaussian calculation is finished, get the RESP charge at QM →
GAMESS/Gaussian → result analysis → RESP Charges.

• Read the charge calculated from the population analysis, e.g. Mulliken or Lowdin charge, for into
the main window.

– In the case of MOPAC, read in the procedure of MO & Charges (mgf).

– For Quantum ESPRESSO, use Solid → Quantum ESPRESSO → Lowdin Charge.

– Otherwise, open the log file in the main window.

• Enter a value for the selected atom.

– Group select atoms for which you want to input a charge in the Viewport, and then input a charge
from Edit → Change Atom Property → Charge/Spin Density.

– edit → Edit Charge to enter charge from.

• Edit and assign directly on the text file.

– Once the molecular structure is saved in File → Save As in mol2 format, open the mol2
file with any text editor and edit the values in the ninth column of the section starting with
@<TRIPOS>ATOM. After editing, click on file → Reload to load the edited structure.

• In the case of polymers, the method of Creating polymer melt system is used because it takes time to
calculate AM1/BCC and RESP charges of the whole molecule directly.

5.2. Assigning point charges 35



Winmostar™ User Manual, Release 11.13.0

5.3 Creating an isolated system (gas phase)

1. Create a structure of one molecule (See Modelling a single molecule). In the case of quantum chemistry simu-
lation, since the period boundary condition is not used, the subsequent operation is unnecessary.

2. In the case of MD simulation, assign point charges (See Assigning point charges).

3. Create a cell by Edit → Create/Build Cell → Create/Edit Cell.

5.4 Creating a small molecule liquid system

1. Create a structure of one molecule (See Modelling a single molecule).

2. In the case of MD simulation, assign point charges (See Assigning point charges).

3. Save a file by File → Export File in mol2 or wmm format.

4. Procedures 1 to 3 are performed for all molecular species to be calculated.

5. Select MD → Solvate/Build Cell.

6. Determine which molecules to put in the system. For the molecules displayed in the main window,
press Add Displayed Molecule. For water molecules, press Add Water. For the other cases, press
Add File.

7. Enter the number of molecules to be inserted into the system.

8. Perform 6 and 7 for all molecular species you want to calculate.

9. Set the system size at Simulation Cell and press Build button.

Note:
• If the density is too high, the creation of the system may fail, so start with a low density (about 40

% of the experimental value of the substance of interest or a substance similar to the substance of
interest, if known) and adjust the density with Edit → Create/Edit cell →Transform Cell or run the
MD calculation and compress gradually to the desired density and pressure with a constant pressure
calculation.

• Use Modify Selected Group → Replicate Group, Create/Edit Cell and Import File when CygwinWM
is not installed or it is difficult to arrange with Solvate/Build Cell.

5.5 Creating polymer melt system

1. Create a polymer repetition unit to be calculated by the method Modelling a single molecule. For example, in
the case of polyethylene, create an ethane molecule instead of an ethylene molecule.

2. In the case of MD calculation, the charge is assigned by the method Assigning point charges in the state of the
repeting unit.

3. In Molecule Display Area, left-click two atoms connected with the neighboring repeat unit and register them as
monomers by MD → Polymer → Register repeat unit.

4. Depending on the structure of the polymer to be created, perform operations MD → Polymer → Homo Polymer
builder, Block Polymer Builder and Random Polymer Builder.
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Tip:
• For example, in the case of a structure like -[AAABBB]-, create AAABBB using Block Polymer Builder first,

then open a wpo file generated in the wpo folder, register as a new repeat unit at Register repeat unit and
execute Homo Polymer builder.

5. Create a simulation cell by performing the operation MD → Polymer → Polymer Cell Builder.

6. If a small molecule component is dissolved in the polymer, create the dissolved small molecule by the procedure
of Modelling a single molecule and Assigning point charges and save it in mol2 format beforehand. Then, select
and insert the mol2 file of small molecule at MD → Insert Molecules, which was saved after step 5. If the density
is not set low in step 5, the insertion of small molecule components may fail.

5.6 Creating gas-liquid interface

1. Create a liquid phase (see Creating a small molecule liquid system).

2. In Edit → Transform Cell, check Transform only along the selected axis and Do not change, then check Set
incremental length or Set total length, enter a value and press the OK button.

Note:
• Select edit → Wrap Around Cell Boundary before expanding the structure of the liquid phase because there

are many atoms with coordinates outside the simulation cell in the structure after MD calculation. For
molecular systems, select relocate molecular units inside the cell; for inorganic systems, select relocate
atomic units inside the cell.

5.7 Creating gas-liquid interface

1. Create one of the liquid phases using Creating a small molecule liquid system. At this time, a mol2 file should
be created in advance for all types of molecules contained in the two phases.

2. Save a file by File → Export File in mol2 format.

3. Select MD → Solvate/Build Cell.

4. Decide which and how many molecules to put in the other phase. For water molecules, click Add Water. Other-
wise, click Add File and select the mol2 file.

5. Enter the number of molecules to be inserted into the system.

6. Perform the steps in 4 and 5 for all the molecular species you want to calculate.

7. On the Simulatoin Cell tab, check the Set Lattice Constants and click the Same as main window button. Next,
select “triclinic” for the Box Type. To the right of the Set Lattice Constants, the cell size of the first phase
you created is displayed. Click the Change only one direction, select Z with the Select direction, and enter the
specified density with the Enter density to automatically set the lattice constants in the z and y directions while
keeping the x and y constants fixed.

8. Press the Build button.

9. Save a file by File → Export File in mol2 format.

10. Click MD → Interface Builder.
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11. Click Browse button of Cell 1 in the Cell tab, and select the file saved in step 2. Similarly, in Cell 2, select the
file which was saved in 9.

12. Input the distance between liquid phases in Direction tab of Interval.

13. Click Build button, type the name of the file to save, and then click Save button.

5.8 Protein creation (no ligand)

1. Open the pdb file of the protein you want to calculate with Winmostar.

2. Use Select → Select by Molecular Species to select a group of non-protein components (e.g., binding
water, buffers, ligands, etc.), and then use Edit → Modigy Selected Group → Delete to delete the
selected group.

3. Edit→Add Hydrogen→Using pdb2gmx. Even if hydrogen appears to be added before the execution,
the calculation may fail later if this process is omitted.

4. Click MD → Solvate/Build Cell. Click Add Displayed Molecule, type “1” in Enter # of molecules
and click the OK button. Next, click Add Water button, input the number of molecules (about 5000
to 10000) at Enter # of molecules and click OK button. Then, click the Build button.

5. To neutralize the system, place ions with the procedure MD → Generate Ions. If the message
“WARNING: The charges defined on the main window will be discarded. Are you sure you want to
continue?” is displayed, click Yes.

If the MD calculation is executed after the above procedure, it is desirable to continue the MD calculation
after the above procedure because if the file is saved after the above procedure is executed, the residue
information may not be saved properly.

5.9 Protein creation (with ligands)

1. Open the pdb file of the protein-ligand complex you want to calculate with Winmostar.

2. Use Select → Select by Molecular Species to select a group of non-ligand components (proteins,
bound water, buffers, etc.), and then use edit → Delete to delete the selected group.

3. Execute Edit → Add Hydrogens → Using OpenBabel.

4. Save the structure of the ligand in mol2 format with file → Export File.

5. Open the pdb file of the protein-ligand complex you want to calculate again with Winmostar.

6. Use Select → Select by Molecular Species to select a group of non-protein components (e.g., binding
water, buffers, ligands, etc.), and then use Edit → Modigy Selected Group → Delete to delete the
selected group.

7. Edit→Add Hydrogen→Using pdb2gmx. Even if hydrogen appears to be added before the execution,
the calculation may fail later if this process is omitted.

8. Click Solvate/Build Cell. Click Add Displayed Molecule, type “1” in Enter # of molecules and click
the OK button. Next, click Add Water button, input an appropriate number of molecules at Enter #
of molecules and click OK button. Then, click Add mol2 File button, open the mol2 file saved in step
4, type “1” in Enter # of molecules, and click OK button. Do you want to arrange these molecules in
a random manner? If asked, click No. Then, click the Build button.
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9. To neutralize the system, place ions with the procedure MD → Generate Ions. If the message
“WARNING: The charges defined on the main window will be discarded. Are you sure you want to
continue?” is displayed, click Yes.

If the MD calculation is executed after the above procedure, it is desirable to continue the MD calculation
after the above procedure because if the file is saved after the above procedure is executed, the residue
information may not be saved properly.

5.10 Preparation of inorganic crystals

If you already have the crystal data you want to calculate, such as a CIF file, open the file with Winmostar.
If such a file does not exist, perform the following operations.

1. Click on solid → Crystal Builder.

2. Select the following item at the top right of Crystal Builder window.

• Select the classification of a crystal from Crystal System of Lattice.

• Select a space group of a crystal from Space Group of Lattice. The choices of Space Group are
changed by Crystal System.

• In Lattice Constants, input the lattice constants of the crystal to be computed.

3. Crystal Builder Input an atom of an asymmetric element in the list at the bottom right of the window.

• Double-click on the Atom field and enter the type of element.

• Double-click the fields of X , Y , Z to fill in the coordinates.

• Add an atom by Add button.

• Removes a selected atom by clicking Remove button.

4. Click the OK button to apply the structure specified by the crystal builder to the main window.

5. If you want to distort the crystal, use the edit → create/edit cell → Transform Cell function.

6. If you want to change the unit lattice of the crystal without changing the crystal structure, perform the
following operations. If you want to convert between primitive and conventional cells, use the solid
→ Convert Lattice (Primitive-Conventional) function. To convert a hexagonal cell to a rectangular
cell, use the solid → Convert lattice to equivalent rectangular cells function. If you want to convert
a unit cell with a rotation matrix, use the solid → Transform Unit Cell function.

7. If the symmetry of the created structure or the structure of the loaded file is broken from the original
one, the solid → Refine Lattice function may improve the symmetry.

5.11 Preparation of inorganic crystals (with point defects or elemen-
tal substitutions)

1. Open a CIF file of the crystal with no defects or create a crystal structure with the method Preparation of inorganic
crystals.

2. Click on Solid → Generate Supercell. Increase the value of a , b , c and specify the size of the supercell (first,
about 2 in each direction). Finally, click the OK button.

3. In the main window, left-click on the atom you want to create a point defect, or the atom you want to replace the
element with, and a red marker will appear.
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4. To create a point defect, click Edit → Delete atom.

5. To replace an element, select the element from Edit → Select Element for Editing Ops and then click on Edit →
Change Atom Property → Element.

5.12 Creation of inorganic slabs (surfaces)

1. Open a CIF file of the crystal in bulk, or create a crystal structure with Preparation of inorganic crystals.

2. Click on solid → Build Cluster Model.

3. Enter the items above Generate Slab button, Miller indices (h k l) etc., then click the Generate Slab button.

4. Click the Generate Slab button after enteringthe following items below Generate Slab button. If the atomic
configuration of both the front and back of the slab structure you want to create is not among the choices of
Surface configurations, ensure that the atomic arrangement on at least one side is the desired structure, then click
OK and delete an unwanted atomic layer with Delete function in the main window. To make the atomic layer
thicker in advance, increase the value of Minimum slab size above Generate Slab button .

5. If you want to change the cell orientation without changing the structure, perform the following operations. If
you want to convert a hexagonal cell to a rectangular cell (for example, if you want to create a solid-solid interface
but the shape of one ab-plane is different from that of the other), use the solid → Convert lattice to equivalent
rectangular cells function . To convert a unit cell with a rotation matrix, use the solid → Transform Unit Cell
function.

6. If the symmetry of the created structure is broken from the original one, the solid → Refine Lattice function may
improve the symmetry.

5.13 Creation of molecular adsorption surfaces

1. Create a molecule to be adsorbed by the method Modelling a single molecule.

2. Save a file by File → Export File in wmm or mol2 format.

3. Create a surface with the method Creation of inorganic slabs (surfaces).

4. If necessary, click on solid → Generate Supercell. Increase the value of a , b and specify the size of the supercell.
Finally, click the OK button.

5. Click (mark) the atom directly below the position on the slab surface where you want the molecule to be adsorbed,
then click Edit → Add Atom → Adding dummy atoms to the center of gravity of a group.Set the Axis to z, set the
Distance appropriately, and click OK.

6. Click MD → Replace Molecules Species=(unknown) and click OK. Then open the file exported in step 2.

7. If you want to rotate adsorbed molecules, use Edit → Modify Selected Group → Rotate by Aligning Marked
Atoms or Rotate (Numerical). If you want to translate the adsorbed molecules, use Edit → Modify Selected
Group → Move (Numerical). For example, if you want to adjust the distance between the surface first layer and a
specific atom in an adsorbed molecule, first click the atom in the surface first layer, then click the specific atom in
the adsorbed molecule, then Ctrl+click the adsorbed molecule to select the group. Then click Edit → Edit Group
→ Move (Numerical), change Definition to Relative coordinate between marked atoms and change the value of
Z.
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5.14 Creation of solid interfaces (grain boundaries)

1. Create one solid using the method Creation of inorganic slabs (surfaces).

2. Save the file as a cif from file → Export File.

3. Create the other solid using the Creation of inorganic slabs (surfaces) method. Now, if the shape of the ab plane
is different from the shape of the ab plane of the structure created in 1, use the solid → Transform Unit Cell
function to re-create the cell.

4. Save the file as a cif from file → Export File.

5. Click MD → Interface Builder.

6. Click Browse button of Cell 1 in the Cell tab, and select the file saved in step 3. Similarly, in Cell 2, select a file
which was saved in step 5.

7. Enter the distance between solids in Interval on Direction tab. Then check Specify interval on selected axis
between outermost atoms of Interval

8. If you move to the Repeat tab, the top two (a-axis and b-axis) of the three Suggest buttons can be pressed. Click
the Suggest button, select a row whose value of Ratio is close to 1 and the system size is not too large, and click
the Set button.

9. Click Build button, type the name of the file to save, and then click Save button.

10. Select one of the solids as a group by Ctrl+Left dragging. See Select menu for details.

11. Click edit → group editing → Move (Numerical) to move the group in the X and Y direction. If you enable view
→ Show Multi-View, it is easier to see the position.

5.15 Creating Molecular Crystals

At present, Winmostar does not have the ability to generate stable structures of physicochemically valid
molecular crystals from the structure of a single molecule, so it is necessary to use a structure file of a
molecular crystal obtained from a database or other source as a starting point. In such a structure file,
the coordinates of molecules across the boundaries of the simulation cell are far apart, and the process
will fail if such a structure file is directly used to perform force field assignment for molecular dynamics
calculations such as Gromacs and LAMMPS. In this section, we introduce a processing method to prevent
the force field assignment from failing as follows. Note that the following processing is not necessary when
only first-principles calculations such as Quantum ESPRESSO and OpenMX are performed.

1. Draw and read structure expressions with file → import → Structural Formula.

2. Edit → Wrap Around Cell Boundary and check Wrap for each atom and click OK.
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SIX

DETAILS OF EACH MENU WINDOW

6.1 File menu

6.1.1 New Project

Create a new project. The file structure of the created project is as follows. Renaming of each file/folder
is not supported. Since renaming of projects is not supported, it is recommended to leave a note in the
Description of File → Project → Get Info about the role of the project, etc. Similarly for working folders,
you can leave notes in the Description of File → Project → Selected Working Folder → Get Info. When
moving project files, move the entire wmpjdata folder.

• .wmpjdata folder: a folder containing all the files in the project. Drag and drop this folder into
Winmostar to open the project.

• .wmpj file: A file containing information about the project. Drag and drop this file into Winmostar
to open the project.

• temp.wmm : This file contains information on the molecular structure being edited.

• index.ndx: the file where information on groups registered with select → register group is stored.

• .wmps* file: the workflow configuration file used for this project.

• work* folder: working folder

• Exec* folder: contains the files that control the jobs in each working folder.

6.1.2 New project with current structure

Create a new project using the structure currently displayed in the molecule display area.

6.1.3 Open Project

Open an existing project.
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6.1.4 Open Recent Project

Open a recently opened project file.

Clear History

Empty the history of recently opened project files.

6.1.5 Project

Get Info

View information about the open project. Some information can be edited here.

Open Temporary File

Open a temporary file of the opened project.

Show in Explorer

Open the wmpjdata folder of the opened project.

Parameter/structure scan result display

You must purchase an add-on to use this feature. After a parameter scan or structural scan calculation, the
results of each calculation can be tabulated.

Check All
Check all working folders in Working Folders.

Uncheck All
Uncheck all working folders in Working Folders.

Check Selected
Check the selected working folders in Working Folders; you can use Shift or Ctrl to select multiple
working folders in Working Folders.

Working Folders
Check the working folder that contains the calculation results you want to visualize.

X Axis
Selects the value of the X axis for visualization.

X Axis
Selects the value of the Y axis for visualization.

Options
Export csv

Outputs a csv file listing the physical properties for each working folder. When outputting a
csv file from a graph, you can only select one physical property, but this function allows you to
output multiple physical properties.
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Export Animation
Create a wmm file with the values selected in End Structure and Property. For example, if you
want to create a Volume-Total Energy graph, create an animation with this feature and then use
the Custom Plot feature to select Volume for the X axis.

Interpolate Structure at Specified Volume
When a structure with a different volume is scanned, it interpolates the structure at the specified
volume.

Draw
Create a graph with the conditions you set.

Stop multiple jobs

Stops selected running jobs in a project at once.

Selected Working Folder

Each function in this menu operates on the working folder selected with working folder in the project
display area on the left of the main window. The same menu is displayed by right-clicking on the working
folder in the project display area.

Open Coordinate (Initial)

Displays the initial structure in the selected working folder. In most cases, this will be the input file for
the job. For the second and subsequent working folders in a series of generated working folders, the same
initial structure as the first working folder will be displayed until the job is executed. After the job is
executed, the original initial structure of the working folder is displayed.

Run

Runs the job in the selected working folder. Select Do not run jobs after saving files in the Job Settings
window and use this function if you want to start the job later.

Stop

Stops (kills) jobs in the selected working folder.

Show Workflow Setup

Displays workflow settings for the selected work folder.
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Show Keyword Setup

Displays keyword settings for the selected work folder. This corresponds to the contents of Details in the
workflow settings.

Show Job Setting

Displays job settings for the selected working folder.

Control Remote Job/Server

Performs remote server operations for jobs in the selected working folder. Available only for remote jobs.

Show Command for Job Submission

Displays the command when a job in the selected working folder is submitted (SUBMIT) on a remote
server. Available only for remote jobs.

Show Result of Job Submission

Displays the result of submitting (SUBMIT) a job in the selected working folder on a remote server. Avail-
able only for remote jobs.

Receive All Remote Output Files

Transfers all output files related to the job in the selected working folder from the remote server to the
local machine. If the job has ended normally, the zip file generated automatically at the end of the job is
acquired. For jobs that have not finished successfully, the zip file is created and retrieved at the timing of
this operation. Available only for remote jobs.

Open Remote stdout

Opens the standard output on the remote server for the job in the selected working folder. Available only
for remote jobs.

Open Remote stderr

Opens the standard error on the remote server regarding the job in the selected working folder. Available
only for remote jobs.
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Delete Remote Working Folder

Deletes the data in the selected working folder on the remote server. This operation cannot be reverted. It
is available only for remote jobs.

Get Info

You can change the Description of the selected working folder; the Description will be the string set in the
job description in the job settings window.

Recheck Status

Re-checks the status of the selected working folder. If for some reason the status is not determined correctly
for a remote job (for example, ABORT is displayed even though the job has ended normally), this function
will re-determine the status.

Delete

Deletes the selected working folder. This operation cannot be reverted.

Show in Explorer

The selected working folder is displayed in Explorer.

6.1.6 New File

Create a new file.

Hint: The shortcut is Ctrl+N .

6.1.7 Open File

Read the molecular structure from file into the main window. It corresponds to the format of various
software. Use Import File if you want to load the structure without switching the current mode file.

Hint: The shortcut is Ctrl+O .
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6.1.8 Open Recent File

Open a recently opened file.

Clear History

Empty the history of recently opened files.

6.1.9 Reload

Re-load the file opened in the main window.

6.1.10 Save

Overwrites the currently open file or project. For details, see Save As .

Hint: The shortcut is Ctrl+S .

6.1.11 Save As

Save the molecular structure displayed in the main window as a different name. After saving, the saved
file will be reopened. If you simply want to output the structure in the specified format without reopening
it, use Export File. It is recommended that you enter the file name and the folder name including all files
(all upper layers) with one-byte alphanumeric characters only.

• If multi-byte characters such as double-byte alphanumeric characters or Japanese characters or spaces
are included, some processing may cause problems.

• Underscores can be used.

If multiple types of charges are set at the same time (e.g., Mulliken and Lowdin charges) and saved in a file
format that contains information on a single type of charge (e.g., mol2), the charge with the highest priority
type is output. User charges have the highest priority, followed by NBO, Mulliken, and Lowdin charges,
with ESP charges having the lowest priority. If multiple types of charges are set at the same time and you
want to output the charge with the lowest priority among them, use Edit Charge to remove the information
of the charge with the highest priority. When saving an input file of various solvers, a file is created based
on the contents of Keyword Editor and Coordinate Viewer. If the keyword of the solver you want to save is
not displayed in Keyword Editor, Configuration window will open automatically. For MOPAC, GAMESS,
Gaussian, NWChem, the coordinates are output in the format selected in File → Coordinate Format.

Hint: The shortcut is Shift+Ctrl+S
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6.1.12 Close

Closes the currently open project or file and returns to the startup screen.

6.1.13 Import File

Loads an existing molecular structure file. You can either discard the current structure and load it, or
append it to the current structure and load it. Open File opens the file in file mode when it is read in, but
this function overwrites the structure of the molecular display area with the structure of the imported file
without switching modes or files.

6.1.14 Import Recent File

Import recently used files.

6.1.15 Import

It reads a specific type of molecular structure.

SMILES

Molecular structure is generated from SMILES format string and read into the main window. When Import
SMILES window opens, enter the SMILES format string in the text box and press Import button. Internally,
conformational search by Bolloon or OpenBabel is also executed at the same time. A working folder named
*_smiles_tmp will be created as an intermediate file.

Structural Formula

Create a molecule by entering a structural formula. Internally, JSME draws the structural formula, and
Balloon or OpenBabel generates the 3D structure by generating SMILES from JSME.

Sample File

Load the files in the Samples folder.

6.1.16 Export File

Outputs the current molecular structure in an arbitrary file format. The detailed behavior of file output
follows Save As.
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6.1.17 Export

Outputs the contents displayed in the main window in the selected format.

SMILES

Outputs the molecular structure displayed in the main window as a string in SMILES format. Not available
when multiple molecules are displayed in the main window. Use OpenBabel on Cygwin. “Do you want
to generate SMILES after completing the hydrogen atoms?” dialog, if “yes”, OpenBabel is executed via
mol2 format with the -b option, if “no”, OpenBabel is executed via xyz format.

Warning: To use this function, CygwinWM setup is required.

Structural Formula

The image of the structural formula of the molecular structure displayed in the main window is output
in SVG format. It can not be used when multiple molecules are displayed in the main window. I use
OpenBabel on Cygwin.

Warning: To use this function, CygwinWM setup is required.

Image

Outputs the contents displayed in the main window in BMP or JPG format.

CHARMM crd File

Outputs the molecular structure displayed in the main window in CHARMM crd format.

LAMMPS data File (for metal)

The molecular structure displayed in the main window is output in LAMMPS data format (readable with
the read_data command), with the format units=metal. The data file is generated assuming that the force
field is set in the various potential files.

SDF File

Outputs the molecular structure displayed in the main window in SDF format.
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6.1.18 Get Info

Displays detailed information about the molecular structure displayed in the main window.

6.1.19 Open in Text Editor

Open the file displayed in the title of the main window with the text editor selected in the configuration
window.

Note: After editing with the text editor, selecting Reload , you can reflect the change on the main window.

6.1.20 Show in Explorer

Open the directory one level higher than the file displayed in the title of the main window.

6.1.21 Exit

Quit Winmostar.

6.2 Edit menu

It is a menu related to modeling function of atomic/molecular structure. See Select menu for how to select atoms to
be edited. Automatically generated bonds are generated when the interatomic distance is less than (sum of covalently
bonded radii) × (coefficient). The coefficient defaults to `` 1.15``, and this value can be changed with Tools → Prefer-
ences . Functions with mouse operations such as Add atom by, Rotate group on axis (selection 2 atoms, mouse control)
can be canceled by unchecking the Esc key or the menu of the same function.

6.2.1 Undo

Revert various editing operations. It is possible up to 50 times.

6.2.2 Redo

Redo the undone operation. It is possible up to 50 times.

6.2.3 Undo text

Restore the edited contents in keyword display area.

50 Chapter 6. Details of each menu window



Winmostar™ User Manual, Release 11.13.0

6.2.4 Reset Structure

New Project or New File will return to the initial structure when clicked.

6.2.5 Select Element for Editing Ops

Select element to be applied in Add atom by or Element .

6.2.6 Add atom by

Specifying Position

Add atoms to the position you click in Viewport. The types of atoms to be added are selected by Select

element for editing ops pull-down menu of Toolbar.

Hint: You can also operate with F4 or from Toolbar.

Specifying Position and Connectivity

Add atom by specifying joint relation and coordinate in Z-Matrix format at the same time. The types

of atoms to be added are selected by Select element for editing ops pull-down menu of
Toolbar. First click on the place where the atom is placed, then click on three connecting atoms (Na,
Nb,Nc) in Z-Matrix notation in order.

Adding dummy atoms to the center of gravity of a group

Adds a dummy atom at the specified distance away from the atom with the marker (red bold circle). You
can select the direction (axis) to add.

Dummy atoms added along selected 2 atoms

Add a dummy atom on a straight line passing through two atoms with markers (red round, red circle).
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Adding dummy atoms to the center of gravity of a group

Group Add dummy atoms to the position of the center of gravity of the selected structure.

6.2.7 Delete atom

Delete the atom marked with marker.

Hint: You can also operate it with Shift + F4 or Toolbar.

6.2.8 Change attributes of atoms

Element

The element of the selected atom is changed to the element selected by the Select element for editing ops

pull-down menu in the Toolbar. If a group is selected, all atoms selected in the group are
targeted.

Hint: You can also operate with Chg button of Shift + F5 or Toolbar.

Note: Lp 0 is a Lone pair, Cb 104 is a Capped bond used to cut out a molecular structure in MOPAC, ++
105 to -108 is a MOPAC sparkle, Tv 109 is a MOPAC translation vector , Xx 110 through Z 112 means the
dummy atom of each solver.

Optimization Flags

Changes the optimization flag for the selected atoms. The optimization flag is a flag that specifies whether
each degree of freedom should be fixed (flag is ‘0’) or variable (flag is ‘1’) in the structural optimization
calculation. By default, all degrees of freedom are variable (1). If a group is selected, all atoms selected
in the group are targeted. If General is selected in Solver, the selected flag for X, Y, and Z is set as it is. If
a specific solver is selected in Solver, the corresponding flag will be set for each.

Warning: In the case of OpenMX, if 0 is displayed on the Coordinate Viewer, 1 is displayed when
saving the file, and conversely 1 is displayed, the output is 0. In other words, the operation follows the
`` Variable`` and `` Fixed`` notation of this function.
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Charge/Spin Density

Changes the value of the charge (User charge) or spin density of the selected atoms. If a group is selected,
all group-selected atoms will be affected. If Overwrite is checked, all values of the selected atoms will
be overwritten with the input values. If Scale is checked, all values of the selected atoms will be scaled
equally.

Note: If you want to display User Charge or Spin Density on the main window, select User Charge or
Spin Density of View → Labels/Charges.

Connectivity

Click on the three connecting atoms (Na, Nb, Nc) in the Z-Matrix of the atom with the marker in order to
set again.

Occupancy

Changes the occupancy of the site where the marked atom is located or the site where the group-selected
atom is located. The total value of Occupancy must be 1. Sites with an occupancy set other than 1 will be
treated by Winmostar as if there are multiple atoms in the site. The same is the behavior when a CIF file
with Occupancy set is read.

Atom Name

Changes the atomic name of the site where the highlighted atom is placed or group selected atoms, affecting
read/write in PDB, mol2, and gro formats.

Residue Name

Changes the residue name of the site where the marked atom is placed or the group-selected atom, affecting
read/write in PDB, mol2, and gro formats.

Residue Number

Changes the residue number of the site where the marked atom is placed or group selected atoms, affecting
read/write in PDB, mol2, and gro formats.

6.2.9 Move atom

Translate

Drag and move marker atom on Viewport.

Hint: You can also operate it with F5.
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Translate (with hydrogen)

Drag and move the atoms with marker and the hydrogen bonded to them on the Viewport.

Hint: You can also use Ctrl+F5 or Alt + drag.

Translate While Keeping Z-Matrix

Drag and move the atom with marker and the atom connected with Z-Matrix on the Viewport at the same
time. Suitable for movement by functional group.

Change Dihedral

Drag and move the atom with marker on the Viewport. Only the dihedral angle of Z-Matrix changes.

Change fractional coordinates

:ref:Specifies the fractional coordinate of the atom with the marker.

6.2.10 Add/Change Bond

A bond is created between two atoms with markers (red round, red circle). If it has already been created,
the type of join is changed. As types of bonds, single, double, triple, aromatic ring (1.5-fold), red are
defined as 5. Please use red coupling for presentation and other purposes.

Hint: you can also operate with F7 or Toolbar.

6.2.11 Delete Bond

Delete the bond between 2 atoms with markers (red round, red circle).

Hint: You can also operate with F8 or Delete bond button of Edit button area.

6.2.12 Add Hydrogens

Make up for missing hydrogen atoms. If you import a file whose bond distance is extremely different from
the original equilibrium length (such as ChemDraw or PubChem mol format), you may not be able to add
hydrogen normally. In that case, please use Edit → Automatically Adjust Atoms/Bonds –> Adjust All Bond
Lengths.
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To all atoms

Automatically adds hydrogen to all atoms. If atoms are group selected, hydrogens are added only to the
atoms.

Hint: You can also operate with Ctrl + H.

To marked atoms (Auto)

Add hydrogens to the markered atom. If atoms are group selected, hydrogens are added to the atoms.

Hint: You can also operate with + H button of Toolbar.

To marked atoms (Single), (Double), (Triple)

Add one to three hydrogens with markers to the atoms. If atoms are group selected, hydrogens are added
to the atoms.

Using pdb2gmx

Use the Gromacs gmx pdb2gmx command to automatically add hydrogen to proteins read from pdb or gro
files. If the original pdb or gro file contains atoms that do not have amino residue information, the process
will fail. An intermediate file is created in a working folder called * _protonate_tmp.

Note: If the structure displayed in the main window contains molecules other than proteins such as ligands
and solvents, delete them with Select → Select by Molecular Species and Edit → Modify Selected Group
→ Delete in advance.

Warning: To use this function, CygwinWM setup is required.

Using OpenBabel

We will automatically add hydrogen using OpenBabel. It is mainly used for ligand molecules cut out from
pdb file. An intermediate file is created in the working folder named * _protonate_tmp.

Note: If the structure displayed in the main window contains molecules other than proteins such as ligands
and solvents, delete them with Select → Select by Molecular Species and Edit → Modify Selected Group
→ Delete in advance.

Warning: To use this function, CygwinWM setup is required.
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6.2.13 Delete All Hydrogens

Delete all hydrogen atoms.

6.2.14 Replace with Fragment

Replaces Marked atoms (thick red circles) with the parts (substituents) selected with the Fragment to

be replaced with pull-down menu on the Toolbar. In the pull down menu, -
CHCH - and - CH - are parts for making a polycyclic structure, which are generated to point in the direction
of the atom with the second marker (thin red circle). If a group has been selected, each group-selected
atom will be replaced. Fragment registration and deletion is done via Save Fragment and Delete Fragment.

Hint: You can also operate with F6, Replace button, or by right-clicking an atom.

6.2.15 Select Fragment

Select the fragment to be replaced with Replace with Fragment . The order of fragments can be changed
in fragment_list.txt in the user configuration folder ( UserPref ).

Save Fragment

Register the molecular structure displayed in the main window as a fragment. Atoms with markers (bold
red circles) will be set as connections during the substitution.

Delete Fragment

Deletes the registration of a fragment selected by fragment in the Toolbar.

6.2.16 Build Ring

When selecting the same function with markers (thick red circle, fine red circle) attached to 2 atoms at
both ends of the connected 4 atoms, it generates aromatic rings containing the 4 atoms in the skeleton.

Hint: You can also operate it with F9.

Hint: For example, if you move a marker to H on both ends of the HCCH portion of a benzene molecule
and call this function, a naphthalene molecule will be created.
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6.2.17 Modify Selected Group

Do the operation on the atom for which group selection (blue circle) was performed.

Rotate group on axis (selection 2 atoms, mouse control)

Rotate the group-selected structure around a vector between two atoms with two markers (red thick circle,
red thin circle) as axes by mouse operation.

Hint: You can also operate with Ctrl + R.

Rotate group on axis (select 2 atoms, specify values)

Rotate the group-selected structure around a vector between two atoms with two markers (red thick circle,
red thin circle), specifying a numerical value.

Rotate Around Axis(3 Marked Atoms)

Rotate the group selected structure around the normal vector of the plane defined by three atoms with a
marker (These can be confirmed by top left Marked Order on Viewport).

Hint: You can also operate with Ctrl + A.

Rotate Group Around Marked Atom

Rotate group-selected structure around the atom with marker (thick red circle).

Hint: You can also operate with Ctrl + F.

Rotate (Numerical)

The structure group selected is rotated around the atom or geometric center marked with marker (red
circle) by slider operation or numerical input. Specify the Euler angles.

Hint: You can also operate with Ctrl + F.
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Rotate by Aligning Marked Atoms

Rotates the group-selected structure so that it is oriented with respect to a specific axis or plane.

Align principle axis to target direction
Rotate the inertia spindle so that its major axis points in the specified direction.

Align 2 marked atoms to target direction
Rotate so that the two atoms marked face the specified axis. The two atoms marked must be included
in the group-selected structure.

Align 3 marked atoms to target plane
Rotate so that the marked 3-atom is included in the specified plane. The marked 3 atoms must be
included in the group-selected structure.

Move (Direct)

Move group-selected structure in Viewport.

Hint: You can also operate with Ctrl + M.

Move (Numerical)

Translate selected group structure by slider operation or numerical input.

• If Definition = Relative coordinate from original position: specify coordinates relative to the position
before the move.

• If Definition = Relative coordinate between marked atoms: Specifies the relative coordinate between
two marked atoms. Before activating this function, you must first click (mark) an atom that is not
included in the group of atoms to be moved, then click (mark) an atom whose position relative to the
atom you want to specify and that is included in the group of atoms to be moved, and then select the
group of atoms to be moved. The group of atoms to be moved must be selected.

• If Definition = Absolute coordinate for center of mass: specifies the absolute coordinates for the
center of mass of the group.

• For Definition = Absolute coordinate for center of geometry: Specify the absolute coordinate for the
geometric center of the group; Direction specifies the direction of movement; for Two marked atoms,
the vector between the last two clicked atoms is used as the direction.

Quick Optimization

We will optimize structure using molecular force field for group selected structure.

Hint: You can also operate with Ctrl + L.
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Creates bonds between adjacent atoms in a group

Automatically generates bonds between neighboring atoms in the group-selected structure. Adjacency is
determined by Voronoi splitting.

Hint: You can also operate with Ctrl + L.

Delete bonds in a group

Deletes bonds in the group-selected structure. Bonds between atoms that are not group-selected and atoms
that are group-selected are not deleted.

Cut

Cut the group-selected structure to the clipboard.

Hint: You can also operate with Ctrl + X.

Copy

Copy the group-selected structure to the clipboard.

Hint: You can also operate with Ctrl + C.

Paste

Paste the group-selected structure from the clipboard. After pasting, drag to determine the position.

Hint: You can also operate with Ctrl + V.

Replicate Group

Duplicate and arrange the group-selected structures at regular intervals. Specify the arrangement interval
and number of copies in each direction in the subwindow.
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Delete

Delete the group-selected structure or any other structure. When a part of the structure in the molecule is
deleted, hydrogen atoms are automatically supplemented to the disconnected part.

Hint: You can also operate with Ctrl + D.

Change Optimization Flags of Group

groupSet the optimization flags for all components of the XYZ coordinates of the selected structure to
0 (fix) or 1 (free). See Optimization Flags for more information on the optimization flags. For more
fine-grained control, choose edit → change attribute → Optimization Flags.

Hint: You can also operate with Ctrl + I.

Fix/Unfix Groups (Z-Matrix)

Sets the optimization flags of all components of Z-Matrix for the group selected structure to 0 (fix) or
1 (free). See Optimization Flags for more information on the optimization flags. For more fine-grained
control, choose edit → change attribute → Optimization Flags.

Shift Charges of Group

The total point charge of the group-selected structure is uniformly shifted to the specified value. This
function is useful when you want to reduce the total system charge to 0, such as when performing MD
calculations.

Average the group’s charge

Corrects the sum of the point charges that a group-selected structure has to their average value. This is
useful if you want to average the charges of equivalent atoms (e.g. the three hydrogen atoms of a methyl
group) after running Use RESP charges or RESP Charges.

6.2.18 Automatically Adjust Atoms/Bonds

Quick Optimization

We will perform structure optimization using molecular force field. The algorithm used can be changed
with Tools → Preferences menu. If the method is “Winmostar”, the algorithm used in Winmostar before
V10 is used. The number of applicable atoms is limited, but the process is faster. If the method is “Open-
Babel”, the OpenBabel installed in CygwinWM is used. Although the process is slower, there is no limit
to the number of atoms that can be applied, and parameters such as the type of force field can be finely
tuned.

Hint: You can also operate with Ctrl + G.
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Regenerate All Bonds

Determine the presence and type of bonds from interatomic distances and reassign the bonds.

Adjust All Bond Lengths

Adjust the coupling length to a reasonable value to some extent.

Hint: Please use this function with Quick Optimization, if necessary.

Delete all bonds

Delete all bonds.

Regenerate Z-Matrix

Automatically regenerate Z-Matrix. Connection atom is also set automatically.

Convert Aromatic Rings to Single and Double Bonds

Change the aromatic ring bond to a combination of a single bond and a double bond.

Change unknown elements to hydrogen.

Change the atoms recognized as Lp or dummy atoms to hydrogen.

Hint: This is useful, for example, for converting deuterium to hydrogen in a CIF file.

Assign different residue numbers to each molecule.

Assign a different residue number to each molecule. A group of atoms connected by bonds is recognized
as a molecule.

Assign different residue numbers to each molecule.

Assign a different residue number to each molecule. A group of atoms connected by bonds is recognized
as a molecule.
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Remove all optimization flags

Set the optimization flags for all atoms to their default (variable) values.

Overwrite Bonds from File

Overwrites the bond information for the current structure with the bond information for the structure writ-
ten in the specified file. If the bond order changes from the order before force field assignment after force
field assignment in MD calculations (LAMMPS, Gromacs, etc.), save a file in mol2, wmm, etc. format
before force field assignment and load the file with this function after force field assignment, and the bond
order will be restored to the one before force field assignment. If you save the file in mol2, wmm, etc.
format before force field assignment, and then load the file with this function after force field assignment,
you can restore the bond information before force field assignment. This function is useful in cases where
a force field has been assigned once and an MD calculation has been performed, but the bond order has
changed since the initial force field assignment and the force field cannot be assigned again. The bond
order after force field assignment is determined by Winmostar’s criterion based on the bond equilibrium
length of the assigned force field, so the aforementioned phenomenon occurs for some types of force fields.

Distribute Charge of Selected Atom in Residue

It distributes the charge of the selected atom to the other atoms in the residue to which it belongs. With
this function, the total charge within the same residue does not change before and after the deletion of a
selective atom.

Merge Overlapping Atoms

For all atoms in the system, look for atoms with overlapping coordinates and elements, and for those that
overlap, consolidate them into one. A threshold value can be set to determine whether or not the coordinates
overlap.

6.2.19 Renumber/Sort

Exchange Between 2 Marked Atoms

Exchange the numbers of the two atoms with the marker. It is mainly used when editing Z-Matrix.

Sort by Atomic Number

Sorts the atoms so that they are ordered by atomic number.
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Sort by H atoms and Others

Arrange the atom numbers so that they are in the order of atoms other than hydrogen, hydrogen atoms.

Sort by Molecular Species

We will rearrange the order of the atoms so that molecules of the same kind are continuous.

Renumber Across Each Molecule

Number the molecules sequentially from the end within the molecule. This is useful, for example, when
selecting both ends of a polymer.

6.2.20 Adjust Axes

Set to Camera Coordinate

Redefine the molecule by redefining the current direction of the camera's line of sight as Z axis, the camera
upward direction as Y axis, and the camera right direction as X axis.

Set Using 3 Marked Atoms

The normal direction of the plane passing through the three atoms with the marker is taken as the Z axis,
and the vector passing through the two atoms with the marker is taken as the X axis.

Set to Principal Axes

Rotate the entire system so that the principal axis of inertia matches the X, Y, Z axes. The long axis is the
X axis.

Set Origin to Marked Atom

Set atoms with markers as origin.

Set Origin to Lower Bound Edge of Cell

Rewrite the coordinate system so that the cell's origin coordinates are (0, 0, 0).

Swap Axes

Swap the axes and recreate the coordinate system.
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6.2.21 Invert Coordinates/Chirality

Invert along X/Y/Z/a/b/c Axis

Inverts the specified axis and recreates the coordinate system.

Generate Enantiomer

Generate an enantiomer of the molecular structure displayed in the main window adjacent to the current
structure.

6.2.22 Create/Edit Cell

Create/Edit Cell

Create the simulation cell

• Set Margin is checked, it creates cell borders at a specified distance from the minimum and maximum
values for each direction of the molecular structure shown in the main window. If Use Cubic Cell is
checked, a cubic cell will be created.

• :guilabel:If Set Dimension is checked, a cell with the specified size cube will be created.

Transform Cell

1. How to transform cell specifies how to transform the cell.

• Check the Transform only along the selected axis if you want to deform the cell only along the selected
axis. Check Set incremental length for length, Set total length for size after deformation, or Set normal
strain for vertical strain. or Set density to specify the deformed density.

• Check Transform similarly to deform the cells similarly. Select Set target density to specify the
density of the transformed cells, or Set target volume to specify the volume of the transformed cells.

• Check Transform by shear strain if you want to apply a shear strain. Specify the direction to be
deformed and the strain to be applied.

• Check Transform by angle if you want to change the angle of a cell. Specify the type and value of
the angle to be transformed.

2. Atomic positions specifies how to move atoms.

• Check Do not change if you want to keep the position of the atoms and only change the cells.

• If you want to change the position of the atoms fixed as the cell is deformed, check the Move with
keeping fractional coordinates checkbox. For molecular systems, check Keep intramolecular coor-
dinates, then intramolecular coordinates are kept fixed.
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Edit Cell Manually

The Create/Edit Cell window opens, where you can create or edit simulation cells such as MD calculations
and plane wave DFT calculations. If the cell does not exist, clicking the Create button creates a cell at a
distance of` Distance` from the minimum and maximum values in each direction of the molecular structure
displayed in the main window. Click the Expand button to expand the cell size in the specified direction.
On the right side of the Create/Edit Cell window, you can edit the cell size value directly. Click Lattice
Vecors, Lattice Constants, LAMMPS Tilt Factors to change the cell size notation.

Note:
• You can also display the lattice parameters in the Viewport by checking Preferences → View → Items

to be drawn → Lattice constant.

• Even if you change the cell size with this function, the coordinates of the atoms do not change, so if
you want to change atomic coordinates similarly to the cell size, use Transform Cell.

• If you want to return atoms outside the simulation cell to the simulation cell before editing, use the
Wrap Around Cell Boundary function.

6.2.23 Delete Cell

Delete Cell.

6.2.24 Wrap Around Cell Boundary

We return the coordinates of the atoms outside the simulation cell into the cell taking into account the
period boundary. Mainly in molecular systems Wrap for each molecules, mainly in inorganic systems
Wrap for each atoms.

Note:
• If Display-> Wrap Around Cell Boundary → Do not wrap is selected, it will be easier to check the

change of coordinates.

• In tne Display → Wrap Around Cell Boundary function, only the display changes and the coordinates
do not change, but in this function the coordinates actually change.

6.2.25 Edit Charge

Edit the value of the charge. Specify the type of charge and set it to user charge. You can also delete
specified charges. It can be adjusted so that the total charge is at a specific value.
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6.3 Select menu

It is a menu related to the function of selecting atoms or molecules.

Hint: How to select atoms
There are two ways to select an atom: The method using a red circle marker and the method using a
blue circle group selection. The method using the red circle marker is mainly used for operation on
one atom.The marker moves to the atom that was left-clicked in Viewport.In the example of the methanol
molecule in the figure below, the oxygen (red) and hydrogen (yellow) of the OH (hydroxy) group are left
clicked. The red thick circle is drawn to the atom to which the marker is finally attached, and the red
thin circle is drawn to the atom attached the marker one before.The marker also moves by left clicking at
Coordinate Viewer in the right red frame of the figure below.Last four atoms marked are internally stored
and displayed as shown in the upper left red frame of the figure below.The number of each atom can be
confirmed in Viewport by selecting View → Labels/Charges → Show Number & Element or Coordinate
Viewer.

The method using group selection of the blue circle is mainly used for operations on multiple atoms.You
can select a group by Ctrl+left drag , Ctrl+left click or Shift+left click in Viewport.You
can also select a group by using the function of Select menu.In the example of the methanol molecule
in the figure below, after Ctrl+left drag around the CH3 (methyl) group, it can be confirmed that the
CH3 group atoms are surrounded by blue circles.You can also select a group by Ctrl+left click in
Coordinate Viewer.On the upper left of Viewport, the number of atoms and composition of the group
selected are displayed

Select Partial Structure Split by 2 Marked Atoms is executed automatically when you execute an operation
on multiple atoms such as Edit→Modify Selected Group in a state where no group is selected. Specifically,
the substructures that are divided by two atoms with a red thick circle and a red thin marker attached are
selected as a group. In the example of a methanol molecule shown below, after oxygen (red) and carbon
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(green) are moved in the order of left click and the marker is moved, Edit → Modify Selected Group
→ Rotate group on axis (selection 2 atoms, mouse control) is selected, the group with the last marker on
the CH3 group is automatically selected (highlighted on the screen).

6.3.1 Select All

Select all atoms as a group.

6.3.2 Select None

Cancel the group selection.

6.3.3 Invert Selection

Select a group that has not been selected as a group, and cancel the group selection of the group that was
selected until then.

6.3.4 Select by Molecular Species

It opens with Use List tab of Select by window checked Molecular Species.Click on each line in the list in
the window and the corresponding molecular species are selected.

Note: When calculating from protein pdb files, this function can be used to extract proteins, ligands,
bound water, buffers, etc.
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6.3.5 Select by Molecules

It opens with Use List tab of Select by window checked Molecules.Click on each line in the list in the
window and the corresponding molecule is selected.

6.3.6 Select by Elements

It opens with Use List tab of Select by window checked Elements.Click on each line in the list in the
window and the corresponding element is selected.

6.3.7 Enter Selection Language

It opens with Use Selection Language tab of Select by window.If you click on Apply button after describing
in the text box, the corresponding atoms are selected.The following syntax is supported in the selection
language.

Table 1: Basic syntax

element C H Select all carbon and hydrogen atoms.
index 1-3 6 8 Select 1, 2, 3, 6 and 9th atoms.
compid 1

Select the molecular species whose CompID is 1.
The correspondence between CompID and
molecular species can be confirmed in the list
under Apply button.

moleid 1-3

Select 1, 2 and 3rd molecules.
You can see the numbers of molecules in the list
under Apply button.

site 1

Select the first atom (site) in each molecule.
You can see the numbers of sites for each
molecule in the list under Apply button.

charge 0.5

Select the atoms whose atom name is CA.
A tolerance of ± 0.1% is provided.

resname GLY Select the atoms whose residue name is GLY.
name CA Select the atoms whose atom name is CA.
x< 10 Select the coordinates where the x-coordinate is

less than 10 Angstrom. (No space between x and
<.) Similarly, y and z can be used. You can also
use x> , x=> and x<=.

bondto H Select the atom to be bonded to the H atom.

The residue name and atom name can be used when PDB or gro format file is opened.
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Table 2: Composite syntax using logical operators

(compid 1) and (site 1) It is a molecular species whose CompID is 1 and the first site in
the molecule is selected.

(current) and (element H) Select only hydrogen atom among atoms currently selected in the
group.

(resname GLY) and (not
(element H))

Select the atom whose residue name is GLY and other than hydro-
gen.

In addition to and, not you can use or and xor. When using these logical operators, use the parentheses
() as in the example above. Also, if you enter %2==0 where you enter an integer, it will assign a sequence
of numbers where the remainder divided by two is zero. For example, typing site %3==1 will select
atoms with sites 1, 4, 7, 10. . . will be selected.

6.3.8 Select Partial Structure Split by 2 Marked Atoms

Substructures that are separated between two atoms with the first and second markers are selected. Details
are described in Select menu with pictures.

6.3.9 Group selection of atoms bound to the current group

Selects an additional group of atoms bound to the current selection group.

6.3.10 Group selection of atoms adjacent to the current group

Select a group of atoms adjacent to the current selection group. Here, adjacent atoms are defined as those
atoms that have the same Voronoi boundary when Voronoi splitting is applied to all atoms.

6.3.11 Group selection of molecules adjacent to the current group

Select a group of molecules adjacent to the current selection group. Here, adjacent atoms are defined as
atoms that have the same Voronoi boundary when Voronoi splitting is applied to all atoms.

6.3.12 Select Atoms Around Marked Atom

Select a group of atoms that exist within a specified distance from the marked atom.

6.3.13 Select Molecules Around Marked Atom

Selects a group of molecules whose center of gravity is within a specified distance from the marked atom.
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6.3.14 Select Residue with Marked Atom

Select Residue with Marked Atom. Residues with the same residue number and consecutive atom IDs are
determined to be the same residue.

6.3.15 Select Groups by Enlarging Each Molecular Species

Enable group selection of atoms by zooming in on the molecule in 3D for each molecular species. In the
Create Group window, use Target to switch molecular species and Ctrl+click on the left side of the window
to select atoms (sites). Click the Add button to register the selected sites, and click OK to create a group
for each molecule’s registered sites.

6.3.16 Register Selected Group

Name and register the selected group so that it can be called from Select Registered Group.

6.3.17 Select Registered Group

Call the group registered with Register Selected Group. When LAMMPS is executed, the groups listed
here are output in the ndx file. If you want to take over the registered group even after restarting Winmostar,
export to the ndx file using Export Groups to Index File (ndx) and then read it using Import Groups from
Index File (ndx).

6.3.18 Import Groups from Index File (ndx)

Reads the group output to the ndx file and makes it accessible from Select Registered Group.

6.3.19 Export Groups to Index File (ndx)

Outputs the groups registered in Select Registered Group to the ndx file.

6.3.20 Add Selected Group to Index File (ndx)

Add the group selected group to the specified ndx file.

6.3.21 Concatenate and Transpose Groups

This function combines multiple groups with equal number of atoms in them and transposes the order.
For example, if group A contains 1, 2, 3, and group B contains 4, 5, and 6, and this function is applied to
groups A and B, three groups will be created: 1 4, 2 5, and 3 6.
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6.4 View Menu

6.4.1 Show Project Area

Show/Hide the project display area in the main window.

6.4.2 Show Keywords & Coordinates Areas

Switch show or do not show Keyword Editor and Coordinate Viewer on the main window.

6.4.3 Show Multi-View

Make Viewport three views.

6.4.4 Coordinate Format

Specifies the display format in the coordinate display area. To switch the output format of coordinates in
the solver’s input file, select the output format in the various solver keyword setting windows.

Hint: Coordinates display area You can also toggle the checkbox at the top.

6.4.5 Reset View

Return the camera to the default position.

6.4.6 Align View

Change the direction of the line of sight of the camera.

6.4.7 Zoom In/Out

Expand or reduce the field of view.

6.4.8 Always View Center

If checked here, even if the displayed molecular structure changes, the center of gravity at that point will
always be the gaze point of the camera. If it is not entered, gaze point will not change unless explicit gaze
change.
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6.4.9 View Marked Atom

Specify atom attached with marker (thick red circle) as gaze point.

6.4.10 Pan

Drag left on the main window to move the line of sight in parallel.

6.4.11 Rotate

Around Center

Drag left in the main window to rotate the camera around the point of interest.

Around X, Y, Z-Axis

Drag left in the main window to rotate the camera around each axis.

Around Line of Sight

Drag left in the main window to rotate the display.

Rotate the display (Numerical)

Enter the rotation angle of the display.

6.4.12 View Preset

Save and load display settings at once.

6.4.13 Perspective

If checked here, perspective is applied to Viewport.

6.4.14 Enable Depth Cueing

If this is checked, fog is applied to Viewport. This makes it easy to distinguish between atoms in front and
back. Fog strength can be set with Tools → Preferences menu.
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6.4.15 Enable Specular Lighting

If this is checked, the atoms will be glossed over in the molecular display area.

6.4.16 Items

Check the items to be displayed in Viewport.

6.4.17 Label/Charge

In Viewport, a label (annotation) and a sphere showing the magnitude of the charge are displayed beside
each atom.

(Hide Label/Charge) Hides the label and charge display. (initial state)
Number&Element Displays the serial numbers of the atoms and the

element names.
Number Displays the serial numbers of the atoms.
Element Displays the the element names.
Mulliken Charge Displays the Mulliken charge read when various

log files are opened.
ESP Charge Displays ESP or RESP charge read when various

log files are opened.
Lowdin Charge Displays Lowdin charge read when various log

files are opened.
NBO Charge Displays Lowdin charge read when various log

files are opened.
Show User Charge

Edit → Chnge Atom Property → Charge/Spin
Density and
MD → Assign Charges and other functions to
display the charge assigned by the user.

Show Spin Density

Spin density read when various log files are
opened
Display the spin density assigned by Edit →
Change Atom Property → Charge/Spin Density.

Show Difference Density Show Difference Density
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6.4.18 Dipole/Transition Moment

Show Dipole/Transition Moment

Displays the dipole moment or transition moment read when various log files are opened.

Select Transition Moment

Select the transition moment to be displayed.

Change Scaling Factor

Specify the magnitude when displaying dipole/transition moment.

6.4.19 Molecular Representation

Select the expression method (model) of the molecule.

6.4.20 Wrap Around Cell BOundary

The display method when the atomic coordinates are smaller than the top and bottom of the cell while
the cell is being created is shown below. The coordinate value itself does not change with this function.
Edit → Wrap Around Cell Boundary, you can set the value of the coordinates to the position of the atom
displayed in this function.

6.4.21 Transparency

Set transparency/opaqueness and adjust transparency for selected groups or all atoms.

6.4.22 Winmostar Viewer

Display the structure displayed in Viewport using Winmostar Viewer.

6.4.23 External viewer

Displays the structure displayed in Viewport with various external programs.

Jmol

Start Jmol.
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Mercury

Start Mercury. If the file being read is CIF, use that file.

ChemscapeChime

Start MDL Chime.

Ray Tracing (POV - Ray)

It outputs a file in POV - Ray format and renders it using POV - Ray.

OpenSCAD

Output the OpenSCAD format file and start OpenSCAD. You can create data for 3D printers.

6.4.24 Copy Image

Copy the image of Viewport to the clipboard.

6.5 QM → MOPAC menu

It is a menu related to MOPAC. MOPAC6 and MOPAC7 are bundled with Winmostar. If you wish to use
other MOPACs, please obtain the MOPAC itself separately and set the path in the Preferences window.

6.5.1 Workflow Setting

Sets up and executes the MOPAC calculation flow in project mode. Local jobs in project mode will use
the binary specified in MOPAC(1) in Tools → Preferences → Program Path.

Preset
Loads and saves a preset of settings.

# of Jobs
Specifies the number of jobs.

Enable parameter/structure scan
This feature requires the purchase of an add-on. It allows you to run multiple calculations where
only certain parameters differ (parameter scan) or to run calculations with the same parameters for
multiple structures (structure scan). Click Config to open the configuration window for the scan cal-
culation. For parameter scans, select %WM_SCAN1% for the Target Variable and enter the param-
eters you wish to set for %WM_SCAN1% in each row of the Values. Then, enter %WM_SCAN1%
in the parameters you want to set in the Workflow Settings window or Keyword Settings window.
For structure scan, select %WM_STRUCT% for Target Variable when the animation appears in the
molecule display area (e.g., by opening an SDF file). After the scan calculation is finished, use File
→ Project → Scan Results to tabulate the calculation results.

Import
Import the settings output by Export. Click the arrow to the right of the button to recall settings used
in the past on the same project or Winmostar.
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Export
Output settings to file.

OK
Run a calculation or generate a file with your settings. See For project mode for details.

Details
Set up detailed calculation conditions. The Configure will be launched.

Task
Specifies the type of calculation.

Configuration details

Energy Method=1SCF

Optimize Method=EF

IR Method=FORCE

Optimize(TS) Method=TS

IRC(Forward) Method=IRC=1
LARGE=50

IRC(Reverse) Method=IRC=-1
LARGE=50

Scan Method=EF
Add the specified Scan content to the last line
of input.

Method
Specify the calculation method (Hamiltonian).

UHF
Specify whether the calculation should be done in a closed or open shell system.

Charge
Specify charge.
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Multiplicity
Specifies spin multiplicity.

6.5.2 Configure

Set calculation condition of MOPAC. To set up the calculations immediately after setting Run button,
once to return to the main window please press OK button. Behavior when clicking Run is see (1) Run
MOP6W70, (2) Run MOP7W70, (3) Run MOPACX. return to the default state with Reset button. . Save
the current state as the default state with Save as Default button. Restore the default state to the factory
condition with Save as Default → Clear Default Settings.

Easy Setup
The simple setting window is displayed.

Hamiltonian
Specify the Hamiltonian to use. The Hamiltonian supported by each version of MOPAC is as follows.

Hamiltonian Version of MOPAC being implemented
AM1 MOPAC 6, MOPAC 7, MOPAC 93, MOPAC 97, MOPAC 2000, MOPAC

2002, MOPAC 2006, MOPAC 2009, MOPAC 2012, MOPAC2016
PM3 MOPAC 6, MOPAC 7, MOPAC 93, MOPAC 97, MOPAC 2000, MOPAC

2002, MOPAC 2006, MOPAC 2009, MOPAC 2012, MOPAC2016
RM1 MOPAC 2007, MOPAC2016
AM1 EXTER-
NAL=RM1.rm1

MOPAC 7.1, MOPAC 93, MOPAC 97, MOPAC 2000, MOPAC 2002,
MOPAC 2006, MOPAC 2009, MOPAC 2012

PM6 MOPAC 2007, MOPAC 2009, MOPAC 2012, MOPAC2016
PM7 MOPAC 2012, MOPAC2016
MINDO/3 MOPAC 6, MOPAC 7, MOPAC 93, MOPAC 97, MOPAC 2000, MOPAC

2002, MOPAC 2006
MNDO MOPAC 6, MOPAC 7, MOPAC 93, MOPAC 97, MOPAC 2000, MOPAC

2002, MOPAC 2006, MOPAC 2009, MOPAC 2012, MOPAC2016
MNDO-d MOPAC 97, MOPAC 2000, MOPAC 2002, MOPAC 2006, MOPAC 2009,

MOPAC 2012, MOPAC2016

Method
Specify the calculation method.

EF
Perform structure optimization calculation by EF (Eigen Vector Following) method.

TS
Find the transition state.

FORCE
Perform vibration analysis.

1SCF
Perform SCF calculation only once. (Structure optimization is not performed.)

IRC
Perform unique reaction coordinate calculation. Energy is not preserved.

IRC=1
Specify the inverse direction of the 1st reference vibration and calculate the unique reaction
coordinate.
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IRC=-1
Specify the positive direction of the first reference vibration and perform the unique reaction
coordinate calculation.

Charge
Specify the value of the charge.

Multiplicity
Specify multiplicity.

OPEN
Specify the number of electrons and the number of orbits in open shell calculation.

MM
MMOK

Molecular dynamics correction is added to CONH bond.

NOMM
Molecular mechanics correction is not added to CONH bond.

GNORM
Specify the threshold value of the energy gradient norm.

LARGE
Information is output for each specified cycle.

GRAPH
Create a file to graphically display molecular orbitals. (GPAGH/GRAPHF)

EXTERNAL
Read parameter file on disk.

STEP
Specify the step width in reaction coordinate calculation.

POINT
Specify the number of calculation points in reaction coordinate calculation.

STEP1/2
Specify the step size in the grid calculation.

POINT1/2
Specify the number of calculation points in the grid calculation.

AUX
Create an AUX file for use with another program.

BONDS
It outputs the final bond order matrix.

ENPART
Specify the energy split that resolves the energy into 1 center and 2 center terms.

ESP
Calculate electrostatic potential.

EXCITED
Optimize the singlet first excited state.

GEO-OK
Ignore the check if the atom is close to abnormal.
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NOINTER
Interatomic distance is not output.

OLDFPC
We use the same reference physical quantity value as the old version MOPAC.

POLAR
Calculate the polarizability.

PRECISE
Set the convergence judgment condition to 100 times stricter.

SYMMETRY
Define the structure using symmetry and equivalent conditions.

UHF
Perform unrestricted Hartree-Fock calculation.

VECTORS
The final eigenvector (wave function) is output.

XYZ
Calculation is performed using the XYZ coordinate system.

Others
Fill in other keywords.

Coordinate format
Specifies the format of the atomic coordinates (XYZ or Z-matrix).

Reset
Reset settings.

Import
Loading configuration file.

Export
Output configuration file.

6.5.3 Import Keywords

Only keywords (calculation conditions) are read from the existing MOPAC input file.

6.5.4 (1) Run MOP6W70, (2) Run MOP7W70, (3) Run MOPACX

If MOPAC input file is opened in the main window, execute MOPAC using that file. If it is not open,
save the input file of MOPAC and execute MOPAC. When saving the input file, the output format of
coordinates changes according to the choice of Coordinate Format ( Z-Matrix or XYZ ) and Coordinate
Viewer of Z-Matrix / XYZ tab. It is assumed that different versions of MOPAC are set for (1) MOP6W70
execution , (2) MOP7W70 execution, and (3) MOPACX execution, and that both are used in different
situations. The (1). The difference between :guilabel:`(1) Execute MOP6W70, (2) Execute MOP7W70,
and (3) Execute MOPACX is the program path of MOPAC to be launched. The program path used for each
menu can be changed in Tools → Preferences → Program Paths. The default MOP6W70 is MOPAC6 and
MOP7W70 is MOPAC7, both of which are built in Winmostar. The (3) Execute MOPACX is intended for
use with programs such as MOPAC2012, which you can obtain and specify separately. Following file will
be generated with execution. For example, the file/folder name when the input file is water.dat is shown
together.
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type Description

out file
water.out

It summarizes the outline of the calculation
result.

arc file
water.arc

It is a file summarizing the details of the cal-
culation result.

mgf file
water.mgf

This file is output by specifying the
keyword GRAPH and contains information
used to draw molecular orbitals.

Working Folder
water_mop_temp\

Working folder.

6.5.5 Open Log File (out)

Open out file in a text editor.

6.5.6 Open Log File (arc)

Open arc file with a text editor.

6.5.7 Animation

Optimization (arc)

Select the arc file and display the animation of the molecular structure. For the animation display operation
method, see Animation operation area.

IRC, STEP (out)

Select out file and display animation of IRC calculation. For the animation display operation method, see
Animation operation area.

80 Chapter 6. Details of each menu window



Winmostar™ User Manual, Release 11.13.0

6.5.8 Analyses

MO & Charges (mgf)

Select the mgf file and display the molecular orbital. GRAPHF must be set on keyword. Refer to Energy
Level Diagram window, Surface Setup / Cubgen window for how to operate the subwindow. Show charges
when you select View → Label/Charges → Show Mulliken Charge.

IR (out)

Select the out file and display the IR spectrum. Vibration calculation must be set with keyword. Refer to
IR Spectrum Window for how to operate the subwindow.

6.5.9 Use Job Manager

When checked, use Winmostar Job Manager when executing MOPAC. Otherwise, Winmostar will be in a
wait state until calculation by MOPAC is completed, and the output result of MOPAC will be automatically
loaded into the main window. It can also be set from Tools → Preferences menu.

6.6 QM → CNDO/S menu

It is a menu related to the CNDO/S program. The CNDO/S program is bundled with Winmostar. The
CNDO/S program is a slight modification of the P083 program registered in the former Japan Chemistry
Program Exchange Organization (JCPE, the present Japan Computer Chemistry Society) to correspond to
Winmostar. The manual of P083 is here <https://winmostar.com/jp/manual_third_party/cndos_man.pdf>.
The CNDO/S program (: file: cndosw.exe) has been compiled with gfortran.

6.6.1 Workflow Setting

Set up and run the CNDO/S calculation flow in project mode.

Preset
Recalls and saves a preset of settings.

# of Jobs
Specifies the number of jobs.

Enable parameter/structure scan
This feature requires the purchase of an add-on. It allows you to run multiple calculations where
only certain parameters differ (parameter scan) or to run calculations with the same parameters for
multiple structures (structure scan). Click Config to open the configuration window for the scan cal-
culation. For parameter scans, select %WM_SCAN1% for the Target Variable and enter the param-
eters you wish to set for %WM_SCAN1% in each row of the Values. Then, enter %WM_SCAN1%
in the parameters you want to set in the Workflow Settings window or Keyword Settings window.
For structure scan, select %WM_STRUCT% for Target Variable when the animation appears in the
molecule display area (e.g., by opening an SDF file). After the scan calculation is finished, use File
→ Project → Scan Results to tabulate the calculation results.

Import
Import the settings output by Export. Click the arrow at the right of the button to recall settings used
in the past on the same project or Winmostar.
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Export
Output settings to file.

OK
Runs a calculation or generates a file with your settings. See For project mode for details.

Details
Set up detailed calculation conditions. The Configure will be launched.

Task
Specify calculation details. (UV-Vis only)

Method
Specify calculation method.

Charge
Specify the charge.

Multiplicity
Specifies spin multiplicity.

6.6.2 Configure

Set calculation conditions of CNDO/S. To set up the calculations immediately after setting Run button,
once to return to the main window please press OK button. Behavior when clicking Run is see Run.

Method
Specify the calculation method. (CNDO or INDO)

Multiplicity
Specify multiplicity.

Basis set
Specify the basis function. (SP or SPD)

BONDS
Specifies to output the bond order

NOINTER
If checked, interatomic distance will not be output.

SHORT
It outputs a simplified log.

OUTMO
It outputs a file for MOLMOL 2.

Repulsion integral
Specify the expression of repulsion integral.

• Parisian

• Ohno

• Nishimoto - Iga

• Theoretical

Nuclear repulsion energy
Specify the expression of inter-nuclear repulsion energy.

• Za * Zb / 1
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• Za * Zb * Gamma ab

PKAPPA
p Specify the value of kappa for electrons.

DKAPPA
d Specify the value of kappa for electrons.

Charge
Specify the charge.

# of CI
Specify the number of states to include in the CI calculation of the excited state. (Max 500)

# of excited states
Specify the number of excitation states to output the bond order.

6.6.3 Import Keywords

Only keywords (calculation conditions) are read from the existing CNDO/S input file.

6.6.4 Run

If the input file of CNDO/S is open in the main window, execute CNDO/S with that file. If it is not open,
save the CNDO/S input file and execute CNDO/S. Following file will be generated with execution. For
example, the file/folder name when the input file is: file: water.cnd is also shown.

type Description

lst file
water.lst

Calculation log file.

Working Folder
water.cnd_temp\

Working folder.

6.6.5 Open Log File (lst)

Open the lst file with a text editor.
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6.6.6 Analyses

UV-Vis

Select lst file and display UV-Vis spectrum and molecular orbital. Refer to UV-Vis Spectrum window,
Energy Level Diagram window, Surface Setup / Cubgen window for how to operate the subwindow.

6.7 QM → GAMESS menu

It is a menu related to GAMESS. In order to use GAMESS you need to install GAMESS separately. The
way to install GAMESS is described in Installing Winmostar and solvers.

6.7.1 Workflow Setup

Sets up and executes the GAMESS calculation flow in project mode. Local jobs in project mode will use
the binary specified in GAMESS(1) in Tools → Preferences → Program Path.

Preset
Import and saves a preset of settings.

# of Jobs
Specify the number of jobs.

Enable parameter/structure scan
This feature requires the purchase of an add-on. It allows you to run multiple calculations where
only certain parameters differ (parameter scan) or to run calculations with the same parameters for
multiple structures (structure scan). Click Config to open the configuration window for the scan cal-
culation. For parameter scans, select %WM_SCAN1% for the Target Variable and enter the param-
eters you wish to set for %WM_SCAN1% in each row of the Values. Then, enter %WM_SCAN1%
in the parameters you want to set in the Workflow Settings window or Keyword Settings window.
For structure scan, select %WM_STRUCT% for Target Variable when the animation appears in the
molecule display area (e.g., by opening an SDF file). After the scan calculation is finished, use File
→ Project → Scan Results Viewer to tabulate the calculation results.

Import
Import the settings output by Export. Click the arrow to the right of the button to recall settings used
in the past on the same project or Winmostar.

Export
Output settings to file.

OK
Run a calculation or generate a file with your settings. See For project mode for details.

Details
Set up detailed calculation conditions. The Configure will be launched.

Task
Specifies the type of calculation. Keywords without a group name beginning with $ are from $CON-
TRL.
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Setting details

Energy RUNTYP=ENERGY

Optimize RUNTYP=OPTIMIZE

IR RUNTYP=HESSIAN

Raman RUNTYP=RAMAN

TDDFT RUNTYP=ENERGY
TDDFT=EXCITE
$TDDFT NSTATE=10

Optimize(TS) RUNTYP=SADPOINT
$STATPT HESS=CALC

Optimize(TDDFT) RUNTYP=OPTIMIZE
TDDFT=EXCITE
$TDDFT NSTATE=10

IRC(Forward) RUNTYP=IRC
$STATPT HESS=READ
$IRC FORWRD=.TRUE. NPOINT=20
MXOPT=40 SADDLE=.TRUE.

IRC(Reverse) RUNTYP=IRC
$STATPT HESS=READ
$IRC FORWRD=.FALSE. NPOINT=20
MXOPT=40 SADDLE=.TRUE.

Optimize+IR RUNTYP=OPTIMIZE
$STATPT HSSEND=.TRUE.

Optimize(TS)+IR RUNTYP=SADPOINT
$STATPT HESS=READ HSSEND=.TRUE.

RESP RUNTYP=ENERGY
MOLPLT=.TRUE.
$ELPOT IEPOT=1 WHERE=PDC
OUTPUT=PUNCH
$PDC PTSEL=CONNOLLY
CONSTR=NONE

6.7. QM → GAMESS menu 85



Winmostar™ User Manual, Release 11.13.0

Method
Specifies the calculation method (Hamiltonian). Keywords without a group name beginning with $
are from $CONTRL.

Setting details

Various DFTs DFTTYP=Various DFTs
(For DFT-D3) $DFT IDCVER=3

MP2 MPLEVL=2
$SYSTEM MEMDDI=500

CCSD CCTYP=CCSD

Basis set
Specifies a basis function.

Charge
Specify charge.

Multiplicity
Specify spin multiplicity.

Solvent
Specify PCM solvent type.

6.7.2 Configure

Set calculation conditions of GAMESS. To set up the calculations immediately after setting Run button,
once to return to the main window please press OK button. See the (1) Run GAMESS, (2) Run GAMESS
for the behavior when clicking Run. Return to the default state with Reset button. Save the current state as
the default state with Save as Default button. Restore the default state to the factory condition with Save
as Default → Clear Default Settings.

Easy Setup
Shows the simple setting window.

NCPUS
Specify the parallel number.

NODES (FireFly)
Specify the directory of the node used for calculation.

Basic Tab
$CONTRL

ICHARG
Specify charge.
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A LOT
Specify spin multiplicity.

SCFTYP
Specify SCF calculation method.

RUNTYP
Select the calculation purpose.

COORD
Specifies the format of the molecular structure coordinates. It is linked to the $DATA coor-
dinate format.

MAXIT
Specify the upper limit of the SCF calculation iteration number.

NZVAR
Specifies the number of internal coordinates. %NZVAR% is assigned 5000 if ZMAT con-
tains DLC=.T. AUTO=.T., 3N-6 if RUNTYP=OPTIMIZE with IFREEZ and 1 numerator
and 5 or more atoms, and 0 otherwise.

EXETYP
To specify whether or not to actually perform the calculation, specify CHECK to check the
input.

NOSYM
Specify whether to use symmetry in calculation.

NPRINT
Specify the detail level of the output.

LOCAL
Specify the method of localization of the trajectory. (Default 0 = not)

PP
Specify Pseudopotential (Effective Core Potential, ECP).

DFTTYP
Specify the basis function system of the density functional theory method.

TDDFT
Specify whether energy calculation of excited state is performed using time-dependent DFT
method

CITYP
Specify whether to perform placement interaction (CI) calculations.

CCTYP
Specify whether or not to perform combined cluster (CC) calculations.

ISPHER
Specifies whether the basis functions should be treated as Cartesian or spherical harmonic
functions. (Default -1 = Cartesian)

MPLEVL
Specify whether to perform Moller-Plesset perturbation (MP) calculations.

Others
Fill in other keywords.

$BASIS
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Basis Set
Specifies the base function system, reflected in GBASIS, NGAUSS, NDFUNC, NFFUNC,
DIFFSP, and DIFFS.

GBASIS
Specify the base set of the base function system.

NGAUSS
Specify the number of Gaussian functions

EXTFIL
Read the basis function from an external file.

NDFUNC
Specify the number of added d-polarization functions

NFFUNC
Specify the number of added f-polarization functions

NPFUNC
Specify the number of added p-polarization function

DIFFSP
Specify whether to add sp-diffuse function

DIFFS
Specify whether to add s-diffuse function

Others
Fill in other keywords.

Advanced tab
$SYSTEM

timl
Specify calculation time limit (default 525600 minutes)

MWORDS
Specify memory usage (default 1 MW)

MEMDDI
Specify maximum summed memory usage for DDI. (Default 1MW)

Others
Fill in other keywords.

$SCF
DIRSCF

Specify whether to use direct SCF calculation method.

DAMP
We use Davidson damping to create Fock matrix.

CONV
Specify the threshold of density change at SCF convergence judgment. (Default 1.0D - 05)

Others
Fill in other keywords.

$GUESS
GUESS

Specify how to calculate the initial wave function.
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Others
Fill in other keywords.

$STATPT
NSTEP

Specify the upper limit of the number of steps of structure optimization. (Default 20)

OPTTOL
Specify the threshold of the energy gradient. (Default 0.0001 Hartree/Bohr)

METHOD
Specify algorithm for structure optimization.

HESS
Specify how to obtain the Hessian matrix.

HSSEND
Specifies whether or not a Hessian matrix is desired at the end of the calculation.

Others
Fill in other keywords.

$FORCE
TEMP

Specifies the temperature (Kelvin) in thermodynamic data calculations. (default 298.15)

Others
Fill in other keywords.

Z-Matrix tab
Set “DLC=.T. AUTO=.T.” if RUNTYP=OPTIMIZE, (# atoms)>5 & (# mols)=1

If checked, set %ZMATDLC%. Set %ZMATDLC% to “DLC=.T. AUTO=.T.” if
RUNTYP=OPTIMIZE without IFREEZ and with 1 numerator and 5 or more atoms.

DFT tab
$DFT

LC
Specify whether to perform long distance correction. (Only for BLYP, BOP and BVWN)

MU
Specify the value of long-distance correction parameter. (Default 0.33)

DC
Specifies whether Grimme’s empirical dispersion force correction should be applied.

IDCVER
Specifies the version of Grimme’s empirical dispersion force correction.

Others
Fill in other keywords.

$TDDFT
NSTATE

Specify the number of desired states (excluding the base state).

NRAD
Specify the number of grid points in the radial direction for deriving the derivative of density
functional. (Default 48)
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NLEB
Specify the number of lattice points in the angular direction. (Default 110)

Others
Fill in other keywords.

MP2 tab
$MP2

CODE
Specify the directory of the node used for calculation.

Others
Fill in other keywords.

Solvent tab
$PCM

SOLVNT
Specify the solvent.

SMD
Specify whether to use SMD (Solvent Model Density).

IEF
Specifies the type of PCM model.

ICAV
Specifies whether Cavitation energy should be calculated.

TABS
Specify temperature (Kelvin). (default 298.0)

Others
Fill in other keywords.

$PCMCAV
RADII

Specifies the type of cavity radius.

Others
Fill in other keywords.

IRC Tab
$IRC

FORWRD
Specifies forward or reverse direction.

PACE
Specify IRC calculation method.

NPOINT
Specify the number of IRC points.

MXOPT
Specify the maximum number of steps for structural optimization at each IRC point.

STRIDE
Specifies the distance between IRC points.
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SADDLE
Specifies whether the structure of $DATA is a saddle point.

OPTTOL
Specifies the threshold value of the energy derivative to determine if a minimum point has
been reached.

Comment tab
Fill in your comments.

Preview tab
A preview of the configuration keywords will be displayed.

Import $HESS
Import $HESS from the punch file.

Import $VEC
Import $VEC from the punch file.

Reset
Reset settings.

Import
Read the basis function from an external file.

Export
Output configuration file.

6.7.3 Import Keywords

Only keywords (calculation conditions) are read from the existing GAMESS input file.

6.7.4 (1) Run GAMESS, (2) Run GAMESS

If the input file of GAMESS is opened in the main window, execute GAMESS using that file. If it is
not open, save the input file of GAMESS and execute GAMESS. When saving the input file, the atomic
coordinate format of $DATA changes according to the setting of COORD in $CONTRL; for ZMTMPC, the
format is MOPAC’s Z-matrix format, otherwise it is Cartesian format. (1) GAMESS run , (2) GAMESS run
are intended to be used with different versions of GAMESS, depending on the situation. The difference
between (1) Execute GAMESS , (2) Execute GAMESS is the program path of GAMESS to be invoked.
The program path used for each menu can be changed in Tools → Preferences → Program Paths. To
use the external basis function file (: command: $ BASIS EXTFIL = .T.), Put basis.lib in the same
directory as GAMESS's EXE file. For WinGAMESS, specify setenv EXTBAS ../ basis.lib in :file:`
runscript.csh`. Following file will be generated with execution. As an example, the file/folder name when
the input file is water.inp is also shown.
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type Description

out file
water.out

Calculation log file.

bat file
water.inp.bat

This is a batch file for running GAMESS.

pun file
water.pun

It is a punch file for detailed result analysis.

The job is run through Winmostar Job Manager.

6.7.5 Open Log File (out/log)

Open the out file with a text editor.

6.7.6 Show log excerpts

Excerpts of key information from the out file.

6.7.7 Animation(Optimization)

Create and display animation such as structure optimization, scanning, IRC calculation, etc. from the out
file information. For the animation display operation method, see Animation operation area.

6.7.8 Analyses

Molecular Orbitals, Charge

Retrieve and display molecular orbital and charge information from out file information Information on the
charge read can be displayed in Viewport by selecting View → Labels/Charges → Show Mulliken Charge
and so on. See Energy Level Diagram window , Surface Setup / Cubgen window for subwindow operation.
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UV-Vis Spectra

Displays UV-Vis spectra from information in out files. See UV-Vis Spectrum window for subwindow
operation.

NMR Spectra

Display NMR spectra from information in out file. See NMR Window for subwindow operation.

IR/Raman

Display vibration spectra (IR or Raman spectra) from the information in the out file. After loading the IR
spectrum from the out file of RUNTYP = HESSIAN, if you subsequently read the out Raman spectrum of
:command: RUNTYP = RAMAN in this menu, both spectra are displayed simultaneously in the subwindow
can. Refer to IR Spectrum Window for how to operate the subwindow.

RESP Charges

Calculate point charge based on RESP method from punch file. The punch file to be loaded must be output
from a calculation performed with the RESP/ESP setting selected in the Preference → Easy Setup. The
spin multiplicity is treated with the assumption of 1. After being asked “Do you assign the same charge to
an atom that is structurally equivalent to a molecule?”, when you click Yes, it internally uses acpype, and
when you click No, it internally uses AmberTools directly to calculate the RESP charge. Basically, it is
recommended to click Yes, but in such cases, click No. It is expected that the results of both calculations
will not change significantly. If you want to average the charges of structurally equivalent atoms (e.g. the
three hydrogen atoms of a methyl group) after choosing No, use Average the group’s charge. Note that
Firefly is not supported by this feature.

Warning: To use this function, CygwinWM setup is required.

6.7.9 Edit PDB file

Editing of atom deletion etc. is done while leaving residue information etc. of PDB data etc.

6.8 QM → Gaussian menu

It is a menu about Gaussian. In order to use Gaussian you need to install Gaussian separately.
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6.8.1 Workflow Settings

Sets up and executes the Gaussian computation flow in project mode. Local jobs in project mode will use
the binary specified in Gaussian in Tools → Preferences → Program Path.

Preset
Recalls and saves a preset of settings.

# of Jobs
Specifies the number of jobs.

Enable parameter/structure scan
This feature requires the purchase of an add-on. It allows you to run multiple calculations where only
certain parameters differ (parameter scan) or run calculations with the same parameters for multiple
structures (structure scan). Click Config to open the configuration window for the scan calculation.
For parameter scans, select %WM_SCAN1% for the Target Variable and enter the parameters you
wish to set for %WM_SCAN1% in each row of the Values. Then, enter %WM_SCAN1% in the pa-
rameters you want to set in the Workflow Settings window or Keyword Settings window. For structure
scan, select %WM_STRUCT% for Target Variable when the animation appears in the molecule dis-
play area (e.g., when you open an SDF file). After the scan calculation is finished, use File → Project
→ Scan Results to tabulate the calculation results.

Import
Load the settings output by Export. Click the arrow to the right of the button to recall settings used
in the past on the same project or Winmostar.

Export
Output settings to file.

OK
Run a calculation or generate a file with your settings. See For project mode for details.

Details
Set up detailed calculation conditions. The Configure will be launched.

Task
Specifies the type of calculation. Note that CHelpG charges are read as ESP charges when the log
file is read.
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Configuration details

Energy

Optimize opt

IR freq=noraman

IR+Raman freq=raman

TDDFT td=(nstates=10)

NMR nmr

Optimize(TS) opt=(ts,noeigentest,calcfc)

Optimize(TDDFT) opt
td

IRC(Forward) irc=(forward,maxpoint=20,stepsize=5,calcfc)
No pop designation

IRC(Reverse) irc=(reverse, maxpoint=20, stepsize=5, calcfc)
No pop designation

Optimize+IR opt
freq=noraman

Optimize+IR+Raman opt
freq=raman

Optimize(TS)+IR opt=(ts,noeigentest,calcfc)
freq=noraman

RESP Pop=mk
scf=tight
iop(6/41=10,6/42=17,6/50=1)
Add %WM_PREFIX%.esp to the last line of
input.

CHelpG Pop=chelpg

Scan opt=modredundant
nosymm
No pop designation
Add the specified Scan content to the last line
of input.
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Method
Specify the calculation method (Hamiltonian).

Configuration details

HF HF

Various DFTs functional name
(For DFT-D3) Empirical Dispersion=gd3

MP2 MP2

Basis set
Specify the set of basis functions.

Charge
Specify the value of the charge.

Multiplicity
Specify Spin multiplicity.

Solvent
Specify solvent type and solvent calculation method.

6.8.2 Configure

Set calculation conditions of Gaussian. To set up the calculations immediately after setting Run button,
once to return to the main window please press OK button. Behavior when clicking Run is see Run. Return
to the default state with Reset button. Save the current state as the default state with Save as Default button.
Restore the default state to the factory condition with Save as Default → Clear Default Settings.

Easy Setup
Show the simple setting window.

%nprocshared
Specify the parallel number(Number of CPU cores used).

Link0
%Chk=file

Specify the checkpoint file.

%Mem=n
Specify the amount of dynamic memory in 8 bytes words. It is also possible to specify units of
KB, MB, GB, KW, MB, GW. (Default: 800 MB)

Comment
Write a comment.
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#
Specify the beginning of the route section.

#N
Output is done at the standard level. (Default)

#P
Perform detailed output. The execution time at the start and end of each link, and the information
on convergence of SCF are output.

#T
Specify a concise output that only outputs important information and results.

Charge
Specify the value of the charge.

Multiplicity
Specify Spin multiplicity.

Additional Chg./Multi.
Specify additional charge and spin multiplicity.

Hamiltonian
Specify the Hamiltonian to use.

Ltd.
Perform Hartree-Fock calculation. Unless explicitly specified, RHF is used for singlet and UHF
is used for higher multiplicity.

rhf
Restricted Hartree-Fock calculation is performed.

uhf
Unrestricted Hartree-Fock calculation is performed.

am1
We will perform semi-empirical calculations using AM1 Hamiltonian.

pm3
We perform semi-empirical calculation using PM3 Hamiltonian.

pm3mm
We perform semi-empirical calculations using PM3 Hamiltonian with molecular dynamics cor-
rection on HCON binding.

b3lyp
Compute the density functional method combining the Becke 3 functional with the LYP nonlocal
correlation functional.

ub3lyp
Unrestricted version of b3lyp.

mp2
Following Hartree-Fock calculation, Moller-Plesset correlation energy correction up to the sec-
ond order is performed.

ump2
It is an Unrestricted version of mp2.

mp4
Following Hartree-Fock calculation, Moller-Plesset correlation energy correction up to the
fourth order is performed.
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ump4
It is an Unrestricted version of mp4.

cis
Calculate the excited state using one-electron excitation CI.

cisd
Calculate the excited state using two electron excitation CI. (Synonymous with CI)

indo
We will perform semi empirical calculations using INDO Hamiltonian.

ondo
We will do semi-empirical calculations using CNDO Hamiltonian.

gvb
Perform general valence bond (GVB) calculation.

Basis
Specify the set of basis functions.

Pop
Control of molecular orbital output, electron density analysis, atomic charge distribution and so on.

none
It does not output molecular orbits and does not analyze electron density.

minimal
It outputs atomic charge and orbital energy.

regular
We output 5 occupied orbits and 5 virtual trajectories. Also output density matrix and Mulliken
electron density analysis.

full
All occupied orbits and virtual trajectories are output. Also output density matrix and Mulliken
electron density analysis.

mk
Output charge fitted to electrostatic potential in Merz-Singh-Kollman scheme.

chelp
Outputs charge fitted to electrostatic potential with CHelp scheme.

chelpg
Outputs charge fitted to electrostatic potential with CHelpG scheme.

(full,chelp)
Outputs charges fitted to the electrostatic potential in the CHelp scheme, all occupied orbitals
and virtual orbitals. It also outputs the density matrix and Mulliken electron density analysis.

(fullchelpg)
Outputs charges fitted to the electrostatic potential in the CHelpG scheme, all occupied orbitals
and virtual orbitals. It also outputs the density matrix and Mulliken electron density analysis.

(full,npa)
Outputs NBO (Natural Bond Orbital) charges by Natural Population Analysis, all occupied orbits
and virtual orbits. It also outputs the density matrix and Mulliken electron density analysis.

OPT/IRC
Controls structural optimization or IRC calculations.
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opt
Perform structure optimization.

opt=z-matrix
Structure optimization is performed with internal coordinates.

opt=modredundant
Add, delete, or modify the definition of redundant internal coordinates (including search and
bound information). An input section is required after the structure specification.

opt=(ts,noeigentest,calcfc)
Optimize for transition state. We do not test curvature. Calculate the force constant for the first
time.

opt=tight
Tighten the threshold for determining convergence of force and coordinate changes.

irc=(forward, maxpoint=20, stepsize=5, calcfc)
Tracks a forward reaction path. Specify the number of points on the path and the step size.
Calculates force constants for the first time.

irc=(reverse, maxpoint=20, stepsize=5, calcfc)
Tracks the reaction path in the reverse direction. Specify the number of points on the path and
the step size. Calculates force constants for the first time.

OptMaxCyc
Sets the maximum number of structural optimization steps.

Scrf
run the calculation with solvent effects.

SCF
Controls SCF calculations.

scf=tight
Convergence decision for normal SCF calculation. (Default)

scf=qc
Use second-order convergence method.

scf=xqc
If the first-order convergence method does not converge, switch to the second-order convergence
method halfway through.

scf=vshift[=N]
Shifts orbit energy by N*0.001 Hartree, default value of N is 100.

Freq
Controls the calculation of force constants and frequencies.

freq
Calculate force constants and frequencies.

freq=raman
We calculate the Raman intensity in addition to the IR intensity.

freq=vcd
Calculate oscillating circular dichroism (VCD) intensity in addition to normal frequency analysis

freq=noraman
Only IR intensity is calculated and Raman intensity is not obtained.
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freq=nraman
Calculate the polarizability derivative by numerically differentiating the analytical dipole deriva-
tive for the electric field.

freq=nnraman
Calculate the polarizability derivative by numerically differentiating the analytical polarizability
on nuclear coordinates.

NMR
Controls NMR calculations.

nmr
Perform NMR calculations.

nmr=giao
Perform NMR calculations using the GIAO method. (Default)

nmr=csgt
NMR calculations using the CSGT method.

nmr=igaim
Perform NMR calculations using atomic center coordinates as gauge origin.

TD
td

Calculate excited state energies using the time-dependent Hartree-Fock or DFT method. (default
singlet).

td=(nstates=n)
For the n states, we obtain the energy of the excited state using the time dependent calculation
method. (Default 3)

td=50-50
Half of the states are calculated as singlet and the other half as triplet. Valid only for closed-shell
systems.

td=triplets
Calculate the triplet state. Valid only for closed-shell systems.

EmpiricalDispersion
Enable empirical dispersion power.

pfd
Add Petersson-Frisch dispersion power.

gd2
Add D2 version of Grimme dispersion force.

gd3
Add D3 version of Grimme dispersion force.

gd3bj
Add D3 version of Grimme dispersion force with Becke-Johnson damping.

Config ONIOM
Set up ONIOM calculation. You must have assigned each atom to a layer with beforehand.

Hamiltonian
Set the Hamiltonian for each layer.

Basis
Sets the basis function for each layer.
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gfinput
Outputs the basis function system in the same format as the input format.

gfprint
It outputs the basis function system in tabular form.

nosymm
Do not reorient the coordinates, run the calculation with the input orientation.

guess=read
Read initial wave function from checkpoint file

geom=check
Fetch the molecule specification section from the checkpoint file.

fchk
Create the Test.FChk file.

counterpoise
Perform a counterpoise calculation. The fragment number set for each atom is assigned the residue
number on Winmostar. Note that the Assign different residue numbers to each molecule. function
can be used to assign different residue numbers to each molecule at once.

Subsection
Fill in other keywords.

Coordinate format
Specifies the format of the atomic coordinates (Cartesian or Z-matrix).

Reset
Reset settings

Import
Output configuration file.

Export
Output the Cube file.

6.8.3 Import Keywords

Only keywords (calculation conditions) are read from the existing Gaussian input file.

6.8.4 Run

If Gaussian's input file is opened in the main window, use Gaussian to execute it. If it is not open, save
the Gaussian input file and run Gaussian. Gaussian's program path can be changed with:: menuselection:
Tools –> Preferences –> Program Path. Following file will be generated with execution. For example, the
file/folder name when the input file is: file: water.gjf is shown together.
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type Description

log file
water.log

Calculation log file.

bat file
water.gjf.bat

It is a batch file for running Gaussian.

Working folder
water_gau_tmp\

Working folder.

The job is run through Winmostar Job Manager.

6.8.5 Open Log File (log/out)

Open the log file with a text editor.

6.8.6 Animation

Optimization

Creates and displays animation of structural optimization calculation from information of log file. For the
animation display operation method, see Animation operation area.

IRC/modred

Creates and displays animation of IRC calculation from information of log file. For the animation display
operation method, see Animation operation area.

6.8.7 Analyses

Molecular orbitals, Charge

Retrieve and display molecular orbital and charge information from log file information Information on the
charge read can be displayed in Viewport by selecting View → Labels/Charges → Show Mulliken Charge
and so on. See Energy Level Diagram window , Surface Setup / Cubgen window for subwindow operation.
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UV-Vis Spectra

Displays UV-Vis spectra from log file information. Refer to IR Spectrum Window for how to operate the
subwindow.

See UV-Vis Spectrum window for subwindow operation.

Display NMR spectra from log file information. See NMR Window for subwindow operation.

IR/Raman

Displays vibration spectra (IR or Raman spectra) from information in the log file. Refer to IR Spectrum
Window for how to operate the subwindow.

RESP Charges

Calculate the point charge based on the RESP method from the esp file. The esp file to be read must
have been output from a calculation performed by selecting RESP/ESP in Configure → Easy Setup. Spin
multiplicity is assumed to be 1. Internally, RESP charge is calculated using Antechamber. To use this
function, you need to use G09.C.01 or later version; if you use the version before G09.C.01, you need to
change the IOP.

Warning: To use this function, CygwinWM setup is required.

Assigning ONIOM layers

Show Layer Flags
Displays the flags for the layers assigned to each atom.

Unset Layers for All Atoms
Delete flags for all atom layers.

Select Atoms in High/Middle/Low Layer
Group selection of atoms set to High/Middle/Low Layer, used to confirm atoms set to
High/Middle/Low Layer.

Set Selected Group to High/Middle/Low Layer
Set the atom of the selected group to High/Middle/Low Layer.

Select All
Group selection of all atoms.

Select None
Deselect group selection.

6.8. QM → Gaussian menu 103



Winmostar™ User Manual, Release 11.13.0

6.8.8 FormChk

Launch Formchk in the G16W, G09W, and G03W utilities to create and display formatted .fch files from
.chk files.

6.8.9 Import Fchk (Cubegen) File

Run Cubegen from the G16G, G09W, or G03W utility and create a Cube file by reading the .fch file. If
Cubegen is not available, use Winmostar’s built-in OpenCubegen. For how to operate the subwindow,
please refer to Surface Setup / Cubgen window and the following.

Property
MO

Molecular orbital

Density
Electron density

ESP
ESP

Spin
Spin density (alpha - beta)

Alpha
alpha spin density

Beta
beta spin density

Current Density
Current Density

Shielding Density
Shielding Density

Type
Specify the option of the Density keyword. (HF, MP 2, CI, QCI)

Cube
Output the Cube file.

OpenCubegen supports fchk files up to approximately 2 GB. The upper size limit depends on the molecule
size and basis functions. We plan to remove the fchk file size limitation in the future.

6.8.10 Import Cube File

Read and display the Cube format file. For GAMESS pun file, convert it to Cube file. For how to operate
the subwindow, please refer to Surface Setup / Cubgen window and the following.

cube Manipulation
Perform operations on cube files specified in File 1 and File 2.

map
Map the data in the lower column to the data in the upper column. (Example mapping ESP to
Density)

subtract
We will cover the difference between the data of the two cube files.
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sub 2
We will cover the difference between the squares of the data of two cube files.

add
We will cover the sum of two cube files.

Cube
The calculation result of the cube file targeted by Map is output and displayed.

Cubegen
Start Cubegen, read the fch file and create a Cube file. For details, see Import Fchk (Cubegen) File.

6.9 QM → NWChem menu

It is a menu related to NWChem.

6.9.1 How to set up NWChem

To install NWChem, install CygwinWM after the 2023/04/05 version, which contains nwchem.exe in /
opt_win/NWChem*/bin/ of CygwinWM. To run MPI parallel calculations, install MPICH according to
the NWChem for Windows Installation Manual. The configuration for using NWChem from Winmostar
is done at Tools → Preferences menu. If you have newly installed Winmostar V11.5.0 or later and are
using CygwinWM 2023/04/05 version or later, no configuration is required. First, under Program Path →
NWChem, select nwchem.exe for the NWChwm you want to use. Next, under Calculation → mpiexec
(NWChem), select MPICH or Select and select mpiexec.exe for the MPI you are using. If you want
to use NWChem stored in CygwinWM, select MPICH. Finally, in Calculation → Options for mpiexec
(NWChem), enter the argument for mpiexec.exe, which does not need to be changed if you use NWChem
in CygwinWM. How to install NWChem on a remote machine is described in Installing Winmostar and
solvers.

6.9.2 Workflow Setting

Sets up and executes the Gaussian computation flow in project mode. Local jobs in project mode use the
binary specified in NWChem of tools → preferences → program path.

Preset
Load and save a preset of settings..

# of Jobs
Specify the number of jobs.

Enable parameter/structure scan
This feature requires the purchase of an add-on. It is possible to run multiple calculations in which
only certain parameters differ (parameter scan) or to run calculations with the same parameters for
multiple structures (structure scan). Click Config to open the configuration window for the scan cal-
culation. For parameter scans, select %WM_SCAN1% for the Target Variable and enter the param-
eters you wish to set for %WM_SCAN1% in each line of the Values. Then, enter %WM_SCAN1%
in the parameters you want to set in the Workflow Settings window or Keyword Settings window.
For structure scan, select %WM_STRUCT% for Target Variable when the animation appears in the
molecule display area (e.g., by opening an SDF file). After the scan calculation is finished, use File
→ Project → Parameter/Structure Scan Results to tabulate the calculation results.
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Import
Loads the settings output by Export. Click the arrow to the right of the button to recall settings
previously used in the same project or on Winmostar.

Export
Output configuration file.

OK
Runs a calculation or generates a file with your settings. See For project mode for details.

Details
Set up detailed calculation conditions. The Configure will be launched.

Task
Specifies the type of calculation.
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Configuration details

Energy task energy

Optimize task optimize

IR task frequencies

IR+Raman task raman
property response 1 8.8559E-2

TDDFT task tddft energy
notriplet
nroots 10
Noautosym True

NMR task energy
task property
property shielding

Optimize(TS) task saddle

Optimize(TDDFT) task tddft optimize
notriplet
civecs
nroots 10
grad root 1
Noautosym True

Optimize+IR task optimize
task frequencies

Optimize(TS)+IR task saddle
task frequencies

NEB task neb
No Mulliken
No Dipole
Noautosym True
Noautoz True
Nocenter True
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Method
Specify the calculation method (Hamiltonian).

Configuration details

HF task scf

Various DFT XC Functional name
(for DFT-D3) Disp vdw 3

Basis set
Specifies the basis function.

Charge
Specify the charge.

Multiplicity
Specify the DFT spin multiplicity.

Solvent
Specify the solvent type.

6.9.3 Configure

Set calculation conditions of NWChem. To set up the calculations immediately after setting Run button,
once to return to the main window please press OK button. Behavior when clicking Run is see Run. Return
to the default state with Reset button to.

Easy Setup
Show the simple setting window.

Use MPI
When checked, MPI is used. Enter the parallel number next to the checkbox.

Basic Tab
Start-up mode

Use “start” to start a new calculation, or “restart” to continue from a calculation that has already
been performed.

Title
Specify the title.

Memory
Specify the memory usage.

Basis
Specify the basis function system. Choose cartesian/spherical. Specify exception for some
atoms with Exception.
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Task
Specify the calculation method (theory) and calculation purpose (operation).

Charge
Specify the charge.

DFT
Multiplicity

Specify the DFT spin multiplicity.

XC
Specifies the exchange-correlation functional of the DFT..

cam
Specifies a long-distance correction.

Disp
Specify empirical dispersion force correction.

SCF
Multiplicity

Specify the SCF multiplicity.

Wave Function
Specify the calculation theory of SCF.

Property
Mulliken

Mulliken Select whether to output electric charge.

Shielding
Select whether to perform NMR calculation.

Dipole
Select whether to output dipole moment.

Advanced tab
Set tolguess

Specify the precision of initial guess.

ECP
Specify the potential of ECP.

Driver (Optimize)
MaxIter

Specify the maximum number of iterations for optimization.

Convergence
Specify the precision of structural optimization.

Others
Describe other input elements.

Geometry
noautoz

Set not to convert internal coordinates.

noautosym
Set to not use symmetry.
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Symmetry
Specify the symmetry.

Others
Describe other input elements.

SCF/DFT
MaxIter

Specify the maximum number of cycles for SCF/DFT energy calculation.

Direct
Specify Direct calculation (2-electron integrals are calculated each time).

Others
Describe other input elements.

Solvent tab
COSMO

Solvent
Specify the solvent type.

Dielec
Specifies the dielectric constant of the solvent.

Ificos
Specifies how the solvent area is divided.

do_cosmo_smd
Configures the use of the SMD method.

do_gasphase
Sets whether the gas phase is calculated before the solvent calculation.

Others
Describe other input elements.

TDDFT tab
NOSINGLET

Sets whether or not to calculate the excited singlet.

NOTRIPLET
Sets whether or not to calculate the excited triplet.

CIVECS
Specifies saving of CI vectors to a file.

Nroots
Specifies the number of excited states to be calculated.

Target
Specifies the solution number of the target’s excited state.

TargetSym
Specifies the symmetry of the target’s excited state.

Grad Root
Specifies the solution number of the target excited state for the TDDFT derivative calculation.

Others
Describe other input elements.
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NEB/String tab
It becomes effective when neb or string is specified as Operation of Task.

NBeads
Specify the number of beads.

KBeads
Specify the spring constant of NEB.

MaxIter
Specify the maximum number of iterations for optimization.

StepSize
Specify the optimization step size.

NHist
Specify the number of histories to use in the quasi-Newton method.

Freeze1
Set whether to fix the first bead with ZTS.

FreezeN
Set whether to fix the last bead with ZTS.

Convergence
Choose the convergence condition from loose/default/tight.

XYZ_Path
Specifies the initial path file. Used for restarting calculations, etc.

Print_Shift
Output paths for each step you specify.

EndGeom
Specify the coordinates of the last bead. You can specify a file by loading it with the Load button.
Load format that can be read with Winmostar in XYZ format. You can also edit with the Edit
button.

Others tab
Other Settings

Describe other input elements.

Coordinate format
Specifies the format of the atomic coordinates (Cartesian or Z-matrix).

Reset
Reset settings.

Import
Loading configuration file.

Export
Output configuration file.
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6.9.4 Import Keywords

Only the keyword (calculation condition) is read from the existing NWChem input file.

6.9.5 Run

If NWChem's input file is open in the main window, use NWChem to execute the file. If it is not open,
save the input file of NWChem and run NWChem. The program path of NWChem can be changed with
Tools → Preferences → program path. Following file will be generated with execution. For example, the
file/folder name when the input file is: file: water.nw is shown together.

type Description

out file
water.out

Calculation log file.

movecs file
water.movecs

It is a file that summarizes detailed informa-
tion of calculation.

bat file
water.bat

It is a batch file for running NWChem.

Working folder
water.nw_temp\

Working folder.

The job is run through Winmostar Job Manager.

6.9.6 Open Log File (out)

Open the out file in a text editor.

6.9.7 Animation

Optimization

Create and display animation such as structure optimization from the out file information. For the anima-
tion display operation method, see Animation operation area.
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NEB/String

Create and display NEB, String calculation animation from xyz file information. For the animation display
operation method, see Animation operation area.

6.9.8 Analyses

Molecular Orbitals, Charge

Retrieve and display molecular orbital and charge information from out file information Information on the
charge read can be displayed in Viewport by selecting View → Labels/Charges → Show Mulliken Charge
and so on. See Energy Level Diagram window , Surface Setup / Cubgen window for subwindow operation.

UV-Vis Spectra

Displays UV-Vis spectra from information in out files. Refer to IR Spectrum Window for how to operate
the subwindow.

NMR Spectra

Display NMR spectra from information in out file. See NMR Window for subwindow operation.

IR/Raman

Display vibration spectra (IR or Raman spectra) from the information in the out file. Refer to IR Spectrum
Window for how to operate the subwindow.

6.10 MD menu

It is a menu on the molecular dynamics method. Also, with almost every feature CygwinWM is required.

6.10.1 Solvate/Build Cell

This function is mainly used for the following two purposes.

1. Arrange solvent molecules around the molecules displayed in the main window

2. Create liquid phase by arranging low molecules

There are three kinds of molecules that can be arranged as follows.

• Molecule displayed in the main window

• Molecules preserved in mol 2 format

• water molecule

A working folder with _builder_tmp added to the end of the current file name is created, and processing
using Packmol is performed in that folder. Details are described in packmol.bat and packmol.log
under the working folder. output.pdb under the working folder is the file containing the final generated
molecular structure.
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Add Displayed Molecule
Add molecules displayed in the main window. After pressing the button, enter the number
of molecules to be added. If only one is placed, other molecules are aligned with the
coordinates fixed for the molecules displayed in the main window.

Add File
Add molecules from a previously saved molecular structure file to the system. After press-
ing the button, specify the location of the file and enter the number of molecules to add. If
the number of molecules to be added is 1, specify whether the molecules are to be placed
randomly or fixed to the coordinates written in the file. When placing a ligand molecule cut
from a PDB file, the placement is usually fixed. When performing MD calculations using
point charges (RESP charges, etc.) obtained from QM calculations, etc., the file specified
here must contain information on the point charges. The point charge information can be
maintained in mol2, wmm, or other formats.

Add SMILES
Specify the type of molecules you want to arrange in SMILES format.

Add Water
Add water molecules to the system. After pressing the button, enter the number of
molecules to be added. The water molecule model is selected from Water Model in Options
tab.

Delete
Deletes the selected item in the above list.

Simulation Cell
Set Density

Specify the density of the simulation cell to be created. If it is too large, you may not
be able to insert the molecule sufficiently, so in case of liquid phase it is usually set to
about 0.5~0.8 g/cm 3.

Set Margin from Solute
When choosing Solvate for Method, specify the distance between the molecule dis-
played on the main window and the simulation cell.

Set Lattice Constants
Specify the size of the simulation cell directly. When you press : guilabel:Same as
main window button, the same value as the cell set in the main window is entered.

Same as main window
Sets the lattice constant of the cells displayed in the molecular display area.

Change only one direction
Used to move one lattice constant to the specified density while keeping two lattice
constants fixed. It can be used by selecting triclinic in Box Type. This is especially
useful when creating interface structures.

Box Type
Specify the shape of the simulation cell.

Option
Water Model

Specify the water model added by Add Water. The coordinate data of the specified
water model will be quoted from the library of the topology file installed in Gromacs
on Cygwin.

Packmol Parameters
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Tolerance
Specify tolerance parameter of Packmol.Specifies the minimum distance between
atoms.

Tolerance(Fixed)
Specifies the minimum distance between atoms and the tolerance parameter in Pack-
mol for molecules with Fixed Position. This is useful when you do not want to place
solvent in a slab or protein.

Margin
Specify the width of the area where no atoms are placed near the edge of the cell
when using Packmol.

Random seed
Specify the seed of random number when using Packmol.

Do not rotate
Align molecules without changing their orientation. It is intended for the creation
of nematic liquid crystal phases, etc.

Automatically change random seed every time
The seed of random number when using Packmol is automatically changed every
time.

Use PBC if Margin=0 and Packmol supports it
When using CygwinWM 2025/7/1 version or later, if Margin is 0, the molecules are
placed considering the periodic boundary condition. If not checked, there will be
no molecules that straddle cell boundaries. This feature is not available for Packmol
in CygwinWM prior to the 2025/7/1 version.

SMILES converter
Specify the program to use when turning SMILES entered in Add SMILES into a 3D
structure.

Shift origin to cell center
Sets the origin to the center of the cell.

Reset
Resets the settings in this window.

Build (Multi)
Create simulation cells according to the settings in this window. Multiple patterns are
generated with different random seeds. The random seed used is the value of Random
seed in the first structure, the value of Random seed plus one in the second structure, and
the value of Random seed plus two in the third structure. The third structure uses the value
of Random seed plus two (as below). This is useful to increase the number of samplings by
performing multiple MD calculations with different initial coordinates using the structure
scan.

Build
Create a simulation cell according to the contents set in this window.
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6.10.2 Insert Molecules

You can add multiple molecules stored in mol 2 format to the structure displayed in the main window. If
no simulation cell has been created, create it with Create/Edit Cell or Solvate/Build Cell beforehand. If
you want to add only one additional molecule without changing the coordinates, please select Import File.
Basic operation is the same as Solvate/Build Cell.

6.10.3 Assign Charges Automatically

Automatically assign charges to multiple molecules. A working folder with _charge_tmp at the end of
the current filename is created and processed. See Use AM1-BCC/Gasteiger charges , Use RESP charges
, Use OPLS-AA charges for more details.

Set . . . for all components
If checked, charges will be calculated for all molecular species displayed in the main win-
dow using the method specified in the pull-down menu. If unchecked, select a Method for
each atomic species.

Except for components that are already charge
If checked, even if Set . . . for all components is checked, no new charge will be as-
signed to molecules that have already been assigned.

Except for protein, monoatomic ion and water
When checked, no charge is assigned to proteins, monatomic ions, and water molecules
in this function. In the MD calculation of proteins, it is necessary to check the box
because it takes time to calculate the charge by methods such as AM1-BCC and the
charge is automatically assigned from the residue name when assigning the force field.

Method
Select the method to assign the charge.

Charge
Set the charge for that molecular species. The charge is specified as 0 for neutral molecules
and +1, -1 for ions.

6.10.4 Assign Charges Manually

Use AM1-BCC/Gasteiger charges

Calling this function while only one molecule is displayed in the main window allocates point charge to
each atom by AM1 - BCC or Gasteiger method. Internally I use the Acpype program on Cygwin. It is used
when creating a file in mol 2 format to be inserted by charge allocation of solute molecules or Solvate/Build
Cell or Insert Molecules. When allocating charge to non-neutral polyatomic ions, it is necessary to use
RESP charge or this function. For polyatomic ions, enter the charge into Total charge [e]. A working
folder with the _acpype_tmp appended at the end of the current file name is created and processed in that.
Details are listed on temp.sh, temp.log under working folder. The value of the charge written in the
working folder below input.acpypeinput_GMX.itp will be the result.
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Use RESP charges

Calculate RESP charge using GAMESS. See RESP Charges for details. The GAMESS keywords (includ-
ing basis functions and calculation methods) and the number of parallels are set in the Tools → Preferences
menu Keywords for automatic RESP charge calculation (GAMESS) and :guilabel:` Number of parallels for
automatic RESP charge calculation with GAMESS` on the Calculation tab of the Calculation.

Use OPLS-AA charges

Use mktop to calculate OPLS-AA charges

6.10.5 Polymer

See MD → Polymer Menu.

6.10.6 Interface Builder

See MD → Interface Builder menu.

6.10.7 Replace Molecules

Replaces all molecules of the specified molecular species with other molecules. Please save the newly
placed molecule (one molecule) in wmm or mol2 format before calling this function.

6.10.8 Generate Ions

Replace water molecules with monoatomic ions. It is necessary to arrange water molecules in the system
in advance. To place water, use Solvate/Build Cell. It is mainly used to neutralize the charge in the system
in protein systems. Internally run gmx genion on Cygwin.

Neutral
In the case of True, we arrange the ions so that the charge of the whole system becomes neutral,
and Number of Cations and Number of Anions are ignored. In the case of False, the number of ions
described in Number of Cations and Number of Anions are respectively allocated.

Concentration
Specify the concentration of ion to be substituted.

Cations/Anions
Specify the type of cations and anions from the pulldown.

Number of Cations/Number of Anions
Specify the number of cations and anions. This setting is valid when Neutral is False.

Execute
Run gmx genion on Cygwin. A working folder with the file name _genion_tmp at the end of the
current file name is created and processed in that. Details are described in temp.sh, temp.log
under the work folder. On the way, automatic creation of a temporary topology file (temp.top) may
fail if the molecules in the system are inappropriate. Details of the topology file creation are output
in temp_top_tmp in the working folder.
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6.10.9 LAMMPS

See MD → LAMMPS menu.

6.10.10 Gromacs

See MD → Gromacs menu.

6.10.11 MODYLAS

MODYLAS Configure, calculation execution, animation display, energy display. Basically it behaves sim-
ilarly to MD → Gromacs menu.

6.11 MD → Polymer Menu

The procedure for preparing the polymer system is as follows.

1. Model the repeat unit and execute Register repeat unit.

2. Register the polymer using the monomer registered in 1 Homo Polymer builder, Block Polymer
Builder, Random Polymer Builder.

3. In the Polymer Cell Builder, construct the cell using the polymer registered in 2.

If you want to create a low molecular-polymer mixed system, create a polymer system by the above pro-
cedure and then add low molecules with Insert Molecules.

6.11.1 Register repeat unit

register the repeat unit to use at Homo Polymer builder, Block Polymer Builder, Random Polymer
Builder.The file is saved with the extension wmo in the save destination of the monomer file set by Set-
tings. The wmo file is a mol2 file with Winmostar’s own comment added.

1) Create the structure of the repeat unit you want to register in the main window.

2) Left click on Head and Tail 2 atoms, red circle’s marker, and call this function.

[Head], [Tail]
The number of the selected Head atom and Tail atom is displayed.

[OK]
Enter a registration name for the repeating unit, register the repeating unit and close the window. A
monomer file will be created.

[Cancel]
Discard the settings and close the Register Monomer window.
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6.11.2 Homo Polymer builder

Create a homo polymer for use with Polymer Cell Builder from the repeat units registered with Register
repeat unit and register. It is stored in the save destination of the polymer file set with Settings with wpo
extension. The wpo file is a mol2 file with Winmostar’s own comment added. The charge of the whole
polymer is the product of the charge of the monomer (repeat unit) used and the degree of polymerization.
Charges for atoms deleted by polymerization are equally allocated to the atoms of the whole polymer.

[Degree of Polymerization]
Specify the degree of polymerization.

[Repeat Unit]
Display selected repeat units.

[Display]
Display selected repeat units.

[Delete]
Delete the selected monomer file.

[Tacticity]
[Isotactic]

Make an isotactic polymer.

[Syndiotactic]
Make a syndiotactic polymer.

[Atactic]
Make atactic polymer.

[Racemo Ratio]
When selecting an atactic polymer, specify the racemism rate (0 &lt;x &lt;1.0).

[Head/Tail Configulation]
[Head to Tail]

Combine the head atom of the repeat unit and the tail atom by overlapping.

[Head to Head]
Combine the Head and Head atoms of the repeat unit. Also, combine the Tail and Tail atoms of
the monomer.

[Build]
Register the polymer. A polymer file is created.

[Close]
Close the window.

6.11.3 Block Polymer Builder

Create a block polymer for use with Polymer Cell Builder from the monomers registered with Register
repeat unit and register it. It is stored in the save destination of the polymer file set with Settings with wpo
extension. The wpo file is a mol2 file with Winmostar's own comment added. The way to assign electric
charge is the same as Homo Polymer builder.

[First Repeat Unit]
Select the first repeat unit from list.

[Last Repeat Unit]
Select the last repeat unit from the list.
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[Middle Repeat Unit]
Select an intermediate repeat units from the repeat unit list. In [Number], enter the number of re-
peating.

[>>Add>>]
Registers the selected repeat unit in the list.

[<<Delete<<]
Delete selected items from list.

[Display]
Display selected repeat units.

[Delete]
Delete selected repeating units.

[Build]
Creates a polymer based on the contents of the list. A polymer file will be created.

[Close]
Close the window.

6.11.4 Random Polymer Builder

Create a random polymer for use with Polymer Cell Builder from the monomers registered with Register
repeat unit and register it. It is stored in the save destination of the polymer file set with Settings with wpo
extension. The wpo file is a mol2 file with Winmostar's own comment added. The way to assign electric
charge is the same as Homo Polymer builder.

[Degree of Polymerization]
Specify the degree of polymerization. Enter the number including the beginning and the end.

[First Repeat Unit]
Select the first repeat unit from the list. If you want to assign the first repetition unit randomly, leave
blank.

[Last Repeat Unit]
Select a tail repeat unit from the list. If you want to assign the tail repeat unit randomly, leave it blank.

[Middle Repeat Unit]
Select an intermediate repeat unit from the list.

[>>Add>>]
The set repeat unit name and occurrence rate (0 < x < 1.0) will be reflected in Middle Repeat
Unit.

[<<Delete<<]
Delete selected items from list.

[Display]
Display selected repeat units.

[Delete]
Register the set repeting unit name and occurrence rate (0 < x < 1.0) in the list.

[Sum of Ration]
The total value of the ratios listed in the Internal repeat unit List is displayed.

[Definition of Ratio]
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[Probability of Each Monomer]
Generate intermediate repeat unit according to appearance rate [Add]. The ratio of the final
intermediate repeat unit does not necessarily correspond to the appearance rate.

[Proportion in Total Monomers]
The ratio of finally obtained intermediate repeat unit is proportional to the appearance rate [Add].

[Number of Patterns]
Specifies the number of patterns of polymers.

[Use Specific Random Seed]
If you want to use a specific random number type, check the box and specify the value. If not specified,
you will get a pattern with a different structure.

[Build]
Create polymers based on the contents of the listings. Polymer files will be created under the polymer
name folder for the number of patterns.

[Close]
Close the window.

6.11.5 Polymer Cell Builder

Build a simulation cell using the polymer registered in Homo Polymer builder, Block Polymer Builder, and
Random Polymer Builder. When using Solvate/Build Cell, it is difficult to create each molecule rigidly
in the simulation cell, so it is difficult to create polymers with high density. However, when using this
function, while executing energy minimization calculation using LAMMPS It can be created at a relatively
high density for placement. The internal process is as follows

1. Place each polymer in a straight line.

2. Only the main chain of each polymer is extracted for structural optimization.

3. Structure optimization is performed by adding side chain atoms that can be added to the extent that
each atom is not in contact with each other.

4. Repeat 3 until all atoms have been added.

[Polymer Available]
[Display]

Show the selected polymer.

[Delete]
Delete the specified polymer file.

[>>Add>>]
The selected polymer is reflected in the Polymers Used list.

[<<Delete<<]
Remove the selected polymer from the Polymers Used list.

[Simulation Cell] tab
[Set Density]

Specify the density.

[Set Dimensions]
Specify a cube cell.

[Cubic Cell]
Specifies the length of a rectangular cell in each direction.
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[Periodic Boundary Condition]
[X],[Y],[Z]

Toggle in the direction that imposes periodic boundary condition.

[Options] tab
[MPI]

LAMMPS used for optimization at creation runs in MPI parallel.

[Processes]
Specify number of MPI ranks.

[Non-bonded inter-atomic distance tolerance]
Specifies the minimum allowable distance between unbonded atoms. If it cannot be created with
the specified tolerance, it will gradually reduce the tolerance, so it may not always be within the
tolerance. Changes of the tolerance are output to the log.

[Randomly select random polymers to be used]
For Random Polymer, randomly select the polymer to be used. If it is not checked, use them in
order.

[Use Specific Random Seed]
If you want to use a specific random number seed, check the box and specify the value. If not
specified, you will get a different structure each time.

[Do not twist each polymers]
Place each polymer in a straight line.

[Build]
Create a simulation cell.

[Close]
Close the window.

6.11.6 Map Repeat Unit

We allocate registered repeat units to DPD particles and acquire the molecular structure of all atoms MD.

6.11.7 Settings

Specify the folder to register the monomer and polymer.

[Monomer(*.wmo) Folder]
Specify the folder to save the monomer file.

[Polymer(*.wpo)Folder]
Specify the folder to save the polymer file.

[OK]
Save the settings and close the window.

[Cancel]
Discard the settings and close the window.
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6.12 MD → Interface Builder menu

Join the two simulation cell files (mol2 or cif format) prepared in advance to create an interface model.
Tools → Preferences menu allows you to switch between the new and old features. The features of the new
spec are as follows

Cell Tab
Specify the two phases (Cell1 and Cell2) across the interface.

Use displayed cell
Specify the model displayed in the main window as a phase.

Load from file
Loads models from structural files in various formats and specifies them as phases.

Direction Tab
Axis perpendicular to interface

Specifies the axis in the vertical direction of the interface.

Order
Specify the order of Cell1 and Cell2 joined.

Interval
Specify the interval between Cell1 and Cell2.

Specify interval between cell boundaries
The entered value is the distance between cell boundaries.

Place atoms on cell boundaries on both sides
If checked, the atoms placed just above the cell boundary are copied and placed on both
sides of the interface vertical. If Axis perpendicular to interface is c-axis, atoms with a
fractional coordinate of 0 or 1 on the c-axis (or z-axis in the case of a rectangular cell) are
copied to position 1 or 0 respectively.

Specify interval on selected axis between outermost atoms
The specified value is the Axis perpendicular to interface is the distance between the outer-
most atoms on the selected axis.

Adjusting cell size parallel to interface
Specifying how to adjust the horizontal cell size of the interface

Scaling cells to average size
Doing Affine deformation so that the horizontal cell size of the created interface model is
the average of the cell sizes of Cell 1 and Cell 2.

Scale to size of. . .
Doing Affine deformation of the atomic positions to match the selected cell size to the other
cell size.

Extend size of smaller cell while keeping atomic positions
The atomic positions are not changed, but the smaller cell size is changed to the larger cell
size.

Repeat Tab
Number of cells

Specify the number of supercells in Cell 1 and Cell 2 when creating the interface model. Clicking
the Suggest button and the ratio of the cell size is shown for the numbers of Cell1 and Cell2. It
is recommended to choose a combination for which Ratio close to 1.
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Operation for atoms outside each cell
Specify how to handle atoms that are located outside the cell.

Wrap for each molecule
Molecules are moved inside the cell taking into account the periodic boundary.

Wrap for each atom
Atoms are moved inside the cell taking into account the periodic boundary.

Do nothing
Do nothing

Build button
The interface model is created based on the settings.

The features of the previous version are as follows

Cell Files
Specify the information of the two cells (Cell 1 and 2) to be joined. After setting each item, click the
[Next] button.

Cell 1 and Cell 2
[Browse]

Specify the file (mol 2 or cif format) to be joined. It is also possible to specify files by
dragging and dropping them.

[Lattice Constants]
[a],[b],[c],[Alpha],[Beta],[Gamma]

The cell constant is displayed.

Direction
Specify the direction to join the cells and the spacing between the cells. After setting each item, click
the [Next] button.

Direction
[a-axis]

Combine two cells along the a-axis direction.

[b-axis]
Combine two cells along the b-axis direction.

[C-axis]
Combine two cells along the c-axis direction.

Order
[Normal]

Place Cell 2 on Cell 1.

[Reverse]
Overlay Cell 1 on Cell 2.

[Interval]
Specify the interval between cells. It is not the distance between the two sides but the length
along the axis.

[Scaling cells to average size]
If there is a difference in cell size, it stretches to the average size.

124 Chapter 6. Details of each menu window



Winmostar™ User Manual, Release 11.13.0

[Padding small cell to the size of large cell]
If there is a difference in the size of the cell, put a vacuum in the smaller cell and align it with
the larger cell.

Repeat
Specify the number of repeats for each cell. Finally click the [Build] button.

Number of Cell 1 and Cell 2
[a-axis]

Specify the number of reports in cell 1 or cell 2 in the a-axis direction.

[b-axis]
Specify the number of repeats in cell 1 or cell 2 in the b axis direction.

[C-axis]
Specify the number of repeats in cell 1 or cell 2 in the c-axis direction.

[Suggest]
We will present a combination of repeat numbers so that Cell 1 and Cell 2 are closer in size.
The combination with Ratio close to 1 reduces the distortion of both cells. Click on the
column and press the Set button, or double-click it to take effect.

Lattice Constrants
[a],[b],[c],[Alpha],[Beta],[Gamma]

The lattice constant of the cell after bonding is displayed.

[Build]
Save the joined cells. Processing time may be prolonged if the size of the system is large.

6.13 MD → LAMMPS menu

It is a menu related to LAMMPS.

6.13.1 How to set up LAMMPS

To install LAMMPS, install CygwinWM version 2023/04/05 or later, which contains /opt_win/
LAMMPS*/bin/ in lmp_serial.exe and lmp _mpi.exe and so on. The configuration for using
LAMMPS from Winmostar is done at Tools → Preferences menu. If you have newly installed Win-
mostar V11.5.0 or later and are using CygwinWM 2023/04/05 version or later, no configuration is required.
First, select the LAMMPS lmp_serial.exe, lmp_mpi.exe or lmp.exe to use with program path →
LAMMPS. (When you select lmp_serial.exe to run MPI, the lmp_mpi.exe in the same folder is au-
tomatically used.) Next, under Calculation → mpiexec (LAMMPS), select MPICH or Select and choose
the MPI mpiexec.exe you want to use. If you want to use LAMMPS stored in CygwinWM, select /
opt_win/MSMPI/Bin/mpiexec.exe under CygwinWM. Finally, at Calculation → Options for mpiexec
(LAMMPS), enter the arguments for mpiexec.exe. If you use LAMMPS in CygwinWM, enter -np %WM_
NUM_PROC%. If you want to add a potential file, click Tools → Preferences menu → Calculation → MD →
LAMMPS potential folder → Open potential directory and in the opened folder Add potential files to the
opened folder. How to install LAMMPS on a remote machine is described in Installing Winmostar and
solvers.
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6.13.2 Assign Force Field

Set the force field. The choices vary depending on the type of solver. After assigning a forcefield, use Get Info to check
the assigned forcefield. In the case of LAMMPS, if a gro file containing velocities is open in the main window at the
time this function is used, a data file containing velocities is generated. Similarly, in the case of Gromacs, if a data file
with velocities is open, a gro file with velocities is generated; this is useful when you want to take over Gromacs and
LAMMPS calculation data with velocities. Once you assign a force field and run the MD calculation, the bond order
is automatically determined from the equilibrium length of the force field parameters. Depending on the type of force
field, the bond order determined at that time may be different from the bond order before the force field assignment.
Some force fields are affected by the bond order. Use Overwrite Bonds from File if you want to return to the bond order
before force field assignment.

Automatically assign parameters
Assign new force field parameters. Structures connected to each other by bonds in the molecule display area will
be recognized as a single molecule.

(General)
Specifies the force field for molecules other than proteins and water molecules. Internally, acpype is used
for GAFF, GAFF2, OPLS/AA-L+GAFF, an in-house program for Dreiding, a proprietary extension of
OpenBabel for UFF, and mktop for OPLS-AA. The configuration for Dreiding is described in polymer/
dreiding.lib.txt. Check Universal Force Field for details on UFF.

Exception
For specific molecules, assign the user specified LJ parameters without using the force field selected
in (General). In the left column of the subwindow, check the molecule you want to specify the LJ
parameter and enter the LJ parameter in the right column.

Note: For example, when you want to allocate LJ parameters to solid phase atoms in a solid-liquid
interface system.

(Protein)
Specify the force field of the protein. Here, the atom to which the name of the amino acid residue is assigned
in the PDB or gro format is recognized as a protein. Internally, gmx pdb2gmx is used.

Warning: This function can not be used when reading the molecular structure from a file not including
residue name.

(Water)
Specify the force field of the water molecule. You must specify the selected water model with Solvate/Build
Cell. Internally we get the parameters from the library of Gromacs topology installed in Cygwin.

Add [position_restraints] for protein
If a protein exists, write information ([position_restraints] section) to constrain the position in the
topology file with -POSRES on the Advanced tab. Ignored when protein is absent.

Add [position_restraints] for selected atoms
For the molecule specified by the user, write information ([position_restraints] section) to constrain
the position in the topology file with -POSRES on the Advanced tab. For example, when fixing solid phase
in solid-liquid interface system.

Add [distance/angle/dihedral_restraints] for selected atoms
For the molecule specified by the user, write information to constrain distance, angle, dihedral angle to
topology file by -POSRES on the Advanced tab.
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Dump Now
Based on the current settings, generate a topology file.

Note:
• If you want to customize the forcefield information by editing it with a text editor, first save the file contain-

ing the forcefield information using Dump Now and edit the top for Gromacs or the data file for LAMMPS
with a text editor.

• Next, for Gromacs, import the gro file at File → Import File (select Discard and import), then at Assign
Force Field select :guilabel:` Select Use parameters written in topology file and click the OK button. You
will then be asked for the location of the top file, so open the top file you just saved and edited.

• For LAMMPS, import the data file at File → Import File (select Discard and import), then at Assign Force
Field, select Use the parameters written in file opened on :guilabel:`main window and click on the Next >
button. If the force field information is not written in the data file, you will get a Choose the type of force
field, choose the type of generic force field you want to use and click the OK button.

• Charges are taken from the structure displayed in the main window. If more than one type of charge is
set in the main window (for example, if the GAMESS log file is opened and Mulliken charge and Lowdin
charge are set), the following order of priority is used: (high priority) User charge > NBO charge > Lowdin
charge > ESP charge > Mulliken charge (low priority). When the file is opened and the Mulliken charge and
Lowdin charge are set (for example, when the file is opened and the Mulliken charge and Lowdin charge are
set), the order of priority is User charge > NBO charge > Lowdin charge > ESP charge > Mulliken charge
(low priority).

Use parameters defined in external parameter file (for inorganic system, ReaxFF or DPD)
(for LAMMPS) Select if you want to use the potential for inorganic materials, ReaxFF or DPD. After pressing
the Next > button, specify the type of force field you actually want to use. pair_style and Potential file must be
set in [Tools]-[Preferences]-[Calculations] to allow the user to enter them freely.

Use parameters written in topology file
(For Gromacs) Select this option if you want to run MD calculations using a top file that already exists. The
corresponding gro file must be opened or imported in the main window. If you edit the structure after opening
or importing it, the correspondence with the top file will be broken and the calculation will not be possible. If
you want to use this function after editing the structure after opening or importing it to the extent that it does not
affect the force field information (for example, editing only the coordinates without changing the bonds), export
the structure in gro format after editing it and open or import that file before using this function.

Use parameters written in file opened on main window
(For LAMMPS) Select this option if you want to run the MD calculation using a data file that already exists. The
main window must have the data file you want to use open or imported. If you edit the structure after opening or
importing the file, the correspondence with the top file will be broken and the calculation will not be possible.
After pressing the Next > button, specify the type of force field to use.

6.13.3 Workflow Setup

Set up and run the LAMMPS calculation flow in project mode. 12-Step Compression in Preset is the poly-
mer equilibration procedure described in [Hofmann2000] , [Larsen2011] . Also, 21-Step Compression-
Decompression is the polymer equilibration procedure described in [Larsen2011].

Preset
Import and saves a preset of settings.

# of Jobs
Specify the number of jobs.
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Enable parameter/structure scan
This feature requires the purchase of an add-on. It is possible to run multiple calculations in which
only certain parameters differ (parameter scan) or to run calculations with the same parameters for
multiple structures (structure scan). Click Config to open the configuration window for scan calcula-
tion. For parameter scans, select %WM_SCAN1% for the Target Variable and enter the parameters
you wish to set for %WM_SCAN1% in each row of the Values. Then, enter %WM_SCAN1% in the
parameters you want to set in the Workflow Settings window or Keyword Settings window. For the
structure scan, select %WM_STRUCT% for the Target Variable with the animation appearing in the
molecule display area (e.g., by opening an SDF file). After the scan calculation is finished, use File
→ Project → Scan Results to tabulate the calculation results.

Import
Import the settings output by Export. Click the arrow at the right of the button to recall settings used
in the past on the same project or Winmostar.

Export
Output settings to file.

OK
Run a calculation or generate a file with your settings. See For project mode for details.

Details
Set detailed calculation conditions. The Configure will be launched.

Ensemble
Specifies the type of ensemble.

128 Chapter 6. Details of each menu window



Winmostar™ User Manual, Release 11.13.0

Setting details

Minimize Ensemble=minimize

NVT Ensemble=nvt

NPT Ensemble=npt

NPT(aniso) Ensemble=npt
Pressure control=aniso

NPT(z) Ensemble=npt
Pressure control=z

NVE Ensemble=nve

NPH Ensemble=nph

NPH(z) Ensemble=nph
Pressure control=z

NPT+Rescale Cell Ensemble=npt
Rescale cell size=True

NVE+Rescale Vel Ensemble=NVE
Rescale velocities=True

NVT(DPD) Ensemble=nve

NVT(SLLOD) Ensemble=nvt
Reset COM=Disable
Enable SLLOD=True
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Temperature
Specify the temperature.

Pressure
Specify the target pressure.

Simulation time
Specify simulation time.

# of snapshots
Specify number of dump and xtc outputs.

Initial velocity
If Random, the first speed is generated randomly; if From parent, the last speed of the previous job
is inherited.

Free boundary condition
Calculate with free boundaries instead of periodic boundary conditions.

Setting details

True Boundary=fff
Neighbor search=nsq
Reset COM motion=angular

False Boundary=ppp
Neighbor search=bin
Reset COM motion=linear

Precision
Set calculation precision.
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Setting details

Low Cutoff(vdW)=10
Cutoff(Coulomb)=10
Log interval=10
Time step(fs)=2
Tchain=3
Pchain=3
Shake tolerance=1e-5
PPPM order=4
K-space accuracy=1-e5

Medium Cutoff(vdW)=12
Cutoff(Coulomb)=12
Log interval=20
Time step(fs)=1
Tchain=3
Pchain=3
Shake tolerance=1e-6
PPPM order=4
K-space accuracy=1e-6

High Cutoff(vdW)=15
Cutoff(Coulomb)=15
Log interval=40
Time step(fs)=0.5
Tchain=1
Pchain=1
Shake tolerance=1e-9
PPPM order=6
K-space accuracy=1e-9

6.13. MD → LAMMPS menu 131



Winmostar™ User Manual, Release 11.13.0

6.13.4 Configure

Set calculation condition of LAMMPS. To set up the calculations immediately after setting Run button,
once to return to the main window please press OK button. Behavior when clicking Run is see Run. Assign
Charges Automatically will be launched automatically if there is a molecule to which no charge is assigned.
If no force field is assigned, Assign Force Field will be launched automatically. Return to the default state
with Reset button. Save the setting except Force Field with Save button. Load the setting saved by Save
with the Load button.

Continue Simulation
Execute a continuous job. For details, see Run.

Preset
Specify the preset of the calculation condition. Each preset changes the following keywords.
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Minimize
(fast)

NVT
(fast)

NPT
(fast)

NVE
(fast)

Pair style lj/cut/coul/long lj/cut/coul/long lj/cut/coul/long lj/cut/coul/long
Time step 2.0 2.0 2.0
# of time steps 5000 5000 5000 5000
Ensemble minimize nvt npt nve

Generate
initial velocity

True False False

Temperature 300 300
Pressure 1.0
Boundary Con-
dition

p p p p p p p p p p p p

Reset COM mo-
tion

linear linear linear linear

Tchain 3 3
Pchain 3
Shake tolerance 1e-5 1e-5 1e-5

Dump interval
(dump)

100 100 100 100

Dump interval
(xtc)

100 100 100 100

Log interval 10 10 10 10
Cutoff (vdW)

10. 10. 10. 10.

Cutoff
(Coulomb) 10. 10. 10. 10.

PPPM order 4 4 4 4
K-space accu-
racy

1e-5 1e-5 1e-5 1e-5
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Minimize
(medium)

NVT
(medium)

NPT
(medium)

NVE
(medium)

Pair style lj/cut/coul/long lj/cut/coul/long lj/cut/coul/long lj/cut/coul/long
Time step 1.0 1.0 1.0
# of time steps 10000 10000 10000 10000
Ensemble minimize nvt npt nve

Generate
initial velocity

True False False

Temperature 300 300
Pressure 1.0
Boundary Con-
dition

p p p p p p p p p p p p

Reset COM mo-
tion

linear linear linear linear

Tchain 3 3
Pchain 3
Shake tolerance 1e-6 1e-6 1e-6

Dump interval
(dump)

200 200 200 200

Dump interval
(xtc)

200 200 200 200

Log interval 20 20 20 20
Cutoff (vdW)

12. 12. 12. 12.

Cutoff
(Coulomb) 12. 12. 12. 12.

PPPM order 4 4 4 4
K-space accu-
racy

1e-6 1e-6 1e-6 1e-6
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Minimize NVT NPT NVE

Pair style lj/cut/coul/long lj/cut/coul/long lj/cut/coul/long lj/cut/coul/long
Time step 0.5 0.5 0.5
# of time steps 20000 20000 20000 20000
Ensemble minimize nvt npt nve

Generate
initial velocity

True False False

Temperature 300 300
Pressure 1.0
Boundary Con-
dition

p p p p p p p p p p p p

Reset COM mo-
tion

linear linear linear linear

Tchain 1 1
Pchain 1
Shake tolerance 1e-9 1e-9 1e-9

Dump interval
(dump)

400 400 400 400

Dump interval
(xtc)

400 400 400 400

Log interval 40 40 40 40
Cutoff (vdW)

15. 15. 15. 15.

Cutoff
(Coulomb) 15. 15. 15. 15.

PPPM order
K-space accu-
racy
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Minimize
(vapor,fast)

NVT
(vapor,fast)

NPT
(vapor,fast)

NVE
(vapor,fast)

Pair style lj/cut/coul/cut lj/cut/coul/cut lj/cut/coul/cut lj/cut/coul/cut
Time step 2.0 2.0 2.0
# of time steps 5000 5000 5000 5000
Ensemble minimize nvt npt nve

Generate
initial velocity

True False False

Temperature 300 300
Pressure 1.0
Boundary Con-
dition

f f f f f f f f f f f f

Reset COM mo-
tion

angular angular angular angular

Tchain 3 3
Pchain 3
Shake tolerance 1e-5 1e-5 1e-5

Dump interval
(dump)

100 100 100 100

Dump interval
(xtc)

100 100 100 100

Log interval 10 10 10 10
Cutoff (vdW)

10. 10. 10. 10.

Cutoff
(Coulomb) 10. 10. 10. 10.

PPPM order
K-space accu-
racy
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Minimize
(vapor)

NVT
(vapor)

NPT
(vapor)

NVE
(vapor)

Pair style lj/cut/coul/cut lj/cut/coul/cut lj/cut/coul/cut lj/cut/coul/cut
Time step 0.5 0.5 0.5
# of time steps 20000 20000 20000 20000
Ensemble minimize nvt npt nve

Generate
initial velocity

True False False

Temperature 300 300
Pressure 1.0
Boundary Con-
dition

f f f f f f f f f f f f

Reset COM mo-
tion

angular angular angular angular

Tchain 1 1
Pchain 1
Shake tolerance 1e-9 1e-9 1e-9

Dump interval
(dump)

400 400 400 400

Dump interval
(xtc)

400 400 400 400

Log interval 40 40 40 40
Cutoff (vdW)

15. 15. 15. 15.

Cutoff
(Coulomb) 15. 15. 15. 15.

PPPM order 6 6 6 6
K-space accu-
racy

1e-9 1e-9 1e-9 1e-9
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Minimize
(ReaxFF)

NVT
(ReaxFF)

NPT
(ReaxFF)

NVE
(ReaxFF)

Pair style reax/c reax/c reax/c reax/c
Time step 0.5 0.5 0.5
# of time steps 20000 20000 20000 20000
Ensemble minimize nvt npt nve

Generate
initial velocity

True False False

Temperature 300 300
Pressure 1.0
Boundary Con-
dition

p p p p p p p p p p p p

Reset COM mo-
tion

linear linear linear linear

Tchain 1 1
Pchain 1
Shake tolerance 1e-9 1e-9 1e-9

Dump interval
(dump)

400 400 400 400

Dump interval
(xtc)

400 400 400 400

Log interval 40 40 40 40
Cutoff (vdW)

15. 15. 15. 15.

Cutoff
(Coulomb) 15. 15. 15. 15.

PPPM order
K-space accu-
racy

MPI
Specify MPI parallel number.

Basic
Units

Specify the unit system.

real
It is mainly specified by molecular system (A, fs, Kcal/mol).

metal
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It is mainly specified by crystal system (A, ps, eV).

lj
It is mainly specified by DPD calculation (dimensionless unit).

Atom Style
Specify the type of system to calculate. Units changes accordingly.

Pair Style
Select the method of interaction calculation. lj/cut/coul/long and boundary is ppf, the command
kspace_modify slab 3 is automatically added and the calculation is performed using the PPPM
method considering the 2-D periodic boundary condition.

Force Field/Potential File
If Units is real, specify the type of force field. Affects the special_bonds, bond_style, angle_style,
dihedral_style, and improper_style keywords. Select the potential file when Units is other than
“real”. List the files in the Potential folder directly under the folder where you installed the
LAMMPS main unit. The choices will change according to Pair Style.

Time Step
Specify the step size of time integration. Units are selected according to the selected Unit.

# of Time Steps
Specify the maximum number of time integration steps.

Ensemble
Specify the type of time integration. nvt (canonical ensemble with constant temperature), npt
(temperature, constant pressure ensemble), nve (micro and canonical ensemble with constant
volume and energy), minimize (CG Energy minimization by law).

Generate Velocity
If you check, the initial speed will be given.

Random Seed
Specify the seed of the pseudorandom number at the time of initial velocity occurrence.

Temperature
Specify the target temperature. At the time of annealing calculation, specify the temperature of
the start condition.

Tdamp
Specify the time constant parameter for temperature control.

Use berendsen thermostat
Use fix temp/berendsen instead of fix nvt or npt to control temperature.

Use velocity rescaling
Use fix temp/rescaling instead of fix nvt or npt for temperature control.

Pressure Control
Specify how cells are moved during pressure control.

Pressure
Specify the target pressure.

Pdamp
Specify the time constant parameter of pressure control.

Use berendsen barostat
Use fix press/berendsen instead of fix nph or npt to control pressure.

Advanced
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Boundary X Y Z
Specify the periodic boundary condition. p (periodic), f (non-periodic and fixed), s (non-
periodic and shrink-wrapped), m (non-periodic and shrink-wrapped with a minimum value). If
pair_style is lj/cut/coul/long and boundary is ppf, the command kspace_modify slab 3 is auto-
matically added and the calculation is performed using the PPPM method considering the 2-D
periodic boundary condition.

Energy Tolerance
minimize Specifies the truncation error on energy during calculation.

Force Tolerance
minimize Specifies the truncation error on force during calculation.

Reset COM Motion
In the case of xy, only the center-of-gravity motion is frozen in the x and y directions, but not in
the z direction.

Reset Interval
Specify Reset COM Motion frequency in time step

Tchain
Specify the number of stages of Nose-Hoover chain.

Pchain
Specify the number of stages of pressure control.

Velocity rescaling interval
Specify how often to apply speed scaling.

Velocity rescaling window
Specify the window (allowable range from set temperature) when applying speed scaling.

Velocity rescaling fraction
Specifies the fraction at which to apply speed scaling; if 1.0, it will match the set temperature
immediately after application.

Control temperature of specific group only
This function controls only the temperature of a specific group. To do this, register a group to
be controlled with Select Registered Group and press Select Group button to select the group.

Constrain hydrogen atoms
We restrict hydrogen atoms by SHAKE method.

SHAKE tolerance
Specify the truncation error of the SHAKE method.

Automatically disable Shake if CH4-like molecule exists
Automatically disables the SHAKE method when methane like molecules are included.

Set “box tilt large”
Specify the allowable degree of deformation of the simulation cell.

Enable dynamic load balancing
Enable dynamic load balancing.

Output
Dump Interval (dump)

Specify the frequency of outputting coordinates in dump format as the number of time steps.

Dump Interval (xtc)
Specify the frequency of outputting coordinates in xtc format as the number of time steps.
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Dump Interval (xyz)
Specify the frequency of outputting coordinates in xyz format by time step number.

Dump Interval (restart)
Specify how often to output the restart file, in number of time steps.

Log Interval
Specify the frequency of writing energy variables to the log file by time step number.

Print log in high precision
Increases the number of digits of the energy variable to be written to the log file.

Sort dump file by id
Makes the order of particles in the dump file sorted by id (consecutive number).

Flush log
Flush each time when the log is output.

Include velocities in dump custom
When outputting in dump format, also output the velocity.

Extra variables for log
Add any variables to thermo_style.

Dump interval (dipole)
Specify the frequency of outputting time series data of dipole moments for the entire system in
terms of the number of time steps.

Calculate Fluctuation Properties
Calculates and outputs on-the-fly specific heat and isothermal compression ratio from fluctua-
tions of thermodynamic quantities.

Calculate Thermal Conductivity
Calculate and output the thermal conductivity on-the-fly from the autocorrelation function of
the atomic flow velocity and the Green-Kubo equation. This method uses the fix ave/correlate
command, so the length of the autocorrelation function is fixed.

Calc interval
Specifies how often the autocorrelation function is calculated.

ACF length
Specifies the length of the autocorrelation function. The maximum time for an autocorrela-
tion function is (Calc Interval)×(ACF Length)×(Time Step).

Calculate viscosity
Calculates and outputs viscosity on-the-fly from the autocorrelation function of the pressure
tensor and the Green-Kubo equation. This method uses the fix ave/correlate command, so the
length of the autocorrelation function is fixed.

Calc interval
Specifies how often the autocorrelation function is calculated.

ACF length
Specifies the length of the autocorrelation function. The maximum time for an autocorrela-
tion function is (Calc Interval)×(ACF Length)×(Time Step).

Calculate heat flux relaxation
Output autocorrelation functions for atomic heat flow. This method uses the fix
ave/correlate/long command (multiple-tau correlator), so you can automatically get long-time
autocorrelation functions depending on the simulation time. Thermal conductivity can be cal-
culated separately from post-processing.
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Calc interval
Specifies how often the autocorrelation function is calculated.

Dump Interval
Specifies the output frequency of the autocorrelation function.

Calculate stress relaxation
Output autocorrelation function for the pressure tensor. This method uses the fix
ave/correlate/long command (multiple-tau correlator) so you can automatically get long auto-
correlation functions depending on simulation time. Viscosity can be calculated separately from
post-processing.

Calc interval
Specifies how often the autocorrelation function is calculated.

Dump Interval
Specifies the output frequency of the autocorrelation function.

Calculate dipole relaxation
Outputs the autocorrelation function of the dipole moments for the entire system. This method
uses the fix ave/correlate/long command (multiple-tau correlator) so you can automatically get
long-time autocorrelation functions depending on simulation time.

Calc interval
Specifies how often the autocorrelation function is calculated.

Dump Interval
Specifies the output frequency of the autocorrelation function.

Interaction
Modify cutoff radii not to exceed L/2

If checked, Cutoff(vdw) and Cutoff(Coulomb) are automatically adjusted so that they do not
exceed half the lattice constant.

Neighbor Search
Specify algorithm for near particle search.

Neighbor Skin
Specify the extra radius of the search radius when searching for nearby particles.

Cutoff(vdw)
vdw (LJ) Specifies the cutoff radius of the potential.

Enable Long Range Correction
Specify the presence or absence of the vdw potential cut-off correction term.

Cutoff(Coulomb)
Coulomb (electrostatic) Specify the cutoff radius of the potential.

Disable Ewald(PPPM) if no charge exists
Automatically disables the Ewald (PPPM) method when the system has no charge.

Automatically set Nmesh
The number of meshes of the PPPM method used when Pair Style = lj/cut/coul/long is
automatically set from K-space accuracy.

Nmesh for kx, ky, kz
Specify the mesh number of PPPM method.

PPPM Order
Specify Spline interpolation order of PPPM method.
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K-space accuracy
Specify the allowable relative error of PPPM method.

Non-equiliibrium (1)
Enable Elongation

Enable decompression calculation. Ensemble can be specified when it is not minimize.

Affine Transformation
Specify whether to modify the atom position according to the simulation cell and to affine (sim-
ilarity) deformation during elongation calculation.

Eng. Strain Rate
Specify the extension speed at extension calculation with industrial strain. Max Eng. Strain
shows the predicted value of the strain at the final step.

Preserve Volume
During elongation calculation, deform the cell size in the direction perpendicular to the elonga-
tion direction so that the volume of the simulation cell is kept constant.

Enable Pulling
Enable Pull calculation to move a specified atom group at a constant speed. Ensemble can be
specified when it is not minimize.

Pulled Atoms
Press Select Group button and select the group in the state where the atoms you want to pull are
registered by Select Registered Group in advance.

Pull Velocity
Specify the pull speed for Pull calculation.

Enable Simulated Annealing
Enable annealing calculations (calculation to change the temperature at a constant speed). En-
semble can be specified when nvt, npt. The value of Temperature is the temperature at the
beginning, and the value of Final Temperature is the temperature of the final state.

Final Temperature
Specify the temperature of the final state at the time of annealing calculation.

Annealing Rate
The heating or cooling rate at the time of annealing calculation is displayed.

Enable pressurization
Enable annealing calculations (calculation to change the temperature at a constant speed). En-
semble can be specified when nvt, npt. The value of Temperature is the temperature at the
beginning, and the value of Final Temperature is the temperature of the final state.

Final Pressure
Specify the temperature of the final state at the time of annealing calculation.

Enable electric field
Gives an external electric field. If you select Sine wave, the electric field is given sine wave.
When Constant is selected, the electric field is given in static.

Amp & Freq
Gives the intensity (Amp) and frequency (Freq) of each direction. If Sine wave in Enable electric
field is selected, the following formula is used to give the electric field, where A is the intensity
and f is the frequency. If you choose Constant, only the intensity is used.

𝐴 sin(2𝜋𝑓𝑡)

Non-equiliibrium (2)
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Enable adding force
Target atoms applies a force in the z-direction to the atoms specified in Target atoms. The force
applied is the value of Target Pzz and the area of the XY plane of the simulation cell. In solid-
liquid interfacial systems, this is useful when you want to apply a force to a solid (slab) and adjust
the pressure throughout the system. The position of the center of gravity in the z-direction of
the atom applying the force is output to thermo_style in the variable v_GrpAddForceCOMz and
can be monitored using Energy Plot.

Target atoms
Press the Select Group button with the atoms you want to force registered beforehand with Select
Registered Group and select that group.

Target Pzz
Enable adding force

Enable direct density control
Force the simulation cell to be linearly deformed so that the density is at the value of Density
at final step at the final step. The deformation is analogous. This is useful when the pressure
control is not stable but you want to compress the system to some extent.

Density at final step
:guilabel:Specifies the density of the final step in the Enable direct density control feature.

Enable SLLOD method
Enable SLLOD method calculation.

Shear strain rate
Specifies the shear rate for SLLOD method calculations.

Restraint
Enable Restraint

Calculation is performed by constraining the distance between specified two atoms. Ensemble
can be specified when it is not minimize.

Restrained Atoms
When you click the Set button, the two atoms with the markers become the target of the con-
straint.

Bond Length
Specify the constraint distance between two atoms at the time of constraint calculation.

Initial Strength
Specify the spring coefficient of the constraint potential in the starting state at the time of con-
straint calculation.

Final Strength
Specify the spring coefficient of the constraint potential in the final state at the time of constraint
calculation.

Enable Position Restraint
Calculate with the absolute coordinates of the specified atom fixed. The temperature of the
unfixed atom is output to the log as TempFree.

Restrained Atoms
Press Select Group button to select the group with the atoms to be constrained registered with
Select Registered Group in advance, .

Use spring potential
If Restrained Atoms is checked, the atoms will be restrained by the spring potential from their
initial position. If Reset positions of restrained atoms after run is checked, the atoms will be
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returned to their initial positions after the calculation is finished, so they will not move away
from their initial positions even if you repeat the continue simulation. If the Restrained positions
of atoms after run checkbox is checked, the position will be returned to the initial position after
the calculation.

Spring constant
Specify the spring coefficient when using the spring potential.

Reset positions of restrained atoms after run
When using the spring potential, the position of the constrained atoms is reset to the initial
position after the calculation is complete.

Automatic
Rescale velocities to..

Use it when you want to bring the system temperature closer to the target temperature in the
NVE ensemble. Calculate the scaling factor from the average temperature under calculation and
the temperature entered here and scale the velocity of each particle in the final structure.

Rescale cell size to..
It is used when calculating with the NVE or NVT ensemble in the state close to the set pressure
after calculating with the NPT ensemble. Scale the final structure to the average cell size under
calculation.

Additional Commands
Add any command just before the read_data line, after the various fix commands, just before the run
(or minimize) line, and just after the run (or minimize) line.

Manual entry
The contents of the generated LAMMPS input script (in file) will be displayed. You can also edit
directly at this location. Any additional information you add here will be discarded when you edit
other keywords. If you want to avoid this, fill in the Additional Commands field.

Options
Restore Working Folder

Click this button to return the working folder to the state before execution, such as when the
continued job terminates abnormally.

Dump all files for remote
Output files necessary for job execution under Linux environment. The same file as the file
generated by Remote job function is output.

Generate gro & ndx files every time
If it is not checked, gro and ndx files will not be generated for continuous jobs.

Extra File
Click Add to copy the selected files to the working folder; click Clear to clear the added files.

Reset
Reset settings.

Import
Loading configuration file.

Export
Output configuration file.
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6.13.5 Run

Execute LAMMPS. The execution method differs depending on the situation.

• (Default) Continue Simulation is unchecked and Automatically assign parameters or Use
parameters defined in external parameter file (for inorganic system, ReaxFF or DPD) in Assign
Force Field is selected

Create a new data file (file containing coordinates and topology) and start the job.

• Continue Simulation is unchecked and Use parameters written in file opened on main window”
in Assign Force Field is selected

Start the job using the data file opened in the main window.

• When Continue Simulation is checked
Start the job using the lmp_tmp_final.data located in the working folder associated with the
data file opened in the main window.

Following file will be generated with execution. As an example, the file/folder name when the input file is
water.data is also shown.

type Description

out file
water.log

This is the log file of LAMMPS.

bat file
water.bat

LAMMPS and its pre/post processing

Working Folder
water_lmp_tmp\

Working folder.

The following files are generated in the working folder. Only the main files are shown here.
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type Description

lmp.data It is the initial state file of the calculation
specified by read_data.

lmp.in It is a file that specifies calculation
conditions.

lmp.log It is a log file.
It is the same as: file: water.log.

lmp.dump It is a trajectory file in dump format.

lmp.restart It is a restart file containing information on
the final state.

lmp_final.data It is a data file containing information on
the final state.
It is generated from the restart file.

postproc.sh The lmp_tmp_final.data generated by
LAMMPS is not sufficient to run LAMMPS
as is, so this script does some processing to
make up for the insufficient information.

lmp.xtc Trajectory file in xtc format for using the
Gromacs tool for results processing.

lmp.gro gro-format coordinate file to use the
Gromacs tool for processing results.
Convert from the data file specified as the
input file

lmp.top :guilabel:Specifies the density of the final
step in the Enable direct density control
feature.
Convert from the data file specified as the
input file

restart.bat When a job is interrupted and terminates
abnormally, this batch file can be executed
to resume the calculation from the state
before the interruption.(only for local job)
If the log and dump files are reopened, they
are automatically combined before and after
the reopening when analyzing results using
the log and dump files.

restart.in When running calculations in restart.bat,
run the calculations in this file instead of
lmp.in.
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Hint: **Working folder**

• A working folder is a folder whose name is the name of the file opened in the main window
plus a suffix.

– The suffix varies depending on the type of solver.
– For example, in the case of Gromacs, if the file opened in the main window is: file:

aaa.gro and the suffix is _ gmx_tmp, the working folder will be named aaa_gmx_tmp
.

• It must be in the same hierarchy as the file opened in the main window.

• Processing continues in the working folder of the same name even when continuing jobs,
but by default the backup of the working directory of the previous job is created just before
the continuation job is executed.

– The name of the backup will be the one with the smallest number in the range where
duplicate names do not exist. For example, if the working folder is aaa_gmx_tmp, it
is aaa_gmx_tmp1.

– Directories without numbers are always up to date.

The job is run through Winmostar Job Manager.

6.13.6 Open Log File

Open the LAMMPS log file ( *.log ) with a text editor.

6.13.7 Show log excerpts

Displays excerpts of key information from the log file.

6.13.8 Animation

Select the data file and dump file and animate the MD calculation trajectory. The file name of the main
window does not change. For the animation display operation method, see Animation operation area. In
the case of calculations where changes in chemical bonds occur, such as ReaxFF, checking the Options →
Enable Dynamics Bond checkbox in the Animation Manipulation Area will determine whether or not a
bond exists based on the bond distance at each step, allowing you to see how the bond changes. You can
check how the bond changes.

6.13.9 Energy Plot

Select the log file and display a graph of various thermodynamic quantities such as energy, temperature
and pressure. You can plot the value specified by thermo_style. Please see Energy Plot window for how
to operate subwindow.
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6.13.10 Import Last Coordinate (data)

Open *_lmp_tmp\lmp_tmp_final.gro. When using this function, the file name of the main window
does not change.

6.13.11 Analyses

Radial Distribution Function

Select the xtc file output by LAMMPS and the gro, ndx file automatically generated by Winmostar and
display the radial distribution function. See Radial Distribution Function for details.

Diffusion Constant/Mean Square Displacement

Select the xtc file output by LAMMPS and the gro, ndx file automatically generated by Winmostar, and
display the mean square displacement and the self diffusion coefficient. See Diffusion Constant/Mean
Square Displacement for details.

Scattering Function

Select the xtc file output by LAMMPS and the gro, ndx file automatically generated by Winmostar and
display the scattering function. For details, see Scattering Function.

Total Linear Moment

Select the xtc file output by LAMMPS and the gro, ndx file automatically generated by Winmostar and
display the total linear moment. See Total Linear Momentum for details.

Velocity Distribution

The xtc and dump files output by LAMMPS and the gro, ndx, mdp, top, and data files automatically
generated by Winmostar are selected and the velocity distribution is displayed. mdp and top files can only
be generated when using general-purpose forcefields such as GAFF, so this function is not available when
using parameter files. This function is not available when using parameter files, for example. See Velocity
Distribution for details.

Velocity Correlation / Vibration Spectrum

Select the xtc file output by LAMMPS and the gro, ndx, mdp, and top files automatically generated by
Winmostar to display velocity correlation functions and vibration spectra.The mdp and top files can only
be generated when using general-purpose force fields such as GAFF, so this function cannot be used when
using parameter files. See Velocity Autocorr/Vibration Spectrum for details.
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Static Dielectric Moment

Select an xtc file output by LAMMPS and a gro, ndx, mdp, or top file automatically generated by Win-
mostar to display the distribution and histogram of relative permittivity or dipole moment.The mdp and
top files can only be generated when using a general-purpose force field such as GAFF, so this function
cannot be used when using parameter files. See Radial Distribution Function for details.

Density Profile

Select the xtc file output by LAMMPS and the gro, ndx file automatically generated by Winmostar and
display the radial distribution function. Since mdp and top files can only be generated when using general-
purpose force fields such as GAFF, this function cannot be used when using parameter files. See Radial
Distribution Function for details.

Free Volume

Select the xtc file output by LAMMPS and the gro, ndx, mdp and top files automatically generated by
Winmostar and display the free volume. Since mdp and top files can only be generated when using general-
purpose force fields such as GAFF, this function cannot be used when using parameter files. See Free
Volume for details.

Various autocorrelation functions (ave/correlate)

Displays the autocorrelation function created by the fix ave/correlate command, which is output when
calculating thermal conductivity and viscosity using the Green-Kubo formula

Various autocorrelation functions (ave/correlate/long)

Displays the autocorrelation function created by the fix ave/correlate/long command.

Bond/Angle/Dihedral Distribution

Select the xtc file output by LAMMPS and the gro, ndx file automatically generated by Winmostar and
display the radial distribution function. Since mdp and top files can only be generated when using general-
purpose force fields such as GAFF, this function cannot be used when using parameter files. For details,
see Scattering Function.

Hydrogen bonding analyses

Select the xtc file output by LAMMPS and the gro, ndx, mdp, top files automatically generated by Win-
mostar and analyze the hydrogen bonds between the selected groups. mdp and top files can only be gen-
erated when using generic forcefields such as GAFF. This function is not available when using parameter
files. See Radial Distribution Function for details.
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radius of inertia

Select the xtc file output by LAMMPS and the gro, ndx, mdp, top files automatically generated by Win-
mostar, and analyze the radius of inertia of the selected group. mdp and top files can only be generated
when using a general purpose force field such as GAFF, so this function is not available when using pa-
rameter files. This function cannot be used when parameter files are used. See Radius of Gyration for
details.

Atom/Group Distance Change

Select the xtc file output by LAMMPS and the gro, ndx, mdp, top files automatically generated by Win-
mostar to analyze the change in distance between specific atoms or groups of atoms. mdp and top files can
only be generated when using generic forcefields such as GAFF. This function is not available when using
parameter files. See Atom/Group Distance Change for details.

viscosity

The viscosity is calculated from the stress autocorrelation function obtained with the Multiple tau corre-
lator (fix ave/correlate/long). The upper graph shows the normalized autocorrelation function C(t)/C(0) in
a log-linear plot, the middle graph shows it in a log-log plot, and the lower graph shows the viscosity ob-
tained from the integrated autocorrelation function. The autocorrelation function plot shows the function
fitted to the lower equation in green.

𝑓(𝑥) = 𝐴1 exp(−(𝑥/𝐵1)
𝐶1) cos(𝐷1𝑥) + (1−𝐴1) exp(−(𝑥/𝐵2)

𝐶2)

In the lower graph, the short-time side has a large error due to insufficient integration range, while the
long-time side has a large error due to insufficient sampling of the autocorrelation function. Also, the
time (excluding the short-time oscillation component) that the fitted function is below the value entered
for Threshold for switching integration from raw to fitted is displayed in the Switch integration at. The
Estimated Viscosity displays the viscosity obtained by integrating the autocorrelation function with the
trapezoidal formula. The numerical integration is performed over the Switch integration at time, with the
short integration over the autocorrelation function obtained directly from the calculation and the long inte-
gration over the function fitted to the above equation. Integrating the long time side over the function fitted
to the above equation reduces the effect of errors due to under-sampling. If Plot Autocorrelation Function
is not checked, only the viscosity obtained from the integrated value of the autocorrelation function will
be plotted. This is useful when determining the interval mean from the graph Options.

Thermal Conductivity

Calculate thermal conductivity from the autocorrelation function of the heat flow obtained with the multi-
ple tau correlator (fix ave/correlate/long). The upper graph shows the normalized autocorrelation function
C(t)/C(0) in a log-log plot, the middle graph shows a log-log plot, and the lower graph shows the ther-
mal conductivity obtained from the integrated value of the autocorrelation function. The autocorrelation
function plot shows the function fitted to the lower equation in green.

𝑓(𝑥) = 𝐴1 exp(−(𝑥/𝐵1)
𝐶1) cos(𝐷1𝑥) + (1−𝐴1) exp(−(𝑥/𝐵2)

𝐶2)

In the lower graph, the short-time side has a large error due to insufficient integration range, while the
long-time side has a large error due to insufficient sampling of the autocorrelation function. Also, the
time (excluding the short-time oscillation component) that the fitted function is below the value entered
for Threshold for switching integration from raw to fitted is displayed in the Switch integration at. The
Estimated Viscosity displays the thermal conductivity obtained by integrating the autocorrelation function
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with the trapezoidal formula. The numerical integration is performed over the Switch integration at time,
where the short time side is integrated over the autocorrelation function directly obtained from the calcula-
tion, and the long time side is integrated over the function fitted to the above equation. Integrating the long
time side over the function fitted to the above equation reduces the effect of errors due to under-sampling.

6.13.12 Dissipative Particle Dynamics

DPD Cell Builder

Create a simulation cell for dissipative particle dynamics.

Reset
Restore all settings to default.

Monomers Available
Select the monomer (particle) that constitutes the polymer chain.

>> Add >>
Add selected monomers.

<< Delete <<
Delete the added monomer.

Branch
Start

Specify the branch start position.

End
Specify the branch end position.

Monomers Used
A list of added monomer species and number is displayed.

Clear
Delete all listed monomer species.

>> Add >>
Add the listed polymer chain to the calculation target.

<< Delete <<
Delete the added polymer chain.

Export
Output the contents of Monomer Used to a file.

Import
Reads the contents of Monomer Used from a file.

Polymers Used
The composition and number of added polymer chains are listed.

Build
Enter dimensionless densities and build simulation cells.

Close
Close the window.
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DPD Potential Editor

Winmostar Create and edit a potential file for proprietary dissipative particle dynamics.

Potential Files
Select the potential file used for dissipative particle dynamics.

New
We will create a new potential file.

Delete
Delete the selected potential file.

Mass tab
Species

The name of the monomer (particle) is displayed.

Mass
Set the mass (dimensionless).

Bond tab
R_0

Set bond (bond) potential parameter R_0 (equilibrium distance, dimensionless).

TO
Set bond (bond) potential parameter K (spring constant, dimensionless).

Nonbond tab
Aij

Enter the unbonded potential parameter Aij (dimensionless).

Rcut
Enter the unbonded potential parameter Rcut (cutoff radius, dimensionless).

Gamma
Enter the coefficient of friction (dimensionless).

Set
The set potential parameters are reflected in the list.

OK
Save the set potential parameters in the potential file and close the window.

Close
Discard the settings and close the window.

6.14 MD → Gromacs menu

It is a menu about Gromacs. Because Winmostar runs Gromacs on the Cygwin environment, in order to
use this function, please set up CygwinWM is required.
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6.14.1 Asign Force Field

Asign Force Field. The choices vary depending on the type of solver. After assigning a forcefield, use Get Info to check
the assigned forcefield. In the case of LAMMPS, if a gro file containing velocities is open in the main window at the
time this function is used, a data file containing velocities is generated. Similarly, in the case of Gromacs, if a data file
with velocities is open, a gro file with velocities is generated; this is useful when you want to take over Gromacs and
LAMMPS calculation data with velocities. Once you assign a force field and run the MD calculation, the bond order
is automatically determined from the equilibrium length of the force field parameters. Depending on the type of force
field, the bond order determined at that time may be different from the bond order before the force field assignment.
Some force fields are affected by the bond order. Use Overwrite Bonds from File if you want to return to the bond order
before force field assignment.

Automatically assign parameters
Assign new force field parameters. Structures connected to each other by bonds in the molecule display area will
be recognized as a single molecule.

(General)
Specifies the force field for molecules other than proteins and water molecules. Internally, acpype is used
for GAFF, GAFF2, OPLS/AA-L+GAFF, an in-house program for Dreiding, a proprietary extension of
OpenBabel for UFF, and mktop for OPLS-AA. The configuration for Dreiding is described in polymer/
dreiding.lib.txt. Check Universal Force Field for details on UFF.

Exception
For specific molecules, assign the user specified LJ parameters without using the force field selected
in (General). In the left column of the subwindow, check the molecule you want to specify the LJ
parameter and enter the LJ parameter in the right column.

Note: For example, when you want to allocate LJ parameters to solid phase atoms in a solid-liquid
interface system.

(Protein)
Specify the force field of the protein. Here, the atom to which the name of the amino acid residue is assigned
in the PDB or gro format is recognized as a protein. Internally, gmx pdb2gmx is used.

Warning: This function can not be used when reading the molecular structure from a file not including
residue name.

(Water)
Specify the force field of the water molecule. You must specify the selected water model with Solvate/Build
Cell. Internally we get the parameters from the library of Gromacs topology installed in Cygwin.

Add [position_restraints] for protein
If a protein exists, write information ([position_restraints] section) to constrain the position in the
topology file with -POSRES on the Advanced tab. Ignored if protein is absent.

Add [position_restraints] for protein
For the molecule specified by the user, write information ([position_restraints] section) to constrain
the position in the topology file with -POSRES on the Advanced tab. For example, when fixing solid phase
in solid-liquid interface system.

Add [distance/angle/dihedral_restraints] for selected atoms
For the molecule specified by the user, write information to constrain distance, angle, dihedral angle to
topology file by -POSRES on the Advanced tab.
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Dump Now
Based on the current settings, generate a topology file.

Note:
• If you want to customize the forcefield information by editing it with a text editor, first save the file contain-

ing the forcefield information using Dump Now and edit the top for Gromacs or the data file for LAMMPS
with a text editor.

• Next, for Gromacs, import the gro file at File → Import File (select Discard and import), then at Assign
Force Field select :guilabel:` Select Use parameters written in topology file and click the OK button. You
will then be asked for the location of the top file, so open the top file you just saved and edited.

• For LAMMPS, import the data file at File → Import File (select Discard and import), then at Assign Force
Field, select Use the parameters written in file opened on :guilabel:`main window and click on the Next >
button. If the force field information is not written in the data file, you will get a Choose the type of force
field, choose the type of generic force field you want to use and click the OK button.

• Charges are taken from the structure displayed in the main window. If more than one type of charge is
set in the main window (for example, if the GAMESS log file is opened and Mulliken charge and Lowdin
charge are set), the following order of priority is used: (high priority) User charge > NBO charge > Lowdin
charge > ESP charge > Mulliken charge (low priority). When the file is opened and the Mulliken charge and
Lowdin charge are set (for example, when the file is opened and the Mulliken charge and Lowdin charge are
set), the order of priority is User charge > NBO charge > Lowdin charge > ESP charge > Mulliken charge
(low priority).

Use parameters defined in external parameter file (for inorganic system, ReaxFF or DPD)
(for LAMMPS) Select if you want to use the potential for inorganic materials, ReaxFF or DPD. After pressing
the Next > button, specify the type of force field you actually want to use. pair_style and Potential file must be
set in [Tools]-[Preferences]-[Calculations] to allow the user to enter them freely.

Use parameters written in topology file
(For Gromacs) Select this option if you want to run MD calculations using a top file that already exists. The
corresponding gro file must be opened or imported in the main window. If you edit the structure after opening
or importing it, the correspondence with the top file will be broken and the calculation will not be possible. If
you want to use this function after editing the structure after opening or importing it to the extent that it does not
affect the force field information (for example, editing only the coordinates without changing the bonds), export
the structure in gro format after editing it and open or import that file before using this function.

Use parameters written in file opened on main window
(For LAMMPS) Select this option if you want to run the MD calculation using a data file that already exists. The
main window must have the data file you want to use open or imported. If you edit the structure after opening or
importing the file, the correspondence with the top file will be broken and the calculation will not be possible.
After pressing the Next > button, specify the type of force field to use.

6.14.2 Workflow Setting

Set up and run the Gromacs calculation flow in project mode. 12-Step Compression in Preset is the polymer
equilibration procedure described in [Hofmann2000_2] , [Larsen2011_2] . Also, 21-Step Compression-
Decompression is the polymer equilibration procedure described in [Larsen2011_2].

Preset
Loads and saves a preset of settings.

# of Jobs
Specifies the number of jobs.

6.14. MD → Gromacs menu 155



Winmostar™ User Manual, Release 11.13.0

Enable parameter/structure scan
This feature requires the purchase of an add-on. It allows you to run multiple calculations where
only certain parameters differ (parameter scan) or to run calculations with the same parameters for
multiple structures (structure scan). Click Config to open the configuration window for the scan cal-
culation. For parameter scans, select %WM_SCAN1% for the Target Variable and enter the param-
eters you wish to set for %WM_SCAN1% in each row of the Values. Then, enter %WM_SCAN1%
in the parameters you want to set in the Workflow Settings window or Keyword Settings window.
For structure scan, select %WM_STRUCT% for Target Variable when the animation appears in the
molecule display area (e.g., by opening an SDF file).

Import
Import the settings output by Export. Click the arrow to the right of the button to recall settings
previously used in the same project or on Winmostar.

Export
Output configuration file.

OK
Run a calculation or generate a file with your settings. See For project mode for details.

Details
Set up detailed calculation conditions. The Configure will be launched.

Ensemble
Specifies the ensemble type. However, tcoupl is forced to nose-hover when Precision is High or
Medium, and pcoupl is forced to berendsen when Precision is Low.
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Configuration

Minimize integrator=steep
tcoupl=no
pcoupl=no

Minimize(NMA) integrator=l-bfgs
tcoupl=no
pcoupl=no
emtol=0.01
-DFLEXIBLE=True

NVT integrator=md
tcoupl=berendsen
pcoupl=no

NPT integrator=md
tcoupl=berendsen
pcoupl=parrinello-rahman
pcoupltype=isotropic

NPT(aniso) integrator=md
tcoupl=berendsen
pcoupl=parrinello-rahman
pcoupltype=anisotropic

NPT(z) integrator=md
tcoupl=berendsen
pcoupl=parrinello-rahman
pcoupltype=semiisotropic

NVE integrator=md
tcoupl=no
pcoupl=no

NPH integrator=md
tcoupl=no
pcoupl=parrinello-rahman
pcoupltype=isotropic

NPH(z) integrator=md
tcoupl=no
pcoupl=parrinello-rahman
pcoupltype=semiisotropic

NPT+Rescale Cell integrator=md
tcoupl=berendsen
pcoupl=parrinello-rahman
pcoupltype=isotropic
Rescale box=True

NVE+Rescale Vel integrator=md
tcoupl=none
pcoupl=none
Rescale velocities=True

NMA integrator=nm
Ext from full-prec traj=True
-DFLEXIBLE=True
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Temperature
Specify temperature.

Pressure
Specify pressure.

Simulation time
Specify simulation time.

# of snapshots
Specify the number of times to output coordinates and velocity to the trr file.

Initial velocity
If Random, the first speed is generated randomly. if From parent, the last speed of the previous job
is inherited.

Free boundary condition
Calculate with free boundaries instead of periodic boundary conditions.

Configuration

True pbc=no
coulombtype=cut-off
nstlist=1
ns-type=simple
cutoff-scheme=group
Use buffer-tolerance=False
comm-mode=angular

False pbc=xyz
coulombtype=pme
nstlist=10
ns-type=grid
cutoff-scheme=verlet
Use buffer-tolerance=True
comm-mode=linear

Precision
Sets the precision of the calculation. However, constraints is forced to hbonds when Ensemble is
Minimize and none when Minimize(NMA) or NMA.
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Configuration

Low Modify cutoff=True
rlist=1
rvdw=1
rvdw-switch=0.9
rcoulomb=1
rcoulomb-switch=0.9
nstenergy=10
dt=0.002
nhchainlen=10
shake-tol=1e-5
pme-order=4
ewald-rtol=1e-6
fourier-spacing=0.12
vdw-modifier=potential-shift-verlet
coulomb-modifier=potential-shift-verlet
nsttcouple=10
nstpcouple=10
Enable double precision=False
nstcomm=50
lincs-order=4
lincs-iter=1
buffer-tolerance=1e-6
constraints=all-bonds

Medium Modify cutoff=True
rlist=1.2
rvdw=1.2
rvdw-switch=1.1
rcoulomb=1.2
rcoulomb-switch=1.1
nstenergy=20
dt=0.001
nhchainlen=10
shake-tol=1e-6
pme-order=4
ewald-rtol=1e-6
fourier-spacing=0.11
vdw-modifier=potential-shift-verlet
coulomb-modifier=potential-shift-verlet
nsttcouple=10
nstpcouple=10
Enable double precision=True
nstcomm=50
lincs-order=4
lincs-iter=1
buffer-tolerance=1e-6
constraints=hbonds

High Modify cutoff=True
rlist=1.5
rvdw=1.5
rvdw-switch=1.4
rcoulomb=1.5
rcoulomb-switch=1.4
nstenergy=40
dt=0.0005
nhchainlen=1
shake-tol=1e-9
pme-order=6
ewald-rtol=1e-9
fourier-spacing=0.10
vdw-modifier=none
coulomb-modifier=none
nsttcouple=1
nstpcouple=1
Enable double precision=True
nstcomm=1
lincs-order=8
lincs-iter=2
buffer-tolerance=1e-9
constraints=hbonds
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6.14.3 Configure

Set calculation conditions of Gromacs. To set up the calculations immediately after setting Run button,
once to return to the main window please press OK button. See Run Gromacs for the behavior when
clicking Run. Assign Charges Automatically will start automatically if there is a molecule to which no
charge is assigned. If no force field is assigned, Asign Force Field will be launched automatically. Reset
button returns to the default state. Save the setting excluding Force Field with Save button. Load the setting
saved with Save with the Load button.

Continue Simulation
Execute a continuous job. For details, see Run Gromacs.

Preset
Specify the preset of the calculation condition. Each preset changes the following keywords.

Minimize
(fast)

NVT
(fast)

NPT
(fast)

NVE
(fast)

dt 0.002 0.002 0.002
nsteps 5000 5000 5000 5000
integrator steep md md md
gen-vel yes no no
tcoupl berendsen berendsen
ref-t 300 300
pcoupl no parrinello-

rahman
ref-p 1,0
pbc yes yes yes yes
comm-mode linear linear linear linear
nstcomm 50 50 50
nh-chain-length 10 10
nsttcouple -1 -1
nstpcouple -1
constraints hbonds all-bonds all-bonds all-bonds
lincs-order 4 4 4
lincs-iter 1 1 1
shake-tol 1e-5 1e-5 1e-5
nstxout 100 100 100 100
nstvout 100 100 100 100
nstenergy 10 10 10 10
buffer-tolerance 5e-3 5e-3 5e-3 5e-3
rvdw 1,0 1,0 1,0 1,0
rvdw-switch 0.9 0.9 0.9 0.9
coulombtype pme pme pme pme
rcoulomb 1,0 1,0 1,0 1,0
rcoulomb-
switch

0.9 0.9 0.9 0.9

fourier-spacing 0.12 0.12 0.12 0.12
pme-order 4 4 4 4
ewald-rtol 1e-5 1e-5 1e-5 1e-5

continues on next page
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Table 3 – continued from previous page

Minimize
(fast)

NVT
(fast)

NPT
(fast)

NVE
(fast)

Enable
double precision

False False False False

-DFLEXIBLE
False False False False

Extend
simulation
from full-
precision
trajectory

False False False False

Minimize
(medium)

NVT
(medium)

NPT
(medium)

NVE
(medium)

dt 0.001 0.001 0.001
nsteps 10000 10000 10000 10000
integrator steep md md md
gen-vel yes no no
tcoupl berendsen berendsen
ref-t 300 300
pcoupl no parrinello-

rahman
ref-p 1,0
pbc yes yes yes yes
comm-mode linear linear linear linear
nstcomm 50 50 50
nh-chain-length 10 10
nsttcouple -1 -1
nstpcouple -1
constraints hbonds hbonds hbonds hbonds
lincs-order 4 4 4
lincs-iter 1 1 1
shake-tol 1e-5 1e-5 1e-5
nstxout 200 200 200 200
nstvout 200 200 200 200
nstenergy 20 20 20 20
buffer-tolerance 1e-6 1e-6 1e-6 1e-6
rvdw 1.2 1.2 1.2 1.2
rvdw-switch 1.1 1.1 1.1 1.1
coulombtype pme pme pme pme

continues on next page
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Table 4 – continued from previous page

Minimize
(medium)

NVT
(medium)

NPT
(medium)

NVE
(medium)

rcoulomb 1.2 1.2 1.2 1.2
rcoulomb-
switch

1.1 1.1 1.1 1.1

fourier-spacing 0.11 0.11 0.11 0.11
pme-order 4 4 4 4
ewald-rtol 1e-6 1e-6 1e-6 1e-6

Enable
double precision

True True True True

-DFLEXIBLE
False False False False

Extend
simulation
from full-
precision
trajectory

False False False False

Minimize NVT NPT NVE

dt 0.0005 0.0005 0.0005
nsteps 20000 20000 20000 20000
integrator steep md md md
gen-vel yes no no
tcoupl nose-hoover nose-hoover
ref-t 300 300
pcoupl no parrinello-

rahman
ref-p 1,0
pbc yes yes yes yes
comm-mode linear linear linear linear
nstcomm 1 1 1
nh-chain-length 1 1
nsttcouple 1 1
nstpcouple 1
constraints hbonds hbonds hbonds hbonds
lincs-order 8 8 8
lincs-iter 2 2 2
shake-tol 1e-9 1e-9 1e-9
nstxout 400 400 400 400
nstvout 400 400 400 400

continues on next page
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Table 5 – continued from previous page

Minimize NVT NPT NVE

nstenergy 40 40 40 40
buffer-tolerance 1e-9 1e-9 1e-9 1e-9
rvdw 1.5 1.5 1.5 1.5
rvdw-switch 1.4 1.4 1.4 1.4
coulombtype pme pme pme pme
rcoulomb 1.5 1.5 1.5 1.5
rcoulomb-
switch

1.4 1.4 1.4 1.4

fourier-spacing 0.10 0.10 0.10 0.10
pme-order 6 6 6 6
ewald-rtol 1e-9 1e-9 1e-9 1e-9

Enable
double precision

True True True True

-DFLEXIBLE
False False False False

Extend
simulation
from full-
precision
trajectory

False False False False

Minimize
(vapor,fast)

NVT
(vapor,fast)

NPT
(vapor,fast)

NVE
(vapor,fast)

dt 0.002 0.002 0.002
nsteps 5000 5000 5000 5000
integrator steep md md md
gen-vel yes no no
tcoupl berendsen berendsen
ref-t 300 300
pcoupl no parrinello-

rahman
ref-p 1,0
pbc no no no no
comm-mode angular angular angular angular
nstcomm 50 50 50
nh-chain-length 10 10
nsttcouple -1 -1
nstpcouple -1
constraints hbonds all-bonds all-bonds all-bonds

continues on next page
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Table 6 – continued from previous page

Minimize
(vapor,fast)

NVT
(vapor,fast)

NPT
(vapor,fast)

NVE
(vapor,fast)

lincs-order 4 4 4
lincs-iter 1 1 1
shake-tol 1e-5 1e-5 1e-5
nstxout 100 100 100 100
nstvout 100 100 100 100
nstenergy 10 10 10 10
buffer-tolerance 5e-3 5e-3 5e-3 5e-3
rvdw 1,0 1,0 1,0 1,0
rvdw-switch 0.9 0.9 0.9 0.9
coulombtype cut-off cut-off cut-off cut-off
rcoulomb 1,0 1,0 1,0 1,0
rcoulomb-
switch

0.9 0.9 0.9 0.9

fourier-spacing
pme-order
ewald-rtol

Enable
double precision

False False False False

-DFLEXIBLE
False False False False

Extend
simulation
from full-
precision
trajectory

False False False False

Minimize
(vapor)

NVT
(vapor)

NPT
(vapor)

NVE
(vapor)

dt 0.0005 0.0005 0.0005
nsteps 20000 20000 20000 20000
integrator steep md md md
gen-vel yes no no
tcoupl nose-hoover nose-hoover
ref-t 300 300
pcoupl no parrinello-

rahman
ref-p 1,0
pbc no no no no

continues on next page
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Table 7 – continued from previous page

Minimize
(vapor)

NVT
(vapor)

NPT
(vapor)

NVE
(vapor)

comm-mode angular angular angular angular
nstcomm 1 1 1
nh-chain-length 1 1
nsttcouple 1 1
nstpcouple 1
constraints hbonds hbonds hbonds hbonds
lincs-order 8 8 8
lincs-iter 2 2 2
shake-tol 1e-9 1e-9 1e-9
nstxout 400 400 400 400
nstvout 400 400 400 400
nstenergy 40 40 40 40
buffer-tolerance 1e-9 1e-9 1e-9 1e-9
rvdw 1.5 1.5 1.5 1.5
rvdw-switch 1.4 1.4 1.4 1.4
coulombtype cut-off cut-off cut-off cut-off
rcoulomb 1.5 1.5 1.5 1.5
rcoulomb-
switch

1.4 1.4 1.4 1.4

fourier-spacing
pme-order
ewald-rtol

Enable
double precision

True True True True

-DFLEXIBLE
False False False False

Extend
simulation
from full-
precision
trajectory

False False False False

Minimize
(NMA)

NMA

dt
nsteps 20000 20000
integrator l-bfgs nm
gen-vel

continues on next page
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Table 8 – continued from previous page

Minimize
(NMA)

NMA

tcoupl
ref-t
pcoupl
ref-p
pbc yes yes
comm-mode
nstcomm
nh-chain-length
nsttcouple
nstpcouple
constraints none none
lincs-order
lincs-iter
shake-tol
nstxout 400 400
nstvout 400 400
nstenergy 40 40
buffer-tolerance 1e-9 1e-9
rvdw 1.5 1.5
rvdw-switch 1.4 1.4
coulombtype pme pme
rcoulomb 1.5 1.5
rcoulomb-switch 1.4 1.4
fourier-spacing 0.10 0.10
pme-order 6 6
ewald-rtol 1e-9 1e-9

Enable
double precision

True True

emtol
0.01

-DFLEXIBLE
True True

Extend simulation
from full-
precision
trajectory

False True

# of Threads
Specify the thread parallel number.

MPI (for Remote Job)
Specify MPI parallel number. It is reflected only when executing by remote job submission.
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Basic
Run Control

dt
Specify one step increment in numerical integration.

nsteps
Specify the maximum number of steps to calculate.

integrator
Specify the calculation algorithm.

Velocity Generation
gen-vel

Specify whether to generate the initial speed.

Fix random seed
When checked, gen-seed will be used.

gen-seed
Specify the initial speed random seed.

Explicitly set gen-temp
If checked, I will do the initial speed temperature here. If you do not enter ref - t will be the
initial speed temperature.

Temperature Coupling
tcoupl

Select the temperature control algorithm.

tc-grps
Specifies the group to be temperature controlled (multiple settings are allowed, separated
by spaces). If freezegrps is set when tc-grps=System, set tc-grps=freeze_xyz no_freeze and
only no_freeze will control temperature.

ref-t
Specify the set temperature (Multiple settings can be set with a space delimiter).

year-t
Specify the time constant for temperature control (more than one can be set with a space
delimiter).

Pressure Coupling
pcoupl

Select pressure control algorithm.

pcoupltype
It shows how to move cells in pressure control.

ref-p
Specify set pressure.

year-p
Specify the time constant for pressure control.

compressibility
Specify the compression ratio of the whole system.

Advanced
Boundary Condition
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pbc
Select the periodic boundary condition.

Energy Minimization
emtol

Specify the maximum force which is the convergence condition of energy minimization
calculation.

emstep
Specify the initial value of step width to move particles in energy minimization calculation.

Run Control
comm-mode

Specify how to remove the momentum of the whole system.

nstcomm
Specify the frequency of removing the momentum of the whole system.

Temperature/Pressure Coupling
nh-chain-length

Specify the number of stages of Nose-Hoover chain when temperature is controlled by the
Nose-Hoover method.

nsttcouple
Specify the frequency of temperature control.

nstpcouple
Specify the frequency of temperature control.

refcoord-scaling
Specify the scaling of the reference coordinates of position restraint during temperature
control.

Constraints
constraints

Select the constraint condition.

constraint-algorithm
Select the constraint algorithm.

continuation
Specify whether to inherit the constraint distance from the parent job.

lincs-order
Specify the order of the LINCS method.

lincs-iter
Specify the number of iterations in the LINCS method.

shake-tol
Specify the truncation error parameter used for the convergence judgment of the SHAKE
method.

Misc.
print-nose-hoover-chain-variables

Specify this parameter when transferring temperature/pressure control parameters to a child
job.
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define -DFLEXIBLE
Select to make water molecule flexible.

define -DPOSRES
Select this to constrain the position of a specific molecule. (Include posres.itp)

Extend simulation from full-precision trajectory
If this item is checked and Continue Simulation is checked, the job is continued from the
trr file of the previous job. If this item is not checked, the job is continued from the gro file
in the final state of the previous job. For example, if you want to run normal mode analysis
after the energy minimization calculation, you need to check the box.

Output
Output Control

nstxout
Specify the frequency of atomic coordinates output in steps.

nstvout
Specify the frequency of atomic velocity output in steps.

nstenergy
Specify the frequency of outputting system-wide statistics such as energy to edr file (energy
file) in steps.

nstxout-compressed
Specify the frequency of atomic coordinates output in xtc format which can save file size by
the step number.

compressed-x-grps
Specifies the group to output in xtc format. By default, the entire system is targeted. If you
want to specify a group other than the default group, use Additional Group to add a group.

energygrps
If you want to obtain the time variation of the potential energy between specific atomic
groups, specify the name of the atomic group to be used here. If you want to specify a
group other than the default group, use Additional Group to add a group.

Additional Group
Adds atomic groups that can be used during MD calculations. Atomic groups must be
registered beforehand in the main window with Register Selected Group. Add the groups
you wish to specify with compressed-x-grps or energygrps. The group specified here will
be added to the ndx file that is read at the time the tpr file is created by the grompp command.

Interaction
Modify cutoff radii not to exceed L/2

When checked, automatically adjusts rlist, rvdw, rvdw-switch, rcoulomb, and rcoulomb-switch
so that they do not exceed half the lattice constant.

Neighbor Searching
nstlist

Specify how often to update the neighbor list.

ns-type
Specify how to create the neighbor list.

cutoff-shceme
Specify the method of selecting atoms to be included in the neighbor list.

6.14. MD → Gromacs menu 169



Winmostar™ User Manual, Release 11.13.0

Use buffer-tolerance
Specify the truncation error of binary potential energy, which is a parameter for automati-
cally setting the cutoff distance of the neighbor list. When unchecked, the value of rlist is
set as the cutoff distance.

rlist
Specify the cutoff distance of the neighbor list.

VdW
vdwtype

Specify the calculation method of van der Waals potential.

rvdw-switch
When Switching is selected for Van der Waals potential calculation, specify the distance at
which Switching starts.

rvdw
Specify the cutoff distance of van der Waals potential calculation.

DispCorr
Select whether long-distance correction of energy and pressure accompany cutoff.

vdw-change
Select settings such as Switching/Shift when Van der Waals potential cutoff.

Electrostatics
coulombtype

Specify the calculation method of coulomb potential.

rcoulomb-switch
When Switching is selected for Coulomb Potential Calculation, specify the distance at which
Switching starts.

rcoulomb
Specify the real space cutoff distance of Coulomb potential calculation.

Coulomb-change
Select the setting such as Switching/Shift at the cutoff of Coulomb potential.

Ewald
Set # of grids for fourier space

If checked, use fourier-spacing. If you do not want to use it, use fourier-nx, ny, nz.

fourier-spacing
Ewald, PME or PPPM method in wave number space mesh size.

fourier-nx, ny, nz
Ewald, PME or PPPM method to specify the cutoff distance or mesh number (x, y, z com-
ponent, respectively) of wave number space.

pme-order
Specifies the order of the extrapolation function in the PME method.

ewald-rtol
Ewald, PME or PPPM method accuracy parameters.

Restraint
Set freezegrps to constrained atoms

Set freezegrps and constrain coordinates based on the optimization flags of the structure in the
main window.
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Automatic
Rescale velocities to..

Use it when you want to bring the system temperature closer to the target temperature in the
NVE ensemble. Calculate the scaling factor from the average temperature under calculation and
the temperature entered here and scale the velocity of each particle in the final structure.

Rescale box size to..
It is used when calculating with the NVE or NVT ensemble in the state close to the set pressure
after calculating with the NPT ensemble. Scale the final structure to the average cell size under
calculation.

Others
Other Parameters

Specify other settings based on the description of the mdp file.

Options
Restore Working Folder

Click to return working folder to its pre-execution status, such as when a continuous job ends
abnormally.

Dump .mdp File
Create and save a Gromacs calculation condition (mdp) file with the settings in the currently
opened window.

Dump All Files for Remote
This function does not run Gromacs, but only saves the files needed for Gromacs calculations.
Please open the Tools → Remote Job Submission window before using this function.

Rerun from xtc
For the structure of the trajectory (xtc) file output from a calculation that has already been com-
pleted, only the energy is calculated using the calculation conditions set in the currently opened
window, and the energy (edr) file is obtained.

Open top file
Open the top file generated by the Assign Force Field function in a text editor.

maxwarn
Allow continuation of calculation warning message Specify the maximum number of messages
(0: suspend with one or more messages)

Verbose Output
Specify this when displaying the step under calculation.

Concatenate .edr and .trr files
Click to merge with the executed .edr file and .trr file. File binding is performed as postprocessing
of Continue Simulation.

Unwrap Atoms (trjconv -pbc nojump)
Output the calculated .gro and .trr files at coordinates that do not wrap around at periodic bound-
aries (unwrapped).

Enable Double Precision
Execute MD calculation and pre-post processing with double precision version of Gromacs bi-
nary.

Overwrites any output file without making a backup in working folder
If checked, when creating a new file in the working folder, a backup will be made if there is an
old file with the same name. To save disk space, it is recommended to uncheck this item if Make
a Backup of Working Folder is checked.
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Read initial temperature and pressure coupling variables from .edr file
Reads temperature/pressure control variables from the source job’s edr file at the time of the
continuation job.

Force use Gromacs 5.0.7 on local computer
When using CygwinWM 2025/7/1 version or later with Gromacs5.0.7 and Gromacs2024.4 in-
stalled, Gromacs5.0.7 is forced to be used where Gromacs2024.4 is used by default. In par-
ticular, if you want to perform free boundary energy minimization calculations, you must use
Gromacs5.0.7 because it is not implemented in Gromacs2024.4. This setting is valid for local
jobs only.

Enable detailed parallelization setting
Instead of using -nt to specify the number of total threads, the number of parallel Thread-MPI
(-ntmpi) and OpenMP (-ntomp) threads can be specified individually.

# of Thread-MPI
Specifies the number of Thread-MPI parallel number.

# of OpenMP
Specifies the number of OpenMP parallel number.

Reset
Reset settings..

Import
Loading configuration file.

Export
Output configuration file.

6.14.4 Run Gromacs

Run Gromacs. The execution method differs depending on the situation.

• (Default) If Continue Simulation is unchecked and Automatically assign parameters is checked
on Asign Force Field

Create a new coordinate file (extension: gro) and topology file (extension: top) before starting
the job.

• If Continue Simulation is unchecked and :guilabel:` Use parameters from topology file` is
selected for Asign Force Field

Start the job using the coordinate file (extension: gro) opened in the main window and the
topology file (extension: top) specified at Asign Force Field.

• When Continue Simulation is checked
The coordinate file ( gmx_mdrun_tmp.gro) and the topology file ( gmx_tmp.top) in the work-
ing folder linked to the coordinate file (extension: gro) ) To start the job.

Following file will be generated with execution. As an example, the file/folder name when the input file is
water.gro is also shown.
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type Description

out file
water.out

water.sh standard output text file.

sh file
water.sh

For running Gromacs and its pre/post
processing
Shell script.

conf.sh file
water_conf.sh

This is a shell script from which settings
that depend on the content of the
calculation are extracted.

bat file
water.bat

This is a batch file for executing water.sh.

Working Folder
water_gmx_tmp\

Working folder.

The following files are generated in the working folder. Only the main files are shown here.
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type Description

input.gro In the case of a new job, the gro file
specified at the time of execution is
copied.
In case of continuous job, it becomes the
file of the previous job.

gmx.top In the case of a new job, the top file
specified at the time of execution is
copied.
In case of continuous job, it becomes the
file of the previous job.

gmx.mdp It is a file that specifies calculation
conditions.

gmx_mdrun.tpr Generate from gro, top, mdp file
It is an input file of mdrun.

gmx_mdrun.ndx Index file for result processing.

gmx_mdrun.edr Temperature, pressure, energy etc. were
stored
It is an energy file.

gmx_mdrun.gro It is a gro file of the final structure.

gmx_mdrun.trr It is a trajectory file.

gmx_mdrun.xtc Compressed trajectory file.

gmx_mdrun.log This is the log file of mdrun.

Hint: ** Working folder **
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• A working folder is a folder whose name is the name of the file opened in the main window
plus a suffix.

– ** The suffix varies depending on the type of solver. **

– For example, in the case of Gromacs, if the file opened in the main window is aaa.gro
and the suffix is _ gmx_tmp, the working folder will be named aaa_gmx_tmp .

• It must be in the same hierarchy as the file opened in the main window.

• Processing continues in the working folder of the same name even when continuing jobs,
but by default the backup of the working directory of the previous job is created just before
the continuation job is executed.

– The name of the backup will be the one with the smallest number in the range where
duplicate names do not exist. For example, if the working folder is aaa_gmx_tmp, it
is aaa_gmx_tmp1.

– ** Directories without numbers are always up to date. **

The job is run through Winmostar Job Manager.

6.14.5 Open Log File (log)

Open the log file (* _ gmx_tmp gmx_tmp_mdrun.log) of gmx mdrun with a text editor.

6.14.6 Open Stdout File

Open the standard output (*. Out) of the shell script when running Gromacs with a text editor.

6.14.7 Animation

Select the gro file and trr file, and animate the MD calculation trajectory. The file name of the main window
does not change. If you open a trr file while a calculation is running, only the collapsed coordinates in
the simulation cell will be read. After the calculation, the gmx trjconv -pbc nojump command will
convert the trr file so that the uncollapsed coordinates are read. For the animation display operation method,
see Animation operation area.

6.14.8 Energy Plot

Selects the Gromacs output edr file and displays graphs of various thermodynamic quantities, such as
energy, temperature, and pressure. Internally, the command gmx energy is executed. Please refer to the
manual of gmx energy for more detailed behavior. Please see Energy Plot window for how to operate
subwindow.
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6.14.9 Import Last Coordinate (gro)

* _ gmx_tmp \ gmx_tmp_mdrun.gro. When using this function, the file name of the main window
does not change.

6.14.10 Configure Sequential Job

Configure settings for continuous execution of Gromacs. If you want to run with settings other than the
presets, enter the calculation conditions you want to run in advance with Configure and save it in gmxset
format with the Save button.

6.14.11 Run Sequential Job

Run Gromacs sequentially based on the contents of Configure Sequential Job.

6.14.12 Analyses

Radial Distribution Function

Select a trr, tpr or ndx file output by Gromacs and display the radial distribution function. Internally, the
command gmx rdf is executed. Please check the manual of gmx rdf for more detailed behavior. Radial
distribution functions are computed between Reference Group and Target Group.

Definition
Atom

Set the calculation target to atomic coordinates.

Center of geometry
The target of the calculation is the geometric mean coordinates of the molecules, using Gromacs
5.0.7 in CygwinWM.

Center of mass
The target of the calculation is the position of the center of mass of the molecule, and Gromacs
5.0.7 in CygwinWM is used.

Output
RDF

Calculate radial distribution function.

Cumulative Number RDF
Calculate the integrated coordination number.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.
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Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.

Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.

Diffusion Constant/Mean Square Displacement

Select the trr, tpr, and ndx files output by Gromacs and display the mean square displacement and self-
diffusion coefficient. Internally, the :command gmx msd is executed. Please refer to the manual of gmx
msd for more detailed behavior.

Type
For no, the mean-square displacement is calculated as usual; for x, y, and z, the mean-square dis-
placement is calculated on each axis.

Diffusion Constant
Use the gmx msd command to display the self-diffusion coefficient calculated from the slope of the
time-mean square displacement graph.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.
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Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.

Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.

Scattering Function

Select a trr, tpr or ndx file output by Gromacs and display the scattering function. Internally, the :command
gmx saxs is executed. Please refer to the manual of gmx saxs for more detailed behavior.

Interval
Specify the interval at which to acquire the snapshot used to calculate the scattering function. Atten-
tion is necessary because enormous calculation is necessary if it is too small.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.

Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.
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Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.

Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.

Total Linear Momentum

Select the trr, tpr, and ndx files output by Gromacs and display the total linear momentum. Internally, the
trajectory is converted to an animated gro file containing the velocities and then the histogram is calculated
inside Winmostar.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.

Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.
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Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.

Velocity Distribution

Select the trr, tpr, and ndx files output by Gromacs and display the velocity distribution. Internally, the
trajectory is converted to an animated gro file containing the velocities and then the histogram is calculated
inside Winmostar.

Norm
Calculates the velocity distribution with respect to the absolute value of the velocity vector.

X/Y/Z
Calculates the velocity distribution for the x, y, and z components of the velocity vector.

# of bins
Specifies the number of divisions of the velocity distribution function.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.

Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.
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Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.

Velocity Autocorr/Vibration Spectrum

Select the trr, tpr, and ndx files output by Gromacs to display the velocity correlation function and the
vibration spectrum. Internally, the :command gmx velacc is executed. Please refer to the manual of gmx
velacc for more detailed behavior.

Velocity Autocorrelation
Output speed correlation function.

Vibration Spectrum
Output vibration spectrum.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.

Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.

Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
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atoms, select a group for analysis in the main window, register the group with Select Registered
Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.

Static Dielectric Constant

Select a trr, tpr or ndx file output by Gromacs to display the distribution and histogram of the relative
permittivity or dipole moments. Internally, the :command gmx dipoles is executed. Please refer to the
manual of gmx dipoles for more detailed behavior.

Dielectric constant
Plot the relative dielectric constant. The value of epsilon at the last time in the graph is the relative
dielectric constant obtained from that calculation. The value is output below the graph.

Total dipole moment
Plot the time variation of dipole moments of molecules belonging to the Target Group.

Histogram of total dipole momen
Plot the distribution of dipole moments for molecules belonging to the Target Group.

Autocorrelation function of dipole moment
Plot the autocorrelation function of the dipole moments. The definition of a dipole moment is selected
in Definition.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.

Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
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add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.

Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.

Share Viscosity

Select the trr, tpr, ndx file output by Gromacs and display the viscosity. Internally, the :command gmx
tcaf is executed. Please refer to the manual of gmx tcaf for more detailed behavior.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.

Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.

Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.
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First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.

Density Profile

Select a trr, tpr or ndx file output by Gromacs to display the density distribution. Internally, the :command
gmx density is executed. Please refer to the manual of gmx density for more detailed behavior.

Group
The density distribution is output for the components that are checked here.

Axis
Specifies the direction in which the density distribution is calculated.

# of slices
Specify the number of points for the density distribution graph.

Definition
Specify the definition of density.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.

Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.

Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
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Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.

Free Volume

Select a trr, tpr or ndx file output by Gromacs to display the density distribution. Internally, the :command
gmx freevolume is executed. Please refer to the manual of gmx freevolume for more detailed behavior.

Radius of probe
Specify the radius of the virtual probe particles that are randomly inserted into the system when
calculating the free volume.

# of probe insertions
Specify the number of virtual probe particle insertions.

Random seed
Specify a random seed to determine where to insert virtual probe particles.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.

Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.

Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
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Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.

Hildebrand Solubility Parameter

Calculate the Hildebrand solubility parameter from the edr, gro file output by Gromacs. Calculation results
of gas phase and liquid phase are required. Hildebrand The gmx energy command is executed to obtain
the cohesion energy, density (specific volume) and compression rate necessary for calculating the solubility
parameter.

Chi/DPD parameter

Calculate the Chi parameter · DPD aij parameter from the edr, gro file output by Gromacs. It is necessary to
calculate the gas phase and liquid phase of each of the two components. Internally use the value calculated
by Hildebrand Solubility Parameter.

Bond/Angle/Dihedral distribution

Select a trr, tpr, or ndx file output by Gromacs to display the distribution of distances, angles, or two-plane
angles between the selected groups. Internally, the gmx distance command (distance) or the gmx angle
command (angle, two plane angle) is executed. Please refer to the manuals of gmx distance and gmx angle
for more detailed behavior.

Type
Select the type of value to plot (bond, angle, dihedral, improper or ryckaert-bellmemans).

Calculate for marked atoms
Calculates the distance, angle, or dihedral angle between atoms marked with a marker in the main
window.

Calculate for target group
Calculate the distance, angle, or dihedral angle using the NDX file selected in the Target Group.

Calculate for
Calculates the angle or dihedral angle for the selected angletype or dihedraltype.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.
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Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.

Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.

Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.

Hydrogen bonding analysis

Selects the trr, tpr, and ndx files output by Gromacs and analyzes the hydrogen bonds between the selected
groups. Internally, the gmx hbond command is executed. Please refer to the gmx hbond manual for
detailed behavior.

Type
Select the type of value to plot: for Autocorrelation function, use Gromacs 5.0.7 in CygwinWM.

Cutoff angle
Specifies the cutoff value for the hydrogen-donor-acceptor angle when determining hydrogen bond-
ing.

Cutoff distance
Specifies the cutoff value for the donor-acceptor distance when determining hydrogen bonding.
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Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.

Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.

Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.

Atom/Group Distance Change

Select a trr, tpr, or ndx file output by Gromacs and analyze the change in distance between specific atoms
or between specific groups of atoms. Internally, the gmx distance command is executed. Please refer to
the manual for the gmx distance command for detailed behavior.

Definition of distance
Select a definition for the distance. For “COMs of Reference and Target Groups”, it calculates the
distance between the center of gravity of the group selected in the Reference Group and the center
of gravity of the group selected in the Target Group. For “Odd and even atoms in Target Group,”
calculate the distance between the odd and even atoms defined in the group specified in the Target
Group.
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Component
Select the type of distance to plot.

Use periodic boundary condition
Apply periodic boundary conditions when calculating distances.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.

Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.

Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.

6.14. MD → Gromacs menu 189



Winmostar™ User Manual, Release 11.13.0

Root Mean Square Deviation

Select the trr, tpr, and ndx files output by Gromacs and display the RMSD (mainly for proteins). Internally,
the :command gmx rms is executed. Please refer to the manual of gmx rms for more detailed behavior.

Group
Results are output for the components checked here. Normally select Backbone.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.

Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.

Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.
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Radius of Gyration

Select a trr, tpr or ndx file output by Gromacs and display the rotation radius (mainly for the protein).
Internally, the :command gmx gyrate is executed. Please refer to the manual of gmx gyrate for more
detailed behavior.

Group
Results are output for the components checked here. Normally you will select Backbone.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.

Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.

Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.
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Ramachandran Plot

Select the trr, tpr, and ndx files output by Gromacs to display the Ramachandran plots for each amino acid
residue. Internally, the :command gmx rama is executed. Please refer to the manual of gmx rama for more
detailed behavior.

Residue
Here a Ramachandran plot of the selected residue is output.

Target Group
Calculate the physical quantity for molecules/atoms belonging to the selected group here. A group
written in the opened ndx file can be selected here.

Reference Group
It only appears for physical quantities to be calculated for atom pairs such as radial distribution func-
tions. The physical quantity is calculated between Target Group and Reference Group.

Edit Group
Adjust the contents of the Target Group and Reference Group.

Create Group (by Element)
In the Create Group window, check Extracted Atom Names and enter New group Name and press
the Create button, the group is added to the ndx file It will be added. When you press the Close
button, the groups added to Target Group and Reference Group are added.

Create Group (by Selecting Atoms in 3D)
In the Create Group window, first select the target molecule species in Target, then Ctrl+click
or Ctrl+drag to select the atoms in the 3D molecule that you want to add to the group, in blue
color. Then click Add. Add all the atoms you want to add to the group, and click OK button to
add the group to the ndx file. Click Close button to add the group you added to the Target Group
or Reference Group.

Select ndx File
Loads a Group from an ndx file. If you want to perform result analysis on an arbitrary group of
atoms, select a group for analysis in the main window, register the group with Select Registered
Group, create an ndx file with Export Groups to Index File (ndx) to create an ndx file and then
select the ndx file with this function.

First Frame
Specify the start time when trajectory is read in ps units.

Last Frame
Specify the end time, in ps, to read trajectories. If Maximum is checked, the last frame is specified.

Edit Commands in Advance
Edit the arguments of the gmx command before running the analysis.

Show Log
Display the log file of the gmx command output during the analysis run.

Draw
Execute the result analysis program and display the graph.

For how to operate the graph drawing area, see How to operate the graph.
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6.14.13 Modify Trajectory File

You can perform operations such as thinning, rotation, and calculation of spatial distribution functions on
the trajectory data in the trr or xtc file output from Gromacs. Internally, the :command gmx trjconv is
executed. Please refer to the manual of gmx trjconv for more detailed behavior. Click Execute button to
start the process.

Output interval
Specify how many frames to output by thinning the trajectory.

Postprocess
Specify the operation after processing. If Spatial distribution function is selected use gmx spatial.

Target group
Specify the group to output.

Rotate and Trans
The group specified by Reference group is fixed so that the group specified by Target group is rotated
and translated.

Reference group
Specify refernce in Roate and Trans.

Group for SDF
Specify which group to calculate SDF calculated when Spatial distribution function (SDF) is selected
in Postprocess.

6.14.14 Start ER

Calculate the solvation free energy using the energy indication (ER) method.

1. Execute the calculation of the following three in Gromacs beforehand and leave each working folder.
Only use equilibrium state data after finishing equilibration such as energy minimization.

A. Solution system (1 solute molecule + many solvent molecules)

B. Solvent system (large number of solvent molecules)

C. Solute system (one solute molecule)

2. Drag and drop the working folder of A. Solution system on the Solution tab. Or, in each column of
the xtc, log, top file, press . . . button to read individual files.

3. Likewise select the B. Solvent system file on the Solvent tab.

4. Similarly select the C. Solute system file in the Solute tab. If an xtc file is specified, if the solute
specifies a flexible model, pdb or gro file, it is treated as a rigid body model.

5. Select the molecular name of the solute in Solute Name.

6. If necessary, specify MPI parallel number at free energy calculation from Options button.

7. To implement free energy calculation in the local environment press the Start button. Calculation
begins when you specify the folder to output the result. On Cygwin, ermod flows.

8. To implement in the remote environment, press the Close button once. And at Re-
mote job execute Program with ermod. On the remote server, it is necessary for
ermod and slvfe command to pass $PATH. (Installing ERmod on remote server is here
<https://winmostar.com/en/gmx4wm_en_linux.html>) After finishing the calculation, press get but-
ton in Remote job, you will find ermod_remote_* under the folder where winmostar.exe is placed
and the result is transferred from the remote server.

6.14. MD → Gromacs menu 193

http://manual.gromacs.org/archive/5.0.7/programs/gmx-trjconv.html


Winmostar™ User Manual, Release 11.13.0

9. After calculating the free energy calculation, to display the result, select the Import ER menu.

Hint: If you want to analyze the data using ERmod functions, which are not supported by Winmostar,
you can also follow the procedure below.

1. First, we will use Winmostar to calculate the MD for solution, solvent only, and solute only. For those
procedures, please refer to the tutorial on using the ER method.

2. Follow the steps after “Generate input configuration for running ermod” in Quick Start Guide on the
official ERmod homepage. Follow the steps after “Generate input configuration for running ermod”.
Click [Tools]-[Cygwin] in Winmostar to start the Cygwin terminal, where the installation of Gromacs,
ERmod, etc. is completed. The “(ERmod directory)” in the procedure is /usr/local/ermod on
Cygwin. The etohsolution.top will be the top file saved at the start of the solution calculation.
Please use solution_run.xtc and solution_run.log which are stored in the working folder of
MD for solution, solvent only, and solute only, respectively.

6.14.15 Import ER

The results processed by Start ER are displayed. After selection, specify the output destination folder
specified by Start ER. You can specify units for displaying energy in Unit. Press the Log button to display
ERmod’s log file.

6.14.16 Start BAR

Calculate the solvation free energy using the Bennett Acceptance Ratio (BAR) method.

1. Calculate the solution system (1 solute molecule plus a large number of solvent molecules) using
Gromacs. Leave all working folders for each step of equilibration and calculation of equilibrium
state.

2. Select Start BAR.

3. Specify how to integrate the state (lambda = 1, Full Coupling) in which the solute is not interacting
with the solvent (lambda = 0) to the interaction state (lambda = 1, Full Coupling) on the Integration
Path tab. Enter the coupling coefficient of van der Waals potential (left) and the coupling coefficient
of coulomb potential (right) in the two columns on the left of the Insert button and press Insert to
add an integration path.You can delete the integration route by pressing Delete.

4. In Procedure tab, specify the simulation procedure of each state on the integration path. Specify the
procedure of equilibration of solution system (lambda = 1) prepared beforehand in folder unit. Add
a folder by dragging and dropping to the Add button or list. Delete folder with Delete button. The
calculations performed in the last step of the list are used for free energy calculations.

5. Press Start to execute MD calculation for each lambda.

6. After finishing MD calculation of each lambda, to display the result, choose Import BAR.
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6.14.17 Import BAR

Display the result of processing with Start BAR. After selecting the menu, specify the destination folder
with Start BAR. The gmx bar is executed in the background and the result is displayed. Please refer to the
manual of gmx bar for more detailed behavior.

Unit allows you to specify the unit in which the energy is displayed. If you press Log button,
the log file of gmx bar will be displayed. The displayed graph shows the change in free energy
between the state in which the solute is not interacting with the solvent (lambda=0) and the state
in which it is interacting (lambda=1).

6.15 Solid Menu

It is a menu related to first principle (band) calculation. Solid pack is required to use the functions of the solid menu.

6.15.1 Crystal Builder

Create a crystal structure. It is mainly used for the following purposes.

• Enter the space group, lattice constant, asymmetric element and create crystal structure.

• Open the CIF file on the crystal builder and replace the axes a, b, c.

• Open a CIF file containing a noninteger occupancy and allocate atoms.

File menu
New

We will create a new crystal structure.

Open
Open the CIF file.

Save As
Save the crystal structure displayed in the crystal builder in CIF format or XYZ format.

Save As P1 CIF
If checked, save it in P1 when saving in CIF format.

Edit Menu
Exchange Axis

Exchange the coordinates (x, y, z) of the axis (a, b, c) and the asymmetric element. For details,
please see International Tables vol.

Discard symmetry
Discard the symmetric operation and let P1 be the space group. At this time, all symmetric
elements reproduced by the existing symmetrical operation are recognized as asymmetric ele-
ments.

Assign Atoms to Non-Integer Occupancy Sites
Random atoms are generated for each site based on the item (_atom_site_occupancy) defined in
the imported CIF file. If you want to create a supercell according to the occupancy rate, use this
function after creating a sufficiently large supercell using the repeat function.

View menu
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Show Multi-View
We will draw by triple drawing. In the three view, only the upper left window corresponds to
free rotation, and the remaining three direction cameras are fixed to the a, b, c axes of the crystal
and therefore will not rotate.

Always View Center
When checked, always keep the gaze point on the center of gravity

Orbit/Roll
Specify the rotation method.

Orbit
It performs free rotation.

Roll around a-, b-, c-axis
It rotates around the a, b, c axes.

Show Bond
Displays the join.

Show Element Name
It displays the element symbol.

Show Atoms on Boundary in Duplicate
Display atoms on the boundary.

Show Unit Cell
Display unit lattice.

Make Replicated Atoms Transparent
Transparent display of atoms generated by symmetrical operation.

Lattice
Crystal System

Select crystal system.

Space Group
Select space group from number or Hermann-Mauguin symbol.

Lattice Constant
Set lattice constants (fields that can be entered depend on the selected space group).

Asymmetric unit
Add atom

Add an atom that becomes an asymmetric element.

Delete atom
Delete the atom which becomes the asymmetric element selected on the list.

Element
Enter/Modify the element symbol.

X, Y, Z
We set the atomic site with the fractional coordinate (fractional coordinate).

OK
Load the created crystal structure into the main window. If you want to cancel the import, please
click Edit → Undo on the main window.

Cancel
Discard the structure entered in the crystal builder and return to the main window.
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6.15.2 Build Cluster Model

If Tools → Preferences menu has Use New Slab Builder checked, it works as follows.

Miller indices
Define the Miller index (hkl) of the surface.

Force orthorhombic cell
If unchecked, the first basic lattice found by the internal process that satisfies the specified Miller
index will appear. If checked, the internal process is executed until a basic lattice of rectangles
satisfying the specified Miller index is found, at which point the structure appears.

Supercell
Enter the number of supercells in the surface horizontal direction (a or b-axis).

Set slab width by length
Specify the thickness of the slab in angstroms, and enter the location of the lower and upper bound
of the slab in the Lower bound and Upper bound.

Set slab width by repeat units
Specify the thickness of the slab in basic cell units, and enter the location of the lower and upper
bound of the slab in the Lower bound and Upper bound.

Vacuum
Enter the thickness of the vacuum layer; if Vacuum is entered, the Total width is automatically
changed.

Total width
Enter the length of the cell in the c-axis direction; if Total width is entered, Vacuum is automatically
changed.

Position
Specify the position of the slab perpendicular to the surface.

Terminate dangling bonds width hydrogen
If checked, hydrogen atoms are added to the bonds that are broken on the slab surface. If more
hydrogen is added than expected, use Delete or Delete atom after using this function to delete excess
hydrogen atoms.

Do not insert vacuum
If checked, no vacuum layer is inserted. This is used when you do not want to create a slab and just
want to re-create the basic lattice with a mirror index.

Maximum slab width internally generated
Specifies the maximum thickness of the slab to be generated by the internal process if the basic grid
is not found at the specified Miller index, such as in the case of a high-index surface. The value
(absolute value) set in Lower bound or Upper bound must be less than half of this value.

OK button
Creates a slab model and displays it in the main window.

If Tools → Preferences menu does not check Use New Slab Builder, it works as follows. Calling this function with
a (bulk) crystal CIF file loaded will create a slab. Internally, it uses pymatgen or an in-house routine that simulates
pymatgen. First, click the Generate Slab button, and then click the OK button.

Miller indices
Define the Miller index (hkl) of the surface.

Minimum slab size
Enter the cell size in the face vertical (c-axis) direction.
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Supercell
Enter the number of supercells in the surface horizontal direction (a or b-axis).

Force c-axis to be perpendicular to a and b axes
Ensure that the c-axis is perpendicular to the a and b axes.

Convert hexagonal to orthorhombic
Convert Hexagonal to Orthorhombic.

Generate Slab button
This button creates a candidate surface structure based on the items above.

Surface configurations
Select a surface structure from among the candidates.

Slab, Vacuum, Total width
Enter the size of the surface vertical. If you enter ont of Vacuum or Total width, the other will be
determined automatically.

Position
Specify the position of the slab perpendicular to the surface.

OK button
Creates a slab model and displays it in the main window.

Warning: In order to use this feature, you need CygwinWM setup.

6.15.3 Generate Supercell

Duplicate the cell displayed in the main window and create a super cell. Enter the number of repetitions in a , b , c and
click the OK button.

6.15.4 Build Cluster Model

Cut out nanoclusters from the crystal structure. The atoms of the original unit cell are opaque and atoms outside the
unit cell are translucent.

View menu
It is the same as Crystal Builder.

Center
Specify the cluster center point in fractional coordinates. With an atom selected on the graphic screen,
click Set to specify the selected atom position as the center point.

Cluster Radius
Specifies the radius of the cluster in angstroms.

Hydrogen
Modifies hydrogen on cluster surface.

OK
Perform the processing.
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6.15.5 Convert Lattice (Primitive-Conventional)

Converts between primitive cells-conventional cells for cells displayed in the main window. Uses spglib in the back-
ground.

6.15.6 Convert lattice to equivalent rectangular cells

Convert to equivalent rectangular cells for cells displayed in the main window. Useful for converting hexagons to
rectangular cells. Uses atomsk in the background.

Warning: In order to use this feature, you need CygwinWM setup.

6.15.7 Transform Unit Cell

The rotation matrix is used to deform the unit grid vectors in each of the a, b, and c axes. Since each element of the
rotation matrix is an integer, the transformed cell is also a unit cell. This is useful when you want to re-transform the
unit cell lattice vectors.

6.15.8 Refine Lattice

This function detects the symmetry of a cell displayed in the main window with a set tolerance, and then slightly
adjusts the coordinates to conform to that symmetry, which may help avoid symmetry-related problems in Quantum
ESPRESSO and other applications. It uses spglib in the background.

6.15.9 Quantum ESPRESSO

See Solid → Quantum ESPRESSO menu.

6.15.10 OpenMX

See Solid → Quantum ESPRESSO menu.

6.15.11 FDMNES

See Solid → FDMNES menu.

6.16 Solid → Quantum ESPRESSO menu

It is a menu related to Quantum ESPRESSO.
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6.16.1 How to set up Quantum ESPERSSO

To install Quantum ESPRESSO, install CygwinWM version 2023/04/05 or later, which contains
pw.exe, etc. in /opt_win/QuantumESPRESSO*/bin/ of CygwinWM. and so on in /opt_win/
QuantumESPRESSO*/bin/. To use Quantum ESPRESSO from Winmostar, use Tools → Preferences
menu. If you use CygwinWM 2023/04/05 version or later, you do not need to configure. First, under pro-
gram path → Quantum ESPRESSO, select the Quantum ESPRESSO pw.exe that you want to use. Next,
under Calculation → mpiexec (QE), select MPICH or Select and select the mpiexec.exe of the MPI
you want to use. If you are using Quantum ESPRESSO in CygwinWM, select /opt_win/MSMPI/Bin/
mpiexec.exe under CygwinWM. Then, under Calculation → Options for mpiexec (QE), enter the argu-
ments for mpiexec.exe. If you use Quantum ESPRESSO in CygwinWM, enter -np % WM_NUM_PROC%.
Finally, select the version of pw.exe that you selected in Calculation → Version of QE to use, or 7.1 if you
are using Quantum ESPRESSO in CygwinWM. If you want to add a pseudo-potential file, click Tools →
Preferences menu → Calculation → Solid → QE pseudo-potential folder → Open QE pseudo directory
and add the pseudo Add the pseudo-potential file to the opened folder. The pseudopotential file extension
must be upf (case insensitive). You can also create and select a new pseudo-potential folder. If you want to
add MOL files for RISM calculations, click Tools → Preferences menu → Calculation → Solid → Folder
for QE MOL files → Open and add MOL files to the opened folder. The pseudopotential file extension
must be mol (case-insensitive); you can also create a new folder for MOL files and select it. Instructions
for installing Quantum ESPRESSO on a remote machine can be found at Installing Winmostar and solvers.

6.16.2 Workflow Setup

Set up and run the Quantum ESPRESSO calculation flow in project mode.

Preset
Import and saves a preset of settings.

# of Jobs
Specify the number of jobs.

Enable parameter/structure scan
This feature requires the purchase of an add-on. It allows you to run multiple calculations where
only certain parameters differ (parameter scan) or to run calculations with the same parameters for
multiple structures (structure scan). Click Config to open the configuration window for the scan cal-
culation. For parameter scans, select %WM_SCAN1% for the Target Variable and enter the param-
eters you wish to set for %WM_SCAN1% in each row of the Values. Then, enter %WM_SCAN1%
in the parameters you want to set in the Workflow Settings window or Keyword Settings window.
For structure scan, select %WM_STRUCT% for Target Variable when the animation appears in the
molecule display area (e.g., by opening an SDF file). After the scan calculation is finished, use File
→ Project → Scan Results to tabulate the calculation results.

Import
Import the settings output by Export. Click the arrow at the right of the button to recall settings used
in the past on the same project or Winmostar.

Export
Output settings to file.

OK
Runs a calculation or generates a file with your settings. See For project mode for details.

Details
Set detailed calculation conditions. The Configure will be launched.

Task
Select the type of calculation.
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Setting details

Energy calculation=scf
ion_dynamics=none
cell_dynamics=none
tprnfor=False
tstress=False
nosym=False
nstep=50
Use cell_factor=False
electron_dynamics=none
pot_extrapolation=none
wfc_extrapolation=none
Unit for atomic position=angstrom

NSCF calculation=nscf
ion_dynamics=none
cell_dynamics=none
tprnfor=False
tstress=False
nosym=False
nstep=50
Use cell_factor=False
electron_dynamics=none
pot_extrapolation=none
wfc_extrapolation=none
Unit for atomic position=angstrom

Optimize(Atom) calculation=relax
ion_dynamics=bfgs
cell_dynamics=none
tprnfor=True
tstress=False
nosym=False
nstep=50
Use cell_factor=False
electron_dynamics=none
pot_extrapolation=none
wfc_extrapolation=none
Unit for atomic position=angstrom

Optimize(Atom&Cell) calculation=vc-relax
ion_dynamics=bfgs
cell_dynamics=bfgs
tprnfor=True
tstress=True
nosym=False
nstep=50
Use cell_factor=True
electron_dynamics=none
pot_extrapolation=none
wfc_extrapolation=none
Unit for atomic position=angstrom

Damp(Atom) calculation=relax
ion_dynamics=none
cell_dynamics=none
tprnfor=True
tstress=False
nosym=False
nstep=50
Use cell_factor=False
electron_dynamics=none
pot_extrapolation=none
wfc_extrapolation=none
Unit for atomic position=angstrom

Damp(Atom&Cell) calculation=vc-relax
ion_dynamics=damp
cell_dynamics=damp-w
tprnfor=True
tstress=True
nosym=False
nstep=50
Use cell_factor=True
electron_dynamics=none
pot_extrapolation=none
wfc_extrapolation=none
Unit for atomic position=angstrom

DFPT(Gamma) calculation=nscf
ion_dynamics=none
cell_dynamics=none
tprnfor=False
tstress=False
nosym=False
nstep=50
Use cell_factor=False
electron_dynamics=none
pot_extrapolation=none
wfc_extrapolation=none
Unit for atomic position=angstrom

DFPT(Dispersion) calculation=nscf
ion_dynamics=none
cell_dynamics=none
tprnfor=False
tstress=False
nosym=False
nstep=50
Use cell_factor=False
electron_dynamics=none
pot_extrapolation=none
wfc_extrapolation=none
Unit for atomic position=angstrom

BOMD calculation=md
ion_dynamics=verlet
cell_dynamics=none
tprnfor=True
tstress=False
nosym=True
nstep=50
Use cell_factor=False
electron_dynamics=none
pot_extrapolation=second_order
wfc_extrapolation=second_order
Unit for atomic position=angstrom

BOMD(Atom&Cell) calculation=vc-md
ion_dynamics=beeman
cell_dynamics=pr
tprnfor=True
tstress=False
nosym=True
nstep=50
Use cell_factor=False
electron_dynamics=none
pot_extrapolation=second_order
wfc_extrapolation=second_order
Unit for atomic position=angstrom

Phonopy calculation=scf
ion_dynamics=none
cell_dynamics=none
tprnfor=True
tstress=True
nosym=False
nstep=50
Use cell_factor=False
electron_dynamics=none
pot_extrapolation=none
wfc_extrapolation=none
Unit for atomic position=crystal
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Charge
Specifies the charge for the entire system.

# of bands
Specify the number of bands.

Spin
Set up the spin polarization calculation. Polarized (Manual) allows you to set the initial magnetization
moment more flexibly for magnetic material calculations because Use Spin Density as is false and
each element can have only one initial magnetization moment.

Setting details

Non-polarized nspin=1

Polarized nspin=2
Use Spin Density as=True

Polarized(Manual) nspin=2
Use Spin Density as=False

Cutoff energy
Sets the cutoff energy (ecutwfc) of the wave function.

Manually specify cutoff energy
If not checked, Cutoff energy is automatically specified from Precision.

K points
Specify how to calculate K points.

Pressure
Specify pressure.

Phonon(DFPT)
Set up phonon calculations using DFPT(ph.x).
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Setting details

Disabled Run phonon=False
epsil=False
lraman=False
asr=no
ldisp=False

Gamma Run phonon=True
epsil=True
lraman=True
asr=crystal
ldisp=False

Dispersion Run phonon=True
epsil=False
lraman=False
asr=crystal
ldisp=True

Use Bravais-lattice index
If checked, input file will be created with other than ibrav=0. Check this box because it is necessary
to set special points from ibrav when calculating band structure and phonon bands.

Pseudopotential
Specify a pseudopotential file. changing Type will narrow down the Functional and Pseudo files.
changing Functional will narrow down the Pseudo files. Changing Functional will narrow down the
Pseudo files. See Pseudopotential in Configure for instructions if the desired choice does not appear.

Properties
Calculate properties checked to match when calculating.

Precision
Set calculation precision.
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Setting details

Extra-low conv_thr=1d-5
etot_conv_thr=1d-3
forc_conv_thr=1d-2
press_conv_thr=1.0
degauss=0.02
tr2_ph=1d-10
Spacing=0.44(metal) 0.63(nonmetal)
ecutwfc=30(metal) 25(nonmetal)

Low conv_thr=1e-6
etot_conv_thr=1d-4
forc_conv_thr=1d-3
press_conv_thr=0.5
degauss=0.02
tr2_ph=1e-11
Spacing=0.44(metal) 0.63(nonmetal)
ecutwfc=40(metal) 30(nonmetal)

Medium conv_thr=2d-7
etot_conv_thr=4d-5
forc_conv_thr=5d-4
press_conv_thr=0.25
degauss=0.02
tr2_ph=1e-12
Spacing=0.31(metal) 0.50(nonmetal)
ecutwfc=50(metal) 35(nonmetal)

High conv_thr=1d-7
etot_conv_thr=2d-5
forc_conv_thr=3d-4
press_conv_thr=0.125
degauss=0.02
tr2_ph=1e-14
Spacing=0.25(metal) 0.44(nonmetal)
ecutwfc=55(metal) 40(nonmetal)

Extra-high conv_thr=5d-8
etot_conv_thr=1d-5
forc_conv_thr=1d-4
press_conv_thr=0.05
degauss=0.01
tr2_ph=1e-16
Spacing=0.08(metal) 0.11(nonmetal)
ecutwfc=60(metal) 50(nonmetal)
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Metal
Enable smearing. (occupations=smearing) Also adjusts the contents of Precision (above).

6.16.3 Configure

Set the calculation condition of Quantum ESPRESSO. To set up the calculations immediately after setting
Run button, once to return to the main window please press :guilabel:` OK` button. See Run for behavior
when clicking Run. Return to the default state with Reset button. Save the setting except Force Field with
Save button. Load the setting saved by Save with the Load button. If the Quantum ESPRESSO keyword
displayed in the Keyword Editor and the contents set in this function window are different, you will be asked
if you want to load the keyword from the Keyword Editor. When invoking this function, if the structure
displayed in the main window can be changed to a primitive cell, Convert Lattice (Primitive-Conventional)
is executed automatically.

Output Directory
Specify the output destination folder (outdir) of the data, and at the same time specify the
new/continued execution of the job.

Create
Create a new folder to output data to. outdir will be set to the new folder.

Continue
Continue with the last executed QE job that is loaded on the main screen. outdir is set to the
outdir of the last executed job.

Select
Specify the folder specified in the dialog that opens as the output destination and continue the
job from the data in that folder. outdir will be set to what you specify here.

Preset
Select preset for setting. Each preset changes the following keywords
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SCF SCF+Bands
+DOS

SCF+Bands
(Fermi
surf)

Relax Relax

(variable
cell)

BOMD CPMD Phonopy

calculation

scf scf scf relax vc-
relax

md cp scf

Use
nbnd

False True True False False False False False

K_POINTS

gamma

automatic
4 4 4 1
1 1

automatic
4 4 4 1
1 1

gamma

automatic
4 4 4 1
1 1

gamma gamma gamma

tstress

False False False False False True False False

Set
ibrav
and
celldm

False True True False False False False False

occupations

smear-
ing

ion_dynamics

bfgs bfgs verlet none

cell_dynamics

bfgs

tprnfor

False False False True True True True True

tstress

False False False False True False False True

Use
cell_factor

False False False False True False False False

pot_extrapolation

sec-
ond_order

wfc_extrapolation

sec-
ond_order

electron_dynamics

sd

Unit for

atomic_position

angstrom angstrom angstrom angstrom angstrom crystal

Band
struc-
ture
plot

False True True False False False False False

DOS
plot

False True True False False False False False

PDOS
plot

False True False False False False False False

Fermi
surface

False False True False False False False False
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Use MPI
Specify whether to execute parallel calculation using MPI when executing QE. Enter the number of
MPI processes in the horizontal field.

Basic Tab
restart_mode

When from_scratch is set, the job is started without using information from previous jobs; when
restart is set, the job is started using information from outdir; when Automatically set, in project
mode, from_scratch is used for new jobs and restart is used for other jobs. Automatically set
is used in project mode for new jobs from_scratch, and restarts for all other jobs. In file mode,
from_scracth is used when Output Directory=Create, and restart is used for other jobs.

calculation
Select the type of calculation.

# of bands
The selection in parentheses displays the number of valence electrons when pseudopotentials
are used. If the valence number fails to calculate automatically, it is displayed as N/A.

Do not specify
nbnd is set automatically.

Specify nbnd
Explicitly specify the number of bands.

Specify nbnd(Relative)
Specified relative to the number of valence bands.

Use nbnd
Specify the number of bands. If not checked, it will be set automatically.

K_POINTS
Choose how you want to specify the k-point from the pull-down menu and specify the k-point
in the QE format in the text box below. If you want to use k-point information generated by a
website such as SeeK-path, select the type of K_POINTS (e.g. crystal) and then paste the k-point
coordinates and points into the text box below it. After selecting the type of K_POINTS (e.g.
crystal), paste the coordinates of the k-points and the number of points into the text box below
it. The number of k points (nks) written to the input file will be automatically filled in.

gamma
Calculated at the Γ point only.

automatic
Use Monkhorst-Pack method. Enter “(number of divisions in kx direction) (number of
divisions in ky direction) (number of divisions in kz direction) (shift flag in kx direction)
(shift flag in ky direction) (shift flag in kz direction)” (separated by spaces). The shift flag
is 0 for no shift (k points contain Γ points) and 1 for shift (k points cross Γ points).

automatic(by spacing)
Use Monkhorst-Pack method. The number of divisions in each direction is set by the Spac-
ing parameter ( Spacing parameter ).

automatic(by spacing,slab)
Use Monkhorst-Pack method. The number of divisions in each direction is set by the Spac-
ing parameter ( Spacing parameter ). However, the number of vertical slab divisions de-
tected automatically is set to 1.

Others
Please refer to the pw.x manual or doc/brillouin_zones.pdf under the QE installation folder
for details.
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Set default k-path
The default k-point path of the Bravo lattice (ibrav) detected for the crystal displayed in the
main window is acquired from UserPref/kpath_default.txt and set.

nosym
Specify whether to use spatial symmetry.

noinv
Specify whether time reversal symmetry is used or not.

Set ibrav = . . . and celldm
If the primitive cell is displayed in the main window and checked, set the appropriate ibrav and
celldm. If it is not checked, set ibrav = 0 and set CELL_PARAMETERS.

ecutwfc
Specify the cutoff energy of the plane wave when calculating the wave function.

Ecut for US/PAW
Sets how ecutrho is specified when selecting an Ultrasoft or PAW pseudopotential file.

Specify ecutrho/ecutwfc
Set ecutrho from the ratio of ecutrho to ecutwfc and the value of ecutwfc.

Specify ecutrho
Directly set the value of ecutrho.

ecutrho
Specify cutoff energy of plane wave at electron density and potential calculation.

tot_charge
Specify the charge of the entire system in the simulation cell.

occupations
Specify smearing for metals and tetrahedron for DOS calculations.

ion_dynamics
Specify the algorithm to change ion (nucleus) position.

cell_dynamics
Specify algorithm to change simulation cell.

tprnfor
I will calculate the force.

tstress
Calculate the pressure tensor.

Advanced tab
conv_thr

Specify tolerance of energy at SCF calculation.

etot_conv_thr
Structural Optimization (relax) Specify the energy tolerance for calculation.

forc_conv_thr
Structural Optimization (relax) Specify the force tolerance during calculation.

press_conv_thr
Specify tolerance of pressure when cell structure optimization (relax - vc) calculation is calcu-
lated.

electron_maxstep
Specify the maximum iteration number of the SCF calculation.
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nstep
Specify the maximum number of steps for structure optimization (relax) calculation and the
number of steps for MD calculation.

upscale
Specify coefficients for automatically decreasing conv_thr during structure optimization (relax)
calculation.

diagonalozation
Specify diagonalization algorithm.

diago_david_ndim
Specifies the size of the workspace when diagonalized with the Davidson algorithm.

spline_ps
Interpolate pseudopotentials with cubic spline, useful for GIPAW calculations.

la2F (for pw.x)
Outputs a file with written eigenvalues for electron-phonon interaction calculations in pw.x.

smearing
Specify the method of occupancy smoothing (smearing).

degauss
Specify the parameter of occupancy smoothing.

mixing_beta
Specify the mixture ratio of old and new KS orbitals in SCF calculation. The closer to 1, the
greater the ratio of predicted values.

mixing_mode
Specify the mixture algorithm of old and new KS orbitals.

vdw_corr
Van der Waals (dispersion) Specify how to correct forces.

Use input_dft
When checked, overwrite the setting of the functional to the setting written in the pseudopotential
file.

nqx1/2/3
Specifies the number of k-point sampling when calculating the Fock operator. If Default, use
the same value as K_POINTS.

cell_dofree
Specify the degree of freedom (direction) for moving the simulation cell.

Use cell_factor
Explicitly specify the construction parameter of the pseudopotential table. Sometimes it is better
to set a larger value for vc - relax (structure optimization calculation with cell size change).

Spin/DFT+U tab
nspin

Set up spin polarization calculation.

Use tot_magnetization
When checked, specify the magnetization of the whole system here. If you do not check it,
specify starting_magnetization.

starting_magnetization
Gives the initial value of the magnetization of each atom species. Use “Use Spin Density as
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starting_magnetization” if you want to calculate antiferromagnets, since in this case all atoms
of the same element have the same value.

noncolin
Specifies whether or not non-colinear calculations are performed. If checked, nspin is not out-
put to the input file. nspin is not output, but nspin=2 must be set on the same tab to set start-
ing_magnetization.

lspinorb
Pseudopotential file with spin orbit interaction can be used during calculation of non-colinear.

Use Spin Density as starting_magnetization
Use the value of Spin Density set in the main window as-is as starting_magnetization. If checked,
the above starting_magnetization is ignored. Use this feature when atoms of the same element
have different starting_magnetization, such as in antiferromagnets.

lda_plus_u
Perform LDA + U calculation.

Hubbard_U/alpha
Specify the U and alpha parameters of Hubbard for each atom type.

Phonon tab
Run Phonon Calculation as Postprocess

Perform a phonon calculation. Specifically, ph.x is run after pw.x is run. To enable this item,
you must select scf, nscf or relax for Calculation. If you want to run ph.x after the SCF or Relax
calculation is finished, you can run it with Calculation=nscf, which will immediately finish pw.x
and immediately start ph.x processing. The ph.x and other input/output files are created in the
working folder.

tr2_ph
Specify the censored error of phonon calculation.

alpha_mix(1)
Specify mixing factor.

epsil=.True.
Calculate the dielectric constant obtained from phonon calculation.

lraman=.True.
Include calculation of Raman spectrum.

electron_phonon
Specifies the method of electron-phonon interaction calculation.

el_ph_sigma
Specifies the interval of double-delta smearing during electron-phonon interaction calculations.

el_ph_nsigma
Specifies the number of double-delta smearing during electron-phonon interaction calculations.

Use fildvscf
Output files used in electron-phonon interaction calculations when running q2r.x.

la2F = .true. (for q2r)
Check in Electron Phonon Interaction Calculations

asr(for dynmat)
Specifies how the Acoustic Sum Rule is given in the post-processing (dynmat.x) after phonon
calculation. It does not affect the phonon calculation itself.
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lperm=.True.(for dynmat)
The contribution of the Gamma point to the dielectric constant is calculated in the post-
processing (dynmat.x) after the phonon calculation.

ldisp=.true.
Calculate phonon dispersion. In order to acquire phonon band structure, phonon density of states
you need to specify this.

nq1,nq2,nq3
Specify the number of K points when computing phonon variance.

Use spacing
Use Monkhorst-Pack method. The number of divisions in each direction is set by the Spac-
ing parameter ( Spacing parameter ).

NMR/EFG tab
Run GIPAW calculation (gipaw.x) as postprocess

Run a GIPAW calculation. Specifically, gipaw.x is run after pw.x is run. The gipaw.x input and
output files will be created in your working folder. To see the details of the results of the GIPAW
calculation, open gipaw.out or gipaw2.out directly in a text editor.

job
Specify what you want the GIPAW calculation to output. If you choose ‘nmr & efg’, gipaw.x
will be invoked twice, with job=nmr and job=efg, respectively.

conv_threshold
Specify the truncation error for diagonalization.

diagonalozation
Specify diagonalization algorithm.

q_gipaw
Specifies the magnitude of the infinitesimal wavenumber to use when calculating with linear
response theory.

verbosity
Specifies the level of output to the log.

use_nmr_macroscopic_shape/nmr_macroscopic_shape
Specifies whether the chemical shift values should be corrected to account for the macroscopic
shape of the sample.

spline_ps
Specifies whether pseudopotentials should be spline complement.

q_efg
Specifies the quadrupole moment of the nucleus.

hfi_nuclear_g_factor
Specifies the g-tensor of the nucleus.

Enter q_efg
This is an input aid for q_efg. You can quote from the default or user-prepared q_efg tables.

Open q_efg table
Open q_efg table.

Dynamics tab
Simulation Package

Specify the calculation package to be used for MD calculation. For cp.x, use the CPMD method.
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DT
Specify the time step of MD calculation with atomic unit.

tempw
Specify the target temperature when temperature control is specified by MD calculation.

press
Specify the target pressure when specifying pressure control in MD calculation.

ion_temperature
Specify the temperature control method of ion (nucleus) in MD calculation.

ion_velocities
Specify the initial velocity of ion for MD calculation.

gangbang
Specify the allowable value of temperature during temperature control.

pot_extrapolation
Born-Oppenheimer Specify the extrapolation method of the potential when using MD.

wfc_extrapolation
Specify the extrapolation method of wave function when Born-Oppenheimer MD is used.

electron_dynamics
Specify the algorithm to change the KS trajectory when Car - Parrinello MD is used.

electron_velocities
Specify the initial speed of electrons when Car - Parrinello MD is used.

emass
Car-Parrinello Specify the virtual mass of electrons when using MD.

emass_cutoff
Car-Parrinello Specifies the cutoff value of the virtual mass of electrons during MD calculation.

orthogonalization
Specify the method of matrix calculation (orthonormalization).

Dipole Corr tab
tefield

A sawtooth type external electric field is applied.

dipfield
Use dipole correction.

edit
Sets the direction in which the tefield and dipfield are applied.

emaxpos
The location where the external electric field is at its maximum value when applying tefield and
dipfield is given in fractional coordinates (in the range of 0 to 1).

eopreg
The size of the region where the external electric field decays when applying tefield and dipfield
is given in fractional coordinates.

eamp
Gives the magnitude of the external electric field when applying the tefield and dipfield.

ESM tab
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assume_isolated=esm
Check if you use ESM (Effective Screening Medium) method.

esm_bc
Specify the type of boundary condition used in the ESM method.

esm_efield
Specify the electric field.

esm_w
Sets the offset for the location where the ESM will be placed.

lfcpopt
Calculation of constant chemical potential (constant mu) will be carried out. The initial system
charge is specified by tot_charge on the Basic tab.

the fcp_m
Set the target value of Fermi energy in constant calculation of chemical potential.

Enter Relative Potential
Supports input of Target Fermi Energy. First, specify the log file for calculation at voltage 0 and
acquire Fermi energy at voltage 0. Next, input the applied voltage. From these two pieces of
information, calculate Target Fermi Energy.

RISM(1) tab
trism=.True.

Enable RISM calculations. Check here to run ESM-RISM calculations, and check as-
sume_isolated = esm on the ESM tab. To use this feature, you need to install a separate version
of Quantum ESPRESSO with the ESM-RISM feature enabled.

closure
Select the closure to use for RISM calculation

tempw
Specify the initial velocity of ion for MD calculation.

ecutsolv
Specify the cutoff energy of the plane wave when calculating the wave function.

solute_lj
Specify the LJ parameter of the solute (DFT region). If none is selected, enter the LJ parameter
in solute_epsilon and solute_sigma below

noinv
Specify the number of molecular species of the solvent.

SOLVENTS
Select the unit of Density from the pull-down menu and specify the density (concentration) of
each solvent molecule type and the name of the MOL file. MOL files must be in the folder
specified by Directory for MOL Files below.

Directory for MOL Files
Specify a folder containing MOL files that can be selected with SOLVENTS.

RISM(2) tab
laue_expand_right/left

Specify the position of the far end of the solvent region in the ESM-RISM calculation.

laue_starting_right/left
Specify the starting position of the solvent region in the ESM-RISM calculation.
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laue_buffer_right/left
Specify the location of the solvent buffer area in the ESM-RISM calculation.

Run only 1D-RISM
If checked, run 1drism.x instead of pw.x. No DFT calculations will be performed. Useful if you
only want to know the correlation function between solvent atoms and the chemical potential
between solvents.

rism3d_conv_level
Specify parameters for dynamically changing the truncation error of 3D-RISM calculation at
each step of SCF calculation.

rism1d/rism3d_maxstep
Specify the maximum number of 1D and 3D-RISM iterations.

rism1d/rism3d_conv_thr
Specify the truncation error for 1D and 3D-RISM.

mdiis1d/3d_size
Specify the convergence parameter of RISM calculation by MDIIS algorithm.

mdiis1d/3d_step
Specify the convergence parameter of RISM calculation by MDIIS algorithm.

Others tab
Fill in the other settings in QE's input file format (FORTRAN namelist format). An example of entry
is displayed by pointing the pointer.

Preview tab
A preview of the configuration keywords will be displayed.

Options Tab
Verbosity

Specify the amount of information output by QE.

atomic_position unit
Specify the unit of ATOMIC_POSITIONS and CELL_PARAMETERS.

Use max_seconds
If checked, processing of QE will be interrupted after the number of seconds entered here.

Options for executable
Gives the arguments of the command to run pw.x or pw.exe. For example, you can specify -nk,
-nb, -nt, or -nd to control parallelism.

Dump all files for remote
Output files necessary for job execution under Linux environment. The same file as the file
generated by the remote job submission function is output.

Open k-path file
Open the configuration file (UserPref/kpath_default.txt) that describes the k-point path specified
by default for each type of ibrav (bracket lattice). If UserPref/kpath_default.txt does not exist, it
is copied from wmx/kpath_default.txt.

QE Version
Specifies the version of the QE to which the input file of the output QE corresponds. The output
format of some keywords (&fcp, HUBBARD, etc.) varies with the version.

Properties tab
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Calculate these properties after pw.x
Select post processing to be executed immediately after executing pw.x. Various parameters of
the processing selected here are specified in the Parameter/Value column on the right.

Pseudopotential tab
Mass

Specify the mass of each element.

Default
Set standard mass.

Light
Set the mass of all elements to 1. It is used for the purpose of promoting structural relaxation
of ions.

Manual
In the list below, for each element, the user individually sets the mass.

Pseudopotential
Select a pseudopotential file from among those that are common to all elements in the system.

(Type)
Select the type of pseudopotential.

(Functional)
Selects the type of functionality. Choose from the choices narrowed down by (Type).

(File)
Select a pseudopotential file. Choose from the choices narrowed down by (Type) and (Func-
tional). If you choose (Manual), the user sets the pseudopotential individually for each ele-
ment in the list below.

Pseudopotential files are searched in the folder specified in the pseudo Directory. Preference is
given to the first entry in qe_pseudo_priority_list.txt in the user configuration folder.

Reload pseudo Files
The pseudo-potential file placed in the folder specified by pseudo Directory is read again.

pseudo Directory
Specify the folder where the pseudopotential file will be placed. If the case of pseudo in QE#39;s
directory, use the pseudo folder under the installation directory of QE. If the case of (select . . . ),
use the directory selected in the dialog.

Open Pseudo Directory
Open the folder specified in pseudo Directory.

Download Pseudo Files
Download the pseudopotential file and install it.

Open Priority List
Open UserPref/qe_pseudo_priority.txt. If it does not exist, it is copied from
wmx/qe_pseudo_priority.txt.

Reset
Reset settings.

Import
Loading configuration file.

Export
Output configuration file.
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Spacing parameter

The Spacing parameter is used to determine the number of k-point divisions 𝑁 in each direction, indepen-
dent of the system size.

𝑁 = max(1, ceiling(|⃗𝑏𝑖|/Spacing))

�⃗�𝑖 (where 𝑖 is the index for each direction 0, 1, 2) is the reciprocal lattice vector �⃗�𝑖𝑏𝑖 = 2𝜋𝛿𝑖𝑗 for the lattice
vector (basic translation vector) �⃗�𝑖.

6.16.4 Run

Run Quantum ESPRESSO. The execution method differs depending on the situation. When CPMD is
selected cp.x, otherwise it executes pw.x.

• (Default) When Output Directory = Create, create a new working folder and execute the calculation.

• If the case of Output Directory = Continue, use outdir of the input file open in the main window as
the working folder then.

• If the case of Output Directory = Select, use the selected folder as the working folder (outdir).

Following file will be generated with execution. As an example, the file/folder name when the input file is
si.pwin is also shown.

type Description

pwout file
si.pwout

Calculation log file.

bat file
si.bat

It is a batch file for running Quantum
ESPRESSO.

Working Folder
si_qe_data\

Working folder.

The following files are generated in the working folder. Only the main files are shown here.
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type Description

Pseudopotential file
*.UPF

The pseudopotential files used in the
calculations are copied here and the
ESPRESSO_PSEUDO environment
variable is set in the working folder.

pw_bands.in This is an input file for executing bands
calculation in post processing.

pw_bands.out This is the log file of pw_bands.in.

pw_dos.in Input file for executing dos calculation in
post processing.

pw_dos.out pw_dos.in log file.

ph.in Input file for running phonon calculations
with ph.x in post-processing.

ph.out This is the log file of ph.in.

Hint: ** Working folder **

• A working folder is a folder whose name is the name of the file opened in the main window
plus a suffix.

– ** The suffix varies depending on the type of solver. **

– For example, in the case of Gromacs, if the file opened in the main window is aaa.gro
and the suffix is _gmx_tmp, the working folder will be named aaa_gmx_tmp.

• It must be in the same hierarchy as the file opened in the main window.

• Processing continues in the working folder of the same name even when continuing jobs,
but by default the backup of the working directory of the previous job is created just before
the continuation job is executed.

– The name of the backup will be the one with the smallest number in the range where
duplicate names do not exist. For example, if the working folder is aaa_gmx_tmp, it
is aaa_gmx_tmp1.

– ** Directories without numbers are always up to date. **

6.16. Solid → Quantum ESPRESSO menu 217



Winmostar™ User Manual, Release 11.13.0

Job is run through Winmostar Job Manager.

6.16.5 Open Log File (pwout)

Open the log file with a text editor.

6.16.6 Show Extracted Log

Excerpts of key information from the log file are displayed.

6.16.7 Animation

Optimization, BOMD(pwout, out)

From the information of the log file, animation such as structure optimization, BOMD calculation etc. is
created and displayed. For CPMD use CPMD(pos). See Animation operation area for animation display
operations. From the animation operation area, you can calculate radial distribution function, self-diffusion
coefficient, mean square displacement, displacement of each atom, etc.

CPMD(pos)

Specify CPMD's pos and cel files and display animation. To display the result of pw.x, use Optimization,
BOMD(pwout, out). See Animation operation area for animation display operations. From the anima-
tion operation area, you can calculate radial distribution function, self-diffusion coefficient, mean square
displacement, displacement of each atom, etc.

6.16.8 Energy Plot

SCF Energy Change (pwout)

Select the log file and display a graph of total energy. For CPMD use CPMD Energy Plot (evp).

Property
Select the values to be displayed in the graph.

Draw
Display the graph. The result analysis program is executed as necessary.

Close
Close the window.

For how to operate the graph drawing area, see How to operate the graph.
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CPMD Energy Plot (evp)

Specify the evp file of CPMD and display time variation of various energies.

Draw
Display the graph. The result analysis program is executed as necessary.

Close
Close the window.

For how to operate the graph drawing area, see How to operate the graph.

6.16.9 Analyses

Density od States

Specify the working folder (outdir) and the SCF calculation log file and display the density of states. Fermi
energy is acquired from the log file of SCF calculation. dos.x runs in the background. The range of energies
where the density of states near the Fermi energy is zero is calculated internally, and the values of the band
gap, VBM (upper end of the valence band) and CBM (lower end of the conduction band) energies are
calculated and displayed.

Draw
Display the graph. The result analysis program is executed as necessary.

Close
Close the window.

For how to operate the graph drawing area, see How to operate the graph.

Projected DOS

Specify the working folder (outdir) and the SCF calculation log file and display projected density of
state(PDOS). Fermi energy is acquired from the log of SCF calculation. Projwfc.x runs in the background.

Check atom using viewport
The molecular structure read from the log file is displayed in 3D. The orbitals of the atoms selected
by clicking there are checked in the list of orbitals.

Draw
Display the graph. The result analysis program is executed as necessary.

Close
Close the window.

For how to operate the graph drawing area, see How to operate the graph.
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Band Structure

Specify the working folder (outdir) and SCF calculation log file and display the band structure. Calculation
must be completed with calculation = bands in advance. Fermi energy is acquired from the log file of SCF
calculation. Bands.x runs in the background.

Draw
Display the graph. The result analysis program is executed as necessary.

Close
Close the window.

For how to operate the graph drawing area, see How to operate the graph.

Lowdin Charge

Specify the working folder (outdir), calculate and display the Lowdin charge. Projwfc.x runs in the back-
ground.

Lowdin Charge

Specify a working folder (outdir) to calculate and display the Bader charge. You must generate a cube file of
all electron densities beforehand using the PAW method. The bader program is playing in the background.

Electron Density

Specify working folder (outdir) and display isoelectric density surface. In the background, pp.x flows, and
a cube file is generated. Refer to Surface Setup / Cubgen window for how to operate subwindow.

Spin Density

Specify working folder (outdir) and display isoelectric density surface. In the background, pp.x flows, and
a cube file is generated. Refer to Surface Setup / Cubgen window for how to operate subwindow.

Potential Energy

Specify a working folder (outdir) and display the isopotential energy surface. In the background, pp.x
flows, and a cube file is generated. Refer to Surface Setup / Cubgen window for how to operate subwindow.

Potential Energy Distribution

Specify the working folder (outdir) and the log file of the SCF calculation to display the potential energy
distribution in the z-axis direction (excluding exchange correlation energy). Fermi energy is acquired
from the log of SCF calculation. The difference between the Fermi energy and the maximum value of
the potential energy ,excluding exchange-correlated energy, distribution is displayed as an estimate of the
work function. Pp.x and average.x flow in the background.

Draw
Display the graph. The result analysis program is executed as necessary.

Close
Close the window.
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For how to operate the graph drawing area, see How to operate the graph.

Fermi Surface

Specify the log file for SCF calculation and bands calculation and display the Fermi surface. For Fermi
surface display, use FermiSurfer <https://mitsuaki1987.github.io/fermisurfer/index_ja.html>. Specify the
k point division number for bands calculation in # of K Points and press the Calc button to display the
Fermi surface.

Dielectric Function

Specify the working folder after calculating the dielectric function and display the dielectric function.

Direction
Specify the direction of the dielectric function to be acquired.

Draw
Display the graph. The result analysis program is executed as necessary.

Close
Close the window.

For how to operate the graph drawing area, see How to operate the graph.

NMR

Specify a working folder after GIPAW calculation to display NMR spectra. See NMR Window for subwin-
dow operation.

IR/Raman

Specify the working folder after phonon calculation and log of SCF calculation and display IR and Raman
spectrum. Refer to IR Spectrum Window for how to operate the subwindow.

Phonon Band Structure

Phonon Specifies the working folder after the variance calculation and displays the phonon dispersion
curve.

ASR
Specify the type of Acoustic Sum Rule to be applied.

K Points
Specify the path of the dispersion curve to be acquired. In each line, describe the x, y, z components
in units of 2pi/a, and next to it describe the number of divisions up to the next point. (Enter a total
of 4 columns with a space separator)

Draw
Display the graph. The result analysis program is executed as necessary.

Close
Close the window.

For how to operate the graph drawing area, see How to operate the graph.
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Phonon Density of States

Phonon Specifies the working folder after distributed calculation and displays the phonon density of states.

ASR
Specify the type of Acoustic Sum Rule to be applied.

K Points
Phonon DOS Specifies the division number of K points during DOS calculation.

Draw
Display the graph. The result analysis program is executed as necessary.

Close
Close the window.

For how to operate the graph drawing area, see How to operate the graph.

Charge/Energy Profile (esm1)

Specify the esm1 file output by ESM calculation (assume_isolated = esm) and display the charge or energy
distribution in the z-axis direction. You can also plot the difference between the two esm1 files.

Draw
Display the graph. The result analysis program is executed as necessary.

Close
Close the window.

For how to operate the graph drawing area, see How to operate the graph.

1D-RISM RMS Change

Plot the change in RMS of the 1D-RISM calculation performed at the beginning of the RISM calculation
(trism = .True.).

Draw
Displays a graph.

Close
Close the window.

For how to operate the graph drawing area, see How to operate the graph.

3D/Laue-RISM RMS Change for Last Step

Plot the change of RMS of 3D-RISM or ESM-RISM calculation in the last SCF step when RISM calcula-
tion (trism = .True.) is executed.

Draw
Displays a graph.

Close
Close the window.

For how to operate the graph drawing area, see How to operate the graph.
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Solvent Pair Distribution Func. (1drism)

Interatomic correlation function (radial distribution function) of RISM region is calculated using 1 drism
file outputted by RISM calculation (trism =. True.).

Obtain Chemical Potentials
The chemical potential between solvent molecules is output in csv format.

Draw
Display the graph. The result analysis program is executed as necessary.

Close
Close the window.

For how to operate the graph drawing area, see How to operate the graph.

Solvent Charge/Energy Profile (rism1)

Calculate the solvent density, energy, and charge in the direction in which the DFT region-RISM region
contacts (vertical direction of the interface) by using the rism1 file output by RISM calculation (trism =
.True.).

Draw
Display the graph. The result analysis program is executed as necessary.

Close
Close the window.

For how to operate the graph drawing area, see How to operate the graph.

6.16.10 Generate MOL File

Creates a MOL file for the solvent used in the RISM calculation (trism=.True.). To set LJ parameters from
a LAMMPS data file, open the data file in the main window and check Use parameters in displayed file in
the main window. The created file should be placed in the folder specified by Directory for MOL Files on
the RISM (1) tab of the Configure window of the MOL file.

6.16.11 Nudged Elastic Band

Workflow Setup/Keyword Setup

Set up and run the conditions for the NEB calculation; use neb.x to run the NEB. Please set in the state
that the structure optimization calculation of each of the start state and the end state has been completed.

6.16.12 Run

Run Quantum ESPRESSO NEB calculation in file mode.
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Open Log File (pwout)

Open the NEB calculation log file in a text editor.

NEB error change

Displays errors in each iteration of the NEB calculation.

Animation

Specify the output file of the NEB calculation and display the changes in energy and atomic structure along
the reaction coordinates after the NEB calculation convergence. If you want to see the energy change at
each iteration of the NEB calculation continuously, use Energy Plot. For the animation display operation
method, see Animation operation area.

Energy Plot

Specify the output file of the NEB calculation and display the change in energy along the reaction coor-
dinates. You can visualize the appearance at each iteration of the NEB calculation. Use Animation if you
want to visualize the atomic structure.

6.16.13 BoltzTraP

BoltzTraP calculates thermoelectric characteristics based on the output of nscf calculation in QuantumE-
SPRESSO.

Configure & Run

Set the calculation conditions for pre-post processing using BoltzTraP and execute pre-processing. Create
.intrans File button

Read nscf calculation output file (.pwout) of Quantum ESPRESSO and generate BoltzTraP set-
ting file (.intrans). Assuming that the output file is mg2si_nscf.pwout, a working folder named
mg2si_nscf is created in the same level. mg2si_nscf.intrans is generated in mg2si_nscf. If the
intrans file is successfully created, read the contents of the file and reflect it in the input fields
of the following keywords.

Fermilevel (Ry)
Fermi energy read from pwout file is set.

energy grid
Specify the interval of the set energy.

energy span
Specifies the range of band energies to consider in calculations around the Fermi level.

number of electrons
Specify the number of electrons in a unit cell.

lpfac
Specify the factor for complementing the band energy by Fourier expansion.

efcut
Specify the calculation range by changing the chemical potential.
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Tmax
Specify the upper limit of the set temperature.

temperature grid
Specify the interval of the set temperature.

energy of bands
Specify the energy width of the band obtained from DOS.

Calculate expansion coeff
If checked, compute expansion coefficients (CALC). If not checked, read expansion coefficients from
file (NOCALC).

Start BoltzTraP button

Recreate the intrans file based on the setting conditions and execute BoltzTraP. At this time, the
following files and folders are created. The main files in the working folder (mg2si_nscf) at the
end of the calculation are described below.

type Description

intfans file
mg2si_nscf.intrans

BoltzTraP input file.

.trace file
mg2si_nscf.trace

This file contains information on energy
and temperature dependence of thermoelec-
tric properties calculated by BoltzTraP. The
BoltzTraP Import Result menu reads this file
and performs visualization.

Cancel button

Close Configure & Run window without doing anything.

Import Result

The following thermoelectric properties calculated by BoltzTraP are read and visualized.

• Seebeck coefficient

• Electrical conductivity

• Electrical thermal conductivity

• Power factor

• Figure of merit

To display the energy dependence of the characteristic value at each temperature, select T [K] from the
combo box and select the target temperature from the list. If you want to display the temperature depen-
dence of the characteristic value for each energy, select E-Ef [eV] from the combo box and select the target
energy from the list.
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6.16.14 Phonopy

Calculations using Phonopy are performed in the following three steps.

1. Create a supercell based on a given crystal structure (project mode) or Quantum ESPRESSO input
file (file mode).

2. Execute Quantum ESPRESSO for all generated super cells.

3. Create a ForceSets file from the Quantum ESPRESSO output file to calculate Phonon bands, DOS,
thermophysical properties, etc.

Create a supercell

Generate a supercell for the Phonopy calculation for the crystal structure displayed in the molecule display
area in the “Project” mode. Depending on the type of crystal, multiple structures may be generated. To run
Quantum ESPRESSO calculations on these structures, use Workflow Setup with Enable scan calculation.

Configure & Run

In file mode, set the calculation conditions for pre- and post-processing using Phonopy and execute the
pre-processing.

Open button
Read the input file (*.in, *.pwin) of Quantum ESPRESSO. Post processing in Phonopy requires
stress information. Therefore, the file to be read must include the tprnfor and tstress keywords. The
input file of Quantum ESPRESSO for Phonopy can be set by using Quantum ESPRESSO Configure
Preset=Phonopy.

DIM
Specify the number of times the supercell repeats in the x, y, and z directions, separated by a space.

MP
Specify the reciprocal lattice when calculating Phono DOS and thermodynamic properties in
Phonopy, separated by a space.

ATOM_NAME
Specify the elements included in the unit cell separated by a space. It is automatically entered when
the input file is opened with the Open button.

Start button

Execute Phonopy based on the setting conditions, and create a super cell that is pre-processing.
At this time, the following files and folders are created.
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type Description

bat file
si.bat

Batch file to execute the preprocessing of
Phonopy.

sh file
si.sh

Shell script file for executing the preprocess-
ing of Phonopy.

si_ph_data folder
si_ph_data

Working folder.

The following files are generated in the working folder si_ph_data.

type Description

mesh.conf file
mesh.conf

Used to calculate density of states and ther-
modynamic properties in post processing of
Phonopy.

band.conf file
band.conf

Used when calculating band structure in
Phonopy post processing.

header file
header.in

Keyword information other than the
structure information specified in si.pwin is
described.

supercell file
supercell-*.in

Supercell information generated by
Phonopy is described in Quantum
ESPRESSO input file format.
Since multiple supercell patterns are
generated, * is replaced by numbers such as
1, 2, and so on.

tmp file
tmp-*.in

Combines header.in and supercell-*.in.

Cancel button
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Close Configure & Run window without doing anything.

Edit .conf File

In file mode, opens the conf file in a text editor. Use this if you want to edit the keywords set in the keyword
configuration screen.

Quantum ESPRESSO Continuous Execution

In File mode, Quantum ESPRESSO is executed on all super cells generated in the Keyword Setup and
Execution screen. If you use this menu, Quantum ESPRESSO will run in the local environment.

Run Phonopy

Performs Phonopy post-processing in file mode. At this time, the following files are created in the working
folder :file: si_ph_data .

type Description

sh file
phonopy.sh

Shell script to execute Phonopy post process-
ing

band.yaml file
band.yaml

Information on the band structure calculated
by post processing of Phonopy is output.

dos.dat
dos.dat

Information on the density of states calcu-
lated by post processing of Phonopy is out-
put.

thermal_properties.yaml file
thermal_properties.yaml

Information on thermodynamic properties
calculated by Phonopy post processing is
output.

Band Structure

Displays the band structure based on band.csv included in the working folder.
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Density od States

Displays the density of states based on toal_dos.csv included in the working folder.

Thermodynamic properties

Displays thermodynamic properties based on thermal_properties.csv included in the working folder.

6.17 Solid → OpenMX menu

Menu related to OpenMX

6.17.1 How to configure OpenMX

VPS and PAO files to be loaded in Winmostar’s workflow and keyword settings are loaded from the
path specified by the OPENMX_DATA_PATH environment variable in CygwinWM. In addition, for re-
mote jobs, the same version of OpenMX as OpenMX on CygwinWM must be installed on the remote
server, and the same environment variable OPENMX_DATA_PATH as on CygwinWM must be set on
the remote server. When using OpenMX3.8 or earlier with DFT_DATA13, copy omxprm_dft_data13.txt
from the wm_systemwmx folder to the UserPref folder as omxprm.txt, and the recommended settings for
DFT_DATA13 will be used by default for the VPS and PAO files. DFT_DATA13 is used by default for
VPS and PAO files.

6.17.2 Workflow configuration

Configure and run the OpenMX calculation flow in project mode.

Preset
Import and saves a preset of settings.

# of Jobs
Specifies the number of jobs.

Enable parameter/structure scan
This feature requires the purchase of an add-on. It makes it possible to run multiple calculations
where only certain parameters differ (parameter scan) or to run calculations with the same param-
eters for multiple structures (structure scan). Clicking on Config opens the configuration window
for the scan calculation. For a parameter scan, select %WM_SCAN1% for the Target Variable and
enter the parameters you want to set for %WM_SCAN1% in each line of the Values. Then enter
%WM_SCAN1% in the parameters you want to set in the workflow settings window or in the key-
word settings window. For structure scans, select %WM_STRUCT% for the Target Variable when
the animation appears in the molecule display area (e.g. by opening an SDF file). After the scan cal-
culation is finished, use File → Project → Scan Results Display to tabulate the calculation results.

Import
Load the settings output by Export. Click on the arrow to the right of the button to recall settings
previously used in the same project or on Winmostar.

Export
Outputs the configuration to a file.

OK
Runs a calculation or generates a file with the settings. See For project mode for more information.
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Details
Set detailed calculation conditions. The Configure will be launched.

Task
Specifies the type of calculation.

Settings

Energy MD.Type=nomd

Optimize(Atom) MD.Type=Opt

Optimize(Atom&Cell) MD.Type=RFC5

BOMD MD.Type=NVE

Charge
Specifies the charge for the entire system.

Spin
Set up spin polarization calculations.

K points
Specifies how the K point is calculated.

Pressure
Specify pressure.

Functional
Specifies a functional.

Properties
Calculate the physical properties checked in conjunction with the time of calculation.

Precision
Sets the calculation accuracy.
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Settings

Extra-low SCF.criterion=5e-6
MD.Opt.criterion=5e-3
KSpacing=0.44(metal) 0.63(nonmetal)
SCF.EnergyCutoff=80(metal) 80(nonmetal)

Low SCF.criterion=5e-7
MD.Opt.criterion=5e-4
KSpacing=0.44(metal) 0.63(nonmetal)
SCF.EnergyCutoff=120(metal) 120(nonmetal)

Medium SCF.criterion=1e-7
MD.Opt.criterion=2.5e-4
KSpacing=0.31(metal) 0.50(nonmetal)
SCF.EnergyCutoff=160(metal) 160(nonmetal)

High SCF.criterion=5e-8
MD.Opt.criterion=1.5e-4
KSpacing=0.25(metal) 0.44(nonmetal)
SCF.EnergyCutoff=300(metal) 200(nonmetal)

Extra-High SCF.criterion=2.5e-8
MD.Opt.criterion=5e-5
KSpacing=0.08(metal) 0.11(nonmetal)
SCF.EnergyCutoff=600(metal) 400(nonmetal)

Metal
Enable smearing. Set SCF.ElectronicTemperature to 800 if enabled, 300 if disabled, and also adjust
the contents of Precision (above).
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6.17.3 Configure

Set the OpenMX calculation conditions. Click the Run button to execute the calculation immediately after
setting, or the: guilabel:` OK` button to return to the main window. See Run for behavior when clicking
Run. The Reset button returns to the default state. Click the OK button to reflect the settings and return to
the main window. Cancel button closes the window without doing anything. When calling this function, if
the structure displayed in the main window can be changed to a primitive cell, Convert Lattice (Primitive-
Conventional) is automatically executed.

Preset
Select a settings preset.

Use MPI
Specify whether to perform parallel computation using MPI when running OpenMX. Enter the num-
ber of MPI processes in the horizontal column.

Use OpenMP
Specify whether to perform parallel computation using OpenMP when running OpenMX. Enter the
number of OpenMP threads in the horizontal column.

Basic tab
Restart

Set to On to take over the final state of the job being taken over.

Restart Directory
Specify the rst folder of the job to take over if other than Restart=Off.

XcType
Specify exchange correlation potential. You can specify “LDA”, “LSDA-CA”, “LSDA-PW”, or
“GvG-PBE”. Here, “LSDA-CA” is the Ceperley-Alder local spin density function, and “LSDA-
PW” is the Perdew-Wang local spin density function with zero density gradient in the GGA
format. “GGA-PBE” is a GGA functional proposed by Perdew et al.

EigenvalueSolver
Specify the calculation method for eigenvalue problems with “scf.EigenvalueSolver”. O (N)
divide-and-conquer method is “DC”, O (N) Krylov subspace method is “Krylov”, numerically
exact low-order scaling method is “ON2”, cluster calculation is “Cluster”, band calculation is
specified “Band”.

Specify Kgrid by spacing
Set Kgrid with the Spacing parameter ( Spacing parameter ).

Kgrid
In OpenMX, the first Brillouin zone in k-space is separated by an equidistant mesh. At that time,
when “Band” is specified with the “scf.EigenvalueSolver” keyword, the number of grids (n1,
n2, n3) for discretizing the first Brillouin zone in k-space must be specified with the “scf.Kgrid”
keyword. Specify as “n1 n2 n3” to discretize the reciprocal lattice vector in k space.

energycutoff
Specifies the cutoff energy that defines the integration grid spacing. This integration grid is
used to calculate matrix elements for the difference electron Coulomb potential and exchange
correlation potential, and to solve the Poisson equation using the Fast Fourier Transform (FFT).

System.Charge
Specifies the charge for the entire system.

ElectronicTemperature
Set the electronic temperature (K).
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MD.Type
Specifies the type of molecular dynamics calculation or structure optimization. Currently avail-
able options are: No MD (“ Nomd ”), structural optimization of atomic coordinates (“ Opt ”),
Structural optimization (“RFC5”), including unit cell flexibility, NVE Ensemble MD (“NVE>”),
NVT ensemble MD (“NVT_VS”) by speed scaling method, NVT ensemble MD (“NVT_NH”)
by the Nose-Hoover method.

Advanced(1) tab
criterion

Specify the convergence condition for the SCF calculation (in Hartree). The SCF iteration ends
when the condition dUele < scf.criterion is met. Here dUele is the absolute difference in band
energy between the current SCF iteration and the previous iteration. The default value is 1.0e-6
(Hartree units).

maxIter
Sets the maximum number of SCF iterations. The SCF iteration loop ends with the number of
times specified by this keyword even if the convergence condition is not met.

Mixing.Type
Specify the electron density mixing method to generate the electron density (or density matrix)
that is input to the next iteration step of the SCF calculation. Simple mixing method (“Simple”),
Guaranteed-Reduction Pulay method (“GR-Pulay”), RMM-DIIS method (“RM-DIIS”), Kerker
method (“Kerker”), or RMM-DIISK method (“RMM- DIISK”) or RMM-DIISH method (“RM-
DIISH”) can be specified. OpenMX’s simple mixing method has been improved to reference
the convergence history to speed up the convergence. When using “GR-Pulay”, “RMM-DIIS”,
“Kerker” or “RMM-DIISK”, the SCF calculation can be accelerated by paying attention to the
following points. Some convergence is required before mixing begins in a way that conforms to
the Pulay method. Therefore, use a slightly larger “scf.Mixing.StartPulay” value. A good value
for “scf.Mixing.StartPulay” is 10-30. For metal systems, use a high “scf.ElectronicTemperature”
value. When “scf.ElectronicTemperature” is small, numerically unstable behavior is often seen.
Increase the value of “scf.Mixing.History”. In most cases, “scf.Mixing.History = 30” is a rea-
sonable value. Among the mixing methods described above, “RMM-DIISK” is the most robust.

Init.Mixing.Weight
Specify the initial mixing ratio used in the Simple, GR-Pulay, RMM-DIIS, Kerker, RMM-
DIISK, and RMM-DIISH methods. Valid range is 0 <Init.Mixing.Weight < 1

Min.Mixing.Weight
Specifies the lower limit of the mixing ratio in simple and Kerker mixing methods.

Max.Mixing.Weight
Specifies the upper limit of the mixing ratio in simple and Kerker mixing methods.

Mixing.History
In the GR-Pulay method, RMM-DIIS method, Kerker method, RMM-DIISK method and RMM-
DIISH method, the input electron density (Hamirutonian) in the next iteration step of SCF
is estimated based on the electron density of the past SCF iteration (Hamiltonian). ). The
“scf.Mixing.History” keyword specifies the number of past SCF iteration steps used for this es-
timation. For example, if “Mixing.History” is set to 3, the 6th SCF iteration takes into account
the 5th, 4th, and 3rd step electron density in the past.

Mixing.StartPulay
Specify the SCF step that starts the GR-Pulay, RMM-DIIS, Kerker, RMM-DIISK, and RMM-
DIISH methods. SCF steps up to the start of these methods use simple or Kerker mixing.

lapack.dste
Select the LAPACK routine.

6.17. Solid → OpenMX menu 233



Winmostar™ User Manual, Release 11.13.0

ProExpn.VNA
Set the neutral atom potential VNA to” ON “when expanding with the projection operator, other-
wise set to” OFF “. When set to” OFF “, the matrix elements of the VNA potential are calculated
using a discrete grid in real space.

HoppingRanges
Defines the radius (Å) of the sphere centered on each atom. In the DC method and the O (N)
Krylov subspace method, a cluster is formed by selecting the atoms contained in this sphere.

KrylovH.order
Specifies the Krylov subspace dimensions for the Hamiltonian of each cut cluster.

KrylovS.order
If you set” Exact.Inverse.S = off “in the keyword below, the inverse matrix of the overlap integral
is approximated using the Krylov subspace method. At this time, specify the dimension of the
Krylov subspace method of the overlap matrix for each cut cluster.

Exact.Inverse.S
When set to” on “, the inverse of the overlap matrix of each clipped cluster is evaluated strictly.
Please refer to the keyword” KrylovS.order “above when setting to” off “.

Recalc.Buffer
If set to” on “, the buffer matrix is recalculated for each SCF iteration. If” off “, the buffer matrix
is calculated in the first SCF step and fixed in subsequent SCF iterations.

Expand.Core
When set to” on “, the core region consists of atoms in a sphere with a radius of 1.2×rmin. Where
rminis the distance between the central atom and the nearest neighbor. This core region defines
the set of vectors used in the first step when generating the Krylov subspace. If” off “, the central
atom is considered the core region.

Advanced(2) tab
maxIter

Specify the maximum number of iterations for MD and structural optimization calculations.

Opt.criterion
If you choose a structure optimization method with the” Type “keyword, set the convergence
condition (Hartree/Bohr) with the keyword” Opt.criterion “. Structural optimization ends when
the maximum absolute value of the force applied to the atom is smaller than the value specified
here.

Opt.DIIS.History
When performing structure optimization using “DIIS”, “EF”, or “RF”, the “Opt.DIIS.History”
keyword is used to specify the past step number to be referred to for structure optimization.

Opt.StartDIIS
Specify the step to start structural optimization with “DIIS”, “EF”, and “RF” with the
“Opt.StartDIIS” keyword. The steepest descent method is used in the previous steps before
starting the DIIS-type structural optimization.

Opt.EveryDIIS
Specifies how often to switch between structural optimization by “DIIS”, “EF”, or “RF”
and structural optimization by the steepest descent method; this setting is ignored when
MD.Type=Opt.

Spin/DFT+U tab
SpinPolarization

Specifies the non-spin or spin polarization of the electron system. Specify “ON” to perform spin
polarization calculations and “OFF” to perform non-spin polarization calculations. In addition
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to the two aforementioned options, specify the option “NC” to perform a non-colinear DFT
calculation. For spin polarization calculations, the initial spin density is set according to the
spin density (interpreted as the difference between the number of Up and Down spin electrons)
set for each atom in the main window. The spin density can be set with Charge/Spin Density
and so on.

SpinOrbit.Coupling
Specifies spin-orbit interaction.

Constraint.NC.Spin
Specifies whether to perform constrained DFT calculations for non-colinear spin orientations.

Constraint.NC.Spin.V
Specifies the strength of the constraint in constrained DFT calculations for noncollinear spin
orientations.

Hubbard.U
Set to“ ON ”for LDA + U and GGA + U calculations.

Hubbard.Occupation
In the LDA + U method, you can choose from three occupancy operators: “onsite”, “full” and
“dual”.

Restart.Spin.Angle.Theta
Specify the Euler angles (theta, phi) of the spin orientation needed to calculate the magnetic
anisotropy energy by the second variational method.

Restart.Spin.Angle.Phi
Specify the Euler angles (theta, phi) of the spin orientation needed to calculate the magnetic
anisotropy energy by the second variational method.

MD tab
TimeStep

Specify time step (fs).

Applied.Pressure
Specify pressure (GPa).

NH.Mass.HeatBath
If you select “NVT_NH” for the “Type” keyword, this keyword sets the mass of the heat bath.
Units are unified atomic mass units (units where the mass of the main isotope of a carbon atom
is 12.0).

TempControl
Specify the temperature of atomic motion in MD and NVT ensembles. If” NVT_VS “is selected,
the temperature of atomic motion can be controlled as shown in the example below.

<MD.TempControl
3
100 2 1000.0 0.0
400 10 700.0 0.4
700 40 500.0 0.7

MD.TempControl>

The description starts with “<MD.TempControl” and ends with “MD.TempControl>” .The first
number “3” indicates the number of lines for the temperature specification that follows. There
are three lines in the example. The first column of the following row indicates the number of MD
steps, and the second column specifies the MD step interval for speed scaling. In the example,
speed scaling is performed every 2 steps up to the 100th step, every 10 steps between 100 and
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400 steps, and every 40 steps between 400 and 700 steps. Columns 3 and 4 specify temperature
(K) and scaling parameter alpha, respectively. For details, refer to the “Molecular Dynamics”
chapter. On the other hand, for NVT_NH, the temperature of atomic motion can be controlled
with the following description.

<MD.TempControl
4
1 1000.0
100 1000.0
400 700.0
700 600.0

MD.TempControl>

The description starts with “<MD.TempControl” and ends with “MD.TempControl>”. The first
number “4” refers to the number of lines that follow the temperature specification. In this exam-
ple, there are 4 lines. The first and second columns of the subsequent rows specify the number
of MD steps and the temperature of the atomic motion, respectively. The temperature between
the specified MD steps is linearly complemented.

Others tab
Enter any OpenMX parameter.

Preview tab
A preview of the configuration keywords will be displayed.

Options tab
level.of.stdout

Specify the level of output information to the standard output. If” 0 “is specified, the minimum
information is output. If “1”, additional information is output in addition to the minimum output.
“2” is an option for developers.

level.of.fileout
Specify the level of output information to the output file. If “0” is specified, the minimum infor-
mation is output (no Gaussian cube and grid file output). “1” is the standard output information
level. If “2”, additional information is output in addition to the standard output.

Atoms.Coord.Unit
Specify the unit of the atomic coordinate.

Edit and confirm Atoms.SpeciesAndCoordinates
Edit Atoms.SpeciesAndCoordinates directly.

Properties tab
dispersion

Set to“ ON ”to evaluate band dispersion.

Use default path
Sets the path of k points for evaluating band variance based on the automatically determined
Bravais lattice type.

DOS.fileout
Set to ON to evaluate the total density of states (DOS) and projected partial density of states
(PDOS).

Erange
Specify the energy range (lower limit and upper limit) for DOS calculation separated by single-
byte spaces.
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Kgrid
Specify (n1, n2, n3) grid points to discretize the first Brillouin zone for DOS calculations.

MO.fileout
If you want to output molecular orbitals to a file, specify “ON”.

num_HOMOs
Specify the number of highest occupied molecular orbitals (HOMO) to output.

num_LUMOs
Specify the number of lowest unoccupied molecular orbitals (LUMOs) to output.

Nkpoint
If “fileout”is set to “ON” and “EigenvalueSolver” in the SCF tab is set to “Band”, specify the
number of k points to output MO with the “Nkpoint” keyword.

Species tab
Atom

Specify the name of the atomic species.

Basis
Specify the number of primitive trajectories and the number of reduced trajectories.

PAO
Specify the file name without extension of pseudo-atomic base orbit.

VPS
Specify file name without pseudopotential extension.

Reset
Reset settings.

Import
Loads a configuration file.

Export
Outputs a configuration file.
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6.17.4 Run

Execute OpenMX The following files are generated upon execution. As an example, the file/folder name
when the input file is: file:` dia.mxin` and System.Name is wm is shown.

Type Description

bat file
dia.bat

A batch file for running OpenMX. Run
dia.sh via CygwinWM.

sh file
dia.sh

A shell script file for running OpenMX.

log file
dia.log

log file of dia.sh

mxout file
dia.mxout

Calculation output file. A copy of wm.out in
the working folder.

Working folder
dia_mx_data\

Working folder

The following files are generated in the working folder. Only the main files are shown here.
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Type Description

tmp.dat File to specify calculation conditions. A
copy of dia.mxin.

tmp.std This is a redirected file of OpenMX
standard output.

wm.out History of SCF calculation and structure
optimization, Mulliken charge, total energy
and dipole moment are preserved.

wm.xyz The final geometric structure obtained by
MD or structural optimization is preserved.

wm.bulk.xyz “scf.EigenvalueSolver = Band” will output
the atomic coordinates including the copied
cell atoms.

wm.md Atomic coordinates for each MD step are
saved.

wm.md2 Atomic coordinates in the last MD step are
saved. An atom is specified using the
specified atomic species symbol.

wm.ene Calculated values for each MD step are
saved. The contents of each saved value can
be checked in the“ iterout.c ”routine.

wm.Band Band dispersion data file is saved.

wm.Dos.val Eigenvalue data file for calculating density
of states.

wm.Dos.vec Eigenvector data file for calculating density
of states.

wm.tden.cube The total electron density in Gaussian cube
format is stored.

wm.sden.cube The spin electron density is preserved when
spin polarization calculations are performed
using “LSDA-CA”, “LSDA-PW”,
“GGA-PBE”.

wm.dden.cube The difference electron density calculated
based on the superposition of the electron
density of the isolated atoms of the
constituent atoms is stored.

wm.v0.cube Kohn-Sham potential is preserved except
for non-local potential of upspin.

wm.v1.cube Kohn-Sham potential is excluded except for
non-local potential of downspin in spin
polarization calculations.

wm.vhart.cube The difference electron Hartree potential
resulting from the difference electron
density is preserved.

6.17. Solid → OpenMX menu 239



Winmostar™ User Manual, Release 11.13.0

Hint: **Working folder**

• A working folder is a folder with the suffix of the name of the file opened in the main
window.

– ** The suffix depends on the type of solver. **

– For example, for Gromacs, if the file opened in the main window is aaa.gro and the
suffix is _gmx_tmp, the name of the working folder is aaa_gmx_tmp.

• It must be on the same level as the file opened in the main window.

• Although processing continues in the working folder with the same name for continued
jobs, by default, a backup of the working directory of the previous job is created immedi-
ately before the continuous job is executed.

– The name of the backup will be the lowest number in the range where there are no
duplicate names. For example, if your working folder is aaa_gmx_tmp, it will be
aaa_gmx_tmp1.

– ** Unnumbered directories are always up to date. **

Job is run through Winmostar Job Manager.

6.17.5 Open Log File (mxout)

Open the log file with a text editor.

6.17.6 Show log excerpts

Displays excerpts of key information from the log file.

6.17.7 Animation (md)

Create and display animations such as structure optimization and molecular dynamics calculations from
md file information. Please refer to Animation operation area for how to operate the animation. From
the animation operation area, you can calculate the radial distribution function, self-diffusion coefficient,
mean-square displacement, and displacement of each atom.

6.17.8 energy change

SCF energy change (std)

Select the std file and display a graph of the residuals. Please refer to How to operate the graph for how to
operate the graph drawing area.
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6.17.9 Analyses

Density of of States

Specify the working folder ( dia_mx_data\) and display the density of states. Calculation must be com-
pleted with Dos.fileout = on Please refer to How to operate the graph for how to operate the graph drawing
area.

Partial DOS

Specify the working folder ( dia_mx_data\) and display the partial density of states (PDOS). Calculation
must be completed with Dos.fileout = on Please refer to How to operate the graph for how to operate the
graph drawing area.

Band Structure

Specify the working folder (dia_mx_data\) and display the band structure. Calculation must be com-
pleted with Band.dispersion=on

Density/Spin/Energy Distribution

Specify the cube file and display the electron density, spin density, and energy distribution. See Surface
Setup / Cubgen window for how to operate subwindows.

Fermi Surface

Specify the working folder ( dia_mx_data\) and display the fermi surface. Use FermiSurfer
<https://mitsuaki1987.github.io/fermisurfer/index_ja.html> to display the Fermi surface. In # of K Points,
specify the number of k-point divisions when calculating bands, and press the Calc button to display the
Fermi surface.

6.18 Solid → FDMNES menu

It is a menu related to FDMNES. The method of installing FDMNES is described in Installing Winmostar
and solvers.

6.18.1 Configure

Set the calculation condition of FDMNES. To set up the calculations immediately after setting Run button,
once to return to the main window please press OK button. See Run for behavior when clicking Run.
Return to the default state with Reset button.

Target Atom
Specify the atom (Absorber) of the XANES spectrum measurement target. Clicking the Set Atom
button will set the atom with the marker in the main window. .

Edge
Select the electron shell of the XANES spectrum you want to obtain.
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Range
Specify the range of the XANES spectrum you want to acquire.

Cluster Radius
Specify the radius of the cluster created by expanding the simulation cell (supercell) inside FDMNES.
The larger this value is, the closer the bulk state is, but the processing speed decreases.

Method
Select the calculation method.

Convolution
Obtain convoluted broadened spectrum with Lorentz function.

Calc LDOS
The local density of states (LDOS) is output into a file whose file name suffix is _sd*.txt.

Definition for Energy
Specify the horizontal axis (energy) definition when displaying XANES spectrum.

6.18.2 Run

Run FDMNES. Following file will be generated with execution. (Only major files are shown) As an ex-
ample, the file/folder name when the input file is cu.fdmnes is also shown.

type Description

log file
cu.log

Calculation log file.

bat file
cu.bat

It is a batch file for running FDMNES.

conv file
cu_conv.txt

XANES This is a text file containing data
such as spectra.

The job is run through Winmostar Job Manager.

6.18.3 Opem Log File (log)

Open the log file with a text editor.
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6.18.4 Analyses

XANES Spectrum

Select the conv file ( *_conv.txt ) and display the XANES spectrum.

6.19 Solids → VASP menu

Menu about VASP.

6.19.1 How to set up VASP

For VASP execution from Winmostar, only remote jobs are supported. In the template script
for the remote job, pass the PATH environment variable through the VASP binaries (vasp_std,
vasp_gam, vasp_ncl, etc.) and specify the PATH_POTCAR_PAW_LDA, PATH_POTCAR_PAW_GGA,
PATH_POTCAR_PAW_PBE variables to specify the directories in which the LDA, GGA, and PBE POT-
CAR files are grouped, respectively. The VASP binary to be used for the actual calculation can be selected
in the Details of the VASP Workflow Configuration or in the VASP Executable of the Basic tab of the
VASP Keyword Configuration. If you want to use different executables on Winmostar, you must pass
them through the PATH with their aliases (vasp_gam, vasp_std, vasp_ncl, etc.). vasp_std is implicit in the
Test Connection function for remote jobs. It is assumed that files are placed under the directories speci-
fied by PATH_POTCAR_PAW_LDA, PATH_POTCAR_PAW_GGA, and PATH_POTCAR_PAW_PBE in
a directory structure named (element name)/POTCAR. If only POTCAR.Z is placed under the directory
with the element name, POTCAR will be automatically extracted.

6.19.2 Workflow Setup

Configures and executes the OpenMX calculation flow in project mode.

Preset
Recalls and saves a preset of settings.

# of Jobs
Specify the number of jobs.

Enable parameter/structure scan
This feature requires the purchase of an add-on. It is possible to run multiple calculations where only
certain parameters differ (parameter scan), or to run calculations on multiple structures with the same
parameters (structure scan). Click Config to open the configuration window for the scan calculation.
For a parameter scan, select %WM_SCAN1% for the Target Variable and enter the parameters you
wish to set for %WM_SCAN1% in each row of the Values. Then, enter %WM_SCAN1% in the
parameters you want to set in the Workflow Settings window or Keyword Settings window. For
structure scans, select %WM_STRUCT% for the Target Variable when the animation appears in the
molecule display area (e.g., with an SDF file open). After the scan calculation is finished, use File
→ Project → Parameter/Structure Scan Result to tabulate the calculation results.

Import
Loads the settings output by Export. Click the arrow to the right of the button to recall settings used
in the past on the same project or Winmostar.

Export
Outputs the configuration to a file.
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OK
Runs a calculation or generates a file with your settings. See For project mode for details.

Details
Set up detailed calculation conditions. Configure will be launched.

Task
Specifies the type of calculation.

Settings

Energy IBRION=-1
ISIF=0
NSW=0

Optimize(Atom) IBRION=1
ISIF=0
NSW=50

Optimize(Atom&Cell) IBRION=1
ISIF=3
NSW=50

BOMD IBRION=0
ISIF=0
NSW=50

Functional
Select the pseudopotential and functional to use.

Cutoff energy
Specify the value if you want to explicitly set the cutoff energy.

Manually specify cutoff energy
explicitly sets the cutoff energy.

Precision
Sets the calculation accuracy.
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Settings

Medium PREC=Normal

High PREC=Accurate

6.19.3 Keyword Settings

Set the calculation conditions for VASP. After setting, press the Run button to run the calculation imme-
diately, or press the OK button to return to the main window once you are done. :guilabel:See Run for
behavior when Run is clicked. Reset button to return to the default state. The OK button applies the set-
tings and returns you to the main window. The Cancel button closes the Window without doing anything.
When invoking this function, if the structure displayed in the main window can be converted to a primitive
cell, then Convert Lattice (Primitive-Conventional) will be executed automatically.

Basic tab
VASP Executable

Specifies the name of the VASP executable binary to be used in the calculation.

PREC
Batch setting for calculation accuracy.

NBANDS
Specifies the number of KS orbitals to use in the calculation.

K-point
In the case of “by KSPACING and KGAMMA”, KSPACING and KGAMMA keywords are used
to set the K points. If “by KPOINTS file” then the KPOINTS file is used to set the K points.

KSPACING
Specifies the density of the K point.

KGAMMA
Specifies whether point K contains the Gamma point.

KPOINTS file
Enter the information to be included in the KPOINTS file.

ISYM
Specifies symmetry handling.

ENCUT
Specifies the cutoff energy of the wave function.

NELECT
Specify the number of electrons.

ISMEAR
Specify smearing method.
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IBRION
Specify the mode of calculation. (SCF calculation, MD calculation, structural optimization
calculation, etc.)

ISIF
Specify whether force and pressure calculations, atomic positions, and cells should be updated.

Advanced tab
EDIFF

Specify the censoring error for SCF calculations.

EDIFFG
Specifies the censoring error for structural optimization calculations.

NELM
Specify the maximum number of iterations for SCF calculation.

NELMIN
Specify the minimum number of iterations for SCF calculation.

NSW
Specifies the maximum number of iterations for structural optimization calculations.

TIME
Specifies time increments in some algorithms.

ALGO
Specify algorithm for SCF calculation.

NSIM
Specify the number of bands to be optimized simultaneously when using the RMM-DIIS
method.

INIWAV
Specifies how the initial value of the orbit is generated when ISTART=0.

SIGMA
Specify smearing width.

IVDW
Specifies the method of dispersion force correction.

GGA
Specify LDA or GGA function.

LHFCALC
Specify the range-separation parameter for the strict-exchange term.

HFSCREEN
Specify the range-separation parameter for the strict-exchange term.

PRECFOCK
Specifies the FFT grid to be used in the calculation of the exact exchange term.

VOSKOWN
Specifies whether or not Vosko-Wilk-Nusair interpolation is used.

ADDGRID
Specify if you want to use an additional grid for Augmentation Charge.

LASPH
Specifies whether to include non-spherical components related to the electron density gradient
in the PAW sphere.
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LREAL
Specifies whether the projection operator is evaluated in real or inverse space.

Spin tab
ISPIN

Specify for spin polarization calculation.

MAGMOM
Specifies the initial spin of each atom.

Output tab
NWRITE

Adjusts the amount of information output to the OUTCAR file.

LWAVE
Specify whether to output wave function information in a WAVECAR file at the end of the
calculation.

LCHARG
Specify whether charge density information should be output to the CHGCAR file at the end of
the calculation.

LPARD
Specifies whether to evaluate partial charge densities resolved at the band or k points.

IBAND
Specifies the band used to evaluate partial charges.

EINT
Specifies the energy interval at which partial charges are evaluated.

LORBIT
Specifies the projection method and whether to output to a PROCAR or PROOUT file.

LORBMOM
Specify whether or not to output orbit moments.

LVTOT
Specify whether all potentials should be output to the LOCPOT file.

LVHAR
Specify whether Vionic(r)+Vhartree should be output to the LOCPOT file.

LELF
Specify whether to output ELFCAR files.

EMIN
Specifies the lower limit of the DOS energy range for output.

EMAX
Specifies the upper limit of the DOS energy range for output.

NEDOS
Specifies the number of grids when evaluating DOS.

LEPSILON
Specify whether to calculate the dielectric matrix, piezoelectric tensor, or Born effective charge
from the DFPT calculation.

MD tab
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MDALGO
Specifies the time evolution algorithm for MD calculations.

POTIM
Specify the time increment for MD calculations or the update step width for structural optimiza-
tion calculations.

TEBEG
Specify default temperature.

TEEND
Specify final setpoint temperature.

SMASS
Specify the method of temperature control or the mass parameters of the heat bath.

LANGEVIN_GAMMA
Specifies friction parameters for the Parrinello-Rahman pressure bath.

LANGEVIN_GAMMA_L
Specify friction parameters for Parrinello-Rahman pressure bath.

PMASS
Specifies the mass parameter of the Parrinello-Rahman pressure bath.

MLFF tab
ML_LMLFF

Specify whether to use a machine learning force field.

ML_ISTART
Specify whether to train and predict machine learning force fields, etc.

ML_LEATOM
Specifies whether to output energy from the machine learning force field.

ML_MB
Specifies the maximum number of local reference placements in the machine learning force
field.

ML_CTIFOR
Specifies the threshold in Bayesian error estimation of forces obtained from machine learning
force fields.

ML_IWEIGHT
Specifies how to set the force, energy, and pressure weightings when training machine learning
force fields.

ML_WTIFOR
Specifies the force weighting when training machine learning force fields.

ML_WTSIF
Specifies the pressure weighting when training machine learning force fields.

ML_WTOTEN
Specifies the energy weighting for learning machine learning force fields.

Others tab
Other settings for INCAR

Enter any other parameters you wish to include in the INCAR file.

Preview tab
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INCAR
This is a preview of the INCAR file that will be generated with the current configuration.

Pseudopotential tab
Pseudopotential

Specifies the type of pseudopotential to use.

Options tab
Dump all files for remote

Outputs files required for job execution in a Linux environment. The output file is the same as
the file generated by the remote job submission function.

Restore Working Folder
Click to restore the working folder to its pre-execution state, for example, when a continuation
job terminates abnormally.

6.19.4 Run

Runs VASP. Local jobs are not supported, so Submit Remote Job will be launched in file mode. The
following files will be generated upon execution. As an example, the file/folder names when the input file
is test.poscar are listed.

type Description

sh file
test.sh

This is a shell script file to run VASP. It does
not contain any job-dependent settings.

conf.sh file
test_conf.sh

This is the configuration file that is read by
the shell script to run the above VASP. It con-
tains a collection of job-dependent settings.

outcar file
test.outcar

Log file. This is a copy of OUTCAR in the
working folder.

Working folder
test_vasp_data\

Working folder.

The following files are generated in the working folder. Only the major files are shown here.
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type Description

INCAR File specifying calculation conditions.

KPOINTS.ori This is the configuration file for point K.

OUTCAR Logfile.

Hint: **working folder**

• A working folder is a folder whose name is the name of the file opened in the main window
plus a suffix.

– **Suffixes vary depending on the type of solver. **

– For example, in Gromacs, if the file open in the main window is aaa.gro with the
suffix _gmx_tmp, the working folder is named aaa_gmx_tmp.

• Must be placed in the same level as the file that is open in the main window.

• Processing flows in the working folder of the same name even for continuation jobs, but
by default, a backup of the working folder of the previous job is created just before the
continuation job is executed.

– The name of the backup will be the lowest numbered to the extent that there are no
duplicate names. For example, if your working folder is aaa_gmx_tmp, it will be
aaa_gmx_tmp1.

– **Unnnnumbered directories are always up-to-date. **

Job will be run through Winmostar Job Manager.

6.19.5 Show Log (OUTCAR)

Open the log file in a text editor.

6.19.6 Animation(OSZICAR)

Create and display animations for structural optimization, molecular dynamics calculations, etc. from
information in OSZICAR files. See Animation operation area for animation display operations. From
the animation operation area you can calculate the radial distribution function, self-diffusion coefficient,
mean-square displacement, displacement of each atom, etc.
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6.19.7 Energy Change

SCF energy change (XDATCAR)

Select a log file to view a graph of energy changes during SCF calculations. See How to operate the graph
for instructions on manipulating the chart drawing area.

6.20 Tool menu

6.20.1 Preferences

Open the Preferences window. For details, see Tools → Preferences menu.

6.20.2 Save/Delete Fragment

Save Fragment

Same as Save Fragment.

Delete Fragment

Same as Delete Fragment.

6.20.3 Enter a structural formula

Same as Structural Formula.

6.20.4 Conformation Search (Balloon)

Conformation search with Balloon. Click the Search button to start the process. In the Options field,
enter the options for the Balloon. An intermediate file will be generated in the working folder named
*_balloon_tmp. This feature works as follows

1. Conformation search without GA for the initial structure Ballon options: -v 1 -c 10 –noGA -i 300
–randomSeed 51277

2. For the lowest energy structure of 1, a conformation search using GA Ballon options: -v 1 -b -k -c
400 –full -R 0.25 –nGene 20 –random 51277

3. Conformation search without GA for 4 structures with low energy of 2 Ballon options: -v 1 -c 25
–noGA -i 300 –randomSeed 51277

4. Select 100 from the low energy structures of 3

5. If Cluster similar structures is checked, cluster 100 structures and aggregate similar structures below
RMSD tolerance and display them in Winmostar (However, due to the simplicity of clustering, the
candidates may not be reduced efficiently)

Warning: This function is affected by the join order.
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6.20.5 Point Group Analysis

Determine point group symmetry of modeled molecules. This function is mainly used for the following
purposes.

(1) Perform point cloud analysis of modeled molecules.

(2) Based on the determined point cloud information, distortion of the molecular structure is resolved.
(Symmetrization)

(3) Conversion of symmetric unit <=> asymmetric unit can be performed.

For organic molecules that do not contain metals, it is easier for point cloud analysis to succeed if cleaned
structures are used. We analyze and visualize point cloud analysis using the following functions.

Analyze
Start point cloud analysis.

Accuracy
Specify analysis accuracy of point cloud analysis. Increasing the accuracy will make the judgment
of symmetry severe, and lowering will make the judgment sweeter.

Shoenflies
The symmetry of the molecule is indicated by the Shoenflies symbol.

i
Point symmetry elements are listed.

On the Axis
The rotationally symmetric elements are listed.

Sn Axis
Recurrence symmetry elements are listed.

Mirror
Mirror symmetry elements are listed.

Select
All symmetric elements listed are selected and displayed on the graphic screen.

Deselect
All symmetric elements listed will be deselected and will be hidden on the graphic screen.

Select All
All symmetric elements are selected and displayed on the graphic screen.

Deselect All
All symmetric elements are deselected and hidden on the graphic screen.

After completing point group analysis, symmetrization of molecular structure and switching between
asymmetric unit and symmetric unit becomes possible by the following operation. However, it is lim-
ited only to point group symmetry other than C1.

Symmetrize
Based on the predicted point cloud information, we eliminate the distortion of the structure (deviation
from perfect symmetric structure).

Show
When Symmetric Unit is checked, symmetric unit is displayed. When Asymmetric Unit is checked,
only asymmetric unit is displayed. (If you go to the GAMESS Configure with only the asymmetric
unit displayed, you can inherit the point cloud information and create the input.)
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Text area in the lower right
Displays the coordinate information of the molecule in XYZ format.

6.20.6 Molecular Surface Area & Volume

Calculate the molecular surface area, volume and oval shape. We use the program of Mr. Nagao of
Hakodate National College of Technology to calculate the surface area and volume of the molecule. (Teruo
Nagao, Improvement of molecular surface area and volume calculation program, bulletin of Hakodate
National College of Technology, No. 27, p 111 - 120, 1993.)

(1) van der Waals Moleuclar Surface (VMS): Surface when atoms are replaced by spheres of van der
Waals radius

(2) Accessible Molecular Surface: Surface of the solvent molecule when traced with a solvent molecule
around the VMS surface

(3) Molecular Surface: Contact surface and reentrant surface traced by solvent molecules around VMS
surface (also called Solvent-excluded surface or Connolly surface)

Molecular volume is the volume of the interior set of spheres of vdw radius centered at each atom.
Ovality (Ovality) is calculated by the following formula. Molecule surface/Minimum surface area =
S/4pi(3V/4pi)**(2/3) Minimum surface area = 4pi(3V/4pi)**(2/3) (surface area of a true sphere having
the same molecular volume)

6.20.7 Aspect Ratio

Calculate the aspect ratio of a molecule. The aspect ratio is defined as the ratio L/D of the length L to the
diameter D of the cylinder of the smallest diameter that encloses all spheres of vdw radius centered at each
atom.

6.20.8 Radius of Gyration

Calculates the radius of inertia of a molecule. The calculated radius of inertia value is saved to a file in the
background. The name of the saved file can be toggled with Tools → Preferences menu.

6.20.9 Dipole Moment

When there is point charge information in the displayed molecular structure, the dipole moment calculated
from the point charge is calculated and displayed. In the case of multiple types of charges, the dipole
moment is calculated and displayed for each type of charge.

6.20.10 Sterimol Parameters

Calculate the Sterimol parameter for the substructure selected for the group on the main window.Click
Calculate button to start the calculation.
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6.20.11 Unit Normal Vector of Ring Structure

This function displays unit normal vectors of ring structures, which are necessary for NICS calculations,
etc. Please group-select a target ring structure then call this function. For example, in the case of a benzene
ring, the six carbons that make up the benzene ring are group-selected. The output vector is calculated as
follows

1. Creates a list of two atoms with covalent bond among the grouped atoms.

2. For each two atoms in the list created in 1, compute a vector perpendicular to the plane stretched by
those two atoms and the three points of the geometric center of the group selection.

3. The average of the vectors calculated in 2 is finally displayed in this function.

6.20.12 Voronoi polyhedral volume

List the Voronoi polyhedron volume for each atom.

6.20.13 Job Manager

Start Winmostar Job Manager that manages local jobs.

6.20.14 Submit Remote Job

Open a window to run and manage remote jobs in file mode. See Each function of the Submit Remote Job
window for details.

6.20.15 emote Server

Operate remote servers for each profile in project mode.

Configure

Configure profile settings.

6.20.16 Cygwin

Start the terminal window (terminal) of CygwinWM.

6.20.17 Log Viewer

Displays the end of a text file (such as a solver’s log file) that is updated in real time. Drag and drop text
files into the window.
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6.20.18 Unit Converter

Opens a unit conversion tool specialized for atomic and molecular systems.

6.20.19 Search String

It searches character strings in various log files and outputs the hit line to Excel or text file.

6.20.20 Superimpose Molecules

Multiple molecules are superimposed and displayed. It is useful for checking the similarity of multiple
molecular structures.

1. Import from Main Window or Import from File button to load the molecular structure you want to
display and add it to the list of Structures. You can also drag and drop to load them directly from
Explorer.

2. In the Structures list, click on the filename you want to highlight and the molecule will be highlighted
in blue.

3. Delete selected molecule with Delete button, Reset button to delete all molecules.

4. You can align the orientation of each molecule with Rotate to align 3 atoms button. Clicking on 3
atoms for each molecule specifies the first point as the origin, the second point on the X axis, and the
third point on the xy plane.

5. If the molecular structures are close, adjust the X , Y , and Z values in the Offset to shift the overlapping
plane.

6. If there are only two molecules in the list of Structures, the RMS-Fit All button will automatically
rotate the molecules so that the RMS (root mean square of the coordinates) between the two molecules
is minimized. Also, the RMS will show the RMS between the two molecules.

7. You can display it with Winmostar Viewer by pressing Open Viewer button.

6.20.21 Aggregate multiple files into SDF format

Aggregate and save multiple files into a single SDF file. Aggregate all files contained within the selected
folder. Only files that can be opened with Open File are read. (Judged by the extension.)

6.20.22 Animation

Switch to animation

Using this function while no animation is displayed will switch to one frame of animation being displayed.
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Discard animation

Using this function while animation is displayed will leave only the current frame and switch to no anima-
tion being displayed.

Add a frame

Duplicates the current frame and adds a new frame to the animation.

Delete current frame

Delete current frame for animation

Separate each molecule into different frames

Separates each molecule into different frames, useful for counterpoise calculations, etc.

6.20.23 Structure scan

Generate and animate a structure with slightly different coordinates and cell sizes.

Transform cell only along the selected axis
Stretch or compress the cell in the direction of the axis selected in Axis. If Variable is Length change,
the value is the incremental length (in angstroms); if it is Normal strain, the value is the strain. A value
of 0 in either case means that the cell size is the same as the original cell size. If Change Atomic
Position with keeping fractional coordinates is checked, the coordinates of each atom will change
with keeping the fractional coordinates fixed, if unchecked, the coordinates of each coordinate will
remain unchanged.

Transform cell by shear strain
Shear strain on cell.

Transform cell similarly
Deforms the cell in a similar manner. Specify the strain in each axis as a value (e.g., a value of
0.1 will multiply the volume by (1 + 0.1)3 = 1.331, a value of -0.1 will multiply the volume by
(1 − 0.1)3 = 0.729). The coordinates of each atom vary while the fractional coordinates are fixed.
Use this when you want to calculate volume strain.

Translate group along selected axis/vector
Translates the coordinates of the selected group in the direction of the axis selected by Axis. The
value is the distance to translate (in angstroms).

Min
Specify the minimum value.

Max
The maximum value of the Max value is displayed. The Max is automatically set from Min, Interval
and # of steps and cannot be specified directly.

Interval
Specifies the interval between values.

# of steps
Specifies the number of values.
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Show Preview
You can see a preview of the animation with your settings.

OK
Generate animation.

6.21 Tools → Preferences menu

We make various settings of Winmostar.

Basic Tab
Language

Select a language.

License code
Set the license code.

Internal UNIX environment
Choose whether to use cygwin for internal UNIX environment or Windows Subsystem for Linux
(Bash on Ubuntu on Windows).

Use internal editor at [File]-[Open in Text Editor]
If checked, use Edit-> Direct Editor function up to V8 when you click File → Open in Text
Editor. If not, use the program set in Editor with Preferences → Program Path.

Use old function adopted up to V8 for unzip
In the remote job, specify the code used to get and unzip the zip file of the working folder from
the remote server. Old-style code generates errors when decompressing huge files (hundreds of
MB or more).

Use old format adopted up to V9 when saving xyz file
When saving in xyz file format, save as xyz file without header which was the default before V9.

Output cell shape to save Xyz file
Output cell shape when saving in xyz file format.

Automatically adjust bond length and hydrogen after reading ChemDraw MOL format.
Automatically adjusts the bond length and hydrogen after reading the MOL format of Chem-
Draw.

Output residue number to save Xyz file
Output the residue number at the end of each line when saving in xyz file format.

Maintain project display area when opening files
Specifies whether the project display area is automatically hidden or maintained when switching
to file mode.

Number of recently used files/projects
Specify the number of recently used files/projects.

Use external viewer to display Cube files
Use an external viewer (such as VESTA) instead of Winmostar Viewer to open Cube files. The
program selected in the Cube Viewer in the program path will be used.

CIF file parse
Specifies the library to use for reading CIF files. Gemmi is the method implemented since
V11.6.0. pymatgen was the method used prior to V11.5.X.
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Use legacy filename for [Tools]-[Radius of Gyration]
Toggle the name of the output file between V11.6.0 or earlier format or V11.6.1 or later format
in [Tools]-[Radius of Gyration].

Edit tab
Bonding Factor

Set the threshold for judging the presence or absence of covalent bond from interatomic distance.

Keep Z-Matrix connectivity while modifying structure
If checked, make sure that the Z-Matrix join relationship does not change when editing molecular
structure.

Convert aromatic ring to single + double bond for MOL file
When storing the MOL file, change the aromatic ring to a combination of single bond and double
bond before outputting.

Bonding exceptions
Use this function when you do not want to create bonds between specific elements in the function
to automatically generate bonds. First press the Add button. Then select the two elements you
want to exclude the join in the two pull-down menus below the list and press the Apply button.
After that, applying Regenerate All Bonds etc will break the bond between the specified elements.
To restore, select the line you want to unset from the list andpress the Delete button.

Move markers to pasted atoms.
If checked, move the marker to the pasted atom when using Paste.

Simple Structural Optimization Methods
Choose the method you want to use with Quick Optimization.

Force field, cutoff, threshold (OpenBabel)
Specify the parameters when the simple structural optimization method is OpenBabel.

Max # of atoms to show atom list
Set the maximum number of atoms to display coordinates in Coordinate Viewer.

Max # of atoms to show atom list
Set the maximum number of atoms to display coordinates in Coordinate Viewer.

Max # of atoms to generate Z-Matrix
Set the maximum number of atoms to automatically generate Z-Matrix.

Max # of atoms to generate bonds
Set the maximum number of atoms to automatically generate Z-Matrix.

Show [CH3], [C2H3] and [C6H5] buttons
Install a fragment selection shortcut button on the toolbar. (similar to V10 and earlier)

Show toolbar captions
Show captions such as “solver”, “element”, “fragment”, etc. in the toolbar.

When right-clicked on viewport
Show context menu

Displays a context menu when right-clicking in the molecule display area.

Replace with fragment
Replace with fragment when right-clicking in molecular display area. (as before V10).

Alphabetically sort fragment list
Sort the list of fragments alphabetically. (as before V10).

Calculation tab
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General
Run MOPAC using Job Manager

When checked, use Winmostar Job Manager when executing MOPAC. If it is not entered,
Winmostar will be in a wait state until calculation by MOPAC is completed, and the output
result of MOPAC will be automatically loaded into the main window. It can also be set from
Use Job Manager.

Run the other solvers using Job Manager
Specify whether to use Winmostar Job Manager to execute programs other than MOPAC.

max # of Jobs
Sets the maximum number of jobs for the Job Manager.

Timeout
Set the time-out period of time-consuming processing.

Use old format adopted up to V9 when saving xyz file
If checked, use the directory name with “wm_” appended to the user name for the work
folder Remote Job Submission.

QM
Forcibly sleep after GAMESS run

If this is checked, GAMESS will be forced to sleep for the specified number of seconds after
executing GAMESS on the local machine. This function is useful when you want to check
the contents of a log immediately after calculation.

mpiexec (NWChem)
Specifies the mpiexec to use for parallel computation in NWChem local jobs. For MPICH,
the mpiexec specified in the program path is used. For Select, any mpiexec can be specified.

Options for mpiexec (NWChem)
mpiexec (NWChem) where Select is the argument for the mpiexec command. Where
%WM_NUM_PROC% is entered, the parallel number is automatically assigned at runtime. (For
example, if you enter -np %WM_NUM_PROC% in Options for mpiexec (NWChem) to calculate
2 parallelisms, mpiexec will actually run with the argument -np 2. )

# of procs for RESP charge calculation (GAMESS)
Specify the number of parallels for automatic calculation of RESP charges using GAMESS.

Keywords for automatic RESP charge calculation (GAMESS)
Sets the keyword for automatic calculation of RESP charges using GAMESS. By default,
the keyword to perform a single point calculation with HF/6-31G* is used.

MD
Modify charges from AmberTools to adjust total charge

When calculating AM1/BCC, Gasteiger, and RESP charges using acpype or AmberTools,
the charge of the entire molecule is set to a strictly integer value. In this case, the value of
the charge of the first atom in the molecule is slightly modified.

Retain residue and atom names during force field assignment
Sets whether residue and atom names are retained during force field assignment.

Case sensitive when generating top file
Specifies whether or not the top file that internally writes force field parameters is case-
sensitive in the detection of atomic name/type name matches when it is generated. This
affects all processes that use force field parameters, not just Gromacs.
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mpiexec (LAMMPS)
Specifies the mpiexec to use for parallel computation in LAMMPS local jobs. For MPICH,
the mpiexec specified in the program path is used. For Select, any mpiexec can be specified.

Options for mpiexec (LAMMPS)
mpiexec (LAMMPS) where Select is the argument for the mpiexec command. Where
%WM_NUM_PROC% is entered, the parallel number is automatically assigned at runtime. (For
example, if you enter -np %WM_NUM_PROC% in Options for mpiexec (LAMMPS) to calculate
2 parallelisms, mpiexec will actually run with the argument -np 2. )

Using double precision in MD results analysis
Sets whether gmx (single precision) or gmx_d (double precision) should be used for result
analysis with Gromacs.

Update elements when top file is loaded
When reading a top file in Gromacs force field assignment, set whether elements are read
from the top file and reflected in the model.

Version of LAMMPS to be used
Specifies the version of LAMMPS to which the output LAMMPS input file corresponds.
The output format of some keywords (e.g. thermo_style) will vary depending on the version.

Version of Gromacs to be used
Specifies the version of Gromacs to which the output Gromacs input file corresponds. The
output format of some keywords (such as tau_p) varies depending on the version..

LAMMPS Potential Folder
Set about the LAMMPS potential folder.

Open potential directory
Open LAMMPS potential folder in Explorer.

Consolidating the same parameter type in LAMMPS data files
Sets whether the same parameters Bond type, Angle type, Dihedral type, and Improper type
are merged in the output LAMMPS data file.

Allow LAMMPS pair_style, Potential file input
In the force field assignment function, allow users to freely input pair_style and Potential
file.

Solid
Distance tolerance for Spglib

Sets the tolerance for automatic crystal symmetry detection in Spglib

Warn calling Spglib if # atoms is more than
Sets the minimum number of atoms to skip Spglib execution.

Default extensions
Set the extension set by default when creating input files for each solver.

Open k-path file
Open a file that sets the default k-point path for calculating band structure in Quantum
ESPRESSO and OpenMX. Set per ibrav in Quantum ESPRESSO.

mpiexec (QE)
Specifies the mpiexec to use for parallel computation in Quantum ESPRESSO local jobs.
For MPICH, the mpiexec specified in the program path for MPICH2 is used. For Select,
any mpiexec can be specified.

Options for mpiexec (QE)
mpiexec (QE) where Select is the argument for the mpiexec command. Where
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%WM_NUM_PROC% is entered, the parallel number is automatically assigned at runtime. (For
example, if you enter -np %WM_NUM_PROC% in Options for mpiexec (QE) to calculate 2
parallelisms, mpiexec will actually run with the argument -np 2. )

Version of QE to be used
Specifies the version of the QE to which the input file of the output QE corresponds. The
output format of some keywords (&fcp, HUBBARD, etc.) is diffrent with the version

QE pseudo directory
Setup about pseudopotential folders for Quantum ESPRESSO.

Open QE pseudo directory
Open Quantum ESPRESSO pseudopotential folder in Explorer.

Download pseudo files
Automatically download pseudopotential files from the web server to the Quantum
ESPRESSO pseudopotential folder.

Open priority list
Sets the order of the list of Pseudo potential choices in the Quantum ESPRESSO Keyword
Settings window. Asterisks can be used as wildcards.

QE MOL directory
Specify a folder to contain the solvent files for the RISM-compatible version of Quantum
ESPRESSO.

Use Pymatgen for Slab Builder
Specifies whether pymatgen is used in the function to create slabs of the old specification.
If not, use the in-house routines.

Use New Slab Builder
If checked, the function to create a slab with the new specification is used; if unchecked, the
function to create a slab with the old specification is used.

View Tab
Color set

Select the color set from Winmostar, GaussView, Jmol, Rasmol, and Old Winmostar.

Color
Selected atom

Change the color of the atom type of the selected particle.

Bond
Change the color of the bond.

Background
Change the color of the background.

Background (Viewer)
Change the background color of Winmostar Viewer.

Text
Change the color of the character on the molecule display window.

Color bonds with color of atoms
Colors the bonds with the color of the atoms.

VDW radius of selected atom
Change the VDW radius for the element of the atom with marker in Viewport.
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Diameter of bond
Specifies the diameter of the bond.

Font size on Keyword Editor
Specify the font size of the Keyword Editor.

Scrolling speed
Adjust the speed of zoom in/out by the mouse wheel in Viewport.

‘Min # of atoms to switch to wire model while zooming’
Sets the minimum number of atoms to be changed to the wire model during zooming.

‘Time to return from wire model after zooming [msec]’
Sets the time in milliseconds to return from the wire model after zooming.

Depth cue
Adjusts the fog density used for depth expression.

Depth cue density
Adjusts the fog density used for depth expression.

Maximum # of atoms for depth cue
Enable depth cue if the number of atoms is greater than the specified value.

View center after opening file
Check View Marked Atom autoatically when opening a file.

‘Interval to show hint [msec]’
Set the wait time in milliseconds for hints to appear when hovering the mouse cursor over various
controls.

‘Font size for hint’
Sets the font size of the hints that appear when the mouse cursor hovers over various controls.

Items to be drawn
Check the items to be displayed in Viewport. You can also be set from View → Items.

Scaling factor of charge
Adjust the size of the charge display when displaying charges in Label/Charge. You can
also be set from View → Items.

Program Path Tab
Specify the install path of various programs. For MOPAC and GAMESS, multiple program paths
can be specified. In project mode only (1) is used. In file mode, you can use QM → MOPAC and
QM → GAMESS in the run menu. The program invoked by the Run button in the file mode keyword
setup window is the program path set in (1). For Quantum ESPRESSO, select pw.exe out of sev-
eral executables. %APPDIR% is an alias character indicating the Winmostar installation folder and
%CYGWINDIR% is the CygwinWM installation folder.

6.22 Window menu

Move between various subwindows. For Animation window and the Energy Plot window etc., you can
open it again after you close it from this menu.
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6.23 Help menu

6.23.1 manual

Display this manual on the local machine.

6.23.2 Web manual

Launch the web browser and display this manual on the web.

6.23.3 winmostar.com

Launch the web browser and display the HP of Winmostar.

6.23.4 Periodic Table

Open the html file of the period table under Winmostar installation folder.

6.23.5 Installation Test

Check the items you want to test and click the Start button to run the various solver operation tests. If the
tests are successful, you will see All tests passed. Under the operating environment of some security
countermeasure software, installation of some files in CygwinWM may be obstructed when installing
CygwinWM, so you can check it easily with this function.

6.23.6 Check CygwinWM

Click Check Now button to check the installation of CygwinWM. In this function, check only existence of
file. If you clear the check, you will see Successfully finished. Close this window. Under the
operating environment of some security countermeasure software, installation of some files in CygwinWM
may be obstructed when installing CygwinWM, so you can check it easily with this function.

6.23.7 Open Preferences Folder

Open the UserPref folder under the Winmostar installation folder.

6.23.8 Debug Mode

Switch to debug mode.
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6.23.9 Reset Job Manager

Reset Winmostar Job Manager status.

6.24 Animation operation area

In the list on the left side of the window, the number of steps, energy, power, etc. of each frame are
displayed. Clicking each line in the list will display the frame corresponding to that line in the main
window. At the bottom of the window, the values of the selected column in the list are displayed in a graph
Column pull-down menu. It is also possible to analyze results directly from this function for animated
(trajectory) data, check Options → Tools for details.

Reload
Re-load the animation file.

Options
Export

Current Frame
Saves the current frame as a different name.

All Frames Separately
Outputs all the frames to a separate file. For example, it is useful when you want to divide
the molecular structure of an SDF file into individual files and save and edit them. To re-
aggregate split files into SDF files, use Aggregate multiple files into SDF format.

GIF Animation
Write a GIF animation file.

JPEG Images
Export serial number JPEG file. You can also operate from the Export button.

XYZ File (Multiframe)
Writes out a xyz file containing all frames.

MOL2 File (Multiframe)
Writes out a mol2 file containing all frames.

SDF File (Multiframe)
Outputs all the frames to a separate file.

WMM File (Multiframe)
Writes out a WMM file containing all frames.

Animated GRO File
Output animation gro file. It can be used for linking with VMD etc.

CSV (Values)
Outputs the numbers displayed in the list in csv format.

Tools
Invert Trajectory

Invert the trajectory. This is useful when you want to combine trajectories for forward and
reverse IRC calculations around the saddle point.

Skip Frames
Thin trajectories are thinned at regular intervals. This is useful when you want to reduce the
size of long trajectories and reduce the processing speed of the analysis.
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Translate All Atoms
Translate every atom in every frame. This function is useful when you want to fine-tune the
position of an atom when visualizing calculated data.

Set Origin as Lower Bound Edge of Cell
Set the starting point in each direction of the simulation cell for each frame to the origin.
This feature is useful in combination with the Translate All Atoms feature.

Append Trajectory
Connects animations from other files to the current animation. This is useful when you want
to join trajectories of forward and reverse IRC calculations around a saddle point.

Mean Square Displacement/Diffusion Constant
Calculates mean-square displacement and self-diffusion coefficient. See Diffusion Con-
stant/Mean Square Displacement for details; some solvers, such as Gromacs, do not enable
this menu, but may provide an equivalent function in the solver’s menu. Some solvers will
ask you how many steps each frame of the animation is output every other step and the time
per step of the simulation (time ticks, delt t). If you are not sure of the value you entered,
check the maximum value on the horizontal axis of the displayed mean-square displacement
and if it matches the simulation time, you are good to go.

Radial Distribution Function
Calculate the radial distribution function. See Radial Distribution Function for details.
Some solvers such as Gromacs do not enable this menu, but equivalent functions may be
provided in the solver menu.

Displacement of Selected Atoms
Change in Number of Molecules for Each Molecular Species

Plot the molecular number change for each molecular species.

Rotational Autocorrelation Function
Calculate the rotational correlation function using the Legendre polynomial P2 of the second
degree of the vector defined between the two atoms. The first vector is defined between the
first and second atoms of the group to be analyzed, the second vector between the third and
fourth atoms. . . The object of analysis is determined in the following way The average of
the rotational correlation function for each vector is plotted.

Intramolecular Vector Autocorrelation Function
Calculate the autocorrelation function of vectors defined between two atoms. The first vector
is defined between the first and second atoms of the group to be analyzed, the second vector
between the third and fourth atoms. . . The object of analysis is determined in the following
way The average of the autocorrelation function for each vector is plotted. It can be used to
obtain the end-to-end vector autocorrelation function of a polymer.

Draw Path
The trajectory of each atom in the selected group is displayed as a line in the molecule
display area.

Extract Trajectory for Selected Group
In the main window, create a trajectory file extracting only the atoms selected from the
group.

Auto
Operates on the structure of each frame when executing file output functions such as File →
Export All Frames Separately. The operations are performed in the menu sequence.

Check All/Uncheck All
Check/Uncheck all items from Deleting Hydrogen to Quick Optimization.
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Deleting Hydrogen
Removes a hydrogen atom from the structure of each frame. This is equivalent to Delete All
Hydrogens.

Extracting One Molecule
For each frame structure, only one molecule is left in the structure.

Adjusting Coordinate
Automatically adjusts the bond length for each frame structure. The same operation is per-
formed as Adjust All Bond Lengths.

Adding Hydrogen
Hydrogen is automatically added to each frame structure. This is equivalent to To all atoms.

Quick Optimization
Performs a simple structural optimization for each frame structure. This is equivalent to
Quick Optimization

Running MOPAC
Execute MOPAC for each frame structure.

Enable Dynamic Bond
Automatically generates joins for each snapshot every time. It is useful for MD calculations
in which chemical bonds are recombined (first principle MD, CPMD, ReaxFF, DCDFTBMD,
etc.).

Speed
Adjust the playback speed.

Loop
If it is checked, the loop will be played.

Open Viewer
Display the currently open animation using Winmostar Viewer.

Frame
Manipulate and adjust the display position.

Plot Column
Specify the columns to be displayed in the graph display section at the bottom of this window. You
can also enter a value directly.

Custom Plot
Opens a window where you can flexibly plot list contents, interatomic distances, angles, lattice con-
stants, etc.

6.25 Energy Level Diagram window

We display energy of molecular orbital in numerical value and diagram. By clicking in the list of numerical
values or in the diagram, its molecular orbital is selected and is reflectted in Selected MO of MO Plot
window. The HOMO level number is displayed in HOMO:, and the HOMO-LUMO gap is displayed in
HOMO-LUMO Gap:.

slider
Adjust the origin and magnification of the diagram.

Excel button
Save the energy value in a CSV file and open it in Excel.
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Close button
Close the window.

6.26 Surface Setup / Cubgen window

Adjust the display of volume data such as molecular orbit, electrostatic potential, various cube files.

File → Open menu
Select the cube file you want to draw.

File → Export VRML menu
Output in VRML format.

File → Export VRML & Open VRML Viewer menu
Output in VRML format and open the file in a VRML viewer, which can be configured in the pref-
erences.

File → Open VRML Viewer menu
Displays the current file in the VRML viewer.

File → Open Winmostar Viewer menu
View the current file in Winmostar Viewer.

File → Close menu
Close this window.

Quantity pulldown menu
Specify the value of the isosurface to draw.

• MO
3D distribution of molecular orbitals selected by Selected MO.

• Surface
Molecular surface drawn at a distance of VDW radius (not exact)

• ESP(Population Charge)
ESP(Population Charge) is a three-dimensional distribution of electrostatic potential calcu-
lated from the point charge after Population analysis. It works faster than ESP. If more than
one type of charge exists, ESP charge (high priority) > Lowdin charge > NBO charge > User
charge > Mulliken charge (low priority) is used in that order.

• ESP(Population Charge)/Surface
Display ESP(Population Charge) information on the molecular surface. When multiple
types of charges are present, it behaves like ESP (Population Charge).

• MO/Surface
Display MO information on the molecular surface.

• Density
It is a three-dimensional distribution of electron density.

• ESP
Three-dimensional distribution of electrostatic potential calculated directly by electronic
state calculation.

Hint: You can display the ESP on the surface of the molecule corresponding to ESP/Surface by
following the steps below. (Not supported for MOPAC.)

1. Check Dump cube file and select Density with Quantity.
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2. Pressing the Draw button creates a file called *_den.cube.

3. Select ESP with Quantity.

4. When the Draw button is pressed, a file called *_esp.cube is created. This processor may take
several minutes.

5. If you open *_den.cube in the main window of Winmostar, a window called Cube Plot will
open.

6. Click the . . . button next to File 2 to open *_esp.cube.

7. Click Draw button

Hint: If you have the Cubegen program included with Gaussian for Windows, you can speed up
the display of ESP. In the Cubegen window that appears when you open a Cube file, check the Use
Gaussian’s cubegen checkbox.

The following items can only be selected for the Cubegen window.

• Spin
This is the three-dimensional distribution of the spin density (density difference between
alpha and beta spins).

• Alpha
This is the three-dimensional distribution of the alpha spin density.

• Beta
This is the three-dimensional distribution of the beta spin density.

• CurrentDensity=X
3D distribution of current density induced by a magnetic field, where X is the direction in
which the magnetic field is applied, rewrite and run Y or Z as needed.

• ShieldingDensity=XX1
This is the three-dimensional distribution of the magnetic shielding density. The first X
after = is the direction in which the magnetic field is applied, the second X is the direction
of the induced field, and the third number is the number of the atom for which the shielding
density is calculated; rewrite and execute as needed.

Selected MO
Specify the number of the molecular orbit to be drawn. Selecting a molecular orbital with Energy
Level Diagram window will set the value in this location.

Show Diagram button
Energy Level Diagram window is displayed.

alpha/beta button
Select a spin.

Draw Style pulldown menu
Display the isosurface in grid (Mesh) or solid (Solid) model.

Transparency
Specify transparency. (0: opaque, 1: transparent)

Isosurface Value
Specify the value of the isosurface to draw.
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Points
Specify the number of grid points on each side.

Scale
Specify the scaling factor that specifies the range to be drawn.

Draw boundary check box
Draw a line on the boundary of the cube file. It is mainly used for band calculation such as Quantum
ESPRESSO, OpenMX.

Draw contour Map check box
Draw a contour line on the specified section.

Dump cube file check box
When you press the Draw button, cube file is output at the same time as drawing.

Draw button
Draw the volume data using Winmostar Viewer.

Close button
Close this window.

6.27 IR Spectrum Window

Display IR and Raman spectra. The list on the left shows the frequency, the IR intensity, the Raman
intensity, and on the graph on the right they are displayed after they are broadened. In GAMESS, you can
display both spectra simultaneously by reading additional Raman spectrum with the IR spectrum read.
When you click on the graph, the row of the peak close to that position is selected in the list.

Freq. Scaling
Select the frequency scaling factor to compensate for systematic errors. From the pull-down menu,
select the method/basis function value used for calculation. You can edit the list of scaling factors by
pressing the Edit button.

Raman
Select Raman Activity / Depolar (P) / Depolar (U).

IR
Display IR spectrum.

Animation
Animate the vibration state of the selected peak.

Vector
Vibration status of the selected peak is displayed.

Magnitude
Adjust amplitude in animation display and length in vector display.

X Range
Specify the range of the horizontal axis.

Reverse
The horizontal axis is inverted and displayed.

Y Scale
Change the scale of the vertical axis.

Reverse
The vertical axis is inverted and displayed.
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Broadening
Set the full width at half maximum of broadening.

Export
Select the format to output the file.

Export csv (Discrete) & Open Excel
Outputs and opens a csv file for a discrete spectrum. See Export csv (Discrete) for the contents
of the csv file.

Export csv (Discrete)
Outputs csv files for discrete spectra. The csv file outputs the spectrum number, wavenumber,
IR intensity, Raman intensity (only if present), polarization resolving factor for plane polarized
incident light (only if present), polarization resolving factor for unpolarized incident light (only
if present), VCD intensity (only if present), and wavenumber after applying scaling factors csv
file.

Export csv (Broadened) & Open Excel
Outputs and opens a csv file for the broadened spectrum, see Export csv (Broadened) for the
contents of the csv file.

Export csv (Broadened)
Outputs a csv file for the broadened spectrum. csv file contains data number, fraction, broad-
ened IR intensity, broadened Raman intensity (only if present), polarization resolving factor of
broadened plane-polarized incident light (only if present), Broadened unpolarized incident light
polarization resolving factor (only if present), broadened VCD intensity (only if present), and
wavenumber after applying the scaling factor are output. The number of points output is fixed
at 1000.

Export Image
Save the graph as GIF or JPEG.

Copy Image
Copy the graph to the clipboard.

Close
Close this window.

6.28 UV-Vis Spectrum window

Display visible ultraviolet spectrum. The numerical value of each spectrum is displayed in the list on the
left and the broadened spectrum is displayed in the graph on the right.

View menu
Draw Peak menu

Draw the spectrum before broadening in the graph.

Draw Curve menu
Draw the broadened graph in the graph.

Export
Select the format to output the file.

Export csv (Discrete) & Open Excel
Output and open csv file for discrete spectra.

Export csv (Discrete)
Output csv file for discrete spectra.
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Export csv (Broadened) & Open Excel
Output and open a csv file for the broadened spectrum.

Export csv (Broadened)
Outputs a csv file for the broadened spectrum.

Copy Image
Copy the graph to the clipboard.

Broadening
Set the width of broadening.

Close
Close the window.

6.29 NMR Window

The NMR spectrum is displayed.

Element
Select the atoms for which you want to display the NMR spectrum.

Reference
Specify references for calculating chemical shifts. When Element is All, no choice appears. The list
of references is managed in the wm_nmr.ref file in the UserPref folder. You can add a reference with
Edit button.

Shielding
Reference displays the value of the selected reference.

Selected
Click in the spectrum graph to display the value of the selected spectrum.

Degeneracy Tolerance
It is a threshold when grouping by assuming that spectrum is degenerate.

Export
Select the format to output the file.

Export csv & Open Excel
Output the csv file and open it.

Export csv
Output csv file.

Copy Image
Copy the graph to the clipboard.

Close
Close the window.
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6.30 Energy Plot window

Time change of thermodynamic quantity such as various energy, temperature, pressure etc. of molecular
dynamics calculation is displayed. The UI appearing by the solver is different. Select the item with Energy
Terms and click the Draw button to display the graph. For how to operate the graph drawing area, see How
to operate the graph.

Uncheck All on Launch
If checked, Energy Terms will be unchecked each time this function is launched. If unchecked, the
checked items in Energy Terms will be saved. It will only appear in certain solvers.

Block Average
Plot the block averaged value with the size specified by Size. It is useful for plotting physical quantities
with large instantaneous fluctuations.

Normalize by Nmol
We standardize the energy by the number of molecules. To obtain the number of molecules, select
the coordinate file.

Plot Each Data Set on Separate Graphs
If checked, each item will be plotted on a separate graph. If unchecked, each item will be plotted
simultaneously on a single graph.

Calc Ave
Output the mean value of each item as a text file. If Calc Stdev and drift is checked, the standard
deviation and drift (difference between the minimum and maximum values of a line obtained by linear
regression of time series data) are also output. In the case of Gromacs, we execute gmx energy, and
physical properties derived from fluctuations such as specific heat and bulk modulus are also output.

Draw
Draw a graph. For Gromacs, execute gmx energy.

Close
Close the window.

6.31 How to operate the graph

Operation in graph drawing area
Left drag

Move the graph in translation. You can restore it with Refresh button.

Drag right
Enlarge the graph. You can restore it with Refresh button.

Show Setting
Autoscale

Set the drawing range automatically.

Min/Max
When you uncheck Autoscale checkbox, specify the drawing area directly.

Logarithm
It displays it in logarithm. The drawing range must be greater than 0.

Refresh
Reset drawing of the graph.
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Options
Copy Image

Copy the graph to the clipboard as an image.

Export csv & Open Excel
Output csv file and open Excel.

Export csv
Output a csv file.

Copy Columns
Copy selected data in a format that can be pasted into Excel.

Export Gnuplot File
Output Gnuplot file.

Calculate Average
Calculates and displays the average value of the displayed data over a specified range.

Add Cumulative Average
Add a plot of the integrated mean of the displayed data.

Add Batch Average
Add a plot of batch averages (moving averages) of the displayed data. The graph will be
smoothed.

Calculate Histogram
Calculate and display a histogram of the displayed data.

Calculate Differences from First/Last Value
Calculates and displays the difference from the first or last value for the displayed data.

Calculate First Differences
Calculates and displays the first difference of the displayed data.

Calcualte Integrated Values
Calculates and displays the integral value of the displayed data.

Calculate Average between Series
Displays data averaged across multiple data (series) displayed.

Fit Curve
Fits the displayed data to a function. In Type, the type of function is selected. In Equation and
List of Parameters, the function and coefficients to be fitted are displayed. If the Type is Custom,
enter the function and coefficients in the Equation and List of Parameters fields. Equation can be
entered in Python format, and Numpy can be called with np.In List of Initial Parameter Values,
enter the initial values of the coefficients, separated by commas. Enter the range of coefficients
in the List of Parameter Value Ranges as a tuple (for example, enter “(lower limit of argument
1, lower limit of argument 2, lower limit of argument 3),(upper limit of argument 1, upper limit
of argument 2, upper limit of argument 3)” when there are three coefficients). Check Specify
Range to specify the range to be fitted. If “Specify 2nd Range” is checked, additional fitting
will be performed in a range other than the one specified in Specify Range. Fitted Parameters
displays the coefficients after fitting, and clicking Fit executes the fitting.

Shift/Scale Data
Shifts the displayed data by a constant multiple or by a constant amount; you can choose whether
to change the data on the x- or y-axis. You can also divide or shift by the value of a specific data
point.

Change Range for Cyclic Variable
For periodic variables such as dihedral angles, change their display range.
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6.32 Winmostar Viewer

Winmostar Viewer is software attached to Winmostar specialized for drawing, displaying molecular orbital etc.
It is also possible to display only specific ingredients in a multicomponent system like MD.

6.32.1 How to use the mouse

Left button + drag

Rotate the viewpoint.
As you drag and release the mouse button it will
continue to rotate.

Right button + up and down drag Zoom In/Out.
Left button + right button + drag It moves vertically and horizontally.

6.32.2 Menu operation

File menu

Open
Read gld and MOLDA format files.

Export GLD
Save the currently open GLD format file with a name.

Export MOLDA
Save the structure displayed in the window in MOLDA format.

Export JPEG (Current frame)
Save the contents displayed in the window as a JPEG file.

Export JPEG (Current frame,Stereo)
Save the left and right screens for stereoscopic viewing as a JPEG file.

Export JPEG (Sequence)
Save the animation as a sequentially numbered JPEG file.

Export GIF (Animation)
Save the animation as a GIF animation.

Launch StereoPhoto Maker
Start StereoPhotomaker.

Exit
Quit Winmsotar Viewer.
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View menu

Representations
Perform detailed drawing adjustment Representations window is displayed.

Perspective
I use perspective.

Background Color
Specify the color of the background.

Winmostar Viewer
Make the background color dark blue.

Winmostar
Make the background color the default background color of Winmostar.

Black
Make the background color black.

White
Set the background color to white.

Model
Select the model to display.

Ball-and-Stick Model
Display the spherical bar model.

Space-Filling Model
Display space filling model.

Stick Model
Displays the bar model.

Wire Model
Display wire model.

Show SPace-Filling Model Overlapping
Display superimposed spatial priority models translucently.

Show Animation Control Panel
Animation operation panel is displayed.

Copy Image
Copy the image displayed in the window to the clipboard.

Help menu

Help
It shows how to use the mouse.

About Winmostar Viewer
Display version.

Debug
Displays debugging information such as memory usage.
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6.32.3 Animation operation panel

When you display animation in Winmostar 3D, the UI for animation operation appears in the upper left corner of
Winmostar 3D window.

slider
Move the frame.

Once
When playback reaches the last frame, playback stops.

Loop
When playback reaches the last frame, return to the first frame and repeat playback.

Round
Repeat playback in round trip.

Close
Close this panel.

6.32.4 Representations window

Orbit/Rotation
Specify the rotation method when rotating the viewpoint with left drag.

Orbit
Rotate freely.

X, Y or Z
Rotate around the horizontal direction within the window, the vertical direction within the screen, or the
direction perpendicular to the screen.

Periodic Boundary Condition
Specify how to display molecules that are outside the cell.

None
Display the original coordinates as they are.

Atom
It displays the structure so that it fits within the cell in atomic units.

Mol
Displays the structure so that the structure fits within the cell in molecule units.

Molecule
From the 1 in the middle of this window 9 is assigned to each molecule.

Composition
Assign 9 from 1 in the middle of this window to each molecular species (with the same molecular weight).

1 - 9
The checked items are displayed. In the pull-down menu BS, SF, ST, WI are Ball-stick model (default), Space
filling , Stick (rod) model, wire model.

Rainbow
It displays in different colors for each molecule.

Gold
The molecule is displayed in gold color.
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Stereo
It displays stereoscopically.

Enantiomer
Display the original structure and its mirror image.

Para
Display in parallel method.

Cross
It displays by the intersection method.

Anag
It displays with anaglyph. (Red and blue glasses are used)

Shift
Specify the distance between molecules.

red
Specify the size of the molecule to rotate.

H
If checked, hydrogen atoms are displayed.

Dummy
When checked, dummy atoms are displayed.

Backbone
If checked, only the backbone will be displayed. (For proteins)

Atom
Sets the display magnification of atoms.

Bond
Sets the display magnification of the join.

Z-Clip
Specify the clipping position in the Z direction.

Surface Style
Specify how to display isosurface such as molecular orbital.

Mesh
We display the isosurface in mesh (lattice) model.

Solid
Displays the isosurface in a solid model.

SmoothSolid
Display the isosurface in a smooth solid model.

Trans
Specify the transparency of the isosurface. (0: opaque, 1: transparent)

Contour Map Position
When mesh (scalar field) information such as molecular orbital is read, draw contour map (contour line) against
the checked surface. The position of the contour map can be adjusted with the slider.
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6.33 Winmostar Job Manager

Winmostar Job Manager (JM) runs as an auxiliary program to Winmostar, scheduling jobs for the various solvers.

MaxCores
Maximum number of cores on which the job will run on the local machine. By default it is set to the
number of cores on the machine. A larger value will allow many jobs to run in parallel at the same
time, but setting it to more than the number of cores on the local machine will not increase efficiency.

6.33.1 Basic actions

When Winmostar executes a job on the local machine in file mode (called local job) or in project mode, the JM
window shown below is launched and the job is registered in the first queue. In file mode, the Status of queued jobs is
first WAIT (waiting to be executed), and then the jobs are registered in order, Priority and RUN in sequence
considering the number of execution cores. The job switches to the next job, and the job is started. The Status of a
finished job changes to END.
JM is automatically started when executing a local job with Winmostar, but it does not end automatically, so if you
want to exit it is the x (close) button File → Exit It ends from. When you exit JM, the following jobs in the: guilabel:
WAIT state will not start.
If you want to start JM at an arbitrary timing such as stopping JM by mistake, click Tools → Job Manager on the
Winmostar main unit.

Hint: If you start the Windows Task Manager and go to the Performance tab, the number of cores of your machine
will be displayed in the Number of logical processors field.

Jobs are basically executed in the order of old jobs in the WAIT state, but you can adjust their order by changing
Priority. Priority has a lower value job execution with higher priority. For remote jobs, the timing of when they are
submitted varies with Priority, and the actual order of execution on the remote server is determined by the scheduling
software such as qsub.
The number of executed cores is set to the value set by the keyword of the solver to be used. For example, the value of
%nproc= for G03W, and the value of NCPUS for GAMESS. G03W requires a parallel calculation version, and there
is a limit of up to 4 cores.
JM has been adjusted not to start twice, and if you start Winmostar multiple times, the job will be registered for one
JM.
JM can manage up to 200 jobs (queues) . If exceeded, old queues are deleted. Even if the running job is deleted from
the queue, the job processing itself will continue.
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Note: For MOPAC, you can select whether to use JM in the Preferences of Winmostar itself. If you do not use JM,
calculation results are automatically loaded into Winmostar's main window after MOPAC calculation, but if you use
JM, the user must explicitly load the calculation result on Winmostar after the job is finished .

6.33.2 About power saving setting

During JM startup, JM prevents automatically entering standby (sleep) or hibernation mode depending on the time
setting. Please note that it does not have a function to automatically restore like a TV recording software after
entering the standby state etc. by manual operation.
When AutoShutdown is checked, all jobs are automatically shut down after entering the END state.
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CHAPTER

SEVEN

REMOTE JOB

With the remote job submission function, it is possible to execute a solver on a Linux machine ( **remote server** )
different from the machine on which Winmostar is installed.

7.1 Supported remote environments

Winmostar supports the job scheduler listed in Recommended remote servers.

• Torque, OpenPBS, PBS Professional (PBS)

• Sun Grid Engine (SGE), Univa Grid Engine (UGE), Altair Grid Engine (AGE)

• Slurm Workload Manager (SLURM)

• FUJITSU Software Technical Computing Suite (PJM)

If the corresponding job scheduler is not installed on the remote server, you can execute the remote job in the following
way.

1. Select Run with Queue setting.

2. Prepare commands and scripts that mimic commands such as qsub, qstat and specify the prefix of these com-
mands with Prefix for Queuing Commands if necessary.

It is also assumed to run basically in a bash shell on a remote server. It is possible to run in other shells, but it may
require more time and effort to change the scripts.

7.2 Remote Job Setup Procedures in file mode

See Basic Operation Flow for remote job setup procedure in project mode. See Basic Operation Flow for the overall
flow of steps to run the simulation. For details of each function, see Each function of the Submit Remote Job window.

1. Install and configure the job scheduler and solver on the server where you want to run the calculations. At this
stage, you must be able to SSH into the server without Winmostar and start the solver on the terminal. If you
are planning to install it now, please refer to here. If you want to run jobs without using job scheduling (not
recommended when running many jobs), you do not need to set up a job scheduler and should select Run in the
Queue setting later.

2. Click Submit Remote Job button | toolbar_submit | on the tool bar.
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3. Submit Remote Job window, if you want to use a profile that is already configured, select the pro-
file to use in Profile. If you are setting up a new profile, select Manage. . . → Add Profile.

4. Enter the following contents on the top of window of Edit Profile.

• Profile Name

• Connection

– Hostname

– Port (normally 22 is used)

– Timeout (Use default value if you do not know)

– Username

– Password (enter passphrase for private key, password otherwise)

– SSH Private Key (only needed when using private key)

Please
ask us to make multi-stage SSH connection to TSUBAME, FOCUS, etc.

5. To test the SSH connection, click the Test Connection button under the Edit Profile window. Check
the SSH Connection Only checkbox and click OK. When a black terminal window opens and
Store key in cache? (y/n) may be displayed at the first connection. In that case, enter y.
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If the connection is successful, the message “Test completed successfully” will be displayed. If the user settings
or other settings are incorrect, please review the one previous setting as the message “The test ended abnor-
mally”. Even if you entered the correct password on the spot, please re-enter it in the Edit Profile window. If
you see ERROR: Connection timed out or an error occurred. at the bottom of the Submit Remote Job
window, please reconsider the connection settings. If a private key is used, the connection may not be possible
due to different key formats. See SSH public/private key authentication for more information. If you cannot
connect even though there are no problems with your input, you may be able to connect by switching the version
of the library (libssh) used for SSH connections inside Winmostar. Go to [Tools] - [Preferences] - [Calculations]
- [Use older version of libssh2 (1.8.2) for SSH connections] and switch the check box.

6. Enter the following contents at the bottom of the window of Edit Profile.

• Queue & Solver

– Queue

– Options (command arguments for submitting jobs such as qsub)

First se-
lect Queue for the job scheduler installed on the server you are connecting to. Next, enter the command argu-
ments to submit the job, such as qsub or sbatch, in the Options field. The information about the resource to
be allocated is set here. In order to improve convenience, it is recommended to enter in the template file and in
Options aliases in which settings such as parallel number and file name depending on each job are assigned at
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job execution . For details, see Alias string available for remote job function.

7. To test the scheduler’s operation, click the Test Connection button under the Edit Profile window. If the remote
server’s queue is full and jobs are not flowing immediately, wait until the queue is free or continue. Check the
“SSH Connection and Job Scheduler” checkbox. Enter the maximum waiting time for the Job Scheduler as well,
and click OK. If the connection is successful, the message “Test completed successfully” will be displayed. If
the setting is incorrect, the message “Connection test failed” will be displayed, so please review the one previous
setting. You can check the details of Test Connection at Test Connection If the queue is full, the test will also
terminate abnormally, in which case, please wait until the queue is empty.

8. Enter the following contents at the bottom of the window of Edit Profile.

• Queue & Solver

– Solver

– Shell Script

First se-
lect Queue as the job scheduler installed on the server to be connected and select solver to use on it with Solver.
Next, click Use Template of Shell Script. If you do not have a template for the selected solver, enter the name of the
template and the template will be opened in a text editor. If you have, select the template file you want to use in the
pull down menu next to Use Template and click on the Edit button below it to open the template file in a text ed-
itor. Commands such as module load ..., source ..., export PATH = ... and other commands such as
mpirun, enter the settings for using the solver selected on that server. Template scripts include module load .
.. ` , :command:`source ... `, :command:`export PATH=... `, and :command:`mpirun to use
the selected solver on the server. Place them between # Insert commands here and # Do not modify the
followings in the template script as much as possible. In order to improve convenience, it is recommended to
enter in the template file and in Options aliases in which settings such as parallel number and file name depending
on each job are assigned at job execution . For details, see Alias string available for remote job function.

9. To test the solver’s operation, click the Test Connection button under the Edit Profile window. If the remote
server’s queue is full and jobs are not flowing immediately, wait until the queue is free or continue. Check the
“Run Tests for SSH Connection, Job Scheduler, and (Solver Name)” checkbox. Set the “Maximum Wait Time
for Job Scheduler [s]” to the appropriate value. Then click OK. If the connection is successful, the message “Test
completed successfully” will be displayed. If the setting is incorrect, the message “Connection test failed” will
be displayed, so please review the one previous setting. You can check the details of Test Connection at Test
Connection If the queue is full, the test will also terminate abnormally, in which case, please wait until the queue
is empty.
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10. Press the OK button to close the Edit Profile window.

11. Close button to close the Submit Remote Job window. When prompted “Do you want to save the remote server
configuration?” Click Yes.

7.3 Remote Job Operation Procedures in File Mode

See Basic Operation Flow for instructions on operating remote jobs in project mode.

• In the Submit Remote Job window, click the Queue → Show Usage of Each Queues menu and make sure the
remote server information is displayed at the bottom of the window.

• If you want to start a job in file mode, click the Send & Submit button. The operation here is the same as for a
normal local job.

The ID of the submitted job is displayed at the bottom of the window. ID is
used to kill the job. The directory in which the job was executed on the remote server can be set
in Remote Directory of Profile → Edit Profile, and the one actually used is displayed on the Remote
Directory field of Submit Remote Job. When a job is started on a remote server, standard output is
output to the file winmos.o and standard error is output to the file winmos.e.

• If you want to check the status of jobs submitted in file mode, use Queue → List Submitted Jobs. If all jobs are
complete, you will see ---.

If the submitted job ends too soon, --- will be displayed even if you submit it.

• To check the status of a specific job on a remote server, please do the following.

– ls button

– cat button

– grep button

– tail button

– Get & Open . . . button

The target job is displayed in the Remote
Directory field. For the default setting, open the input file of the job you want to target in the main
window and select the profile when you submitted the job.

• If you want to run the result analysis of a job finished on a remote server in file mode on your local machine,
click the Get All Files button.

The target job is displayed in the Remote Directory field. For the default
setting, open the input file of the job you want to target in the main window and select the profile
when you submitted the job. After file acquisition, result analysis can be performed by the same
operation method as local job.
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7.4 Each function of the Submit Remote Job window

File menu
Revert All Changes

Discard the changes and reload the server configuration file.

Restore Setting File
Restore the server configuration file to the factory condition.

Import Setting File
It loads the server configuration file and adds the profile contained in it to the list of existing profiles.

Restore Setting File
Restore the server configuration file to the factory condition.

Close
Close this window.

Profile Menu
Add Profile, Duplicate Profile, Remove Profile

Add, duplicate, and delete server connection profiles. The same operation is possible from the Manage
button in the window.

Edit Profile
Edit the profile of the server connection. Some settings can be edited directly in the Submit Job window.

Profile name
Specify the profile name displayed in the Submit Job window.

Hostname
Specify the host name or IP address of the remote server.

Port
Specify the port number used for connection.

Timeout
Specify the time (unit: second) for automatically disconnecting the connection when there is no re-
sponse from the remote server.

Username
Specify the login ID (user name) to the remote server.

Password
Specify the password of the login ID. If you click [View], password hiding will be canceled.

SSH Key
Set the SSH key as needed.

Queue
Select the type of job scheduler running on the remote server to be connected.

Solver
Select the program to use in this profile. You can also change it in the window.

Shell Script
Check Use Default to execute calculations using the default shell script, or Use Template to customize
the shell script. If you check Use Template, select a template file to use in the pull-down menu beside
it, and if you want to add, edit or delete a template file Add, Edit Remove button. You can use Alias
string available for remote job function in the template file. The template file is saved in UserPref in
Winmostar installation folder. You can also change it in the window.
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Options
Set arguments to be given after job submission command (qsub etc.). You can use Alias string available
for remote job function for this item. You can also change it in the window.

Remote Directory
Specify the working folder of the remote server. If it is empty (Local User ID)/(program name)/(file
name) is the working directory from the home directory. The Local User ID is the user name under
Windows in operation and is displayed in the title of the Submit Remote Job window. If the Local User
ID contains double-byte characters or half-width spaces, the directory name is internally converted
to single-byte alphanumeric characters. If you enclose it with a single quotation like :command: ‘/
work/dir’, create (Local User ID)/(program name)/(file name) from the specified directory.
Also, if you enclose two single quotations like ''/work/dir'', a directory with (Local User ID) will
not be created. You can use Alias string available for remote job function for this item.

Prefix for Queueing Commands
When executing commands such as qsub, if you need the prefix of those commands, set them here.
Normally it is empty.

Test Connection
Test SSH connection, details of the Test Connection can be found at Test Connection.

Connection Menu
Test Connection and File Transfer

The same operation is possible with the Test Connection button in the window.

Job Menu
Send Local Files & Submit Job

Generate an input file required for calculation, transfer it to the remote server by SFTP, and submit it to
the job scheduler. After submitting, the ID of the job is displayed. Generate the input files needed for
the calculation, transfer them to the remote server via SFTP, and then submit them to the job scheduler.
The ID of the submitted job is displayed at the bottom of the window; the ID is used to cancel (KILL)
the job. The same operation is possible with the Send & Submit button in the window.

Submit Job
It generates an input file necessary for calculation and transfers it to the remote server by SFTP.

List Files at Remote Directory
Get the list of files in Remote Directory. The same operation is possible with the ls button in the
window.

Display Remote File
Retrieve the contents of the selected file in Remote Directory. The same operation is possible with the
cat button in the window.

Display Last Part of Remote Log File
Get the end of the log file in Remote Directory. The same operation is possible with the tail button in
the window.

Search String in Remote Log File
Search strings in the log files in Remote Directory. The same operation is possible with the grep button
in the window.

Restert Terminated Job
If a remote job is forcibly interrupted by the job scheduler, etc., this function restarts the calculation.

Force Job Finalization
If all files are not generated due to abnormal termination of calculation, and Get All Remote Files does
not operate normally, executing this function forcibly terminates the process, and Get All Remote Files
can be executed.
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Get Remote File and . . .
Get a specific file in Remote Directory and visualize it. The same operation is possible with the Get
File & . . . button in the window.

Queue menu
A concrete command name in the selected job scheduler is displayed in parentheses in each menu name.

List Submitted Jobs
Get a list of jobs registered in the job scheduler. The same operation is possible with the button with
the same command name in the window.

Kill Submitted Job
Suspends the job registered in the job scheduler. You must enter the ID of the job displayed immediately
after submitting. The same operation is possible with the button with the same command name in the
window.

List Submitted Jobs in Detail
Get a detailed list of jobs registered in the job scheduler. The same operation is possible with the button
with the same command name in the window.

Show Information of Each Queue
Get the list of queues managed by the job scheduler. The same operation is possible with the button
with the same command name in the window.

Show Usage of Each Queue
Get usage status of each queue. The same operation is possible with the button with the same command
name in the window.

Show Information of All Nodes
Get information on all machines managed by Job Scheduler. The same operation is possible with the
button with the same command name in the window.

Other menu
The same command as the item name is executed on the remote server.

Options Menu
Hide Other Users Info

Specifies whether to display information about other users when qstat -a is run.

Enable Admin Mode
Used to access the remote server with root privilege

7.5 Alias string available for remote job function

Arguments of shell scripts and submit commands used when executing jobs may change dynamically depending on
calculation conditions, so you can use alias strings to deal with such situations. A list of available alias strings is shown
below.

%WM_USER_ID% Local user ID for remote directory creation
%WM_SOLVER% Type of solver
%WM_INPUT% Input file name
%WM_PREFIX% Input file name minus extension
%WM_EXT% Input file name extension
%% WM_NUM_PROC Number of MPI processes
%WM_NUM_THREAD% Number of threads per MPI process (or total threads if MPI is not used)
%WM_NUM_PARALLEL% Product of% WM_NUM_PROC% and% WM_NUM_THREAD%
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7.6 Remote job configuration file

Profile settings are saved in UserPref\winmos_profile.ini in Winmostar installation folder. When reading, in
order to maintain compatibility with old versions of V8 or earlier, it is read in the following order of priority. UserPref\
winmos_profile.ini > UserPref\winmos_server.ini > wm_system\RemoteJobdefault_profile.ini

7.7 How to use Windows server

A Windows PC are available as a remote server. The following preparations are required to use it.

• Install an OpenSSH server on the remote server so that clients can connect with SSH.

• Install Winmostar on the remote server and always start Winmostar Job Manager.

Set as follows.

• In the Profile edit window, select JM (Windows) for Queue.

• Set Winmostar Path installed on the remote server to Winmostar Path.

• Since the default shell script cannot be used, select Use Template to create a template file. The contents of the
batch file that runs on Windows.

There are operational differences from other job schedulers as follows.

• It also checks whether the job manager is running when the Test Connection button is pressed.

• The information displayed by the List Jobs button is the same as Job Manager, from the left: number, status,
priority, number of cores, job name, start date/time, end date/time, and batch file.

• If you want to cancel the job with the Delete Job button, enter the job name.

7.8 How to connect via HTTP proxy

To connect to a remote server via SSH through an HTTP proxy server, follow the steps below.

• Tools → Cygwin to start Cygwin.

• Enter the command as shown below. Where REMOTE_SERVER, PROXY_HOST_NAME, PROXY_PORT,
and USER_NAME should be replaced by the remote server name, proxy server name, proxy port number, and
user name, respectively.

ssh -L1234:REMOTE_SERVER:22 -o “ProxyCommand connect-proxy -H PROXY_HOST_NAME:PROXY_PORT
%h %p” USER_NAME@REMOTE_SERVER

• With the above connection, set Host Name to localhost and Port to 1234 in the Edit Profile screen.
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7.9 SSH public/private key authentication

Winmostar’s remote job feature also supports connection methods using SSH public/private key authentication.
Some versions of Winmostar only supports connections in PEM format. When generating keys in the terminal,
run $ ssh-keygen -m pem -f (filename of the private key) to ensure they are generated in PEM format.
(OpenSSH requires -m pem because the default key format may be RFC4716). To convert an already generated key
to PEM format, run $ ssh-keygen -p -N "" -m pem -f (private key filename). In some cases, it is nec-
essary to change the permissions of the private key file before conversion, in which case you can run $ chmod 600
(private key filename) in advance. To convert a PuTTY Private Key (ppk) format file to PEM format, first launch
PuTTYgen, which is included with PuTTY. Next, click “Load” under “Actions” and open the ppk file. If a passphrase
has been set, enter the passphrase in the “Key passphrase” and “Confirm passphrase” fields. Then, from the Conversions
menu, click Export OpenSSH key and enter the file name of the newly created private key in PEM format.

7.10 Test Connection

The Test Connection function is available in the Job Settings window, Remote Server Profile window, Control Remote
Job/Server window, and Submit Remote Job window to test the status of remote jobs. The Test Connection function is
available in the Job Settings window, Remote Server Profile window, Control Remote Job/Server window and Submit
Remote Job window. If the test fails, you can open the file used for the test. test_connection.log contains detailed
information about the test and is useful for reviewing the configuration. In SSH connection only, test the SSH connection
by sftp-sending a file named send_file.txt to the server and then receive. If this test fails, review the various settings for
Host Name, Port, User Name, Password, SSH Private Key, and Port Forward. The SSH connection and job scheduler
tests the job scheduler by actually submitting a simple shell script, remote_test.sh, to the job scheduler and checking
that the shell script returns the expected output, in addition to the SSH connection only test. The job scheduler is tested
by actually submitting a simple shell script called remote_test.sh to the job scheduler and checking whether the shell
script returns the expected output. This test will fail unless the job scheduler is actually free and the submitted job
runs immediately. If this test fails even though there is room in the job scheduler, please review the various settings in
Queue, Options, and Prefix for Queueing Commands. submit_stdout.txt will output the standard output of the submitted
command. remotejob_stdout.txt will output the standard output of the job that was executed. In SSH connection and
job scheduler and (solver name), in addition to testing the SSH connection and job scheduler, you can test the various
solvers by actually submitting a simple job to the job scheduler and checking whether the job returns the expected
output. Solver testing is performed by actually submitting a simple job to the job scheduler and checking that the
job returns the expected output. This test will fail unless the job scheduler is actually free and the submitted job
executes immediately. If this test fails even though there is room in the job scheduler, review the various settings in
the template script. submit_stdout.txt will output the standard output of the submitted command. remotejob_stdout.txt
and remotejob_stderr.txt will output the standard output of the executed job and standard error. winmos_script.txt is
the submitted shell script.
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CHAPTER

EIGHT

ADD-ON

8.1 Frangment ER

Calculate relative binding free energy between protein and ligand using Fragment ER method. Purchase
of add-on is necessary for using. We use NAMD for molecular dynamics solver.

8.1.1 Fragment ER window

File menu
New Project

Initialize the project.

Open Project
Open the project.

Save Project
Overwrite and save the project.

Save Project As
Save the project with a name.

Close
Close the Fragment ER window.

MD menu
NAMD Keywords Setup

Open NAMD Configure window.

Run NAMD
Run NAMD locally.

Run NAMD On Remote Server
Open Remote Job Submission window for NAMD execution on remote server.

Edit .log File
Open the log file at NAMD execution with a text editor.

Energy Plot
Draw graph of energy change from log file at NAMD execution.

Import NAMD Trajectory
Open the MD trajectory.
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Clear NAMD Output Files
Delete the output file made by NAMD execution. Delete RunNAMD.bat, RunNAMD.log, various dcd, log,
coor, namd, vel, xsc, xst files etc ..

Analysis menu
Calculate Free Energy

Calculate free energy.

Edit .log File
Open the log file at free energy calculation with a text editor.

Import Result
Import the free energy calculation result and display it in Result display window.

Clear Analysis Output Files
Delete the output file made by free energy calculation. Delete FreeEnergy.sh, FreeEnergy.log,
calc_PdP_kai2.out, parameters_fe file, refs, soln folder etc.

Tools menu
Preferences

Preferences window is displayed.

Solution
Specify PDB file of solution type by clicking . . . button. If more than one ligand molecule is present, designate
the ligand molecule. Ligand molecules are displayed in the view.

Set Core
By clicking on the atom of the fragment part from the initial ligand and clicking the Set Core button, the remaining
part is set as the mother nucleus.

Add
After selecting a new fragment with a combo box, click the Add button to add the ligand with the new fragment
added to the mother nucleus to the final ligand list.

Configure
Fragment ER setting window is displayed.

Check
It checks whether atom types of mother nuclear parts of various ligands match. At the same time it generates
force field of ligand.

Setup
Generate input file (PDB, PSF file) of NAMD.

Close
Close the Fragment ER window.

8.1.2 Fragment ER setting window

Set up Fragment ER calculation. The setting contents are recorded in the project file.

Solvation
Drop water and solvate for In-protein

Set whether water molecules should be rearranged by calculation of In-protein system. If you do not do
this, water molecules of the solution system you read will be used as a solvent. If this is not done, periodic
boundary cells must be set.
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Drop water and solvate for In-aqua
Set whether water molecules are rearranged by calculation of In-aqua system. If you do not do this, water
molecules of the solution system you read will be used as a solvent. If this is not done, periodic boundary
cells must be set.

Distance from solute to cell boundary
Specify the distance from the solute to the periodic border cell.

Forcefield for Ligands
Select the type of force field to use for the ligand.

N-terminal modification
Specify N-terminal modification of protein.

C-terminal modification
Specify the C-terminal modification of the protein.

Import trajectory Interval
Specify how often to thin out when trajectory is imported.

ERmod
# of bins for binding energy

Specify the division number of binding energy.

# of insersions for solute (maxins)
ermod Specify maxins at runtime.

# of division of the simulation (engdiv)
ermod Specify engdiv at run time.

# of OpenMP threads (for local run)
ermod Specifies the number of OpenMP threads on local execution.

# of MPI processes (for remote run)
ermod Specifies the number of MPI processes at remote execution.

OK
Save the settings and close the window.

Cancel
Close the window without saving the setting.

8.1.3 NAMD Configure window

Set up MD calculation by NAMD. The setting contents are recorded in the project file. Select the system
to be calculated with the check box.

Conf
Set the input file for NAMD calculation of each system.

numdcd
Specify the output interval of the trajectory.

numlog
Specify the output interval of the log file.

temperature
Specify the temperature. In the equilibrium calculation of In-protein, it is the temperature at the first stage
of the stage temperature rise.
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timestep
Specify the time step of 1 step of MD.

numstep
Specify the number of MD steps.

Number of Therad
Specify the number of threads when NAMD is executed.

Generate Conf Files
Output the input file (namd file).

Run
Output the input file and execute NAMD locally.

Close
Close the NAMD Configure window.

Load Default
Load default setting condition.

Save Default
Save the current setting condition as the default setting.

Reset Default
The default setting condition is reset to the initial state.

8.1.4 Result display window

A summary of the results is displayed in Summary. A graph of the energy distribution function is displayed.
You can select which system to display.

log
Open the log file with a text editor.

Excel
Save the data displayed in the graph as a CSV file and open it with the application.

Close
Close the result display window.

8.1.5 Preferences window

NAMD Path
Set the path of the NAMD executable file.

Protein Topology Path
Specify the protein topology file.

Protein parameter Path
Specify the protein parameter file.
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8.2 DCDFTBMD

It is a menu related to the divide and conquer type density functional the strongly bound molecular dy-
namics method. Purchase of add-on is necessary for using. How to install DCDFTBMD is described in
Installing Winmostar and solvers.

8.2.1 Configure

After setting, press the OK button. The Reset button returns to the default state. Save button to save the
settings. Load button loads settings saved with Save.

Continue Simulation
Run a continuation job. The keyword RESTART = TRUE is set, and the calculation restarts from the
restart information. See Run for details.

# of Threads
Specify the OpenMP parallel number.

Use MPI
Use MPI. Specify the MPI parallel number in the horizontal column.

Basic
Charge

Specify the charge of the entire system.

Multiplicity
Specify the spin multiplicity of the entire system.

Parameter Set
Select the type of parameter to use. The names of folders placed in the DFTBParam folder under
the Winmostar installation folder (by default C:\winmos10\) are listed.The folder placed under
the DFTBParam folder must contain parameter files such as skf. For example, a hierarchical
structure of C:\winmos11\DFTBParam\mio-1-1\C-C.skf is assumed.

Open Directory for Parameter Set
Open the aforementioned DFTBParam folder.

Reload Parameter Set
Reload the aforementioned DFTBParam folder and update the list of Parameter Set.

Executable
Specifies the binary of DCDFTBMD used for the calculation. When using MPI, it is necessary
to specify an MPI compatible binary such as dftb_mpiomp_mpich.00.x. The binary specified
here must be passed through PATH on the remote server.

Advanced
Method

Select SCC or NCC.

THIRDFULL
Use third-order correction for SCC Hamiltonian.

DAMPXH
Use short-range damping of SCC interactions for X-H pairs.

MAXITER
Specifies the maximum number of SCC cycles.
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ECONV
Specify the convergence condition of energy change. (atomic unit)

DCONV
Specify the convergence condition of the gradient change. (atomic unit)

DISP
Use empirical dispersion force correction.

DISPTYPE
Specifies the type of empirical dispersion force correction.

DC
Use divide and conquer method.

SUBTYPE
Specify how to create a subsystem.

BUFRAD
Specifies the radius of the spherical buffer area. (angstrom)

DELTAR
Grid when dividing system into cubic space with SUBTYPE = AUTO (angstrom)

OPT/FREQ
OPT

Perform structural optimization calculations.

MAXITER
Specify the maximum number of structural optimization cycles.

DCONV
Specify the convergence condition of the gradient change. (atomic unit)

FREQ
Perform harmonic vibration analysis

MO
Perform molecular dynamics calculations

NSTEP
Specify the number of steps. When Continue Simulation is checked, it is necessary to
enter the sum of the number of steps of the job before continuing and the number of
steps of the job to be run.

DELTAT
Specify time step (second)

BATHTEMP
Specify the heat bath temperature when using NVT and NPT ensembles. (Kelvin)

Ensemble
Specify the type of ensemble.

NVTTYPE
Specify the settings for the hot bath.

INITTEMP
Specify the initial temperature (Kelvin)

PRINT
Specify the output frequency to the file such as coordinates during simulation.

8.2. DCDFTBMD 295



Winmostar™ User Manual, Release 11.13.0

CALCPRESSURE
Calculate the pressure. Care should be taken when performing a continuous job, as it
cannot be changed from the settings of the job before takeover.

Properties
PRINT

MO
Output molecular orbital coefficient (only when the number of subsystems is 1)

ATOME
Outputs the contribution from each atom to the total energy.

HS
Outputs zero-order Hamiltonian and overlap matrix (only when the number of subsystems
is 1)

FORCE
Calculate energy and force.

STRESS
Calculate stress tensor and lattice vector

Options
Restore Working Folder

Click to return the working Folder to its pre-execution status, such as when a continued job ends
abnormally.

8.2.2 Run

To run DCDFTBMD, open Remote job. See Remote job for detailed instructions. The execution method
depends on the situation.

• (Default) If Continue Simulation is unchecked
Save the input file (extension dci) with the name specified by the user at the time of execution,
and execute the calculation using it.

• When Continue Simulation is checked
Create a backup of the existing working directory associated with the input file opened in the
main window, save the input file as dftb.inp in the newly created working folder, and use it to
perform calculations .

The following files are generated with execution. As an example, the file/folder name when the input file
is water.dci is also shown.
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Type Explanation

dco file
water.dco

DCDFTMD standard output file.
A copy of dftb.out in your working
folder.

Shell script
water.sh

To perform DCDFTBMD and its pre/post
processing
shell script.

conf file
water_conf.sh

Contains variables used in the above shell
script
file.

Working folder
water_dc_data\

working folder.

The following files are generated in the working folder. Only the main files are shown here.

Type Explanation

dftb.inp Input file actually passed to DCDFTMD

dftb.out Standard output file

dftb.dat Detailed output file

traject Trajectory file in MD calculation

restart Restart file

Hint: ** Working folder **

• A working folder is a folder with the suffix of the name of the file opened in the main
window.
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– ** The suffix depends on the type of solver. **

– For example, for Gromacs, if the file opened in the main window is aaa.gro and the
suffix is _gmx_tmp, the name of the working folder is aaa_gmx_tmp.

• It must be on the same level as the file opened in the main window.

• Although processing continues in the working folder with the same name for continued
jobs, by default, a backup of the previous job’s working folder is created immediately
before the continued job is executed.

– The name of the backup will be the one with the lowest number in the range where
there are no duplicate names. For example, if your working folder is aaa_gmx_tmp, it
will be aaa_gmx_tmp1.

– ** Unnumbered directories are always up to date. **

8.2.3 Open Log File (dco)

Open the dco (standard output) file with a text editor.

8.2.4 Open Detailed Data File (dat)

Open the detailed output file in a text editor.

8.2.5 Animation

OPT (dco)

Select a dco file and animate optimization calculation trajectory. See Animation operation area for anima-
tion display operations. From the animation operation area, you can calculate radial distribution function,
self-diffusion coefficient, mean square displacement, displacement of each atom, etc.

MD (traject)

Select dci and traject files and animate MD calculation trajectory. The main window file name does not
change. See Animation operation area for animation display operations. From the animation operation
area, you can calculate radial distribution function, self-diffusion coefficient, mean square displacement,
displacement of each atom, etc.

8.2.6 Energy Plot

Select a log file and display graphs of various thermodynamic quantities such as energy and temperature.
See Energy Plot window for how to operate subwindows.
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8.3 Towhee

Menu about Towhee.

8.3.1 Assigning force fields

If you are performing a Gibbs Ensemble Monte Carlo (GEMC) or Grand Canonical Monte Carlo calculation, the main
window must be in animated view at this point and the number of frames in the animation must be 2.For GEMC, the
first phase must have been created on the first frame and the second phase on the second frame.In the case of GCMC,
the system to be calculated must be created in the first frame and the molecules not included in the first frame must be
created in the second frame. Sets the force field. The options change depending on the type of solver. After assigning
a forcefield, use Get Info to check the assigned forcefield. In the case of LAMMPS, if a gro file with velocities is
open in the main window at the time this feature is used, it will generate a data file with velocities.Similarly, in the
case of Gromacs, if a data file containing velocity is open, a gro file containing velocity is generated.This is useful
when you want to take over Gromacs and LAMMPS computed data with velocities. Once you assign a force field
and run the MD calculation, the bond order is automatically determined from the equilibrium length of the force field
parameters.Depending on the type of force field, the bond order determined at that time may be different from the bond
order before the force field assignment.Some force fields are affected by the bond order. Use Overwrite Bonds from
File if you want to return to the bond order before force field assignment.

Assign parameters automatically
Assign new force field parameters. Structures connected to each other by bonds in the molecule display area will
be recognized as a single molecule.

(General)
Specifies the force field for molecules other than proteins and water molecules. Internally, acpype is used
for GAFF, GAFF2, OPLS/AA-L+GAFF, an in-house program for Dreiding, a proprietary extension of
OpenBabel for UFF, and mktop for OPLS-AA. The configuration for Dreiding is described in polymer/
dreiding.lib.txt. Check Universal Force Field for details on UFF.

Exception
Assigns a user-specified LJ parameter to a specific molecule, instead of using the force field selected
in (General). Check the molecules for which you want to assign LJ parameters in the left column of
the sub-window and enter the LJ parameters in the right column.

Note: This is used, for example, when you want to assign LJ parameters to atoms in the solid phase
in a solid-liquid interface system.

(Protein)
Specify the force field of the protein. Here, the atom to which the name of the amino acid residue is assigned
in the PDB or gro format is recognized as a protein. Internally, gmx pdb2gmx is used.

Warning: This function is not available if the molecular structure is read from a file that does not
contain residue names.

(Water)
Specifies the force field of water molecules. You must specify the water model selected in Solvate/Build
Cell. Internally, the parameters are taken from the library of Gromacs topologies installed in Cygwin.

[position_restraints] added for proteins
If the protein is present, write information (in the [position_restraints] section) to the topology file
to constrain the position with -POSRES in the Advanced tab. If the protein is not present, it is ignored.
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[position_restraints] added for selected atoms
Writes information (in the [position_restraints] section) to the topology file for a user-specified
molecule to constrain its position with -POSRES on the Advanced tab. This is used, for example, to con-
strain the solid phase in a solid-liquid interface system.

[distance/angle/dihedral_restraints] added for selected atoms
Writes information to the topology file to constrain the distance, angle, and dihedral angle with -POSRES
on the Advanced tab for the molecule specified by the user.

Dump Now
Generate a file with force fields assigned based on the current settings.

Note:
• If you want to customize the forcefield information by editing it with a text editor or similar, first save the

file containing the forcefield information using Dump Now and edit the top for Gromacs or the data file for
LAMMPS with a text editor or similar. Please use a text editor or similar to edit the data file.

• Next, for Gromacs, import the gro file at File → Import File (select Discard and Load), then at Assign
Force Field select :guilabel:` Select Use parameters written in topology file and click the OK button. You
will then be asked for the location of the top file, so open the top file you just saved and edited.

• For LAMMPS, import the data file by File → Import File (select Discard and Import), select Use param-
eters written in file in main window for Assign Force Field Use the parameters written in the file in the
:guilabel:`main window and click on the Next > button.If the data file does not contain force field informa-
tion, you will be prompted to Select the type of force field, select the type of generic force field you want to
use and click the OK button.

• Charges are taken from the structure displayed in the main window. If more than one type of charge is set
in the main window (for example, if you open a GAMESS log file and set a Mulliken charge and a Lowdin
charge), the (high priority) User charge > NBO charge > Lowdin charge > ESP charge > Mulliken charge
(low priority) Priority is used in that order.

Using parameter files (for inorganic, ReaxFF, and DPD)
(for LAMMPS) Select if you want to use the potential for inorganic materials, ReaxFF or DPD. After pressing
the Next > button, specify the type of force field you actually want to use. pair_style and Potential file must be
set in [Tools]-[Preferences]-[Calculations] to allow the user to enter them freely.

Use parameters written in topology file
(For Gromacs) Select this option if you want to run MD calculations using a top file that already exists. The
corresponding gro file must be opened or imported in the main window. If you edit the structure after opening
or importing it, the correspondence with the top file will be broken and the calculation will not be possible. If
you want to use this function after editing the structure after opening or importing it to the extent that it does not
affect the force field information (for example, editing only the coordinates without changing the bonds), export
the structure in gro format after editing it and open or import that file before using this function.

Use parameters written in file in main window
(For LAMMPS) Select this option if you want to run the MD calculation using a data file that already exists. The
main window must have the data file you want to use open or imported. If you edit the structure after opening or
importing the file, the correspondence with the top file will be broken and the calculation will not be possible.
After pressing the Next > button, specify the type of force field to use.
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8.3.2 Workflow Configuration

Set up and run Towhee’s calculation flow in project mode.

Preset
Recalls and saves a preset of settings.

# of Jobs
Specifies the number of jobs.

Enable parameter/structure scan
This feature requires the purchase of an add-on. It allows you to run multiple calculations where
only certain parameters differ (parameter scan) or to run calculations with the same parameters for
multiple structures (structure scan). Click Config to open the configuration window for the scan calcu-
lation.For parameter scans, select %WM_SCAN1% for the Target Variable and enter the parameters
you wish to set for %WM_SCAN1% in each row of the Values.Then, enter %WM_SCAN1% in the
parameters you want to set in the Workflow Settings window or Keyword Settings window.For struc-
ture scan, select %WM_STRUCT% for Target Variable when the animation appears in the molecule
display area (e.g., by opening an SDF file). After the scan calculation is finished, use File → Project
→ Scan Results Viewer to tabulate the calculation results.

Import
Load the settings output by Export. Click the arrow to the right of the button to recall settings used
in the past on the same project or Winmostar.

Export
Output settings to file.

OK
Run a calculation or generate a file with your settings. See For project mode for details.

Details
Set detailed calculation conditions. The Keyword Settings will be launched.

Ensemble
Specifies the type of ensemble.
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Configuration

NVT ensemble=nvt
Ratio(Vol)=0
Ratio(Insert)=0

NPT ensemble=npt
Ratio(Vol)=0.001
Ratio(Insert)=0

uVT ensemble=uvt
Ratio(Vol)=0
Ratio(Insert)=0.001

GEMC-NVT ensemble=nvt
Ratio(Vol)=0.001
Ratio(Insert)=0.001

GEMC-NPT ensemble=npt
Ratio(Vol)=0.001
Ratio(Insert)=0.001

Temperature
Specify temperature.

Pressure
Specify pressure.

# of steps
Specifies the number of steps to execute.

# of snapshots
Specifies the number of steps to execute.

Chemical Potential
Specify chemical potential.

For equilibration
This is used for equilibration calculations, not for this calculation. It uses an algorithm that has no
statistical validity but allows the system to relax quickly.
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Configuration

True rmin=0.01
Specify nstep/maxdispfreq=False

False rmin=1.0
Specify nstep/maxdispfreq=True

Calc as Rigid
Forces the CBMC probability to be zero and computes the numerator as a rigid body. This improves
calculation speed because the computation of internal degrees of freedom is omitted.

Precision
Set calculation precision.

Configuration

Low rcut=8
ewald_prec=1d-4

Medium rcut=10
ewald_prec=1d-5

High rcut=12
ewald_prec=1d-6

8.3.3 Keyword Settings

Set the Towhee calculation conditions. After setting, press the Run button to run the calculation imme-
diately, or press the OK button to return to the main window once more. :guilabel:See Run Towhee for
behavior when Run is clicked. If there are molecules with no charge assigned, Assign Charges Automati-
cally will automatically start up. If no forcefield is assigned, Assigning force fields will automatically raise.
Reset button to return to the default state. The Save button saves your settings except for the Force Field.
The Load button loads the settings saved at Save.

Continue Simulation
Running continuation job. See Run Towhee for details.
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Preset
Specify presets for calculation conditions. Each preset changes the following keywords:

NVT
Equil

NVT
Prod

NPT
Equil

NPT
Prod

ensemble nvt nvt npt npt
Ratio(Vol) 0 0 0.001 0.001
Ratio(Insert) 0 0 0 0
rmin 0.01 1.0 0.01 1.0
Specify
nstep/maxdispfreq

False True False True

uVT
Equil

uVT
Prod

ensemble uvt uvt
Ratio(Vol) 0 0
Ratio(Insert) 0.001 0.001
rmin 0.01 1.0
Specify nstep/maxdispfreq False True

GEMC-NVT
Equil

GEMC-NVT
Prod

GEMC-NPT
Equil

GEMC-NPT
Prod

ensemble nvt nvt npt npt
Ratio(Vol) 0.001 0.001 0.001 0.001
Ratio(Insert) 0.001 0.001 0.001 0.001
rmin 0.01 1.0 0.01 1.0
Specify
nstep/maxdispfreq

False True False True

Basic
nstep

Specify the number of steps.

ensemble
Specify ensemble.

temperature
Specify temperature.

pressure
Specify pressure.
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chempot
Specify chemical potential.

random_seed
Specifies the seed of the random number.

random_allow_restart
In continuation jobs, inherit the state of random number generation in the previous job.

Specify ratio instead of cumulative probabilities
If checked, specifies the probability of each operation (translation, rotation, CBMC, volume,
insertion). If unchecked, specifies the integration probability; CBMC is an update operation for
intramolecular degrees of freedom.

Disable CBMC
Forces CBMC probability to 0. All molecules are treated as rigid.

Fix 1st component
Freeze the coordinates of the first molecular species that appears in the system (or the first molec-
ular species that appears through the first or second system in the case of GEMC).

Specify nstep/maxdispfreq
Give trmaxdispfreq and volmaxdispfreq as a ratio to nstep.

trmaxdispfreq
Specify how often to automatically update the maximum displacement for translational and ro-
tational operations.

volmaxdispfreq
Specify how often to automatically update the maximum displacement for volume operations.

Advanced (1)
pmtracm

Specifies the cumulative probabilities of translational operations; if Specify ratio instead of cu-
mulative probabilities is checked, you cannot enter the value directly and the automatically cal-
culated value will be displayed.

pmtcmt
Specifies the cumulative probability for each molecular species of a translational operation; if
there are more than two molecular species, enter them separated by spaces.

rmtrac
Specifies the maximum displacement for translational operations.

tatrac
Specify the target adoption rate to update with trmaxdispfreq.

pmrotate
Specify cumulative probabilities for rotational operations.If Specify ratio instead of cumulative
probabilities is checked, you cannot enter the value directly and the automatically calculated
value will be displayed.

pmromt
Specifies the cumulative probability for each molecular species of the rotation operation.If there
are more than two types of molecules, enter them separated by spaces.

rmrot
Specifies the maximum displacement for rotational operations.

tarot
Specify the target adoption rate to update with trmaxdispfreq.
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pmcb
Specify cumulative probabilities for CBMC operations; CBMC is an intramolecular degree of
freedom update operation.If Specify ratio instead of cumulative probabilities is checked, you
cannot enter it directly and the value will be calculated automatically.

pmcbmt
Specifies the cumulative probability for each molecular species in a CBMC operation.If there
are more than two types of molecules, enter them separated by spaces.

pmall
Specify the probability for each molecular species that the entire molecule will be regenerated
in a molecular regenerating operation.If there are more than two types of molecules, enter them
separated by spaces.

pmvol
Specify cumulative probabilities for volume operations.If Specify ratio instead of cumulative
probabilities is checked, you cannot enter the value directly and the automatically calculated
value will be displayed.

pmvlpr
Enter the total probability of volume operation for each phase, separated by spaces if there are
more than two phases.

rmvol
Specifies the maximum displacement for volume operations.

tavol
Specifies the target adoption rate to update with volmaxdispfreq.

Advanced (2)
pmuvtcbswap

Specify cumulative probabilities for insert and delete operations in GCMC. If Specify ratio in-
stead of cumulative probabilities is checked, you cannot enter the value directly and the auto-
matically calculated value will be displayed.

pmuvtcbmt
Specify the cumulative probability for each molecular species for insert and delete operations in
GCMC. If there are more than two types of molecules, enter them separated by spaces.

pm2boxrbswap
Specify the cumulative probabilities of rigid insertion operations in GEMC. If Specify ratio
instead of cumulative probabilities is checked, you cannot enter the value directly and the auto-
matically calculated value will be displayed.

pm2rbswmt
Specifies the cumulative probability for each molecular species of a rigid insertion operation in
GEMC. If there are more than two types of molecules, enter them separated by spaces.

pm2rbswpr
Specifies the integration probability for each interphase of a rigid insertion operation in GEMC.
If there are more than three phases of molecules, enter them separated by spaces.

pm2boxcbswap
Specify cumulative probabilities for flexible insertion operations in GEMC

pm2cbswmt
Specifies the cumulative probability for each molecular species of a flexible insertion operation
in GEMC
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pm2cbswpr
Specifies the integration probability for each interphase of a flexible insertion operation in
GEMC. If there are more than three phases of molecules, enter them separated by spaces.

Output
printfreq

Specify how often statistics should be output on standard output.

moviefreq
Specify how often to output trajectory files.

blocksize
Specifies the size of the block when block averaging.

backupfreq
Specify how often to output the restart file.

restartfreq
Specify how often to output a restart file with the number of steps in the name.

pdb_output_freq
Specify how often to output PDB files.

pressure_virial_freq
Specify how often to calculate virial pressure.

chempotperstep
Specifies the number of times per MC step of additional insertion operations for chemical po-
tential calculations.

loutchempotdata
Specify whether chemical potentials should be output to another file.

Interaction
rcut

Specifies the cutoff radius of the vdw(LJ) potential.

rmin
Specify a hard inner cutoff where no more atoms can approach. A reasonable value will speed
up the calculation.

rcutin
Specifies the inner cutoff used by CBMC.

ltailc
Specifies whether the cutoff correction term for the vdw potential is present.

electrostatic_form
Specify whether electrostatic potential calculations are performed.

coulombstyle
Specifies how the electrostatic potential is calculated.

kmax
Specifies the maximum wavenumber in the Ewald method.

kalp
Specify the product of the alpha parameter of the Ewald method and the short side of the cell.

rcelect
Specifies the real space cutoff radius for the Ewald method.
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ewald_prec
Specifies the relative precision of the Ewald method.

Options
Restore Working Folder

Click to restore the working folder to its pre-execution state, for example, when a continuation
job terminates abnormally.

Reset
Reset settings.

Import
Loading configuration file.

Export
Output configuration file.

8.3.4 Run Towhee

Runs Towhee. The method of execution depends on the situation.

• (Default) Continue Simulation is unchecked
Generate a new wmm file before starting the job.

• Continue Simulation is checked
Start a job using towhee_final in the working folder associated with the wmm file open in the
main window.

The following files will be generated upon execution. As an example, the file/folder name of the input file
is water.wmm. Note that the wmm file is Winmostar’s proprietary molecular structure file and is not directly
read by Towhee.

Type Description.

bat file
water.bat

This is a a batch file for running Towhee
and its pre- and post-processing.

Workign folder
water_twh_tmp\

Working folder

The following files are generated in the working folder. Only the major files are shown here.
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Type Description.

towhee_input This is the main input file with some of the
calculation conditions and force field
information.

towhee_ff This file contains force field parameters and
other information.

towhee_coords File with initial coordinates.

towhee_initial This is the towhee_final of the previous
job at the time of the continuation job.

lammps_data Coordinates and force field files for
LAMMPS used to generate
towhee_coords , towhee_ff ,
towhee_input.

gromacs.top lammps_data and topology file for
Gromacs with equivalent conditions. Can
be used for result analysis.

towhee.log Towhee’s standard output (log file).

towhee_movie Trajectory file generated by Towhee
calculations.

towhee_final This file contains the final state at the end of
the calculation (coordinates, various
parameters of the Monte Carlo method,
etc.).

Hint: **Working Folder**

• A working folder is a folder whose name is the name of the file opened in the main window
plus a suffix.
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– **Suffixes vary depending on the type of solver. **

– For example, in Gromacs, if the file open in the main window is aaa.gro with the
suffix _gmx_tmp, the working folder is named aaa_gmx_tmp.

• Must be placed in the same level as the file that is open in the main window.

• Processing flows in the working folder of the same name even for continuation jobs, but
by default, a backup of the working folder of the previous job is created just before the
continuation job is executed.

– The name of the backup will be the lowest numbered to the extent that there are no
duplicate names. For example, if your working folder is aaa_gmx_tmp, it will be
aaa_gmx_tmp1.

– **Unnumbered directories are always up-to-date. **

Job will be run with Winmostar Job Manager.

8.3.5 Show log

Open the Towhee log file ( towhee.log) in a text editor.

8.3.6 Displays excerpts of key information from the log file.

Displays excerpts of key information from the log file.

8.3.7 Animation

towhee_input and towhee_movie to animate the trajectory of the MC calculation. See Animation op-
eration area for animation display controls.

8.3.8 Energy Change

Select towhee.log to display graphs of various thermodynamic quantities such as energy, temperature,
and pressure. See Energy Plot window for subwindow operation.
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CHAPTER

NINE

HOW TO ADJUST THE ATOMIC AND MOLECULAR STRUCTURE
DISPLAY

9.1 How to display a specific molecule in the presence of many
molecules such as MD

1. First load the entire system you want to display as usual. The same goes for animations.

2. Select a group of molecules to display. See Select menu for how to select a group.

3. view → Transparency, click make all atoms transparent, then click make group selected atoms opaque and adjust
transparency as needed. Adjust transparency accordingly.

9.2 How to show/hide atoms just above the simulation cell at both
ends of the cell in crystals

Display → Display Presets If you want more fine-tuning, adjust the settings for Tools → Preferences →
Display → Display Items → Atoms on cell boundaries duplicated at both ends.

9.3 How to make a drawing (in two shades of black and white) for a
patent application document

Tools → Preferences, click the Display tab, check the Display for patent applications checkbox and click
OK If the outlines are too coarse, zoom the camera in.
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TEN

INTEGRATION WITH OTHER SOFTWARE

10.1 Integration with ChemDraw and Chem3D

Obtain and install ChemDraw or Chem3D at your own risk. Molecules created by drawing structural formulas in Chem-
Draw can be loaded into Winmostar via the following SMILES format or mol format.When importing 3D structures
created by Chem3D, please use Gaussian input format from Chem3D to Winmostar, because the 3D structure and
hydrogen atom information will be missing via SMILES or mol format.

10.1.1 Reading from ChemDraw in SMILES format

The operating procedure is as follows.

1. After modeling the molecule in ChemDraw, click Edit → Copy As → SMILES.

2. In Winmostar, click on file → import → SMILES and paste the string into the Enter SMILES field.

3. Click the Import button to model the molecule in the main window.

10.1.2 Reading from ChemDraw in mol format

The operating procedure is as follows.

1. After modeling the molecule in ChemDraw, click on File → Save As and select the MDL MolFile format to save
the file.

2. Winmostar will automatically adjust the bond length and add hydrogen to the mol file because the mol file in
ChemDraw does not contain hydrogen and the bond length is not appropriate.

10.1.3 Reading from Chem3D in Gaussian input file format

The operating procedure is as follows.

1. After modeling the molecule in ChemDraw, click on File → Save As and select the MDL MolFile format to save
the file.

2. Open the file you just saved in Winmostar and the molecules will be displayed in the main window. After that,
set up your calculations from Configure of the solver you want to use.
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10.2 Working with VMDs

VMDs are obtained and installed by the user at his/her own risk.

10.2.1 For animation

1. With the animation displayed, click Options → Export → Animated GRO File. . . to save the gro file.

2. Start VMD, then click File → New Molecule. . . and open the gro file saved in 1.

10.2.2 If not animated

1. File → Export File and save it in gro or pdb format.

2. Start VMD, click File → New Molecule. . . and open the file saved in 1.

10.3 Working with VESTA

Obtain and install VESTA at your own risk.

1. Tools → Preferences, on the Basic tab, check Use external viewer to view Cube files, on the Program
path tab Cube Viewer and specify the VESTA executable file ( VESTA.exe ).

2. When you open a cube file in Winmostar, a Cube Plot window will open, click the Draw button and
VESTA will open.
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CHAPTER

ELEVEN

OTHER TOPICS

11.1 How to launch from the command prompt

It is possible to start by specifying various options from the command prompt.
Specify the input file name and processing contents in the option.
The processing contents that can be specified are as follows.
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Recognize input files as SMILES and build molecules
(using Balloon)
(Professional Edition Premium Elite Only)

smilesballoon

Recognize input files as SMILES and build molecules
(using OpenBabel)
(Professional Edition Premium Elite Only)

smilesbabel

Execution of MOPAC

-mopac1, -mopac2, -mopac3
These correspond to the three MOPAC binaries selected
in Tools → Preferences menu → Program Path.

Molecular Surface Area & Volume -molsv
Aspect Ratio -aspect
Radius of Gyration -radgyr
Adjust All Bond Lengths -adjust
To all atoms -hadd
Delete All Hydrogens -hdel
Quick Optimization -clean
Use RESP charges (only for one molecule) -resp (charge value, 0 for neutral molecules)

Use AM1-BCC/Gasteiger charges (only for AM1-BCC
one molecule)
(Professional Edition Premium Elite Only)

-am1bcc (charge value, 0 for neutral molecules) (Profes-
sional Edition Premium Only)

Solvate/Build Cell (the first argument is ignored) -pack (file name of 1st molecule type):(number
of 1st molecule type):(file name of 2nd molecule
type):(number of 2nd molecule type) . . . (density
[g/cm^3])

Insert Molecules
(Professional Edition Elite Only)

-insertmol (file name of 1st molecule type):(number
of 1st molecule type):(file name of 2nd molecule
type):(number of 2nd molecule type) . . . (enumerated
similarly thereafter)

Calculation of LAMMPS (Local Job)
(The lmpset file can be obtained from the Save button
in the LAMMPS Preference window.)
(lmpset files are specified by relative path from the first
argument)

-lammps (type of forcefield) (preset name or lmpset file
name of the 1st job):(preset name or setting file name of
the 2nd job) . . . (parralel number)

Output LAMMPS coordinate file
(see Assign Force Field for force field type)
(Professional Edition Premium Elite Only)
Specify UFF or Dreiding as “GAFF(1=UFF)” etc. for a
partial species in the force field for general molecules.

-lammpsfile (type of force field for general molecules)
(type of force field for water molecules) (name of data
file to output)

Output Gromacs coordinate and force field files
(see Asign Force Field for force field types)
(Professional Edition Premium Elite Only)

-gromacsfile (type of force field for general molecules)
(type of force field for water molecules) (name of output
gro file) (name of output top file)

Build Cluster Model
(Professional Edition Elite Only)
New specifications for V11.13.0 and later

-slabbuilder (h) (k) (l) (supercell size in direction a) (su-
percell size in direction b) (true if cells are forced to be
rectangular, false otherwise) (true if slab size is speci-
fied per unit cell, false if specified in angstrom) (slab size
value) (vacuum layer size value) (true if surface is hydro-
gen terminated, false otherwise) (true if vacuum layer is
not inserted)

Build Cluster Model
(Professional Edition Elite Only)
Old specifications before V11.12.X

-slab (h) (k) (l) (supercell size in direction a) (super-
cell size in direction b) (true if you want to force the c
axis to be perpendicular to the a and b axis, false other-
wise) (true if you want to convert hexagonal to orthorom-
bic, false otherwise false) (true if you want to specify
the minimum slab size as number of hkl planes, false if
you want to specify it as angstrom) (minimum slab size
value) (c-axis length of the entire system)

Generate Supercell
(Professional Edition Elite Only)

-supercell (number of cells along axis a) (number of
cells along axis b) (number of cells along axis c) (regen-
bond to regenerate bonds, noregenbond not to regenerate
bonds)

Deform cells in uniaxial direction
(Professional Edition Elite Only)

-editcellaxis (inclen to specify the change in cell size,
totlen to specify the cell size after the change, strain to
specify the strain, density to specify the density after the
change) (value to specify) (axis direction (a, b or c) to de-
form) (posi for + direction, nega for - direction, both for
the both direction) (keepfrac to keep the fractional co-
ordinates, nochange to keep the fractional coordinates)
(keepintra to keep the coordinates in the numerator, no-
keep to keep the coordinates in the numerator)

Change file type and save -o output_file_extension

Save the file by specifying a file name
(if a relative path is specified, the UserData folder is the
starting point)

-outfile output_file_name
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Use case:

\"C:\\winmos11\\winmostar.exe\" COO -s -smilesballoon -outfile ethanol.mol2
\"C:\\winmos11\\winmostar.exe\" \"C:\\winmos11\\samples\\dbt.dat\" -s -mopac1
\"C:\\winmos11\\winmostar.exe\" \"C:\\winmos11\\samples\\dbt.dat\" -s -molsv 1 2.0␣
→˓0.02
\"C:\\winmos11\\winmostar.exe\" \"C:\\winmos11\\samples\\dbt.dat\" -s -o pdb
\"C:\\winmos11\\winmostar.exe\" \"C:\\winmos11\\samples\\dbt.dat\" -s -adjust -hadd␣
→˓-clean -o gjf
\"C:\\winmos11\\winmostar.exe\" \"C:\\winmos11\\samples\\ch4.mol2\" -s -pack ch4.
→˓mol2:100:ethanol_am1.mol2:2 0.6 -outfile ch4_100_etoh_2.mol2
\"C:\\winmos11\\winmostar.exe\" \"C:\\winmos11\\samples\\ch4_100_etoh_2.mol2\" -s -
→˓lammps "Dreiding" "Minimize (fast):NVT (fast):NPT (fast)" 2
\"C:\\winmos11\\winmostar.exe\" \"C:\\winmos11\\samples\\ch4_100_etoh_2.mol2\" -s -
→˓lammpsfile GAFF SPC/E ch4_100_ethoh_2_auto.data

Specify input file at first argument.
When -s is specified, Winmostar ends automatically after processing, so you can write DOS BAT file and run
MOPAC etc. continuously. See Sampleswmjobs.bat for reference.
Commands starting with “-” except “-s” are executed in the order specified.
If you want to run Gaussian and GAMESS sequentially, use Tools → Batch Queue instead.

11.2 CygwinWM

CygwinWM is Cygwin for Winmostar. It is called internally by Winmostar in the processing described in
this manual as follows.

Warning: To use this function, CygwinWM setup is required.

Installation method is described in CygwinWM setup.

Warning:
• Some security countermeasure software may automatically delete or interfere with normal mod-

ule in CygwinWM due to malfunction.

• If you download and install the CygwinWM installer from the Winmostar official HP, you can
easily check for missing files in CygwinWM by using Help→Check CygwinWM function. (Only
the existence of the file is checked.)

• If trouble occurs with the function that uses CygwinWM, please also check the activity report of
security countermeasure software.

If you select Tools → Cygwin, you can start the console of CygwinWM directly.
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11.3 Force Field

11.3.1 Universal Force Field

The Universal Force Field (UFF) available in Winmostar’s molecular dynamics calculations (Gromacs,
LAMMPS) is implemented as follows. First, use OpenBabel’s UFF parameter assignment function to
assign parameters to the molecule of interest. Then, for atoms that do not correspond to the atom type
described in the original UFF paper [Rappe1992], the Coordination is automatically changed and a closer
atom type is assigned. See the OpenBabel source code for more information. The functional form of
UFF cannot be completely reproduced by the functions available in Gromacs and LAMMPS, so the coef-
ficients are converted for the functions available in Gromacs and LAMMPS using the method of OBGMX
[Garberoglio2012]. For the Improper torsion, the same harmonic function (improper_style harmonic) is
used instead of the LAMMPS improper_style fourier. Improper torsion is calculated using the same har-
monic function (improper_style harmonic) as in Gromacs, instead of using the improper_style fourier in
LAMMPS. In addition, fourth-order function is used in Winmostar because the Angle potential in the
square planar and octahedral structures does not give a proper stable structure due to the fact that there is
only one minuscule point int OBGMX method. The coefficients of the quadratic function were determined
by the following policy.

• Reproducing the position (angle, energy) of two potential minimum points

• Reproducing the energy of a maximum point between two potential minima

• In the case of LAMMPS, however, the coefficient of zero order cannot be set, so only the energy is
shifted by a constant amount (the force, which is a derivative of the energy, is the same for Gromacs
and LAMMPS, so there is no practical effect).

Because of the above policy, the resulting equilibrium structure and distribution is expected to remain
largely unchanged from the case using the UFF original potential. Note that the widely used OpenBabel
also adds its own penalty function to the Angle potential, which strictly deviates from the UFF original
potential. In Winmostar, the coefficients of Angle for square planer and octahedral are as follows. 𝐶𝑖,gro

is the coefficient of Gromacs’ fourth-order function, 𝑘𝑎,uff is the coefficient of UFF; in LAMMPS, only
𝐶2,gro and 𝐶4,gro are used.

𝐶0,gro =
1

4
(2−

√
2)𝑘𝑎,uff

𝐶1,gro = 0

𝐶2,gro = − 8

𝜋2
(2−

√
2)𝑘𝑎,uff

𝐶3,gro = 0

𝐶4,gro =
64

𝜋4
(2−

√
2)𝑘𝑎,uff

𝜃0,gro =
3

4
𝜋

Also, the calculation of Improper torsion angle in Gromacs depends on the order of particle indices (jkl)
(LAMMPS does not). Therefore, Winmostar automatically adjusts the index order so that the results in
Gromacs and LAMMPS are consistent. (For details, see Gromacs to LAMMPS force field file conversion)
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11.3.2 Dreiding

Dreiding, which is available in Winmostar’s molecular dynamics calculations (Gromacs, LAMMPS), is
implemented as follows. As for Improper torsion, Gromacs does not implement the function for dreiding,
so I use harmonic (funct=2) in Gromacs and improper_style umbrella in LAMMPS to calculate it. In
Winmostar, the coefficients are converted as follows. 𝑘𝜉,gro are the coefficients of Gromacs and 𝐾lmp are
the coefficients of LAMMPS. We adopt the form of the Taylor expansion at the potential minima, ignoring
after the fourth-order terms.

𝐾lmp =
1

2
𝑘𝜉,gro

11.4 Editing an SDF file

SDF files are widely used in material informatics and machine learning.

11.4.1 Visualization of SDF file

If you select a SDF file from Open File and open it, Animation operation area will be displayed and you
can check each structure in the SDF file in turn.

11.4.2 Editing an SDF file

1. After opening the SDF as described above, you can choose Options→Export All Frames Separately in Animation
operation area to output each structure as a separate file in the selected folder.

• If you want to adjust bond lengths, add hydrogen, or do quick optimization for each structure in a SDF
file, click Automation → Check All of Animation operation area, then do Options → Export All Frames
Separately or File → Export Run the `SDF File.

• If you want to output a Gaussian input file (gjf file), do Configure before executing Options → Export All
Frames Separately.

2. Then drag and drop a file corresponding to each structure into Open File or Winmostar to open it, edit it, and
save it from Save to overwrite it.

3. If you select the folder you just output from Aggregate multiple files into SDF format, you can create the SDF
file again.

11.5 Functional verification of Winmostar

Winmostar maintains its high quality by calling on open source software used by researchers around the world. On the
other hand, there are some features that strongly depend on Winmostar’s own implementation, and here we show the
validation results of such features. The verifications shown here have been performed prior to release.
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11.5.1 Gromacs to LAMMPS force field file conversion

Winmostar generates a data file for LAMMPS using a generic force field by converting the top file for Gromacs. Here are
the results of calculating the energy for the same system using Gromacs and LAMMPS with this conversion mechanism.

Table 1: Relative energy difference between Gromacs and LAMMPS for
each energy component

Force Field Bond Angle Dihedral Improper Coulomb Vdw Total
UFF 2.57E-8 6.965E-9 1.17E-8 2.11E-8 7.21E-8 3.71E-8 7.55E-9
Dreiding 6.32E-9 4.25E-8 7.20E-9 5.37E-8 7.21E-8 3.62E-8 2.47E-8
GAFF 2.82E-8 3.06E-8 1.10E-8 2.97E-9 7.61E-8 9.51E-10 3.62E-9
OPLS-AA/L+GAFF 2.82E-8 3.06E-8 1.10E-8 2.97E-9 7.22E-8 1.67E-8 6.31E-8
OPLS-AA 1.64E-9 2.60E-8 1.10E-8 2.97E-9 7.22E-8 1.67E-8 5.93E-9

The detailed calculation conditions are as follows

• One molecule of benzene, calculated with AM1-BCC charge

• Free boundary condition, cutoff radius 20 Å, no constraints on bond length or angle

• Gromacs uses the 5.0.7 double precision version, LAMMPS uses the March 9, 2016 version

• Coulomb, Vdw includes 1-4 interactions

• Dreiding’s Improper is calculated with Improper Harmonic because Gromacs does not have a function equivalent
to LAMMPS’ Improper_style umbrella.

• Since the 1-4 interaction scaling coefficients in Gromacs are processed internally in single precision, the single
precision equivalent coefficients are also set in LAMMPS.

• The files generated by mktop is used for OPLS-AA

From the above table, we can see that the energies of Gromacs and LAMMPS are in agreement by 8-10 orders of
magnitude for all components. It is difficult to get an exact match due to minor implementation differences between
Gromacs and LAMMPS (e.g., approximate calculations of various functions, parallel calculations, etc.). Similar tests
have also been conducted on systems focusing on each component of energy, multi-molecular systems, etc.

11.6 Regarding various parameters

11.6.1 Physical constants

The physical constants used in Winmostar are the 2018 CODATA recommended values [2018CODATA].

11.6.2 Atomic data

The following are references for atomic data used in Winmostar.

Covalent radius (single bond) [Cordero2008]
Covalent Radius (Multiple Coupling) [Pyykko2008]
van der Waals radius (typical elements) [Mantina2009]
van der Waals radius (transition metal elements) [Rahm2016]
Atomic mass [NIST966]

11.6. Regarding various parameters 319



Winmostar™ User Manual, Release 11.13.0

Note that you can set the display radius of each element to any value by editing the third column of atoms1.wmx in
Help → Open Preferences Folder.

11.6.3 Combining Criteria

single bond decision

If the distance between two atoms is shorter than the sum of the covalent bond radii (single bond) of each atom multiplied
by the bonding coefficient, then it is determined to be a single bond. As an exception, H-H, O-O, and F-F bonds are
determined by multiplying the values in the following table (unit: Å) by the bond coefficient. The H2, HOOH, and F2,
respectively, were calculated using structural optimization calculations in B3LYP/6-31G*.

H-H 0.74
O-O 1.45
F-F 1.40

Multiple join determination

For some two-atom combinations, if the distance between the two atoms is shorter than the sum of the covalent bond
radii (multiple bonds) of the respective atoms times 1.03, it is determined to be a double or triple bond. If it is shorter
than 1.03 times the sum of the averages of the single and double bonds, it is determined to be a 1.5-fold bond (aromatic
bond). As an exception, N=N, O=O, and P=O double bonds are determined by multiplying the values in the following
table (unit: Å) by 1.03. HNNH, O2, H3PO4, respectively, were calculated using structural optimization calculations in
B3LYP/6-31G*.

N=N 1.246
O=O 1.215
P=O 1.473

The following table shows the types of bonds that are being judged.

Binding type 1.5 double bond double bond triple bond
C-C ✓✓✓ ✓✓✓ ✓✓✓
C-N ✓✓✓ ✓✓✓ ✓✓✓
C-O ✓✓✓
C-S ✓✓✓ ✓✓✓
N-N ✓✓✓ ✓✓✓ ✓✓✓
N-O ✓✓✓ ✓✓✓
O-O ✓✓✓
P-O ✓✓✓
P-S ✓✓✓
S-O ✓✓✓
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KNOWN PROBLEMS

• If you start Winmostar with administrator privileges, you can not open files with drag-and-drop.

• Some software will not work if the Windows option “Use Unicode UTF-8 for worldwide language support” is
enabled.

• Opening some subwindows such as Animation, Submit Job and so on, it will not appear even if you try to open
again after closing.

• Graph display at the bottom of animation operation area is corrupted. Other UI displays are corrupted.

• If you select a range of text in the console window where the job of the local machine is flowing, the job is
recognized as terminating on Job Manager.

• Gromacs freezes while running Gromacs on local machine.

• When using the RISM compatible version of Quantum ESPRESSO, it may be displayed that the main window
keyword has been changed even though it has not been changed.

• MOL files that could be processed successfully with the ESM-RISM version of QE based on Quantum
ESPRESSO 6 cannot be read properly when using QE 7.1.

• The units of Isothermal Compressibility and Adiabatic Bulk Modulus output by Gromacs are wrong.

• Molecules that should be connected to each other are displayed separately in the structure or the final structure
after loading the Gromacs trajectory.

• When loading SMILES strings using [File]-[Import]-[SMILES], but the structure is not loaded as intended.

• Winmostar freezes when deleting the working directory or working folder directly on Windows (Explorer)
while Winmostar is processing.

• Cannot open large size cube file in Winmostar Viewer.

• Winmostar toolbar and tool buttons are displayed incorrectly when Windows display magnification is other
than 100%.

• Under some conditions, LAMMPS fails to recognize elements in the structure file after the calculation is
completed when using a potential file.

• Cannot exit a job from the Stop menu from Job Manager in Windows 11.

• Molecules with the same composition and different binding modes are recognized by the same molecular
species in the force field assignment function.

• The crystal symmetry detection process fails when the security software McAfee is running.
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12.1 If you start Winmostar with administrator privileges, you can not
open files with drag-and-drop.

In the current Winmostar (Winmostar V.8), if you start Winmostar with administrator privileges, you can not open the
file by dragging and dropping. It is due to be fixed in the future, but the working time is unknown. (Reported on May
24, 2018)

12.2 Some software will not work if the Windows option “Use Unicode
UTF-8 for worldwide language support” is enabled.

In Windows 10, if [Control Panel] - [Clock and Region] - [Change Date, Time, and Numeric Format] - [Manage]
- [Change System Locale] - [Use Unicode UTF-8 for World Wide Language Support] is checked, various remote
job executions, LAMMPS execution, and FDMNES execution failed when the “Use Unicode UTF-8 for World Wide
Language Support” checkbox is checked. The problem is due to files being output with a BOM. We are working to
address Winmostar sequentially at the time the problem occurred, but please let us know if you experience similar
problems with other functions. (Reported May 25, 2018)

12.3 Opening some subwindows such as Animation, Submit Job and
so on, it will not appear even if you try to open again after closing.

It has been confirmed in only a few environments. If it does not appear, a menu such as [Return to original size]
[Move] [Size change] . . . will appear when you press Alt + Space key, so when selecting [Move] and dragging it, the
window reappears I will. Alternatively, it can be resolved by restarting Winmostar. We are currently considering better
countermeasures. (Reported on 14th June 2018)

12.4 Graph display at the bottom of animation operation area is cor-
rupted. Other UI displays are corrupted.

If you change the size of desktop text or other items from the default value (100%), the display will collapse. For
Windows 8, set [Control Panel] - [Customize Desktop] - [Display] - [Change the size of all items] to Small -100%
(prescribed). For Windows 10, set [Windows setting] - [system] - [display] - [custom scaling] to [100]. (Reported on
June 26, 2018)

12.5 If you select a range of text in the console window where the job
of the local machine is flowing, the job is recognized as termi-
nating on Job Manager.

In the Windows 10 console window, selecting the range of the log text of the job being executed will recognize that the
job has ended. If this causes a problem, open the log file to be output directly with a text editor, and select and copy
the range of the text there. If processing is interrupted after selecting the range, processing will resume by pressing the
Enter key. It occurs in Windows 10 or later. (Reported on July 20, 2018)
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12.6 Gromacs freezes while running Gromacs on local machine.

On some machines, Gromacs freezes while running Gromacs on the local machine. It occurs during MD calculation and
the contents of standard output do not change. There is no reproducibility in the place where it freezes. In such cases,
you can avoid by setting “# of Threads” of Gromacs Configure to 1. As a matter of course, processing becomes slower,
please use remote job submission function using remote server if you want to run full-scale calculation. LAMMPS can
be used with Winmostar in a similar way to Gromacs, so you can also choose to use LAMMPS. (Reported on December
4, 2020)

12.7 When using the RISM compatible version of Quantum
ESPRESSO, it may be displayed that the main window key-
word has been changed even though it has not been changed.

During constant-mu calculation (lfcpopt = .True.), it is erroneously determined that the value of fcp_mu has been
updated. Since the value is not actually changed, it can be used as is. (Reported on June 2, 2019)

12.8 MOL files that could be processed successfully with the ESM-
RISM version of QE based on Quantum ESPRESSO 6 cannot be
read properly when using QE 7.1.

This problem occurs when a string in a tag such as MOL_INFO contains an & (ampersand) (e.g., H2O.tip5p.MOL,
which is provided with the program). Removing the ampersand will allow normal processing. (Reported on January
29, 2025)

12.9 The units of Isothermal Compressibility and Adiabatic Bulk Mod-
ulus output by Gromacs are wrong.

In the gmx energy log, the units for Isothermal Compressibility is “J/m^3”, but the correct unit is “m^3/J”. Similarly,
the Adiabatic Bulk Modulus unit is correctly “J/m^3”. (Reported on June 29, 2020)

12.10 Molecules that should be connected to each other are displayed
separately in the structure or the final structure after loading
the Gromacs trajectory.

This is due to a bug in Gromacs itself. The longer the calculation time, the more likely it is to occur. However, there
is no problem with the MD calculation itself, since the atomic configuration is correct when periodic boundaries are
taken into account. The problem occurs especially when two systems are joined by an interface builder. There are two
ways to put a disjointed molecule back together. The first method is to select [MD]-[Gromacs]-[Assign Force Field],
then [Use Parameters Written in Topology File] and select the top file of the target data. In the second method, first, in
[Edit]-[Rearrange atoms based on periodic boundary conditions], click [Rearrange atoms inside cells atom by atom] →
click [Apply] → click [Revert rearranged structure atom by atom] → click [Apply] → click [OK]. However, since this
operation must be performed in the same cell as when the calculation was performed, please perform it before using
the interface builder, etc. (Reported on December 25, 2020)
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12.11 When loading SMILES strings using [File]-[Import]-[SMILES],
but the structure is not loaded as intended.

There are several programs in the world that load SMILES, and each of them has a slightly different im-
plementation that can change the molecules generated. Winmostar uses either OpenBabel or Balloon to im-
port SMILES, and you can choose which one to use in the Import SMILES window. For example, in Open-
Babel, “C[C@@H]1CCCC[C@@@H]1C” (originally cis-1,2-Dimethylcyclohexane) was recognized as trans-1,2-
Dimethylcyclohexane. (Reported on January 29, 2020)

12.12 Winmostar freezes when deleting the working directory or
working folder directly on Windows (Explorer) while Winmostar
is processing.

Delete when the process is finished or when Winmostar is closed. (Reported on December 24, 2021)

Hint: **working folder**

• A working folder is a folder whose name is the name of the file opened in the main window plus a
suffix.

– **The suffix varies depending on the type of solver.**

– For example, in Gromacs, if the file opened in the main window is aaa.gro and the suffix is
_gmx_tmp, the working folder will be named aaa_gmx_tmp.

• It must be placed in the same directory as the file opened in the main window.

• The process runs in a working folder of the same name during a continuation job, but by default, a
backup of the working folder of the previous job is created just before the continuation job is executed.

– The name of the backup will be the one with the lowest number, as long as there are no duplicate
names. For example, if your working folder is aaa_gmx_tmp, then it will be aaa_gmx_tmp1.

– **Un-numbered directories are always up-to-date.**

12.13 Cannot open large size cube file in Winmostar Viewer.

Please use other cube file visualization software such as VESTA or VMD. You can directly launch them instead of
Winmostar Viewer by checking [Tools]-[Preferences]-[Basic]-[Use external viewer to display cube files] in Winmostar
and specifying the cube file visualization software in [Program path]-[Cube Viewer]. You can directly start those
software instead of Winmostar Viewer. (Reported October 21, 2022).
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12.14 Winmostar toolbar and tool buttons are displayed incorrectly
when Windows display magnification is other than 100%.

In Windows 10, this can be changed by going to Settings→System→Display→Scaling and Layout. If the display is
too small to read the text, reduce the screen resolution. (Note that this feature in Windows is also a problem for various
applications other than Winmostar.) (Reported on October 28, 2022)

12.15 Under some conditions, LAMMPS fails to recognize elements in
the structure file after the calculation is completed when using
a potential file.

For example, if you use the MEAM potential available in the NIST repository to calculate the mass of a Sn crystal,
the file output by the write_restart command will show a mass of “118” instead of “118.7107”. Winmostar recognizes
elements based on their mass values, and if it cannot recognize an element, it judges it as a coarse-grained atom such
as CGA. This is a bug in LAMMPS (at least confirmed in the 20160309 version), so please correct the masses in the
Masses section of the final structure data file using a text editor, etc. (Reported on December 8, 2022)

12.16 Cannot exit a job from the Stop menu from Job Manager in Win-
dows 11.

Please close the calculation window or terminate the process using Task Manager or similar. In the case of NWChem,
some users have reported that the CPU usage of the Job Manager becomes so high that it cannot even be terminated.
(Reported on May 20, 2023)

12.17 Molecules with the same composition and different binding
modes are recognized by the same molecular species in the
force field assignment function.

This has been fixed in Winmostar V11.2.0. Users of Winmostar V10 or earlier should upgrade to Winmostar V11.

12.18 The crystal symmetry detection process fails when the security
software McAfee is running.

When the security software McAfree is running, the symmetry detection process that is executed when starting
the slab creation function or the workflow setup and keyword setup functions of Quantum ESPRESSO, OpenMX,
VASP, AkaiKKR, etc. may fail. This may be caused by the automatic removal of an internal module called find-
prim_spglib.exe. In this case, stopping (or pausing) McAfee will allow the process to run successfully. (Reported on
February 27, 2025)

12.14. Winmostar toolbar and tool buttons are displayed incorrectly when Windows display
magnification is other than 100%.
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FREQUENTLY ASKED QUESTIONS · TROUBLESHOOTING

• Purchase

– Q. Please tell me how to pay the price.

– Q. Please tell me the types of documents issued by the company.

– Q. How do I place an order other than an end user, such as an agency?

– Q. Is it possible to split the price of Winmostar and maintenance? Is it possible to sell maintenance only?

– Q. Is there a warranty for the product?

– Q. Is there any discount for personal use? Do you have a license for individuals?

– Q. I am both an educational and research institution. Can I use my institution’s budget to purchase a
license for an educational institution?

– Q. What is the process of signing a site license agreement when purchasing a site license from a distrib-
utor?

– Q. Can I purchase on a daily or monthly basis?

– Why is Winmostar more cost-effective than similar GUI software products from other companies?

• License Code

– Q. Is it possible to change the registered user of a specific user license?

– Q. If I move from the institution where I purchased my educational license to another institution, can I
continue to use that license?

– Q. Do I need to reinstall the software when I change editions, such as from a free edition to a student
edition, or from a free trial to a professional edition?

– Q. Can I install different editions of Winmostar, such as the free version and the professional version?

– How do I change an already entered license code?

– Q. Please tell me how to display the MAC address.

– Q. Does Winmostar license fee include Gaussian and/or VASP license fee, and is there a Winmostar
lineup with Gaussian and/or VASP license?

– Q. What will happen to my Winmostar when the license expires?

– Q. Can I purchase a license for an educational institution for my personal learning purposes?

– Q. What is the procedure for renewing my license?
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– Q.. What if a teacher wants to pre-evaluate the student edition that the supervising student is going to
use?

– Q. What happens when the Professional Edition (Trial) expires? Will I have to pay a fee?

• Support and Maintenance

– Q. What does maintenance include?

– Q. If I have a question, can I email the person in charge directly?

– Q. What is the difference between paid e-mail support (support on how to operate via e-mail) and free
inquiry form questions?

– Q. Can I get support for bugs or patches?

– Q. How long do you plan to support and maintain the previous version?

– Q. Who is the developer (manufacturer) of Winmostar? Where is it manufactured?

– Q. Can I get in touch with the developer (manufacturer) directly?

– Q. Is it possible to update/upgrade version of the Winmostar I am using?

– Q. Are there any precautions when asking a question?

– Q. Do you sell maintenance only?

– Q. Do you sell maintenance only?

– Q. What happens when the annual maintenance on a perpetual licence expires?

– Q. Do you offer technical support for your various solvers? How can I get technical support for various
solvers?

– Q. Do you provide support via telephone or online meetings?

• Functions and use of the software

– How to pronounce Winmostar.

– Q. Does Winmostar connect to internal and external servers or the cloud, or can it be used without a
LAN connection?

– Q. Please tell me the minimum and recommended specifications of PC for Winmostar.

– Q. Is it possible to use the data generated by Winmostar for conference presentations and papers? How
should I quote at conference presentations and paper submissions?

– Q. Is it possible to upload videos or images of the Winmostar screen to YouTube or other web sites?

– Q. Do you have any calculation software installed on Winmostar itself?

– Q. Do you let Winmostar run calculations in the cloud?

– Q. Does Winmostar support GPU computation?

– Q. Which CPU is more suitable for operation, Intel or AMD? Which one would you recommend?

– Q. Is it possible to do parallel computation using Winmostar?

– Q. Is there an upper limit to the number of cores that can be used for parallel computing using Win-
mostar? Does the cost vary depending on the number of cores available?

– Q. Does Winmostar work on macOS and Linux?

– Q. How can I install Gaussian?
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– Q. How can I install VASP?

– Q. Windows or Explorer freezes when I start the CygwinWM installer. What should I do?

– Q. How many atoms or molecules can I calculate with Winmostar? Is there an upper limit to the number
of atoms or molecules that can be handled?

– Q. Can I use Winmostar to calculate coarse-grained models?

– Q. What is the difference between the latest stable version and the latest development version? Which do
you recommend?

– Q. Who owns the rights to the calculation results and output files obtained using Winmostar?

• Software operations

– Q. I can not create a model as I expected. It can not calculate. It does not work.

– Q. “ERROR: I/O error 32” is displayed and the processing fails.

– Q. Process using Cygwin will end abnormally. / Help → Check CygwinWM function will display . . .
ERROR . . . . / Cygwin’s black window shows child_info_fork :: abort: . . . Loaded to different address:
parent . . . ! = Child . . . .

– Q. Help → Check CygwinWM function displays No reference file (. . . filelist_cygwinwm.txt) was
found. . . .

– Q. Help → Check CygwinWM function will display WARNING . . . some files are missing.

– Q. Tools → Diagnose CygwinWM function shows ERROR . . . Failed to generate a current file list.

– Q. Tools → Diagnose CygwinWM function displays ERROR: Getting SMILES . . . . OpenBabel process
terminates abnormally.

– Q. The job registered in Job Manager is not executed.

– Q. When executing a job, an alert saying “Unable to execute (Access denied.)” appears and the job will
not start.

– Q. In the functions where a black console window appears, such as various functions of Winmostar or the
execution of the solver, the processing of the black console window does not end and does not proceed.

– Q. When I open a file or model a molecule, the bonds no longer appear or a lot of extra bonds have come
to appear.

– Q. How do I view the extension in Windows Explorer?

– Q. Markers (red circles) and group selections (blue circles) are not displayed. Atoms can no longer be
selected.

– Q. The toolbar and tool buttons are not displaying properly. Can I fix it?

– Q. What is an optimization flag?

– Q. Can I have Winmostar not run calculations directly from Winmostar and just save the file, or can I
edit the file that Winmostar generates and then run the job?

– Q. Is it possible to use the latest version of each solver or a version not listed in Winmostar’s operating
environment?

• File I/O

– Q. I cannot open files created by other than Winmostar with Winmostar. When I edit the file generated
by Winmostar and try to open it with Winmostar, it cannot be opened.
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– Q. When opening a file in MOL or SDF format, the bond length becomes unnatural. Hydrogen does not
appear.

– Q. When I load SMILES, it does not generate the intended structure. Why is this? What should I do?

• On the modeling of molecules and creation of systems

– Q. How do I change the type of chemical bond (single, double etc.)?

– Q. MD → Solvate/Build Cell function will display Error: Failed to solvate. and processing will fail.

– Q. When I run some functions, I get \357\273\277 etc. and the process fails.

• MPI on local machine, parallel execution

– Q. Why does the parallel computation that flows by itself terminate abnormally? The parallel test in the
installation test succeeds. Serial calculations also terminate normally.

– Q. MPICH ends during computation.

– Q. When executing parallel MPI of LAMMPS or Quantum ESPRESSO, warning is displayed as Unable
to open the HKEY_LOCAL_MACHINE\SOFTWARE\MPICH\SMPD\process\???? registry key, error
5 , Access denied.

– Q. The installation of .NET Framework 3.5 using dotNetFx35setup.exe fails. What should I do?

– Q. I cannot find the number of parallels I want to set when I pull down the Number of Parallels combo
box. How can I set the number of parallels I want?

• Remote Jobs

– Q. Please tell me how to submit a job to a supercomputer or a linux server in my company or my campus.

– Q. I cannot connect from Winmostar to a server that allows SSH connections with various terminal
software.

– Q. SSH connection with public key method fails, when I specify the same private key file with other
software such as TeraTerm or Cygwin, the connection succeeds. Is there a solution?

– Q. The connection test with Test Connection succeeds, but the job submission fails.

– Q. Connection test with Test Connection succeeds, but Putty’s WARNING is displayed and various op-
erations fail.

– Q. What type of MPI (MPICH, OpenMPI, etc.) can I use on the remote server?

– Q. Why are some environment variables (e.g. PATH) that should be set on the remote server by filling in
bashrc, etc., not set when running from Winmostar? What should I do in such cases?

– Q. Is there any difference in behavior between the Windows version of the solver and the Linux version
of the solver?

– Q. Can I run calculations simultaneously for remote jobs that run on different servers?

– Q. Where are passwords entered in the remote job profile stored? Is the password information stored in
the project folder?

– Q. Why can I SSH to an Ubuntu machine, including WSL2 use, but cannot successfully execute a remote
job?

• Simulation in general

– Q. Is it possible to calculate the interaction between one substance and another substance with Win-
mostar?

– Q. Can I calculate bond energies and bond divergence energies for a given bond in a molecule?
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• MOPAC, CNDO/S, GAMESS, NWChem, Gaussian

– Q. I get an error while running a quantum chemistry calculation, what should I do?

– Q. The Hamiltonian calculation method (Hamiltonian) or basis function (Basis Set) that I want to use
is not found in the Configure window or the Easy Setup window for MOPAC, GAMESS, Gaussian and
NWChem. How do I set it up?

– Q. How are bonds determined when opening an input/output file or when regenerating bonds?

– Q. Unnecessary bonds are displayed while modeling the system or when reading the calculation results.
Or the bonds are not displayed. How can I fix this?

– Q. Is it possible to optimize substructures from Winmostar using quantum chemical calculations?

– Q. Why does the Dipole moment value displayed at the bottom of the Winmostar molecule display area
differ from the dipole moment value manually calculated from the charges assigned to each atom, such
as Mulliken charges?

– Q. How many atoms can be calculated with MOPAC?

– Q. It will display abnormally with the message ATOMS **, **, AND ** ARE WITHIN. ****
ANGSTROMS OF A STRAIGHT LINE displayed in the MOPAC log.

– Q. When MOPAC is executed, “UNRECOGNIZED KEY - WORDS: (PM 6 (Hamiltonian name))” is
output to the log and the calculation ends.

– Q. How do I use the solvent effect (COSMO method) in the MOPAC attached with Winmostar?

– Q. When I calculate with MOPAC other than Winmostar built-in (e.g. MOPAC2016), only some molec-
ular orbitals are displayed.

– Q. It can not be calculated when Method=INDO is used in CNDO/S.

– Q. Is there a guideline for the maximum number of atoms (memory requirement) that can be calculated
in GAMESS, Gaussian, and NWChem?

– Q. Is it possible to speed up 3D display of ESP (electrostatic potential) of GAMESS, Gaussian, and
NWChem?

– Q. When running GAMESS, “* ERROR: MEMORY REQUEST EXCEEDS AVAILABLE MEMORY” etc.
will be output to the log and the calculation will end abnormally.

– Q. Immediately after installing GAMESS for Windows, I was able to use it without any problems, but at
some point, all the calculations started to terminate abnormally in the middle. Is there a way to fix this?

– Q. GAMESS outputs “WARNING. NUMBER OF INTERNAL COORDINATES IS GREATER THAN (3N
- 6), BUT NO SYMMETRY COORDINATES ARE GIVEN.” in the calculation of only one atom and
abnormally ends.

– Q. The message **** ERROR **** PCM SPHERE (S) MUST HAVE A POSITIVE RADIUS is dis-
played in the log of GAMESS and abnormally ends.

– Q. When GAMESS is executed, “ERROR: BAD DELOCALIZED COORDINATES GENERATED !!!” is
output to the log and the calculation ends abnormally.

– Q. When I try to run NMR calculation in GAMESS (using RUNTYP=NMR), I get an error.

– Q. When I use Diffuse functions in GAMESS, the SCF calculation does not converge.

– Q. For some molecules, after optimization of Firefly, when I check the Molecular Orbit UVvis. . . , I get
the error '*******' is not valid floating point value”.
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– Q. How do I deal with the message “THE GEOMETRY SEARCH IS NOT CONVERGED!” when I run
a structural optimization calculation with GAMESS?

– Q. I cannot download the GAMESS installer. How can I do this?

– Q. The DFT calculation in GAMESS does not converge after displaying “CONVERGED TO SWOFF,
SO DFT CALCULATION IS NOW SWITCHED ON”. Is there any way to deal with this?

– Q. When parallel execution of NWChem, the calculation outputs “Please specify an authentication
passphrase for smpd:” to the log and dows not run.

– Q. When I run NWChem, I get the message “sym_geom_project: sym_center_map is inconsistent with
requested accuracy” in the log and the calculation does not run.

– Q. How can I put the solvent effect in NWChem?

– Q. When executing NWChem, lines including “out of memory”, “alloc failed”, “ma_push failed”,
“nga_create failed”, and “Global memory limit unreasonable” are printed in the log and calculations
do not run.

– Q. The Gaussian calculation may or may not work correctly.

– Q. I read the Gaussian log file, but the orbital (eigen) energy etc. are not written.

– Q. How do I calculate the chk file read in Gaussian?

– Q. I get an error when I try to load a Gaussian fchk file that is several GB in size and display molecular
orbitals.

– Q. How can I perform vibration calculations in Gaussian that take isotope effects into account?

• LAMMPS, Gromacs

– Q. I would like to run molecular dynamics calculations, but which should I use, LAMMPS or Gromacs?

– Q. I get an error while running a molecular dynamics calculation, what should I do?

– Q. How can we equilibrate the system in molecular dynamics calculation?

– Q. I ran MD calculations from the same initial configuration but got different results. Why is this?

– Q. The final density obtained from the NPT calculation is much lower than the density predicted from
experimental values and other sources. What should I do?

– Q. In the MD calculation, how does the constraints by the SHAKE method etc. affect the calculation
result? How do I choose a constraint method ?

– Q. Why do molecules sometimes come out of the cell when in the trajectory or the final structure afterMD
calculation?

– Q. When I create a cell by adding water molecules from a cell in the [Solvate/Build Cell] menu to a large
molecule such as a protein, the molecules sometimes stick out of the cell.

– Q. The [MD]-[Solvate/Build Cell] and [Insert Molecule] processes do not finish after many minutes. Is
there a solution?

– Q. In the [MD]-[Assign Charges Automaticcally] menu, the error message “Topology file not found” is
displayed. Is there a solution?

– Q. The process of assigning the force field takes a long time and never ends. Is there a solution?

– Q. I get an error message when assigning a force field. Is there a solution?

– Q. How do I assign a point charge to a polymer?

– Q. Can I calculate dielectric constant from Gromacs or LAMMPS (Molecular Dynamics Calculation)?
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– Q. When I try to run an MD calculation from a structure created with the interface builder, the force
field assignment fails or the MD calculation fails. Is there a solution?

– Q. When pressure control (constant NPT or NPH) is used, the calculation fails in the middle of the
process. Is there a solution?

– Q. How do I decide interaction parameters between liquid (organic) and solid (inorganic) in LAMMPS
and Gromacs?

– Q. When I run Gromacs, I get the error “There is no domain decomposition for 49 ranks that is compatible
with the given box and a minimum cell size of. . . ”. error. How should I deal with this?

– Q. When I load the final structure or animation from Gromacs, or when I edit it in some way and then
run the MD calculation again, the force field assignment fails or the MD calculation breaks down. Is
there a solution?

– Q. When loading the final structure or animation in Gromacs, the molecules are sometimes displayed in
pieces.

– Q. Even if Gromacs ER method result loading is executed, the result can not be displayed / an error will
appear.

– Q. The error message “Out of range atoms - cannot compute PPPM” appears in the LAMMPS log and
the calculation terminates abnormally. Please let me know how to deal with this.

– Q. How can I plot the trajectory of a specific atom?

– Q. The dissipative particle dynamics (DPD) calculation gave me a different result than intuitive. Why is
this?

• About Quantum ESPRESSO, OpenMX

– Q. I installed the Quantum ESPRESSO pseudopotential file as per the instructions, but it is not recog-
nized.

– Q. I don’t know how to find a pseudopotential file for Quantum ESPRESSO. How do I find them?

– Q. Calculation using Quantum ESPRESSO fails. An error appears in displaying the calculation result.

– Q. When executing Phonon calculation using Quantum ESPRESSO, “third order derivatives not imple-
mented with GGA” is output in the ph.x output (ph.out), and the calculation result cannot be obtained.

– Q. Quantum ESPRESSO, OpenMX SCF calculation or structure optimization calculation does not con-
verge.

– Q. I cannot visualize the three-dimensional distribution of electron density, spin density, and potential
in Quantum ESPRESSO.

– Q. The SCF calculation of Quantum ESPRESSO is displayed as “too few bands” in the output file (.pwout
or .out) and abnormally ends. I do not know how to set nbnd.

– Q. The SCF calculation of Quantum ESPRESSO terminates abnormally with “fixed occupations and
lsda need tot_magnetization” displayed in the output file (.pwout or .out). How do I resolve this?

– Q. Quantum ESPRESSO’s structural optimization calculation (vc-relax) terminates abnormally with the
output file (.pwout or .out) showing “smooth g-vectors missing ! in the output file (.pwout or .out) and
terminates abnormally. How can I resolve this?

– Q. The SCF calculation of Quantum ESPRESSO on metal is terminated abnormally with “charge is
wrong” displayed in the output file (.pwout or .out). How do I resolve this?

– Q. When calculating the dielectric function using Quantum ESPRESSO, “bad band number” is displayed
in the epsilon.x output (eps.out) and it is not possible to acquire the dielectric function.
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– Q. When calculating the dielectric function using Quantum ESPRESSO, “USPP are not implemented”
is displayed in the epsilon.x output (eps.out) and it is not possible to acquire the dielectric function.

– Q. My Phonon calculation using Quantum ESPRESSO failed and I cannot get the results.

– Q. I cannot find a norm-preserving, LDA functional pseudopotential file for Quantum ESPRESSO for
the element I want to calculate in the pseudopotential files installed by default. How can I find it?

– Q. When I try to output the Fermi surface, they do not appear.

– Q. Can I calculate the dielectric constant from Quantum ESPRESSO (band calculation)?

– Q. How do you set up the type of functionalities in Quantum ESPRESSO?

– Q. Why does the cell size structure optimization in Quantum ESPRESSO result in discontinuous changes
or energy increases in the final structure energy?

– Q. Quantum ESPRESSO terminates normally for systems with a small number of atoms, but for large
systems it terminates abnormally with an error such as “cannot allocate . . . ”. for large systems. What
can I do about this?

– Q. Why do the values for Total DOS appearing in Projected DOS (PDOS) and DOS appearing in Density
of States (DOS) differ in Quantum ESPRESSO?

– Q. When I set Hubbard U in Quantum ESPRESSO for structural optimization, it terminates abnormally
with the error message “NR-step length unreasonably short”. What can I do about this?

– Q. Why does the number of cycles required for convergence of SCF calculations before and after Quan-
tum ESPRESSO 6.6 change so much?

– Q. When I use hybrid functional (e.g. HSE) in Quantum ESPRESSO, the band structure collapses. Is
there a way to deal with this?

– Q. Unnecessary bonds are displayed while modeling the system or when reading the calculation results.
Or the bonds are not displayed. How can I fix this?

– Q. When setting up workflow and keywords in Quantum ESPRESSO, even if the cell is not converted to
a primitive cell, it is converted to a primitive cell when the calculation is executed.

– Q. When I run a calculation on a local machine with MPI enabled in OpenMX, I get the error
tcp_peer_send_blocking: send() to socket 12 failed: Transport endpoint is not connected.

– Q. After running a structural optimisation calculation with a change in cell size in OpenMX, if I run a
continuation job with SCF.Restart=On, the standard output shows Failed (3) in reading the restart files,
<Restart> Could not find restart files.

• Addons

– Q. When calculating the Hansen solubility parameter of a polymer using the solubility parameter cal-
culation module, the output value changes depending on how the repeating structure (monomer) of the
polymer is taken.

– Q. The value of the Hansen solubility parameter obtained using the solubility parameter calculation
module is significantly different from the literature value.
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13.1 Purchase

13.1.1 Q. Please tell me how to pay the price.

A.
[For corporations]
It becomes postpay under the following conditions.

Payment method: Cash transfer to our designated bank account
Payment due date: End of the next month of the purchase date

[For individuals]
Pay with credit card at PayPal.

13.1.2 Q. Please tell me the types of documents issued by the company.

A.
An invoice, a delivery note and a quotation will be issued.
In the case of PayPal, please obtain a receipt from PayPal.
Please consult us when you wish other documents. However, please understand that it may be refused depending on
the matter.

13.1.3 Q. How do I place an order other than an end user, such as an agency?

A.
Please see Price and Purchase for more information.

13.1.4 Q. Is it possible to split the price of Winmostar and maintenance? Is it pos-
sible to sell maintenance only?

A.
Cannot be split. But only for the educational lineup after V11, you can only purchase maintenance if the maintenance
has expired after purchasing the V11 unit.

13.1.5 Q. Is there a warranty for the product?

A.
There is no warranty document, but the Terms of Use and Support Service Terms, which you agree to when you
purchase the product, contain the text equivalent to the contents of the warranty for maintenance, etc. Please use the
Terms of Use and Support Service Terms as a substitute for the warranty.
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13.1.6 Q. Is there any discount for personal use? Do you have a license for individ-
uals?

A.
None in particular. The free version can be used by individuals. For the Professional Edition, please purchase a
license for educational institutions if you belong to an educational institution and intend to use it for your own
purposes, or for private companies and government offices if you do not belong to an educational institution.

13.1.7 Q. I am both an educational and research institution. Can I use my institu-
tion’s budget to purchase a license for an educational institution?

A.
Not available. If the purchasing organization is a research institute, it is necessary to purchase a license for private
companies or government agencies.

13.1.8 Q. What is the process of signing a site license agreement when purchasing
a site license from a distributor?

A.
As with direct sales, we will conclude a site license agreement between our company and the customer (end user).

13.1.9 Q. Can I purchase on a daily or monthly basis?

A.
This is only possible for the first year of a site license. If you need a specific user license or a node-locked license that
operates only until the end of the fiscal year due to budget constraints, for example, we can issue a license that
operates only until the desired date within one year from the license start date, without discount.

13.1.10 Why is Winmostar more cost-effective than similar GUI software products
from other companies?

A.
There are several reasons.

First of all, we do not develop the programs (solvers) that run the simulations themselves in-house, but use open
source software that is well proven throughout the world. However, the Winmostar support team is familiar with each
solver at the source code and algorithm level, so we can provide sufficient support. We can also improve and modify
the solvers as needed, so you can be assured of the quality of the software.
Another advantage is that Winmostar is a purely domestic software. Winmostar is available in Japan without any
exchange rate effects.
However, Winmostar has been developed and supported for more than 20 years and its experience is reflected in its
products and services, so its functions, quantity and quality of documentation (manuals), defect countermeasures and
quality control, and support for beginners are as good as those of higher priced products.
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13.2 License Code

13.2.1 Q. Is it possible to change the registered user of a specific user license?

A. This is not possible in the case of private companies and public offices. For educational institutions, it is possible
to change if more than one year has passed since the last user change (or purchase if it is the first time). Please
understand that the specific user license is set at a low price instead of being available only to a specific individual.

13.2.2 Q. If I move from the institution where I purchased my educational license to
another institution, can I continue to use that license?

A. If you are no longer affiliated with the institution at the time of purchase, you will not be able to use the software,
even if it is a perpetual license. This is because the license for educational institutions is specially priced for
students, researchers, and faculty who belong to the educational institution and use the software only for the
educational institution’s business.

13.2.3 Q. Do I need to reinstall the software when I change editions, such as from a
free edition to a student edition, or from a free trial to a professional edition?

A. Not required. Enter the licence code you want to use from now on in the Tools → Preferences menu under Licence
code. All settings except the licence code will be taken over.

13.2.4 Q. Can I install different editions of Winmostar, such as the free version and
the professional version?

A. Yes, it is possible. In this case, please specify a separate installation location for each edition in the Winmostar
installer.

13.2.5 How do I change an already entered license code?

Enter the license code you want to use from now on into license code in Tools → Preferences menu.
If you are a student and want to switch from the free version to the student version, check the student version on the
License registration page and register the license again.
In that case, the settings other than the licence code will be taken over.

13.2.6 Q. Please tell me how to display the MAC address.

A. For Winmostar V11, the MAC addresses of the machine is displayed when it is started with an unregistered license.

Winmostar V10 or lower and Windows 10, first click Start Menu → Windows System Tools → Command Prompt to
launch the command prompt. Next, in the Command Prompt window, type ipconfig /all and press Enter. Various
information will be output, look for the “physical address” line in the output. Its contents are the MAC address. If
there is more than one “physical address” line, basically any “physical address” can be used as the MAC address for
Winmostar’s node-locked license purchase.
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13.2.7 Q. Does Winmostar license fee include Gaussian and/or VASP license fee,
and is there a Winmostar lineup with Gaussian and/or VASP license?

A. Winmostar license fee does not include Gaussian and/or VASP license fee. There is no Winmostar lineup with
Gaussian license. Please purchase it separately from Gaussianand/or VASP distributor.

13.2.8 Q. What will happen to my Winmostar when the license expires?

A. When you start Winmostar after the license expiration date, a window for entering the license code will open and
the various functions that were previously available will no longer be available. If you update your Winmostar license
and enter it again, you will be able to use the software as it was before the license expired.

13.2.9 Q. Can I purchase a license for an educational institution for my personal
learning purposes?

A.
At this time, you cannot purchase a license for an educational institution unless you belong to an educational
institution and use it for your own purposes. For individual use, see Q. Is there any discount for personal use? Do you
have a license for individuals?.

13.2.10 Q. What is the procedure for renewing my license?

A.
If you have purchased the Professional Edition, please inform us of your renewal request from the email source at the
time of delivery or via the contact form. If you are a free or student version, please check to see if the terms of use
apply to you before registering again.
If you have purchased the Professional Edition, please inform us of your renewal request from the email source at the
time of delivery or via the contact form. After informing us of your renewal request, we will send you a quotation for
the renewal. The licence code for the renewal will then be delivered within three working days after the order has
been formally placed with us. In the case of free or student editions, please check whether the terms and conditions of
use apply to you before registering again.

13.2.11 Q.. What if a teacher wants to pre-evaluate the student edition that the su-
pervising student is going to use?

A.
Please obtain and evaluate the student version through your current student affiliation. In this case, use for purposes
other than evaluation is prohibited. If teachers wish to use the software to further their own research, please purchase
the Professional Edition. If you do not currently have any students affiliated with you, please contact us individually
via the Contact Form.
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13.2.12 Q. What happens when the Professional Edition (Trial) expires? Will I have
to pay a fee?

A.
After the expiration date, Winmostar cannot be activated. There is no automatic charge for this service. If you wish to
continue using the software, please request a quote. Data generated during the trial period will be available for
viewing after purchase.

13.3 Support and Maintenance

13.3.1 Q. What does maintenance include?

It is written in the contents of the Terms of Use. Here it is (Winmostar Terms of Use).

13.3.2 Q. If I have a question, can I email the person in charge directly?

A. If you have a question, please do not email the person in charge directly, but first contact us via the Contact Form.
The reason for this is that it is easier for the user to get the desired answer in a shorter period of time if you ask
your question via the form. If the information required for a response is not included in the e-mail, we will need
to ask you for it again, which will cause unnecessary back-and-forth. Also, if you do not use the form, it will take
time for us to assign a person in our company who can respond to your questions accordingly.

13.3.3 Q. What is the difference between paid e-mail support (support on how to
operate via e-mail) and free inquiry form questions?

A. The clear definition of paid e-mail support (support for operating instructions by e-mail) is described in the
Support Service Terms and Conditions ). Otherwise, you can use the free Contact Us Form to ask questions.
In practice, questions, inquiries, and bug reports related to Winmostar-specific functions are free of charge, while all
other inquiries will be supported by e-mail for a fee. Winmostar Specific Function refers to the operation of
Winmostar GUI itself, and does not include open source or other modules (including solvers) developed by third
parties that Winmostar runs in the background.
Specifically, for free inquiries, we will focus on the documentation (tutorials and user manuals). If you would like an
answer to a question that is covered in the documentation but is more tailored to your research problem, you can ask a
question for a fee.
If you are in doubt, please first use the free contact form to ask your question. We will let you know if we will be able
to help you for a fee.

13.3.4 Q. Can I get support for bugs or patches?

This will be done in accordance with the terms of use. The latest terms of use are here ( Winmostar V11 Terms of Use
).
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13.3.5 Q. How long do you plan to support and maintain the previous version?

A. Based on the terms of use in effect for your version of Winmostar. In addition, simple instructions on how to
operate the system will be provided to the extent possible.

13.3.6 Q. Who is the developer (manufacturer) of Winmostar? Where is it manufac-
tured?

A. X-Ability Co. Ltd.. Place of manufacture is Japan.

13.3.7 Q. Can I get in touch with the developer (manufacturer) directly?

A. You can contact us through the contact form, but our availability is subject to our terms and conditions. The
latest terms of use are here ( Winmostar V11 Terms of Use ).

13.3.8 Q. Is it possible to update/upgrade version of the Winmostar I am using?

A. Minor version (and revision) updates can be done as many times as you like during the availability period. Renewal
of a major version requires renewal of the license for a permanent license, and is enforceable for an annual license.
As an example, for “V8.039”, “8” refers to the major version and “039” to the minor version. For V9.1.0, “9” refers to
the major version, “1” to the minor version, and “0” to the revision.
For example, a perpetual licensee of Winmostar V9 can update from V9.1.0 to V9.1.5 or V9.4.4, but it is not possible
to update to V10.0.0.

13.3.9 Q. Are there any precautions when asking a question?

A. If you have a question that the calculation does not work properly, please send us an input or output file that
reproduces the situation in principle.

13.3.10 Q. Do you sell maintenance only?

A.
Please check Q. Is it possible to split the price of Winmostar and maintenance? Is it possible to sell maintenance
only?.

13.3.11 Q. Do you sell maintenance only?

A.
Please check Q. Is it possible to split the price of Winmostar and maintenance? Is it possible to sell maintenance
only?.
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13.3.12 Q. What happens when the annual maintenance on a perpetual licence ex-
pires?

A.
You can continue to use the software in the version that was available before the maintenance expired. Renewing
maintenance allows you to update to the version released after the renewal. However, if you wish to upgrade across
different major versions, you must purchase a new licence.

13.3.13 Q. Do you offer technical support for your various solvers? How can I get
technical support for various solvers?

A.
We provide technical support for various solvers, but we do not provide stand-alone technical support for various
solvers, except in special cases such as organizational unit partnerships and collaborations.
We provide technical support for various solvers as part of Winmostar ancillary support.
Please purchase Winmostar first and ask email questions within the scope of support that comes with the product
itself.
If you have used up the support included with the product, please purchase additional support as needed.
For questions that require the support team to spend some man-hours to answer, we will prepare a separate estimate at
that time.

In the case of other vendors, we have seen a form of open source solver technical support that is set at a fixed price
regardless of the content, and on the surface unlimited support.
However, in practice, there are often no guarantees as to how much support will be provided for that amount of
money, and we believe that such a format is not fair to both the vendor and the user, as there are many variations in the
level of difficulty of the support provided. We provide support in the above format.

13.3.14 Q. Do you provide support via telephone or online meetings?

A. With the exception of payment inquiries, we do not provide telephone or online meeting support. Consultations
about product content prior to purchase and questions about features and support are handled via our contact
form or email. There are two reasons for this. The first is that Winmostar covers a wide range of methods, and
some questions/supports require a support team of multiple people, which is not efficient if we have to call or set
up meetings at specific times. Second, our goal is to continue to provide our high-quality products and support
at a low price, and to reduce inefficient support as much as possible.On the other hand, we will hold meetings for
the paid individual follow-up and individual planning as many times as you request, so if you absolutely need a
meeting for support, please request that.

13.4 Functions and use of the software

13.4.1 How to pronounce Winmostar.

A. win·mo·str
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13.4.2 Q. Does Winmostar connect to internal and external servers or the cloud, or
can it be used without a LAN connection?

A. Yes, it is possible. Download the software described in Installing Winmostar and solvers and copy it to a PC not
connected to the network. Then, follow the procedure in Installing Winmostar and solvers to install the software.

13.4.3 Q. Please tell me the minimum and recommended specifications of PC for
Winmostar.

A. See Hardware requirements for Winmostar itself.
If you do not know the recommended specs, including the execution of the solver and not Winmostar itself, please do
the following
This question is for those who do not have much experience with calculations and do not have a clear picture of the
specific calculation conditions and calculation load.
Basically, when you start up an atomic-scale simulation business, it is rare to keep it running 24/7 as a routine work
like CAE (structural and fluid calculations), and in most cases, especially when you start learning it, it is likely to be
used as a research tool on a spot basis.
In such cases, it is not advisable to worry too much about the specifications of the calculator from the beginning,
since most of the time is spent in planning and discussing the calculation rather than in computing time.
Therefore, it is more important to first develop an understanding of the calculations than the capabilities of the
calculator, so we recommend installing Bronze Support or higher support.
Improper planning of calculations can result in calculations that are dozens of times more wasteful than would be the
case if they were appropriate.
Next, we recommend the use of a PC (workstation) with as many cores as possible costing 500,000 to 1,000,000 yen
if possible, but it is not required.
If the computing power of the PC at hand is not sufficient for your immediate research project, you can use a cloud
service such as FOCUS supercomputer or HPC Systems Science Cloud and other cloud services can be used to
temporarily secure a large amount of computing power.
After 1-2 years, you will know the amount of calculations required for your business, and it would be a good idea to
select a PC to keep on hand on that basis.
GPUs do not need to be considered because Winmostar does not allow them to be used for calculations on local jobs.
Even for remote jobs, we recommend that you do not consider GPUs for the time being, since the benefits of installing
GPUs are limited to cases where the cost and effort of installing GPUs outweigh the benefits.

13.4.4 Q. Is it possible to use the data generated by Winmostar for conference pre-
sentations and papers? How should I quote at conference presentations and
paper submissions?

A. No problem with using it. When presenting it please quote as About quotation.
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13.4.5 Q. Is it possible to upload videos or images of the Winmostar screen to
YouTube or other web sites?

A. Yes, you can. When uploading, please cite the URL of Winmostar’s website and state that you are using
Winmostar and the version of Winmostar you are using. It is strictly prohibited to upload the preferences window
where the license key is displayed.

13.4.6 Q. Do you have any calculation software installed on Winmostar itself?

A. Only MOPAC and CNDO/S are installed in Winmostar. Other software is not bundled with Winmostar due to
licensing issues and must be installed separately. Many software can be installed for free, and the instructions are
described in Installing Winmostar and solvers.

13.4.7 Q. Do you let Winmostar run calculations in the cloud?

A. It is possible to have it calculated in the cloud, or not. By default, we don’t use the cloud, but let you run the
calculations on a Windows PC with Winmostar installed.

13.4.8 Q. Does Winmostar support GPU computation?

A. GPU calculations are supported, but the default setting is to not use the GPU. Some solvers are GPU-enabled, but
you will have to pay for the work to verify that they work, build them, and configure them. If you have already built a
solver with a GPU configuration and have already verified that it works without Winmostar, you can use GPU
calculations from Winmostar with only Winmostar configuration. Due to reasons on the solver side, not on the
Winmostar side, depending on the combination of OS, machine configuration (including GPU), and solver
type/version, it may not be possible to build with a configuration that uses GPU (rather, most cases fall into this
category), so before installing a GPU, please contact a vendor that provides hardware for simulation. We recommend
that you consult with the vendor that provides the hardware for your simulation.

13.4.9 Q. Which CPU is more suitable for operation, Intel or AMD? Which one would
you recommend?

A. In general, there is no such thing as a better simulation.

13.4.10 Q. Is it possible to do parallel computation using Winmostar?

A. It is possible. Details can be set in the Keyword Settings window for each solver in file mode, or in the Job Settings
window in project mode.
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13.4.11 Q. Is there an upper limit to the number of cores that can be used for parallel
computing using Winmostar? Does the cost vary depending on the number
of cores available?

A. You can specify an unlimited number of parallels within the range of user-provided hardware. Winmostar’s price
does not change depending on the number of parallels. In the case of a local job, change the maximum number of
cores because the job will not run if it exceeds the maximum number of cores set by Winmostar Job Manager.

13.4.12 Q. Does Winmostar work on macOS and Linux?

A. Winmostar only supports Windows OS. You can check the supported Windows operating systems at System
Requirements. If you want to run the Winmostar application on macOS or Linux, please install Windows OS in a
virtual environment such as VirtualBox.
Linux and macOS can be used as the computer to run the remote job.

13.4.13 Q. How can I install Gaussian?

A. For instructions on installing Gaussian, get them from your Gaussian distributor. After installing Gaussian, In
the Tools → Preference → Program Path, select the Gaussian program path(g03.exe, g09.exe, g16.exe etc.).

13.4.14 Q. How can I install VASP?

A. Installation instructions for VASP can be obtained from your VASP distributor. VASP is only available for remote
jobs; after installing VASP, edit the template script and specify the directory where you placed the VASP binary
and pseudopotential files.

13.4.15 Q. Windows or Explorer freezes when I start the CygwinWM installer. What
should I do?

A. It is very likely that your security software is interfering with the CygwinWM installer, please specify the Cyg-
winWM installer as an exception to be monitored by your security software. This can happen in a variety of
cases. This was actually reported on June 9, 2025 when cygwin_wm_20250413.exe was launched in a Windows
11 environment running Trend Micro Apex One.

13.4.16 Q. How many atoms or molecules can I calculate with Winmostar? Is there
an upper limit to the number of atoms or molecules that can be handled?

A. Assuming that the operating speed is not considered, we have confirmed the operation of up to about 1 million
atoms. Since the operating speed strongly depends on the execution environment, please check it with the free
trial before purchasing. We are planning to increase the speed of Winmostar in future versions.
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13.4.17 Q. Can I use Winmostar to calculate coarse-grained models?

A. As coarse-grained models in the sense that they are not pure quantum chemical, ab initio, or classical molecular
dynamics calculations, dissipative particle dynamics (DPD) calculations using LAMMPS and the Kremer-Greset
model are supported (please inquire separately for Kremer-Greset). The United atom model and its derived
coarse-grained models will be supported in the future. For other models, please contact us separately. The
reason for this is that we recognize that most research using coarse-grained models cannot be meaningfully
accomplished by simply using the software, but requires careful consulting. Winmostar’s support case study
shows the simulation results of a well validated coarse-grained model.

13.4.18 Q. What is the difference between the latest stable version and the latest
development version? Which do you recommend?

A. The latest development version is the latest revision of the latest minor version, and the latest stable version is the
latest revision of the previous minor version. (For example, in the case of V11.10.3, 11 is the major version, 10 is the
minor version, and 3 is the revision.) When a minor version is updated, new features are added or relatively large
specification changes are made. When a revision is updated, defects are fixed and relatively small specification
changes are made.
If you do not need to use new features that are only available in the latest development version, we recommend using
the latest stable version.

13.4.19 Q. Who owns the rights to the calculation results and output files obtained
using Winmostar?

A. Belongs to the user. The user is free to use it.

13.5 Software operations

13.5.1 Q. I can not create a model as I expected. It can not calculate. It does not
work.

A. First, please perform the following basic checks.

• Check the Installation precautions.

• Check whether Winmostar in use is a free version, a student version, a professional version, or a professional
version (trial), and whether the function causing the problem is available in that version with function table.

• Check the activity record of the security software in use and check whether there is any record in which the
activities of the application under Winmostar, CygwinWM and each solver’s installation folder are disturbed.

• Update Winmostar to the latest version (it is possible to coexist with the version you are using), check if there is
a situation similar to Known problems and Frequently asked questions · Troubleshooting.

• If the names of files to be saved and directories containing them (including all upper layers) contain multibyte
characters such as Japanese and special symbols including sapces, some solvers may cause problems. Therefore,
use only single-byte alphanumeric characters.

• Check the working folder to see if the log is being output by the executed process and check the contents of the
log.
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• If calculation is started but the calculation result is wrong, click “Open Log File” etc from the solver menu used
in the main menu and check the contents of the log.

• For the calculation failure, check that the version of the solver is the same as the version recommended in the
Winmostar installation guide. (Especially Gromacs, LAMMPS, or Quantum ESPRESSO)

• Disable the “Use Unicode UTF-8 for worldwide language support” option on Windows if it is enabled. (See
Some software will not work if the Windows option “Use Unicode UTF-8 for worldwide language support” is
enabled. for details)

• If a project or file is saved and used on a network drive and unexpected behaviour is observed, save and use it on
a non-network drive (e.g. C drive).

Next, please make it possible to record subsequent work with Notepad etc. If you find out how to reproduce the
problem, you may be able to fix it in a relatively short time if you report along with the record of work.
Please trace the basics tutorial of the solver you want to use in tutorials.
If you fail to trace the basics tutorial, try the following.

• Ensure that the calculations are carried out using exactly the same substances and conditions as in the basic
version. (This is not limited to Winmostar, but in all cases where the substances and conditions are different, the
calculations may not always end successfully using the methods described in the tutorial).

• Trace again to confirm that it is not a misoperation.

• If parallel execution is performed, switch to serial execution (parallel number 1).

• Restart Winmostar.

• Restart the OS.

• With security software, Exclude Winmostar, installation folder of CygwinWM, and solvers including MPI from
monitoring.

• If you are using CygwinWM, run Help → Check CygwinWM and perform a simple diagnosis of CygwinWM.

• Reinstall Winmostar, CygwinWM and the solver you are using.

• Try with another PC.

Next, trace the tutorial which seems to be as close as possible to what you want to calculate finally. If it succeeds,
please change the calculation condition such as Number of atoms, size of super cell, degree of polymerization, type of
element, number of phases, etc. so that it finally gets to calculate what you want to calculate and try to identify where
the problem occurs.

• Please check for similar cases in Frequently asked questions · Troubleshooting.

• If the problem is occured in the part where Winmostar calls external software, Please check also information of
the software.

• If there is a problem with processing using Cygwin, please confirm Cygwin general problem.
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13.5.2 Q. “ERROR: I/O error 32” is displayed and the processing fails.

A. The file related to processing may be opened by an application or process other than Winmostar, locked, or it may
have been deleted.
Restart OS and try again in the situation other applications are not open.

13.5.3 Q. Process using Cygwin will end abnormally. / Help → Check CygwinWM
function will display . . . ERROR . . . . / Cygwin’s black window shows
child_info_fork :: abort: . . . Loaded to different address: parent . . . ! = Child
. . . .

A. Please do the following procedure one by one from the top, and re-do the process where the error occurred each
time.

1) Perform general dealing with common problems.

2) Restart your PC

3) Open Windows Security and go to App & browser control and click Exploit protection. Then change
the value of Force randomization for images to Off by default or Use default (Off).

4) If the value of force image randomization is reset after restarting Windows, start PowerShell with
administrator privileges and execute the following command.

cd C:\cygwin_wm
Get-ChildItem -Recurse -File -Include *.exe | %{ Set-ProcessMitigation -
→˓Name $_.Name -Disable ForceRelocateImages }

Then double-click make_symlink.cmd under C:\cygwin_wm.

5) Check the operation with other applications closed. (In rare cases, there may be conflicts with other
applications.)

6) Search and delete anything other than cygwin1.dll and restart the machine

Warning:
• This operation is necessary in some cases if cygwin1.dll exists in addition to CygwinWM on

the same machine.

• cygwin1.dll may be included in various freeware etc even if you do not install Cygwin in other
location.

7) With all Cygwins on the machine being used terminated, at the [Run] of Windows C:\cygwin_wm\
bin\ash.exe (when CygwinWM is installed in C:\cygwin_wm ), execute the /bin/rebaseall
-v, and restart the machine.

8) Temporarily disable security software.

9) Disable software that tends to cause problems described in Cygwin FAQ .

10) In addition, try the method described in Cygwin FAQ fork() related failures.

11) Install a new version of Cygwin from the Cygwin official site and check if you can start a terminal.
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13.5.4 Q. Help → Check CygwinWM function displays No reference file (. . .
filelist_cygwinwm.txt) was found. . . .

A. The first thing the CygwinWM diagnostic function does is to look for a file named filelist_cygwinwm.txt directly
under the folder where CygwinWM was installed, and the error message is that this file is missing. Please look for
filelist_cygwinwm.txt in the location where CygwinWM was installed (by default C:\cygwin_wm) and specify the
folder directly above it in [Tools]-[Preferences]-[Program Path]. Find filelist_cygwinwm.txt in the location where
CygwinWM was installed (by default C:\cygwin_wm) and specify the folder directly above it in
[Tools]-[Preferences]-[Program Path]. If you cannot find filelist_cygwinwm.txt, the installation of CygwinWM may
have failed, so please review the settings of your security software and reinstall CygwinWM.

13.5.5 Q. Help → Check CygwinWM function will display WARNING . . . some files
are missing.

A. Please reinstall CygwinWM.
If it is displayed even after the reinstallation, temporarily disable the security software, or exclude installation
destination and installer from monitoring.

13.5.6 Q. Tools → Diagnose CygwinWM function shows ERROR . . . Failed to gen-
erate a current file list.

A. Your Cygwin environment may be corrupted. Please check Cygwin common bugs.

13.5.7 Q. Tools → Diagnose CygwinWM function displays ERROR: Getting SMILES
. . . . OpenBabel process terminates abnormally.

A. If OpenBabel for Windows is installed separately from CygwinWM, Winmostar’s internal processing may use
OpenBabel for Windows when it should use OpanBabel for CygwinWM, causing a problem. Uninstall the Windows
version of OpenBabel or delete the Windows OpenBabel installation folder from the PATH environment variable.

13.5.8 Q. The job registered in Job Manager is not executed.

If the specified parallel number of MPI is larger than the MaxCore setting of Job Manager, the job will not be
executed.
The default value of MaxCore should be set to the number of cores of the running PC, but make sure that it has not
been changed or that the number of parallel MPIs has not been set higher.
If you want to run without using Job Manager, uncheck “Run MOPAC using Job Manager” or “Run the other solvers
using Job Manager” in Calculation tab of the Tools → Preferences window.
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13.5.9 Q. When executing a job, an alert saying “Unable to execute (Access de-
nied.)” appears and the job will not start.

A. Please try general errors. In particular, remove the installed Winmostar and Solver folders from the monitoring of
your security software.

13.5.10 Q. In the functions where a black console window appears, such as various
functions of Winmostar or the execution of the solver, the processing of the
black console window does not end and does not proceed.

A. If you happen to click on the black console window, the process will be suspended from there due to the Windows
specification.
The processing will resume when ESC key is pressed while the console window is active.

13.5.11 Q. When I open a file or model a molecule, the bonds no longer appear or a
lot of extra bonds have come to appear.

A. First of all, in quantum chemical calculations and first-principles calculations (solid-state physics calculations),
bond information does not affect the calculation results in any way, so please assume that the presence or absence of
bonds is only a display issue.If the bond generation behavior has changed since you installed Winmostar, the bonding
factor value in Tools → Preferences → Edit may not be appropriate. Either reset it to the default value or set it to a
value around 1.15. If the default value does not give you the desired result, use edit → Add/Change Bond or Edit →
Delete Bond to create or delete bonds.

13.5.12 Q. How do I view the extension in Windows Explorer?

In the case of Windows 7:
• Open Explorer

• Press the Alt key.

• Open View tab in Tools → Folder Options menu

• uncheck hide extensions for known files type

For Windows 8, 10
• Open Explorer

• Open View tab

• Check File name extensions
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13.5.13 Q. Markers (red circles) and group selections (blue circles) are not dis-
played. Atoms can no longer be selected.

A. Check the display → display items → selective atom markers checkbox.

13.5.14 Q. The toolbar and tool buttons are not displaying properly. Can I fix it?

A. First, close Winmostar, make a backup of the UserPref folder, then delete the contents of the UserPref folder and
restart Winmostar. If that doesn’t make a difference, try the Winmostar toolbar and tool buttons are displayed
incorrectly when Windows display magnification is other than 100%. workaround.

13.5.15 Q. What is an optimization flag?

A. See Optimization Flags.

13.5.16 Q. Can I have Winmostar not run calculations directly from Winmostar and
just save the file, or can I edit the file that Winmostar generates and then
run the job?

A. Yes. Follow the instructions in Basic Operation Flow if you do not want to run the calculation directly from
Winmostar and only want to save the file.

13.5.17 Q. Is it possible to use the latest version of each solver or a version not
listed in Winmostar’s operating environment?

A. It depends on the type of functionality you want to use with that solver. While we expect most basic functionality
to work, we do not guarantee it, so if you want to use a version that is not listed in Winmostar’s Checking, we
recommend you check it out in a trial before you buy it. The versions listed in the Confirmation of Operation are the
versions used in Winmostar’s pre-shipment testing. For some solvers (LAMMPS, Quantum ESPRESSO, etc.), you
can use Tools → Preferences menu to switch the version of the solver that Winmostar outputs.
Winmostar plans to update the supported solver versions as they become available. If there is no specific timeline for
updating supported versions and you need immediate support, please consider using paid customization.

13.6 File I/O

13.6.1 Q. I cannot open files created by other than Winmostar with Winmostar.
When I edit the file generated by Winmostar and try to open it with Winmostar,
it cannot be opened.

A. Please check if the line break code or encoding has been changed. If you still cannot open the file, please attach the
file and contact us using the contact form.
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13.6.2 Q. When opening a file in MOL or SDF format, the bond length becomes
unnatural. Hydrogen does not appear.

Follow the steps below to modify the molecular structure. (1) Adjust All Bond Lengths (2) Regenerate Z-Matrix (3) To
marked atoms (Auto) In the case of SDF files, refer to Editing an SDF file procedure.

13.6.3 Q. When I load SMILES, it does not generate the intended structure. Why is
this? What should I do?

A. The characteristics of the external program that reads SMILES may not generate the intended structure; switching
the external program that reads SMILES may solve this problem. In File -> Import -> SMILES, select either Use
OpenBabel or Use Balloon.

13.7 On the modeling of molecules and creation of systems

13.7.1 Q. How do I change the type of chemical bond (single, double etc.)?

A. You can change it by the following method, for example.
1) Edit → Automatically Adjust Atoms/Bonds → Add/Change Bond or by pressing the Add/Change Bond button at
the top of the main window multiple times.
2) Edit → Automatically Adjust Atoms/Bonds → Regenerate All Bonds is selected, the type of chemical bond is
automatically changed by the bond degree determined from the interatomic distance. If you optimize the structure
with Edit → Automatically Adjust Atoms/Bonds → Quick Optimization in advance, it may be changed automatically
more reasonably.
3) If only one small molecule is displayed, execution of MOPAC calculation will automatically change the coupling
order using the population analysis result.

13.7.2 Q. MD → Solvate/Build Cell function will display Error: Failed to solvate. and
processing will fail.

——— Question details ——— When executing MD → Solvate/Build Cell, the following is output to generate.log
and processing does not end normally.

gmx insert-molecules -try 100 -f gmx_tmp_water.gro -o gmx_tmp_water_tmp.gro -ci mol0.gro␣
→˓-nmol 64
...
set +v
Error : Failed to solvate.

A. Try general errors and Cygwin general errors and execute after reducing the number of molecules or reducing
the density.
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13.7.3 Q. When I run some functions, I get \357\273\277 etc. and the process fails.

——— Question details ——— When I run MD → Solvate/Build Cell, the following output appears in packmol.log
and the process does not end normally. ::: packmol.log.

/cygdrive/C/winmos11/UserData/builder_tmp/packmol.sh: line 1: $'\357\273\277packmol':␣
→˓command not found

A. \357\273\277 is a code contained in a UTF format text file called BOM and is not supported by programs in Cygwin
and Linux environments. If you have checked [Beta: Use Unicode UTF-8 with worldwide language support] in [Clock
and Region] - [Change Date, Time, and Numeric Format] - [Administration] tab - [Change System Locale] in the
Control Panel, please uncheck the box if you do not mind.

13.8 MPI on local machine, parallel execution

13.8.1 Q. Why does the parallel computation that flows by itself terminate abnor-
mally? The parallel test in the installation test succeeds. Serial calculations
also terminate normally.

A. Gradually increase the number of parallels to 2, 4, 6. . . . and observe the behavior. If the number of parallelisms is
too large for the problem size, the program may terminate abnormally. Also, if you are using a generation Intel Core
series CPU with a high-performance core (P-core) and a high-efficiency core (E-core), make sure that the number of
parallels does not exceed the number of cores in the P-core.

13.8.2 Q. MPICH ends during computation.

——— Question details ———
While executing MPICH, the following error may be displayed and the calculation may be ended prematurely.
op_read error on left context: Error = -1
op_read error on parent context: Error = -1
unable to read the cmd header on the left context, Error = -1
unable to read the cmd header on the parent context, Error = -1
Error posting readv, An existing connection was forcibly closed by the remote host.(10054)
connection to my parent broken, aborting.
state machine failed.

A.
This error is because MPICH uses the network adapter even if it is localonly and the network adapter is disconnected
in the middle.
However, if the network adapter has disconnected from the beginning, this error will not occur because MPICH does
not use the network adapter.
When computing for a long time using MPICH, please disable the network adapter and start the calculation.
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13.8.3 Q. When executing parallel MPI of LAMMPS or Quantum
ESPRESSO, warning is displayed as Unable to open the
HKEY_LOCAL_MACHINE\SOFTWARE\MPICH\SMPD\process\???? registry
key, error 5 , Access denied.

A. MPICH tries to rewrite the registry but it failed because there is no administrator authority.
If you start Winmostar with administrator privileges, you will not get a message. Even when a message is displayed,
the calculation itself is executed normally, so it can be ignored.

13.8.4 Q. The installation of .NET Framework 3.5 using dotNetFx35setup.exe fails.
What should I do?

A. You may be able to avoid this problem by installing from Windows PowerShell. Start Windows PowerShell with
administrator privileges and enter the following command.

Set-ItemProperty -Path 'HKLM:\Software\Policies\Microsoft\Windows\WindowsUpdate\AU' -
→˓Name 'UseWUServer' -Value 0;
restart-service wuauserv;
dism /online /Enable-Feature /FeatureName:NetFx3;
Set-ItemProperty -Path 'HKLM:\Software\Policies\Microsoft\Windows\WindowsUpdate\AU' -
→˓Name 'UseWUServer' -Value 1;

13.8.5 Q. I cannot find the number of parallels I want to set when I pull down the
Number of Parallels combo box. How can I set the number of parallels I
want?

A. Enter a value in the Number of Parallels field using the keyboard instead of selecting it by pull-down. You can
enter any value in the Number of Parallels field using the keyboard.

13.9 Remote Jobs

13.9.1 Q. Please tell me how to submit a job to a supercomputer or a linux server
in my company or my campus.

A. If you need environment settings specific to the computer to which you are connecting, you can do it by creating a
template script for remote jobs.
See Remote job for more information.
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13.9.2 Q. I cannot connect from Winmostar to a server that allows SSH connections
with various terminal software.

A. First check the steps described in Remote job. If this does not solve the problem, you may be able to connect by
changing the version of libssh, the library used by Winmostar for SSH connections. Check [Tools] - [Preferences] -
[Compute] - [Use older version of libssh2 (1.8.2) for SSH connections].

13.9.3 Q. SSH connection with public key method fails, when I specify the same pri-
vate key file with other software such as TeraTerm or Cygwin, the connection
succeeds. Is there a solution?

A. The key format may not be supported by Winmostar. See SSH public/private key authentication.

13.9.4 Q. The connection test with Test Connection succeeds, but the job submis-
sion fails.

A. There are various reasons. Here are some examples

1. If there is a limit on the number of SSH connections such as TSUBAME3.0, please consult us to avoid it without
executing SSH connection every time.
2. In some cases, this can be avoided by activating password authentication as well as secret key authentication on the
server side.
3. If there are multiple login server entities and they are automatically selected in the background, you may be able to
avoid this by using only a specific login server or connecting until all servers are registered in the cache .
4. Even if Winmostar submits a job submission command (such as qsub) from the local machine, the command may
not be found on the remote server. This can be avoided by filling Profile –> Edit Profile. . . ’ in the :guilabel:`Submit
Remote Job window with the path of an executable such as qsub. To avoid this problem, add the path of an executable
such as qsub to Prefix for queueing commands of Profile –> Edit Profile. . . in the Edit Profile. For example, if the
full path of :command:`qsub is /usr/local/bin/qsub, type “/usr/local/bin/” in Prefix for queueing commands.

13.9.5 Q. Connection test with Test Connection succeeds, but Putty’s WARNING is
displayed and various operations fail.

——— Question details ———
Even though the result of TestConnection is OK, various commands can not be executed.
And the following dialog is displayed at the time of launching remote job submission window or TestConnection etc.
WARNING: Putty default host name was found in registry.
(\SOFTWARE\SimonTatham\PuTTY\Sessions\Default%20Settings\HostName)
This may cause errors while job submission.
Clear this setting.

A.
Reason:
This WARNING occurs when Putty's HostName is set.
Since Putty's settings are saved in the Windows registry, even if the Putty is other than Winmostar bundled version,
this problem will occur when some sort of character string is saved in HostName.
Solution:
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Launch Putty from Connection → Open Putty Remote Job Submit window. Check a character string is set in the
HostName field of Default Settings.
You can solve this problem by deleting this string and saving it with Default Settings selected.
(The input contents in the Port column are not particularly affected.)

13.9.6 Q. What type of MPI (MPICH, OpenMPI, etc.) can I use on the remote server?

A. Basically any type of MPI is available. We have experience with MPICH, OpenMPI and MVAPICH.
By editing the template script, you can freely execute commands such as source, module, and export, and set up the
environment for executing any MPI.
The solver used must be compiled with the MPI (mpicc, mpif90) used.

13.9.7 Q. Why are some environment variables (e.g. PATH) that should be set on
the remote server by filling in bashrc, etc., not set when running from Win-
mostar? What should I do in such cases?

A. This is because the processing flow on the remote server may differ between interactive shell operations in the
terminal and direct command execution with ssh command arguments. bash command arguments may do the same.
As a workaround, please create a template script and explicitly fill in the environment variable settings, etc.
separately in the script.
If you have an Ubuntu machine including WSL2 as a remote server, please also refer to here

13.9.8 Q. Is there any difference in behavior between the Windows version of the
solver and the Linux version of the solver?

A. There is essentially no difference in functionality except for calculation speed. Performance varies depending on
compiler, MPI, and compilation settings.

13.9.9 Q. Can I run calculations simultaneously for remote jobs that run on different
servers?

A. Yes. However, in project mode, each job is tied to the runtime profile information, so create a different profile for
each server.

13.9.10 Q. Where are passwords entered in the remote job profile stored? Is the
password information stored in the project folder?

A. Passwords are stored encrypted in winmos_profile.ini under the user settings folder (UserPref in the Winmostar
installation folder). It is not stored anywhere else, so there is no password information stored in the project folder. For
example, when you send us your project folder for support, we will not send you the password information.
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13.9.11 Q. Why can I SSH to an Ubuntu machine, including WSL2 use, but cannot
successfully execute a remote job?

A. On Ubuntu machines, because of the following part written at the beginning of the .bashrc file, remote job
execution does not reflect the PATH and other settings that are set after this.
# If not running interactively, don’t do anything
case $- in

*i*) ;;
*) return;;

esac
Delete or comment out these lines.
Also, for WSL2 Ubuntu, since zip is not included by default, please also run the following command to install zip.
sudo apt-get install zip unzip

13.10 Simulation in general

13.10.1 Q. Is it possible to calculate the interaction between one substance and
another substance with Winmostar?

A. This kind of question is very common, but the definition of the word “interaction” is broad, so it depends on the
definition.
First of all, please check the manual of each solver beforehand, because Winmostar depends on what each solver
(GAMESS, Gaussian, LAMMPS, Gromacs, Quantum ESPRESSO) can do, in terms of whether it can perform
quantum chemistry, molecular dynamics, and ab initio calculations itself for the material you are focusing on.
Secondly, interactions in the sense of wanting to know the mechanism of some physical property or phenomenon that
we are focusing on cannot be answered immediately, because it requires knowledge specific to that material system,
and the investigation of whether it is computable requires sufficient investigation itself. We also offer a service to
conduct investigations for a fee for private companies
If you want to quantitatively evaluate the bonding or association caused by the interaction, you can discuss the change
of energy versus bonding distance for absolute zero, or the radial distribution function between binding materials or
the autocorrelation function of the bonding time series data for the kinetic state.
Finally, if you know the specific analysis, such as Kitaura-Morokuma analysis or interaction energy analysis such as
Coulomb-vdW interaction in MD, please ask about it.
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13.10.2 Q. Can I calculate bond energies and bond divergence energies for a given
bond in a molecule?

A. Perform quantum chemical calculations of the stable conformations of the bound and dissociated states and
calculate from the energy difference between them. The two molecules in the dissociated state should be calculated
separately, and the spin and charge should be set carefully.

13.11 MOPAC, CNDO/S, GAMESS, NWChem, Gaussian

13.11.1 Q. I get an error while running a quantum chemistry calculation, what
should I do?

A. First trace the Winmostar tutorial. If that fails, you may have failed to build the environment, and for Gaussian,
also check if the license allows parallel computation.
Next, if you did the calculation in project mode, check the error column in the working folder for the corresponding
calculation. You can also hover the mouse pointer over the working folder to see the error. If the error message is in
the FAQ, try the workaround described there. Especially for IR calculations of large molecules, the default amount of
memory specified may not be enough and the calculation may stop.
If the energy (SCF) calculation does not converge, please check or try the following.
- Check for proper initial structure, charge, and spin multiplicity.
- Using large basis functions and diffuse functions makes convergence difficult. Consider using smaller basis
functions.
- If the DFT calculation in GAMESS does not show “DFT CODE IS SWITCHING BACK TO THE FINE GRID”
after displaying “CONVERGED TO SWOFF, SO DFT CALCULATION IS NOW SWITCHED ON” without
approaching convergence please set the variables NRAD0 and NLEB0 in the DFT tab of the Keyword Setup window.
- In Gaussian, if the result of a small basis function is used as the initial trajectory, it is more likely to converge in the
large basis function. In project mode, the energy calculation is first performed on the small basis function, and then a
continuation job is performed on the large basis function. At that time, the continuation source should be specified as
a small basis function calculation, and in addition, the guess=read checkbox should be checked in the Keyword Setup
window.

13.11.2 Q. The Hamiltonian calculation method (Hamiltonian) or basis function (Ba-
sis Set) that I want to use is not found in the Configure window or the Easy
Setup window for MOPAC, GAMESS, Gaussian and NWChem. How do I set
it up?

A. If you can enter directly on the keyboard in the Calculation Method and Basis Function setting fields, you can do
so directly. Please check the manual of the respective solver, as the description of how to specify polarization
functions (represented by “*”, “p”, “d”, or “f”) may differ from solver to solver.
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13.11.3 Q. How are bonds determined when opening an input/output file or when
regenerating bonds?

A. Combining Criteria.

13.11.4 Q. Unnecessary bonds are displayed while modeling the system or when
reading the calculation results. Or the bonds are not displayed. How can I
fix this?

A. See this FAQ for more information.

13.11.5 Q. Is it possible to optimize substructures from Winmostar using quantum
chemical calculations?

A. As of V11.3.1, the support is as follows
MOPAC6: Only Z-Matrix is supported
GAMESS: not supported
Gaussian: only Z-Matrix supported (opt=z-matrix required)
NWChem: only Z-Matrix supported

13.11.6 Q. Why does the Dipole moment value displayed at the bottom of the Win-
mostar molecule display area differ from the dipole moment value manu-
ally calculated from the charges assigned to each atom, such as Mulliken
charges?

A. The Dipole moment value displayed at the bottom of the Winmostar molecule display area is the dipole moment
for the entire molecular system directly output by MOPAC, GAMESS, Gaussian, and NWChem. This value is the
exact dipole moment calculated by calculating the center of gravity of all negatively charged electrons and the center
of gravity of all positively charged nuclei. In the calculation of this value, no operation to assign an electron to each
atom is involved.
On the other hand, in atom-by-atom charge calculations such as Mulliken charge, the boundary between atoms cannot
be uniquely determined and remains arbitrary. The formula for assigning a charge to each atom differs depending on
the method of charge calculation, such as Mulliken or NBO charge. Therefore, the dipole moment values calculated
from Mulliken charges, etc. are slightly different from the dipole moment values for the entire molecular system
output by MOPAC, GAMESS, Gaussian, and NWChem, which are displayed at the bottom of the Winmostar
molecular display area.

13.11.7 Q. How many atoms can be calculated with MOPAC?

A. 70 heavy atoms (other than hydrogen) and 90 light atoms (hydrogen).
You can also download the executable binary of MOPAC6 for large molecules (up to 420 atoms) from the here
<https://winmostar.com/jp/mop6wxxx.zip>.
Winmostar has been confirmed to work with MOPAC2016.
MOPAC2016 will be available free of charge from 2021 with no limit on the number of atoms.
MOPAC main page
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13.11.8 Q. It will display abnormally with the message ATOMS **, **, AND ** ARE
WITHIN. **** ANGSTROMS OF A STRAIGHT LINE displayed in the MOPAC
log.

——— Question details ———
It stops with an error saying that 3 atoms are linear as shown below.
CALCULATION ABANDONED AT THIS POINT

THREE ATOMS BEING USED TO DEFINE THE
COORDINATES OF A FOURTH ATOM, WHOSE BOND-ANGLE IS
NOT ZERO OR 180 DEGREEES, ARE IN AN ALMOST STRAIGHT
LINE. THERE IS A HIGH PROBABILITY THAT THE
COORDINATES OF THE ATOM WILL BE INCORRECT.
THE FAULTY ATOM IS ATOM NUMBER 69
Finally, comes
ATOMS 68, 57, AND 54 ARE WITHIN .0134 ANGSTROMS OF A STRAIGHT LINE
.

A.
It is displayed when an angle close to 180 degrees is included in Z-Matrix.
Change the connectivity of atoms by the coordinate editing function in the lower right of the main window so that
there is no angle close to 180 degrees from Z-Matrix.
If you are new to Z-Matrix, you may be able to avoid this error by adding “XYZ” to the keyword as a different method.
Alternatively, by adding a dummy atom of the atomic type XX to a position out of the line where three atoms are
aligned in a straight line and designating it as a connection destination on the Z-Matrix of the atoms arranged in the
line,
Sometimes it is possible to avoid errors.

13.11.9 Q. When MOPAC is executed, “UNRECOGNIZED KEY - WORDS: (PM 6
(Hamiltonian name))” is output to the log and the calculation ends.

A. If you can avoid the error by changing Hamiltonian to AM1 with MOPAC Configure, the selected Hamiltonian is
not supported by the MOPAC you are using.
Check the list of Hamiltonians supported by each version and select the appropriate Hamiltonian.
If it still does not work, please take action of general errors .
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13.11.10 Q. How do I use the solvent effect (COSMO method) in the MOPAC attached
with Winmostar?

A. MOPAC which is included in Winmostar does not support the solvent effect (COSMO method). Please consider
using GAMESS which is more accurate than MOPAC, although it takes more time to calculate.

13.11.11 Q. When I calculate with MOPAC other than Winmostar built-in (e.g.
MOPAC2016), only some molecular orbitals are displayed.

A. Check the ALLVECS checkbox in the MOPAC Setup window to create an input file and perform the calculation.

13.11.12 Q. It can not be calculated when Method=INDO is used in CNDO/S.

A. The elements after F are not supported by Method=INDO.
set Method=CNDO, or use a non-empirical solver such as GAMESS.

13.11.13 Q. Is there a guideline for the maximum number of atoms (memory require-
ment) that can be calculated in GAMESS, Gaussian, and NWChem?

A. There is no simple guideline for the amount of memory required, as it depends on the molecule size, basis
functions, calculation contents, and number of parallels.
When a calculation is actually performed and stops due to insufficient memory, the log file will indicate how much is
missing, so it is common to make a judgment based on that value.

13.11.14 Q. Is it possible to speed up 3D display of ESP (electrostatic potential) of
GAMESS, Gaussian, and NWChem?

A. If you have installed the Windows version of Gaussian, check the Cubegen check box in the Cubegen window that
appears when you open the Cube file, and the processing will be relatively fast using the Cubegen program included
with Gaussian.
In the future, we plan to speed up the cube file processing program (OpenCubegen) included with Winmostar.

13.11.15 Q. When running GAMESS, “* ERROR: MEMORY REQUEST EXCEEDS
AVAILABLE MEMORY” etc. will be output to the log and the calculation
will end abnormally.

A. This means that the amount of memory specified in the input file is not enough.
Increase the value of MWORDS in the $SYSTEM column of the Advanced tab of the GAMESS Configure window.
(MWORDS number) x 8MB is the maximum amount of memory used per CPU core. For example, if MWORDS is
200, the maximum amount of memory per CPU core is 200 x 8MB = 1600MB = 1.6GB. Please set MWORDS
according to your computer and the number of parallels.
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13.11.16 Q. Immediately after installing GAMESS for Windows, I was able to use it
without any problems, but at some point, all the calculations started to
terminate abnormally in the middle. Is there a way to fix this?

A. First of all, please take action of general errors. If this does not work, perform the following steps in order.
1. Launch the GAMESS installer -> Select Remove -> Uninstall GAMESS.
2. Go to Windows Settings -> Apps -> Apps and Features -> Select Microsoft MPI -> Uninstall Microsoft MPI
3. Reinstall GAMESS and MS-MPI according to the GAMESS installation manual for Windows in the
Winmostar Installation Guide.

In particular, when it shows “mpiexec . . . server rejected credentials” etc. in the console window when running
GAMESS, this method may be effective.

13.11.17 Q. GAMESS outputs “WARNING. NUMBER OF INTERNAL COORDINATES
IS GREATER THAN (3N - 6), BUT NO SYMMETRY COORDINATES ARE
GIVEN.” in the calculation of only one atom and abnormally ends.

A. This is a message indicating a problem caused by using Z-Matrix in a system with only one atom.
In this case, Cartesian coordinates are used (COORD=UNIQUE) to solve it.
Set UNIQUE to COORD on Wimostar's GAMESS Configure window.

13.11.18 Q. The message **** ERROR **** PCM SPHERE (S) MUST HAVE A POSITIVE
RADIUS is displayed in the log of GAMESS and abnormally ends.

A. GAMESS may not contain Cavity radius for some atoms.
To specify the Cavity radius, add the following statement just after the $PCM line.
$PCMCAV RIN(13)=1.55, RIN(15)=1.55 $END
In this example, Cavity radius is set to the 13th and 15th atoms.

13.11.19 Q. When GAMESS is executed, “ERROR: BAD DELOCALIZED COORDI-
NATES GENERATED !!!” is output to the log and the calculation ends ab-
normally.

A. In the GAMESS Configure window of Wimostar, select the Z-Matrix tab and uncheck $ZMAT.

13.11.20 Q. When I try to run NMR calculation in GAMESS (using RUNTYP=NMR), I
get an error.

A. GAMESS NMR calculations are only compatible with the closed-shell Hartree-Fock method, and other DFT
methods cannot be used.
Also, the execution of NMR calculations in GAMESS can be slow, so we recommend using NWChem or Gaussian
instead.
If you really want to calculate with GAMESS from Winmostar, uncheck the DIRSCF checkbox in the $SCF of the
Advanced tab in the Setup window.
In addition, parallel computing is not supported, so please set the parallel number to 1.
You can find detailed instructions in the log file with an error, so please refer to that as well.
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13.11.21 Q. When I use Diffuse functions in GAMESS, the SCF calculation does not
converge.

A. Add ICUT=11 to the Others column in the $CONTRL box on the Basic tab of the GAMESS Setup to make the
cutoff value for the two-electron integration smaller (stricter).

13.11.22 Q. For some molecules, after optimization of Firefly, when I check the
Molecular Orbit UVvis. . . , I get the error '*******' is not valid floating point
value”.

A. The linear dependence of the basis is large because 6-31+G* has the diffuse functions.
Therefore, a part of the value of the molecular orbital coefficient becomes very large, and **** is output in the log.

The solutions are
1. Use 6-31G* basis set
2. If you use 6-31+G*, use GAMESS instead of Firefly
.

Because GAMESS has processing of linear dependency,
Firefly and GAMESS may have slightly different energy values.
execute a series of calculations with either Firefly or GAMESS.

13.11.23 Q. How do I deal with the message “THE GEOMETRY SEARCH IS NOT
CONVERGED!” when I run a structural optimization calculation with
GAMESS?

If the animation shows structural optimization information and the energy continues to drop, the calculation has been
completed with insufficient number of structural optimization cycles. Please perform the structural optimization
calculation again with the final structure.
For some larger molecules (roughly 100 atoms or more), structure optimization with DLC=.T. may result in a
significant loss of structure. In that case, unchecking $MAT’s Set DLC=.T. . . . unchecked and run, which may resolve
the problem.
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13.11.24 Q. I cannot download the GAMESS installer. How can I do this?

A. If an error occurs on the download site and the registration form does not appear, please try another browser. If you
are using Microsoft Edge, try accessing the site again in Internet Explorer mode. Also, sometimes the download site
system is down, in which case please wait up to a week.

13.11.25 Q. The DFT calculation in GAMESS does not converge after displaying
“CONVERGED TO SWOFF, SO DFT CALCULATION IS NOW SWITCHED
ON”. Is there any way to deal with this?

A. GAMESS DFT energy calculations are typically performed in three steps to improve convergence and calculation
efficiency. The first step is a Hartree-Fock calculation, followed by a DFT calculation on a rough grid, and finally a
DFT calculation on the default or input-specified grid. When “CONVERGED TO SWOFF, SO DFT
CALCULATION IS NOW SWITCHED ON” is displayed, the second step of DFT calculation with the rough grid
starts, but for some molecules, the grid is too rough to converge and the “DFT CODE IS SWITCHING BACK TO
THE FINE GRID” may not be displayed.
To increase the number of grid points in the second step, enter “NRAD0=99 NLEB0=302” in the Others field on the
DFT tab of the GAMESS Keyword Setup window.

13.11.26 Q. When parallel execution of NWChem, the calculation outputs “Please
specify an authentication passphrase for smpd:” to the log and dows not
run.

A. If you omit the pass phrase (passphrase) when installing MPICH 2, such an error may occur.
There are several solutions, but after uninstalling MPICH2, reinstalling MPICH 2 may resolve it.
In that case, you need to stop smpd before uninstalling MPICH2 and install smpd after reinstalling MPICH2.
Also, if you are using 32-bit MPICH2 on 64-bit Windows, use the 64-bit version.

13.11.27 Q. When I run NWChem, I get the message “sym_geom_project:
sym_center_map is inconsistent with requested accuracy” in the log and
the calculation does not run.

A. If the structure deviates slightly from NWChem’s molecular symmetry criterion, it will stop with an error. Select
[Tools]-[Point Group Analysis] in the Winmostar main window and click [Analyze], then [Symmetrize] to make the
structure with exact symmetry, or check noautosym in the Advanced tab of the Keyword Settings window, or move
one atom slightly to make the structure with broken symmetry.

13.11.28 Q. How can I put the solvent effect in NWChem?

A. Please put the name of the solvent molecule in ***. Please see
https://nwchemgit.github.io/COSMO-Solvation-Model.html#solvents-list-solvent-keyword for more information
about supported solvent molecules.
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13.11.29 Q. When executing NWChem, lines including “out of memory”, “alloc
failed”, “ma_push failed”, “nga_create failed”, and “Global memory limit
unreasonable” are printed in the log and calculations do not run.

A. None of the calculations are stopped because the amount of memory specified in the input is not sufficient. Please
increase the value of Memory in the Basic tab of the NWChem Keyword Setup window.

13.11.30 Q. The Gaussian calculation may or may not work correctly.

A. In case of single core version of Gaussian, Gaussian will be terminated when you try to run more than two jobs. If
you want to run two or more Gaussian local jobs sequentially on Winmostar using a single-core version of Gaussian,
set the parallel number of each job (%nproc or %nprocshared) to 1, and set Max Cores of Winmostar JM to 1. Please
set the Max Cores of Winmostar JM to 1.

13.11.31 Q. I read the Gaussian log file, but the orbital (eigen) energy etc. are not
written.

A. It is not output if pop=full and gfprint is missing in the Gaussian input file.
When you open a Gaussian input or output file in Winmostar, not only the structure but also the calculation conditions
will be loaded. If you open such a file and set the keywords, make sure that pop=full and gfprint are set.

13.11.32 Q. How do I calculate the chk file read in Gaussian?

A. For remote jobs, check [Advance] in the SubmitJob window and uncheck [Delete *.chk] to leave the chk file. And
the chk file is loaded and the calculation runs when the same name was used.

The method using –Link1– is simpler in setting itself, so please consider using it as well.

13.11.33 Q. I get an error when I try to load a Gaussian fchk file that is several GB
in size and display molecular orbitals.

A. We can handle fchk files up to roughly 2 GB. The upper size depends on the molecule size and basis functions. We
plan to eliminate the fchk file size limitation in the future.

13.11.34 Q. How can I perform vibration calculations in Gaussian that take isotope
effects into account?

A. Set freq=readisotopes in the Freq column of the Gaussian Keyword Setup window and write the following items
one line at a time in the Subsection column.
Temperature (K) Pressure (atm)
Mass of the first atom
Mass of the second atom
. . .
Mass of the n-th atom
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13.12 LAMMPS, Gromacs

13.12.1 Q. I would like to run molecular dynamics calculations, but which should I
use, LAMMPS or Gromacs?

A. If you are not sure, we recommend LAMMPS, which is slower than Gromacs, but it supports a wider range of
force fields and allows for more flexible schemes for non-equilibrium calculations. Winmostar allows you to use
LAMMPS and Gromacs with the same ease of use, making the transition to Gromacs relatively easy.

13.12.2 Q. I get an error while running a molecular dynamics calculation, what
should I do?

A. First trace the Winmostar tutorial. If that fails, you may have failed to build the environment.
Next, check if the error is reproducible. If it is not reproducible, it is often an environmental (either or both hardware
and software) problem or a random number derived problem.
Next, calculate one molecule of each component, without charge. If you still get an error, change the type of force
field as well.
If no error occurs with one molecule of each component and no charge, set the charge or increase the number of
molecules and observe the behavior.
Next, if you get errors with long calculations, increase the equilibration time.
If you get an error during the equilibration process, try the following.
- Check for conservation of conserved quantities (total energy, extended Hamiltonian) and reduce the time
increments.(1 fs→0.5 fs→0.2 fs→0.1 fs, and so on, gradually decreasing the time increments to find the value at
which stable operation is achieved.)
- If parallel computation is not performed or it is impractical to set the number of parallels to 1 due to computation
time issues, the number of parallels should be reduced gradually.
- If parallel computation is not performed or it is impractical to set the number of parallels to 1 due to computation
time issues, the number of parallels should be reduced gradually.
- Use Berendsen and velocity scaling methods for temperature and pressure control.
- Use double precision (for Gromacs)
- Do not use constraints (such as the SHAKE method). Instead, use time increments of about 0.1 fs.
- If the cell size is less than twice the cutoff radius, the calculation fails due to the implementation of the solver, so the
number of numerators is increased to increase the cell size and the calculation is performed again.
- Separate the calculation by a short number of steps and repeat the continuation. (Especially useful when initial and
final densities differ significantly during pressure control).
- Change the initial density (decrease or increase).
Change the random number seed for initial speed generation.
Change the random number seed for initial structure generation.
If it finishes successfully up to the NVT calculation but fails in the NPT calculation, see Q. When pressure control
(constant NPT or NPH) is used, the calculation fails in the middle of the process. Is there a solution?.
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13.12.3 Q. How can we equilibrate the system in molecular dynamics calculation?

A. First of all, describing the case where the calculation of the aggregation system (liquid and solid, not gas) of the
equilibrium state of low molecular is target.
When aligning molecules in the initial state, please set the density as close as possible to the final density.
However, when it is not possible to arrange it unless it is considerably low density, it does not matter.
After that, please carry out energy minimization, constant temperature calculation, constant temperature pressure
calculation until the change of the potential energy, temperature and density converge.
If the initial density is too low, compress it with a pressure higher than the target pressure (for example, about 100
times) by constant temperature pressure calculation.
Finally, if you are interested in the ensemble average physical quantity and reaching the target temperature and
pressure after equilibration, the difference in the fine equilibration procedure is less likely to have a significant
influence on the calculation result.
In the case of polymers and glasses, in most cases it is impossible to obtain an equilibrium state in a real sense,
because realistic computation time is almost impossible, so the convergence of energy, temperature and density, the
influence on the physical quantity to be observed is affected Equilibrium calculation is carried out for a time to the
extent that the correlation of physical quantities considered to be large reaches zero.
Since pressure control is unstable in the case of gas, equilibrium state is obtained only by energy minimization and
constant temperature calculation.
Also, it may be difficult to reach equilibrium density for tonic or bulky molecules, see Q. The final density obtained
from the NPT calculation is much lower than the density predicted from experimental values and other sources. What
should I do? in that case.

13.12.4 Q. I ran MD calculations from the same initial configuration but got different
results. Why is this?

A. The floating-point arithmetic used inside MD programs has the characteristic that the result changes when the
order of addition and subtraction is changed (the digits near the end of significant digits change), and in normal
parallel computation, the order of addition and subtraction changes depending on the accidental timing of com-
munication, i.e., the result during parallel computation In other words, there is no reproducibility in the results
of parallel calculations. In addition, because many-body problems such as those calculated with MD have the
property that very small differences in values expand exponentially over time (chaotic nature), changes in values
during parallel calculations can change the trajectory of each atom in many ways. The reason why different cal-
culation results are obtained is due to this change. This change in results is reasonable because the distribution of
results is expected to converge to a similar distribution if the MD calculation is performed for a sufficient amount
of time and sampling is sufficient.

13.12.5 Q. The final density obtained from the NPT calculation is much lower than
the density predicted from experimental values and other sources. What
should I do?

First, check to see if it has equilibrated sufficiently, and if it is the last case where the temperature, potential energy,
pressure, and density are still changing significantly, calculate for a longer simulation time.
Second, if the molecule is a solid or bulky molecule with multiple aromatic rings, it may take a very long simulation
time to converge to the equilibrium density at the desired temperature and pressure. This is especially true for liquid
crystals and large monomeric polymers. This is due to the fact that the molecules (monomers) are hard or large, and
once they aggregate, it is difficult to get another configuration. In such cases, density equilibration can be greatly
accelerated by interspersing equilibration at a higher temperature than the target temperature (e.g. 600 K when 300 K
is the target temperature) as appropriate. In the LAMMPS, Gromacs workflow setup, such equilibration can be easily
set up by using Preset=12-Step Compression or 21-Step Compression-Decompression.
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13.12.6 Q. In the MD calculation, how does the constraints by the SHAKE method
etc. affect the calculation result? How do I choose a constraint method ?

A. The SHAKE, RATTLE, LINCS, and SETTLE methods are applied between atoms that are covalently bonded to
restrict the bond length, so that the time step can be increased and even longer computations can be performed more
stably with the same amount of computation. “Stable” is in terms of Hamiltonian (total energy) conservation.
Functions that express covalent bonds when not constrained also do not accurately represent actual phenomena.
Therefore, assuming that stable calculations are being performed, there are deviations from the actual phenomena due
to the respective circumstances both in the case of restraining and in the case of not restricting, in terms of the effect
on various calculated physical properties.
Unless the vibrational motion in the molecule itself has the purpose of calculation, it is basically recommended to
select the condition that the Hamiltonian preserves for a long time in each case.
However, if the bonds of the hydrogen atoms are not constrained, the atoms will move at high speed significantly in
the system, which may cause the drift of the Hamiltonian. Therefore, in many cases, the bonds of the hydrogen atoms
are constrained.

13.12.7 Q. Why do molecules sometimes come out of the cell when in the trajectory
or the final structure afterMD calculation?

A. Using periodic boundaries, the entity of the molecule should be inside the cells of the periodic boundaries.
But, solvers such as Gromacs and LAMMPS record trajectories with translational values as they are without folding
coordinates even when molecules cross over cell boundaries to calculate mean square displacement, etc.
Either way, the result will be properly considered and the same result will be output during the result analysis, so there
is no effect on the result analysis.
If the appearance of molecules jumping out of the cell is not good, adjust the settings of View - Wrap Around Cell
Boundary.

13.12.8 Q. When I create a cell by adding water molecules from a cell in the [Sol-
vate/Build Cell] menu to a large molecule such as a protein, the molecules
sometimes stick out of the cell.

A. Select [View]-[Wrap/Unwrap Around Cell Boundary]-[Wrap for each atoms] and if there is no interference
between protein and water molecules, then there is no problem in the calculation.
If you want to center the protein, which is a matter of appearance only, select the atoms near the center before adding
the solvent and perform [Edit]-[Adjust Axes]-[Set Origin to Marked Atom] to move the molecule near the center.

13.12.9 Q. The [MD]-[Solvate/Build Cell] and [Insert Molecule] processes do not fin-
ish after many minutes. Is there a solution?

A. Reduce the density. When the molecules are relatively small (generally within 30-40 atoms), set the density at
50-75% of the expected density. If the molecules are large or depending on the shape of the molecules, it may be
necessary to further reduce the density (several percent to 10%, etc.), so observe the behavior while gradually
reducing the density. Even if the initial density is far from the original density, it is expected to eventually change to
an appropriate density by running MD calculations with pressure control.
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13.12.10 Q. In the [MD]-[Assign Charges Automaticcally] menu, the error message
“Topology file not found” is displayed. Is there a solution?

It is very likely that the molecule you are trying to assign a charge to is not compatible with Acpype. Check the log
file and sqm.out under the [filename]_charge_tmp folder. If there is an atom that is not supported, please assign a
charge with MOPAC or QM, or enter it manually.

13.12.11 Q. The process of assigning the force field takes a long time and never
ends. Is there a solution?

A. Especially when GAFF or OPLS-AA/L+GAFF is selected as the type of force field, it may take a long time
to process. This is caused by the fact that acpype is used to allocate GAFF, OPLS-AA/L+GAFF, and acpype
processing is slow. In the case of macromolecules with nearly 10,000 atoms per molecule, we have confirmed
that the process can be completed normally after about 5-6 hours. Depending on the environment, it may be
faster than this, or conversely, it may be slower. In the future, Winmostar will work on speeding up the process
of allocating these force fields.

13.12.12 Q. I get an error message when assigning a force field. Is there a solution?

It is very likely that the molecule you are trying to assign force field to is not compatible with Acpype. Check the log
file and sqm.out under the [filename]_charge_tmp folder. If there is an atom that is not supported, try a versatile force
field such as UFF or Dreiding.

13.12.13 Q. How do I assign a point charge to a polymer?

A. Polymers have large molecular weights, and using the point charge assignment method commonly used for small
molecules would require quantum chemical calculations for huge molecules, which would require extremely long
calculation times and would be impractical. Also, polymers assume various conformations in vacuum, and the effect
of these conformations would be significant when performing quantum chemical calculations for the entire molecule,
but the model in the classical force field for polymers does not want extreme charge changes between repetition units.
For this reason, polymers are usually assigned point charges in a different way than small molecules. Winmostar’s
Polymer Builder allows you to assign point charges in the state of the repeating unit, which are then used to
automatically configure the polymer charge. Details can be found in Homo Polymer builder , Block Polymer Builder ,
Random Polymer Builder.

13.12.14 Q. Can I calculate dielectric constant from Gromacs or LAMMPS (Molecu-
lar Dynamics Calculation)?

A. Since the dielectric constant is a physical property dependent on the frequency of the external field, and the
mechanism is different for each frequency band, we cannot answer them all.
The dielectric constant calculated from Winmostar’s Gromacs and LAMMPS is a component derived from molecular
orientation on the assumption that intramolecular polarization does not change with time.
And among them, it is the infinitely slow low frequency limit value calculated from the fluctuation of the dipole
moment of the whole system within the simulation time of molecular dynamics calculation.
Be careful for substances with large molecular weights and slow relaxation, such as polymers, because only
information within the range that can be observed within the simulation time is known.
The dielectric function calculated from Winmostar’s Quantum ESPRESSO is the dielectric function of the high
frequency component derived from the polarization of the electron with the atomic coordinates fixed.
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It is necessary to plan the calculation considering how to obtain the experimental value of the dielectric constant to be
compared, the properties of the material, and the research purpose.
In addition, it is possible to help with planning with our paid support.

13.12.15 Q. When I try to run an MD calculation from a structure created with the
interface builder, the force field assignment fails or the MD calculation
fails. Is there a solution?

A. If the distance between the layers is too short, the molecules of the two layers will collide, and unwanted covalent
bonds will be created based on the interatomic distance, or a large force will be applied at the start of the MD
calculation, causing the MD calculation to fail. The best way is to increase the value of [Direction]-[Interval] in the
interface builder and take a long time to equilibrate

13.12.16 Q. When pressure control (constant NPT or NPH) is used, the calculation
fails in the middle of the process. Is there a solution?

A. First of all, in a situation where the interaction between molecules is extremely weak, such as in the gas phase or
when other phases are dispersed in the gas phase, the pressure control is not stable, so try a method without pressure
control. Next, look at the change in density over time in the broken calculation to see what’s going on. Also, the
energy, temperature, and pressure must be sufficiently equilibrated at a constant density before pressure control can be
performed. At the end of equilibration at constant density, the pressure (the mean value of) is preferably 0 or negative.
If the pressure value is large at the end of equilibration at a constant density, the system size will change drastically
immediately after starting pressure control. If you want to reduce the pressure at the end of equilibration at a constant
density, reduce the initial density (Approximate 50% of final density, possibly larger or smaller). If this does not solve
the problem, (1) change the pressure control to Berendsen method instead of Parrinello-Rahman (Nose-Hoover)
method, (2) increase the time constant of the pressure control, and (3) divide the calculation with the pressure control
into several short calculations.

13.12.17 Q. How do I decide interaction parameters between liquid (organic) and
solid (inorganic) in LAMMPS and Gromacs?

A. First, collect as much information as possible what experimental facts are known and related research about the
liquid-solid interface. In particular, it is desirable to know the atomic structure of the surface (e.g., Miller’s index,
functional groups, etc.) and the chemical properties of the surface (rough things such as wettability, hydrophobic or
hydrophilic).

If the LJ parameter and charge values are listed in the appropriate relevant research literature, it is best to use those
values. In Winmostar, Set values as follows.
- For the charges, save them once in mol2 format and rewrite the values of the charges to the values in the paper.
- For LJ parameters, use the [Assign Force Field] function to enter the values for each element from [Exception].

If the appropriate values were not listed in the literature, but some chemical properties are known, run simulations
with several different charge and LJ parameters, compare the results of the calculations and adopt the parameters that
seem reasonable.

If only the atomic structure of the surface is known, the parameters are determined with ab initio calculations
(Quantum ESPRESSO).
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In some cases, the Lowdin charge function of Quantum ESPRESSO can be used to determine the charge. However,
when using lowdin charges, the total value of the charges does not equal zero, so adjustment of the values (e.g.,
shifting charges of all atoms) is necessary. It is also important to note that the polarization may be overestimated in
Lowdin charges.
For LJ parameters, use known parameters (e.g., Dreiding, UFF, CLAYFF, etc.) or calculate them from ab initio
calculations and algorithms such as Force Matching.

This complexity of the liquid (organic) - solid (inorganic) interaction parameters stems from the following facts.
1. The interaction parameters (epsilon, sigma, and charge) depend on the atomic position in classical MD, however,
The approximation error is larger in the organic-inorganic interface system than in the organic-organic system.
2. Although the surface of inorganic materials in real devices is covered with oxide films, it is not easy to observe
them experimentally and it is difficult to model accurately at atomic resolution.

13.12.18 Q. When I run Gromacs, I get the error “There is no domain decomposition
for 49 ranks that is compatible with the given box and a minimum cell size
of. . . ”. error. How should I deal with this?

A. Most MD simulation software divides the simulation cell during parallel computation and assigns the divided
region (subregion) to each process. Gromacs (and other major software) is designed in such a way that each edge of
this subregion cannot fall below the cutoff radius of the uncoupled interaction (the near component of LJ or
Coulomb). This error means that each edge of the subregion is below the cutoff radius. There are several ways to deal
with this problem, but basically, the number of molecules (number of atoms) should be increased or the number of
parallelism should be reduced to a level where the error does not occur. Although there may be requests to increase
the number of parallels to the limit, in reality, if the small area becomes smaller than a certain level, the amount of
communication increases in relation to the amount of calculation, and the parallel efficiency drops significantly.

13.12.19 Q. When I load the final structure or animation from Gromacs, or when I
edit it in some way and then run the MD calculation again, the force field
assignment fails or the MD calculation breaks down. Is there a solution?

A. There is a possibility that the molecules are separated due to a bug in Gromacs. To determine if a molecule is
separated or not, go to [Select]-[Select by molecular species] and see if there are any unexpected components. If it is
separated, please refer to Molecules that should be connected to each other are displayed separately in the structure
or the final structure after loading the Gromacs trajectory..
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13.12.20 Q. When loading the final structure or animation in Gromacs, the
molecules are sometimes displayed in pieces.

A. Please refer to Molecules that should be connected to each other are displayed separately in the structure or the
final structure after loading the Gromacs trajectory..

13.12.21 Q. Even if Gromacs ER method result loading is executed, the result can
not be displayed / an error will appear.

A. Please check the contents of ermod.out generated in the output destination directory specified when executing the
ER method.
If it says “The minimum of the energy coordinate is too large” in ermod.out, press the [Options] button on the ER
method execution window and select [For Solution System] Please reduce the value of [minimum value of the
solute-solvent energy (ecdmin)].
For details on how to set concrete values, please see ERmod wiki FAQ.
Similarly, check the contents of ermod.out and ERmod wiki FAQ and if you need to change the setting of ermod, set it
in [Options] of ER method execution window.

13.12.22 Q. The error message “Out of range atoms - cannot compute PPPM”
appears in the LAMMPS log and the calculation terminates abnormally.
Please let me know how to deal with this.

A. That message is displayed when an MD calculation fails in a general sense. See Q. I get an error while running a
molecular dynamics calculation, what should I do?.

13.12.23 Q. How can I plot the trajectory of a specific atom?

A. Please operate as follows
1) Display animation
2) Click the atom for which you want to draw a trajectory in the molecular display area.
3) Click [Custom Plot] in the animation operating window.
4) Check the second item under [X axis] and select “Atomic position (x)” (choose an appropriate direction as
appropriate).
5) Click [Apply] under [X axis].
6) Check the second item under [Y axis] and select “Atomic position (y)” (choose an appropriate direction as
appropriate).
7) Click [Add] under [Y axis].
8) Uncheck [Y axis] except for “Atomic position (y)”.
9) Uncheck [Autoscale] from [X Axis] and [Y Axis] below the graph and set [Min] and [Max] accordingly.
In addition, we are planning to develop a function that simplifies the above operations.
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13.12.24 Q. The dissipative particle dynamics (DPD) calculation gave me a different
result than intuitive. Why is this?

There is no single pathway to approximate actual molecular assemblies with a DPD model, and it is likely that this is
where the model was inadequate. It is also likely that the interactions between DPD particles are modeled quite boldly,
and that the system you want to represent is beyond the expressive power of DPD in the first place. The construction of
coarse-grained MD models, including DPD models, is highly individualized, and in many cases, a coping strategy will
not lead to a fundamental solution, so Winmostar’s support basically consists of individual consulting, starting with
asking about the original research objectives.

13.13 About Quantum ESPRESSO, OpenMX

13.13.1 Q. I installed the Quantum ESPRESSO pseudopotential file as per the in-
structions, but it is not recognized.

A. Copy the pseudopotential files with the .UPF extension (e.g. O.pw-mt_fhi.UPF,
Au.pbe-dn-rrkjus_psl.0.1.UPF, etc.) to the pseudo folder under the Quantum ESPRESSO installation folder (
By default, this is C:\Program Files\Quantum ESPRESSO 64-bit 5.2.1pseudo etc.) under the Quantum ESPRESSO
installation folder. However, if you download and save the UPF file using a browser such as the old Internet Exproler,
there have been reports of problems such as the extension being changed without your permission, so please also try a
browser such as Edge or Chrome.

13.13.2 Q. I don’t know how to find a pseudopotential file for Quantum ESPRESSO.
How do I find them?

A. It is described in Quantum ESPRESSO for Windows Installation Manual.

13.13.3 Q. Calculation using Quantum ESPRESSO fails. An error appears in dis-
playing the calculation result.

A. First of all, please take action of general errors.
Next, since Winmostar continuously executes each module of QE by batch processing, we look at the flow of
processing described in Winmostar generated bat file (local execution) or sh file (remote execution) While checking
the generated output file (pwout or out) file in order.
For example, check ph.x output log (ph.out) for phonon calculation.
Please take action on the place where error such as “Error in routine . . . ” appears first, then execute the job again.
Errors related to specific keywords, please confirm the setting of that keyword official site
<https://www.quantum-espresso.org/Doc/INPUT_PW.html>.
Typical QE error handling is described in official site FAQ <http://www.quantum-espresso.org/resources/faq>.
If you change to nosym=.True. and the calculation flows, you may be experiencing a bug that originates from the
detection of symmetry in the atomic configuration.
Reducing the number of parallels may cause the calculation to flow normally; changing the diagonalization (david,
cg, rmm-*, etc.) may solve this problem. Since this phenomenon varies depending on the type of compiler, MPI, or
numerical library that built Quantum ESPRESSO, it is also useful to change these settings and rebuild Quantum
ESPRESSO as necessary in the case of remote jobs. For remote jobs, changing the parallel distribution method (-nk,
-nt, -nb, -nd) can also improve the results, so it is useful to adjust the pw.x arguments in the template script
accordingly.
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13.13.4 Q. When executing Phonon calculation using Quantum ESPRESSO, “third
order derivatives not implemented with GGA” is output in the ph.x output
(ph.out), and the calculation result cannot be obtained.

A. This can be solved by selecting a pseudopotential other than GGA.

13.13.5 Q. Quantum ESPRESSO, OpenMX SCF calculation or structure optimization
calculation does not converge.

A. Please carry out the following countermeasures in order.
Always to try:
· First-principles calculations have many setting items, so do not change the calculation conditions appropriately, and
stream a series of calculations while recording properly.
Take action for general problem of QE.
· Plot the Estimated accuracy against the number of SCF cycles for QE. It is still good if it is a log-log plot.
· Spin Polarization State · Determine whether electric charge is appropriate.
· Gives the order of up/down spins.
· If you shift K_POINTS in Hexagonal crystal, remove the shift.
· Constrain the magnetic moment of the whole system.
· Use a reasonable initial structure.
· Use structures obtained by experiments and other calculation methods.
· Check to see if the calculation converges with a simpler model, such as a surface model only for an interface
(adsorption) model, a bulk model for a surface model, or a bulk model for a defect model.
· If there are atoms whose placement is arbitrary in the calculation (light elements invisible in X-rays, solid solutions,
defects, non-integer compositions, slab surface end structures, etc.), try a different placement.
· For slabs, reconsider the cutout and modification of the termination structure.
· In cases where solid solution · defects are included, make the initial structure so that large dipole moment does not
occur in the system.

Try next:
· Adjust mixing_mode and diagonalization.
· Make mixing_beta smaller.
· Increase nbnd.
· Change the type of pseudopotential file.
· Adjust the initial value of spin polarization. (Atomic unit or whole system)
· If the entire system may have a dipole moment, such as in a slab model, consider using a dipole correction or using
the ESM method (bc=1) or changing the surface composition.
· If the U parameter is used, gradually increase it from U=0 to check the behavior.
· If relatively complicated conditions such as external electric field, defect, adsorption, etc. are set, try them under
simpler conditions than eliminating them, and if the calculation converges, the final state of the calculation (atomic
arrangement · wave function Etc.) as the initial state and starts the calculation.
· Calculation is started from halfway of computation that did not converge (SCF algorithm depends on history).

Try in balance with calculation time / calculation precision:
· Take a large cutoff energy.
· Take a lot of K points.
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Try with balance with calculation accuracy:
· In the case of spin polarization calculations, first check for convergence without spin polarization.
· Adjust smearing (use/not use, type, width).
Loosen the convergence parameter of the SCF.

13.13.6 Q. I cannot visualize the three-dimensional distribution of electron density,
spin density, and potential in Quantum ESPRESSO.

A. First trace the Quantum ESPRESSO Basics section of the Winmostar tutorial and see if you can display them on a
small system size. If not, please refer to Q. I can not create a model as I expected. It can not calculate. It does not
work. and rebuild your environment. If the tutorial works fine but does not, first check if a cube file has been
generated in your working folder, if so, this may be due to a problem with Winmostar Viewer. If a cube file is
generated, please refer to Cannot open large size cube file in Winmostar Viewer. to fix the problem.

13.13.7 Q. The SCF calculation of Quantum ESPRESSO is displayed as “too few
bands” in the output file (.pwout or .out) and abnormally ends. I do not
know how to set nbnd.

A. First of all, please check nbnd description of the QE official manual.
If you do not use nbnd when you do the calculation, QE automatically calculates nbnd by setting it automatically, so
please uncheck “Use nbnd” on the keyword setting screen of Winmostar.
To increase nbnd, set nbnd to a value larger than the value of “number of Kohn-Sham states” that is output to the
pwout or out file when executed without using nbnd.
Also please refer to the value of “# valence bands:” displayed at “Use nbnd” on Configure window of Winmostar (See
Solid → Quantum ESPRESSO menu for detail).

13.13.8 Q. The SCF calculation of Quantum ESPRESSO terminates abnormally with
“fixed occupations and lsda need tot_magnetization” displayed in the out-
put file (.pwout or .out). How do I resolve this?

A. Select smearing in the occupations section, or use tot_magnetization instead of starting_magnetization.

13.13.9 Q. Quantum ESPRESSO’s structural optimization calculation (vc-relax) ter-
minates abnormally with the output file (.pwout or .out) showing “smooth
g-vectors missing ! in the output file (.pwout or .out) and terminates abnor-
mally. How can I resolve this?

A. Recalculate using the structure output at the end of the pwout or out file. on the Winmostar GUI, create a new job
with the structure optimization animation displayed and the final structure.
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13.13.10 Q. The SCF calculation of Quantum ESPRESSO on metal is terminated
abnormally with “charge is wrong” displayed in the output file (.pwout or
.out). How do I resolve this?

A. First try the Q. Quantum ESPRESSO, OpenMX SCF calculation or structure optimization calculation does not
converge. procedure.
The “charge is wrong” is immediately preceded by “WARNING: integrated charge= . . . expected= . . . ” in the log, the
charge or spin polarization calculation settings may not be appropriate for the model. is wrong, the settings for charge
or spin polarization calculation may not be appropriate for your model, so please set tot_charge, nspin,
starting_magnetization or tot_magnetization accordingly. For example, if the number of electrons in the simulation
cell is odd, such as in a defect or surface model, one might set nspin=2 and tot_magnetization=1.
If this does not solve the problem, make sure that occupations is set to smearing in the Quantum ESPRESSO
Keyword Settings window, and if necessary, set ecutrho to a larger value (such as 400 Ry) and the number of k-point
divisions to a larger value (gradually increasing) Set the k-point divisions as large (gradually increasing) as necessary.

13.13.11 Q. When calculating the dielectric function using Quantum ESPRESSO,
“bad band number” is displayed in the epsilon.x output (eps.out) and it is
not possible to acquire the dielectric function.

A. It is solved by increasing the number of bands (nbnd) by SCF calculation.

13.13.12 Q. When calculating the dielectric function using Quantum ESPRESSO,
“USPP are not implemented” is displayed in the epsilon.x output (eps.out)
and it is not possible to acquire the dielectric function.

A. Select a norm preserving pseudopotential in the SCF calculation.

13.13.13 Q. My Phonon calculation using Quantum ESPRESSO failed and I cannot
get the results.

A. First, please do not run the Phonon calculation, but use the same pseudopotential file and other calculation
conditions to make sure that the SCF calculation finishes successfully. Next, check the ph.out (the output file of the
Phonon calculation module ph.x) in the working directory (the folder ending in _qe_data). If it says “The phonon
code with US-PP and raman or elop not yet available” there, you can solve it by selecting a norm-preserving
pseudopotential. Also refer to Q. I cannot find a norm-preserving, LDA functional pseudopotential file for Quantum
ESPRESSO for the element I want to calculate in the pseudopotential files installed by default. How can I find it?
when looking for pseudopotential files. Similarly, if you are using a PAW potential, Raman calculations, etc., are not
supported, and you can solve this problem by choosing a norm-preserving pseudopotential. If you are experiencing
symmetry-related errors, please run [Solids]-[Refine Lattice] before running the Phonon calculation.
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13.13.14 Q. I cannot find a norm-preserving, LDA functional pseudopotential file for
Quantum ESPRESSO for the element I want to calculate in the pseudopo-
tential files installed by default. How can I find it?

A. This DB <https://pseudopotentials.quantum-espresso.org/legacy_tables/hartwigesen-goedecker-hutter-pp>`_
contains a relatively large number of norm-preserving and LDA-functional pseudopotential files. The pseudopotential
file is not limited to this pseudopotential file. Please verify the cutoff energy and the number of k-points used in your
calculations, not limited to this pseudopotential file.

13.13.15 Q. When I try to output the Fermi surface, they do not appear.

A. First, make sure that the target substance is a metal. Next, output the density of states, and confirm that the density
of states is not 0 on Fermi energy.

13.13.16 Q. Can I calculate the dielectric constant from Quantum ESPRESSO (band
calculation)?

A. See Q. Can I calculate dielectric constant from Gromacs or LAMMPS (Molecular Dynamics Calculation)?.

13.13.17 Q. How do you set up the type of functionalities in Quantum ESPRESSO?

A. In Quantum ESPRESSO, since a pseudopotential file is created for each function, the function is basically
determined when the pseudopotential file is selected. Some functions (e.g., HSE, vdw functions) select the
pseudopotential file created by the base function (e.g., PBE in the case of HSE) and then use the input_dft keyword to
override the function’s settings.

13.13.18 Q. Why does the cell size structure optimization in Quantum ESPRESSO
result in discontinuous changes or energy increases in the final structure
energy?

A. The reason for the slight discontinuity in the energy change at the end is that Quantum ESPRESSO is reworking
the plane wave set to use only the last calculation to avoid problems caused by the Pulay pressure.
This energy jump can be reduced to some extent by increasing the cutoff energy.
If the final structure differs significantly from the initial structure, continue and run the structural optimization
calculation again.

13.13.19 Q. Quantum ESPRESSO terminates normally for systems with a small
number of atoms, but for large systems it terminates abnormally with an
error such as “cannot allocate . . . ”. for large systems. What can I do about
this?

A. Please refer to the FAQ on memory usage in the official QE documentation.
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13.13.20 Q. Why do the values for Total DOS appearing in Projected DOS
(PDOS) and DOS appearing in Density of States (DOS) differ in Quantum
ESPRESSO?

A. In Quantum ESPRESSO, PDOS is calculated by projecting the electronic states obtained in the plane-wave basis
onto the atomic basis, but this projection is not perfect. This is a property of plane wave basis DFT codes in general,
not just Quantum ESPRESSO.

13.13.21 Q. When I set Hubbard U in Quantum ESPRESSO for structural optimiza-
tion, it terminates abnormally with the error message “NR-step length un-
reasonably short”. What can I do about this?

A. If the version of Quantum ESPRESSO is 5 series, the force calculation for Hubbard U is not implemented and this
error occurs. Therefore, upgrading to Quantum ESPRESSO version 6 or later will solve this problem.

13.13.22 Q. Why does the number of cycles required for convergence of SCF cal-
culations before and after Quantum ESPRESSO 6.6 change so much?

A. One reason is that the default value of diago_david_ndim was changed from 4 to 2 in Quantum ESPRESSO 6.6
and later. Even after QE6.6, if diago_david_ndim is explicitly set to 4, the behavior is similar to earlier versions.

13.13.23 Q. When I use hybrid functional (e.g. HSE) in Quantum ESPRESSO, the
band structure collapses. Is there a way to deal with this?

A. Unfortunately, as of version 7.1, Quantum ESPRESSO itself does not support band structure calculations with
hybrid functionals (mixed functionals). It is possible to do so by post-processing using an external module (such as
Wannier90), but Winmostar (as of V11.6.4) does not support such post-processing, so users must perform
post-processing on Winmostar’s output results themselves. The user must perform the post-processing on the
Winmostar output.

13.13.24 Q. Unnecessary bonds are displayed while modeling the system or when
reading the calculation results. Or the bonds are not displayed. How can
I fix this?

A. See this FAQ for more information.

13.13.25 Q. When setting up workflow and keywords in Quantum ESPRESSO, even
if the cell is not converted to a primitive cell, it is converted to a primitive
cell when the calculation is executed.

A. Do not check “Use Bravais-lattice index” or “Set ibrav = N and celldm”.

Q. Is there any scaling factor proposed for first-principles calculations (e.g. Quantum ESPRESSO) such that the vi-
brational spectra (IR, Raman) obtained from calculations such as quantum chemical calculations (e.g. GAMESS,
Gaussian) are matched to experimental values?
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A. It seems to be not proposed. The reason is that quantum chemical calculations (Gaussian basis) have only
Hamiltonian (including functional) and basis functions as parameters, whereas ab initio calculations (plane-wave
basis pseudopotential method) have many parameters, and it is difficult to propose a generic scaling factor that takes
them into account. There is no guarantee that this will work, but if you are in a situation where you can compare
experimental and calculated values, you may want to construct your own scaling factor for a particular combination of
pseudopotential, k-point density, cutoff energy, and functional.

13.13.26 Q. When I run a calculation on a local machine with MPI enabled in
OpenMX, I get the error tcp_peer_send_blocking: send() to socket 12
failed: Transport endpoint is not connected.

A. For issues specific to Cygwin’s OpenMPI, go to Windows Settings - Network and Internet - Change Adapter
Options and disable the network adapter you are not using. Also, OpenMX recommends that you use OpenMP on the
local machine.

13.13.27 Q. After running a structural optimisation calculation with a change in cell
size in OpenMX, if I run a continuation job with SCF.Restart=On, the stan-
dard output shows Failed (3) in reading the restart files, <Restart> Could
not find restart files.

A. The error message indicates that the number of charge density meshes in the restart file is different from the
number of meshes you are about to calculate. This can happen if the cell size changes significantly during the
structural optimisation calculation. In such cases, a new SCF calculation must be performed after the structural
optimisation calculation.

13.14 Addons

13.14.1 Q. When calculating the Hansen solubility parameter of a polymer using the
solubility parameter calculation module, the output value changes depend-
ing on how the repeating structure (monomer) of the polymer is taken.

A. It is because of the group contribution algorithm implemented. When searching for an atomic group, the search is
started from the largest atomic group. It is recommended that functional groups that seem to be important be included
in the repeating unit.
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13.14.2 Q. The value of the Hansen solubility parameter obtained using the solubil-
ity parameter calculation module is significantly different from the literature
value.

A. The solubility parameter calculation module outputs Hansen solubility parameters using the group contribution
method trained by the neural network using various literature values as learning data. Therefore, it does not return
exactly the same value as the literature value. Please note that the unit of the solubility parameter differs depending on
the literature.
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	Known problems
	If you start Winmostar with administrator privileges, you can not open files with drag-and-drop.
	Some software will not work if the Windows option “Use Unicode UTF-8 for worldwide language support” is enabled.
	Opening some subwindows such as Animation, Submit Job and so on, it will not appear even if you try to open again after closing.
	Graph display at the bottom of animation operation area is corrupted. Other UI displays are corrupted.
	If you select a range of text in the console window where the job of the local machine is flowing, the job is recognized as terminating on Job Manager.
	Gromacs freezes while running Gromacs on local machine.
	When using the RISM compatible version of Quantum ESPRESSO, it may be displayed that the main window keyword has been changed even though it has not been changed.
	MOL files that could be processed successfully with the ESM-RISM version of QE based on Quantum ESPRESSO 6 cannot be read properly when using QE 7.1.
	The units of Isothermal Compressibility and Adiabatic Bulk Modulus output by Gromacs are wrong.
	Molecules that should be connected to each other are displayed separately in the structure or the final structure after loading the Gromacs trajectory.
	When loading SMILES strings using [File]-[Import]-[SMILES], but the structure is not loaded as intended.
	Winmostar freezes when deleting the working directory or working folder directly on Windows (Explorer) while Winmostar is processing.
	Cannot open large size cube file in Winmostar Viewer.
	Winmostar toolbar and tool buttons are displayed incorrectly when Windows display magnification is other than 100%.
	Under some conditions, LAMMPS fails to recognize elements in the structure file after the calculation is completed when using a potential file.
	Cannot exit a job from the Stop menu from Job Manager in Windows 11.
	Molecules with the same composition and different binding modes are recognized by the same molecular species in the force field assignment function.
	The crystal symmetry detection process fails when the security software McAfee is running.
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	Functions and use of the software
	How to pronounce Winmostar.
	Q. Does Winmostar connect to internal and external servers or the cloud, or can it be used without a LAN connection?
	Q. Please tell me the minimum and recommended specifications of PC for Winmostar.
	Q. Is it possible to use the data generated by Winmostar for conference presentations and papers? How should I quote at conference presentations and paper submissions?
	Q. Is it possible to upload videos or images of the Winmostar screen to YouTube or other web sites?
	Q. Do you have any calculation software installed on Winmostar itself?
	Q. Do you let Winmostar run calculations in the cloud?
	Q. Does Winmostar support GPU computation?
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	Q. Is it possible to do parallel computation using Winmostar?
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	Q. Does Winmostar work on macOS and Linux?
	Q. How can I install Gaussian?
	Q. How can I install VASP?
	Q. Windows or Explorer freezes when I start the CygwinWM installer. What should I do?
	Q. How many atoms or molecules can I calculate with Winmostar? Is there an upper limit to the number of atoms or molecules that can be handled?
	Q. Can I use Winmostar to calculate coarse-grained models?
	Q. What is the difference between the latest stable version and the latest development version? Which do you recommend?
	Q. Who owns the rights to the calculation results and output files obtained using Winmostar?

	Software operations
	Q. I can not create a model as I expected. It can not calculate. It does not work.
	Q. “ERROR: I/O error 32” is displayed and the processing fails.
	Q. Process using Cygwin will end abnormally. / Help  Check CygwinWM function will display … ERROR …. / Cygwin’s black window shows child_info_fork :: abort: … Loaded to different address: parent …! = Child ….
	Q. Help  Check CygwinWM function displays No reference file (… filelist_cygwinwm.txt) was found….
	Q. Help  Check CygwinWM function will display WARNING … some files are missing.
	Q. Tools  Diagnose CygwinWM function shows ERROR … Failed to generate a current file list.
	Q. Tools  Diagnose CygwinWM function displays ERROR: Getting SMILES …. OpenBabel process terminates abnormally.
	Q. The job registered in Job Manager is not executed.
	Q. When executing a job, an alert saying “Unable to execute (Access denied.)” appears and the job will not start.
	Q. In the functions where a black console window appears, such as various functions of Winmostar or the execution of the solver, the processing of the black console window does not end and does not proceed.
	Q. When I open a file or model a molecule, the bonds no longer appear or a lot of extra bonds have come to appear.
	Q. How do I view the extension in Windows Explorer?
	Q. Markers (red circles) and group selections (blue circles) are not displayed. Atoms can no longer be selected.
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	Q. What is an optimization flag?
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	Q. Is it possible to use the latest version of each solver or a version not listed in Winmostar’s operating environment?

	File I/O
	Q. I cannot open files created by other than Winmostar with Winmostar. When I edit the file generated by Winmostar and try to open it with Winmostar, it cannot be opened.
	Q. When opening a file in MOL or SDF format, the bond length becomes unnatural. Hydrogen does not appear.
	Q. When I load SMILES, it does not generate the intended structure. Why is this? What should I do?

	On the modeling of molecules and creation of systems
	Q. How do I change the type of chemical bond (single, double etc.)?
	Q. MD  Solvate/Build Cell function will display Error: Failed to solvate. and processing will fail.
	Q. When I run some functions, I get \357\273\277 etc. and the process fails.

	MPI on local machine, parallel execution
	Q. Why does the parallel computation that flows by itself terminate abnormally? The parallel test in the installation test succeeds. Serial calculations also terminate normally.
	Q. MPICH ends during computation.
	Q. When executing parallel MPI of LAMMPS or Quantum ESPRESSO, warning is displayed as Unable to open the HKEY_LOCAL_MACHINE\SOFTWARE\MPICH\SMPD\process\???? registry key, error 5 , Access denied.
	Q. The installation of .NET Framework 3.5 using dotNetFx35setup.exe fails. What should I do?
	Q. I cannot find the number of parallels I want to set when I pull down the Number of Parallels combo box. How can I set the number of parallels I want?

	Remote Jobs
	Q. Please tell me how to submit a job to a supercomputer or a linux server in my company or my campus.
	Q. I cannot connect from Winmostar to a server that allows SSH connections with various terminal software.
	Q. SSH connection with public key method fails, when I specify the same private key file with other software such as TeraTerm or Cygwin, the connection succeeds. Is there a solution?
	Q. The connection test with Test Connection succeeds, but the job submission fails.
	Q. Connection test with Test Connection succeeds, but Putty’s WARNING is displayed and various operations fail.
	Q. What type of MPI (MPICH, OpenMPI, etc.) can I use on the remote server?
	Q. Why are some environment variables (e.g. PATH) that should be set on the remote server by filling in bashrc, etc., not set when running from Winmostar? What should I do in such cases?
	Q. Is there any difference in behavior between the Windows version of the solver and the Linux version of the solver?
	Q. Can I run calculations simultaneously for remote jobs that run on different servers?
	Q. Where are passwords entered in the remote job profile stored? Is the password information stored in the project folder?
	Q. Why can I SSH to an Ubuntu machine, including WSL2 use, but cannot successfully execute a remote job?

	Simulation in general
	Q. Is it possible to calculate the interaction between one substance and another substance with Winmostar?
	Q. Can I calculate bond energies and bond divergence energies for a given bond in a molecule?

	MOPAC, CNDO/S, GAMESS, NWChem, Gaussian
	Q. I get an error while running a quantum chemistry calculation, what should I do?
	Q. The Hamiltonian calculation method (Hamiltonian) or basis function (Basis Set) that I want to use is not found in the Configure window or the Easy Setup window for MOPAC, GAMESS, Gaussian and NWChem. How do I set it up?
	Q. How are bonds determined when opening an input/output file or when regenerating bonds?
	Q. Unnecessary bonds are displayed while modeling the system or when reading the calculation results. Or the bonds are not displayed. How can I fix this?
	Q. Is it possible to optimize substructures from Winmostar using quantum chemical calculations?
	Q. Why does the Dipole moment value displayed at the bottom of the Winmostar molecule display area differ from the dipole moment value manually calculated from the charges assigned to each atom, such as Mulliken charges?
	Q. How many atoms can be calculated with MOPAC?
	Q. It will display abnormally with the message ATOMS **, **, AND ** ARE WITHIN. **** ANGSTROMS OF A STRAIGHT LINE displayed in the MOPAC log.
	Q. When MOPAC is executed, “UNRECOGNIZED KEY - WORDS: (PM 6 (Hamiltonian name))” is output to the log and the calculation ends.
	Q. How do I use the solvent effect (COSMO method) in the MOPAC attached with Winmostar?
	Q. When I calculate with MOPAC other than Winmostar built-in (e.g. MOPAC2016), only some molecular orbitals are displayed.
	Q. It can not be calculated when Method=INDO is used in CNDO/S.
	Q. Is there a guideline for the maximum number of atoms (memory requirement) that can be calculated in GAMESS, Gaussian, and NWChem?
	Q. Is it possible to speed up 3D display of ESP (electrostatic potential) of GAMESS, Gaussian, and NWChem?
	Q. When running GAMESS, “* ERROR: MEMORY REQUEST EXCEEDS AVAILABLE MEMORY” etc. will be output to the log and the calculation will end abnormally.
	Q. Immediately after installing GAMESS for Windows, I was able to use it without any problems, but at some point, all the calculations started to terminate abnormally in the middle. Is there a way to fix this?
	Q. GAMESS outputs “WARNING. NUMBER OF INTERNAL COORDINATES IS GREATER THAN (3N - 6), BUT NO SYMMETRY COORDINATES ARE GIVEN.” in the calculation of only one atom and abnormally ends.
	Q. The message **** ERROR **** PCM SPHERE (S) MUST HAVE A POSITIVE RADIUS is displayed in the log of GAMESS and abnormally ends.
	Q. When GAMESS is executed, “ERROR: BAD DELOCALIZED COORDINATES GENERATED !!!” is output to the log and the calculation ends abnormally.
	Q. When I try to run NMR calculation in GAMESS (using RUNTYP=NMR), I get an error.
	Q. When I use Diffuse functions in GAMESS, the SCF calculation does not converge.
	Q. For some molecules, after optimization of Firefly, when I check the Molecular Orbit UVvis…, I get the error '*******' is not valid floating point value”.
	Q. How do I deal with the message “THE GEOMETRY SEARCH IS NOT CONVERGED!” when I run a structural optimization calculation with GAMESS?
	Q. I cannot download the GAMESS installer. How can I do this?
	Q. The DFT calculation in GAMESS does not converge after displaying “CONVERGED TO SWOFF, SO DFT CALCULATION IS NOW SWITCHED ON”. Is there any way to deal with this?
	Q. When parallel execution of NWChem, the calculation outputs “Please specify an authentication passphrase for smpd:” to the log and dows not run.
	Q. When I run NWChem, I get the message “sym_geom_project: sym_center_map is inconsistent with requested accuracy” in the log and the calculation does not run.
	Q. How can I put the solvent effect in NWChem?
	Q. When executing NWChem, lines including “out of memory”, “alloc failed”, “ma_push failed”, “nga_create failed”, and “Global memory limit unreasonable” are printed in the log and calculations do not run.
	Q. The Gaussian calculation may or may not work correctly.
	Q. I read the Gaussian log file, but the orbital (eigen) energy etc. are not written.
	Q. How do I calculate the chk file read in Gaussian?
	Q. I get an error when I try to load a Gaussian fchk file that is several GB in size and display molecular orbitals.
	Q. How can I perform vibration calculations in Gaussian that take isotope effects into account?

	LAMMPS, Gromacs
	Q. I would like to run molecular dynamics calculations, but which should I use, LAMMPS or Gromacs?
	Q. I get an error while running a molecular dynamics calculation, what should I do?
	Q. How can we equilibrate the system in molecular dynamics calculation?
	Q. I ran MD calculations from the same initial configuration but got different results. Why is this?
	Q. The final density obtained from the NPT calculation is much lower than the density predicted from experimental values and other sources. What should I do?
	Q. In the MD calculation, how does the constraints by the SHAKE method etc. affect the calculation result? How do I choose a constraint method ?
	Q. Why do molecules sometimes come out of the cell when in the trajectory or the final structure afterMD calculation?
	Q. When I create a cell by adding water molecules from a cell in the [Solvate/Build Cell] menu to a large molecule such as a protein, the molecules sometimes stick out of the cell.
	Q. The [MD]-[Solvate/Build Cell] and [Insert Molecule] processes do not finish after many minutes. Is there a solution?
	Q. In the [MD]-[Assign Charges Automaticcally] menu, the error message “Topology file not found” is displayed. Is there a solution?
	Q. The process of assigning the force field takes a long time and never ends. Is there a solution?
	Q. I get an error message when assigning a force field. Is there a solution?
	Q. How do I assign a point charge to a polymer?
	Q. Can I calculate dielectric constant from Gromacs or LAMMPS (Molecular Dynamics Calculation)?
	Q. When I try to run an MD calculation from a structure created with the interface builder, the force field assignment fails or the MD calculation fails. Is there a solution?
	Q. When pressure control (constant NPT or NPH) is used, the calculation fails in the middle of the process. Is there a solution?
	Q. How do I decide interaction parameters between liquid (organic) and solid (inorganic) in LAMMPS and Gromacs?
	Q. When I run Gromacs, I get the error “There is no domain decomposition for 49 ranks that is compatible with the given box and a minimum cell size of…”. error. How should I deal with this?
	Q. When I load the final structure or animation from Gromacs, or when I edit it in some way and then run the MD calculation again, the force field assignment fails or the MD calculation breaks down. Is there a solution?
	Q. When loading the final structure or animation in Gromacs, the molecules are sometimes displayed in pieces.
	Q. Even if Gromacs ER method result loading is executed, the result can not be displayed / an error will appear.
	Q. The error message “Out of range atoms - cannot compute PPPM” appears in the LAMMPS log and the calculation terminates abnormally. Please let me know how to deal with this.
	Q. How can I plot the trajectory of a specific atom?
	Q. The dissipative particle dynamics (DPD) calculation gave me a different result than intuitive. Why is this?

	About Quantum ESPRESSO, OpenMX
	Q. I installed the Quantum ESPRESSO pseudopotential file as per the instructions, but it is not recognized.
	Q. I don’t know how to find a pseudopotential file for Quantum ESPRESSO. How do I find them?
	Q. Calculation using Quantum ESPRESSO fails. An error appears in displaying the calculation result.
	Q. When executing Phonon calculation using Quantum ESPRESSO, “third order derivatives not implemented with GGA” is output in the ph.x output (ph.out), and the calculation result cannot be obtained.
	Q. Quantum ESPRESSO, OpenMX SCF calculation or structure optimization calculation does not converge.
	Q. I cannot visualize the three-dimensional distribution of electron density, spin density, and potential in Quantum ESPRESSO.
	Q. The SCF calculation of Quantum ESPRESSO is displayed as “too few bands” in the output file (.pwout or .out) and abnormally ends. I do not know how to set nbnd.
	Q. The SCF calculation of Quantum ESPRESSO terminates abnormally with “fixed occupations and lsda need tot_magnetization” displayed in the output file (.pwout or .out). How do I resolve this?
	Q. Quantum ESPRESSO’s structural optimization calculation (vc-relax) terminates abnormally with the output file (.pwout or .out) showing “smooth g-vectors missing ! in the output file (.pwout or .out) and terminates abnormally. How can I resolve this?
	Q. The SCF calculation of Quantum ESPRESSO on metal is terminated abnormally with “charge is wrong” displayed in the output file (.pwout or .out). How do I resolve this?
	Q. When calculating the dielectric function using Quantum ESPRESSO, “bad band number” is displayed in the epsilon.x output (eps.out) and it is not possible to acquire the dielectric function.
	Q. When calculating the dielectric function using Quantum ESPRESSO, “USPP are not implemented” is displayed in the epsilon.x output (eps.out) and it is not possible to acquire the dielectric function.
	Q. My Phonon calculation using Quantum ESPRESSO failed and I cannot get the results.
	Q. I cannot find a norm-preserving, LDA functional pseudopotential file for Quantum ESPRESSO for the element I want to calculate in the pseudopotential files installed by default. How can I find it?
	Q. When I try to output the Fermi surface, they do not appear.
	Q. Can I calculate the dielectric constant from Quantum ESPRESSO (band calculation)?
	Q. How do you set up the type of functionalities in Quantum ESPRESSO?
	Q. Why does the cell size structure optimization in Quantum ESPRESSO result in discontinuous changes or energy increases in the final structure energy?
	Q. Quantum ESPRESSO terminates normally for systems with a small number of atoms, but for large systems it terminates abnormally with an error such as “cannot allocate …”. for large systems. What can I do about this?
	Q. Why do the values for Total DOS appearing in Projected DOS (PDOS) and DOS appearing in Density of States (DOS) differ in Quantum ESPRESSO?
	Q. When I set Hubbard U in Quantum ESPRESSO for structural optimization, it terminates abnormally with the error message “NR-step length unreasonably short”. What can I do about this?
	Q. Why does the number of cycles required for convergence of SCF calculations before and after Quantum ESPRESSO 6.6 change so much?
	Q. When I use hybrid functional (e.g. HSE) in Quantum ESPRESSO, the band structure collapses. Is there a way to deal with this?
	Q. Unnecessary bonds are displayed while modeling the system or when reading the calculation results. Or the bonds are not displayed. How can I fix this?
	Q. When setting up workflow and keywords in Quantum ESPRESSO, even if the cell is not converted to a primitive cell, it is converted to a primitive cell when the calculation is executed.
	Q. When I run a calculation on a local machine with MPI enabled in OpenMX, I get the error tcp_peer_send_blocking: send() to socket 12 failed: Transport endpoint is not connected.
	Q. After running a structural optimisation calculation with a change in cell size in OpenMX, if I run a continuation job with SCF.Restart=On, the standard output shows Failed (3) in reading the restart files, <Restart> Could not find restart files.

	Addons
	Q. When calculating the Hansen solubility parameter of a polymer using the solubility parameter calculation module, the output value changes depending on how the repeating structure (monomer) of the polymer is taken.
	Q. The value of the Hansen solubility parameter obtained using the solubility parameter calculation module is significantly different from the literature value.
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